• 9000001 Blocking Copilot in Windows 10 and 11 Home sku

    Home » Forums » Knowledge Base » 9000001 Blocking Copilot in Windows 10 and 11 Home sku

    Author
    Topic
    #2607335

    9000001 Blocking Copilot in Windows 10 and 11 Home sku

    Info to enable/disable Copilot in Windows

    To block Microsoft’s AI in Windows 10 and 11 Home sku’s we will use a series of registry keys OR we can turn it off in the GUI.

    At this time it’s only dribbling out in North America and certain other countries. It will not be in the EU at this time.

    On Windows 11, you can enable Copilot through the Settings app or the Registry after installing the update KB5031455, KB5027397 (23H2 feature release) or any later November or later updates to your Windows 11 system.

    If the icon has shown up down in your system tray you can turn it on or off by performing the following steps in settings on Windows 11:

    Open Settings on Windows 11.

    Click on Personalization.

    Click the Taskbar tab.

    Turn on (or OFF) the Copilot toggle switch.

    Screenshot-2023-12-01-221856

    Alternatively use the following registry key:

    Open Start.

    Search for regedit and click the top result to open the Registry.

    Navigate to the following path:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    Double-click the ShowCopilotButton DWORD and set its value to 1 to enable the feature.

    To disable copilot Use the following:

    Windows Registry Editor Version 5.00

    ‘[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\WindowsCopilot]
    “TurnOffWindowsCopilot”=dword:00000001`

    ‘[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsCopilot]
    “TurnOffWindowsCopilot”=dword:00000001`

    To make it easier

    Here is the registry key to disable Copilot in Windows

    Simply click on the link above and approve the UAC prompt to install it on your system.

    If at a later date you want to reenable it, click on this registry key file.

    Disable/Enable Copilot in Edge

    There is a second Copilot that you may wish to also disable.

    Note that if you do not have a Microsoft account or use Edge as your default browser, Copilot won’t have any control over your system so it’s up to you if you want to perform this next step if you always use Chrome or Firefox as your default browser.

    Open Edge and click on the main 3-dots menu button on the toolbar and select Settings.
    Click on Sidebar tab or section in the left-side pane of Settings page.
    Under App and notification settings section, click on Copilot option.
    You can also turn off the “Always show sidebar” toggle switch

    Screenshot-2023-12-01-222803

    Turn off Let Copilot use content from Microsoft Edge.

    Users can modify this permission by going to Microsoft Edge  click on the three dots and then  Settings > Sidebar > App and notification settings > App specific settings > Copilot and then turning on or off the ‘Allow Microsoft to access page content’ toggle.

    Screenshot-2023-12-02-220200

    Copilot in Edge | Microsoft Learn

     

     

    Susan Bradley Patch Lady/Prudent patcher

    14 users thanked author for this post.
    Viewing 10 reply threads
    Author
    Replies
    • #2607342

      The Windows 11 registry key in Susan’s post is trimmed on my system. the full path is shown here.

      HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

      cheers, Paul

    • #2607356

      Turn off Let Copilot use content from Microsoft Edge.

      That setting is in Copilot, not Edge, and doesn’t disable Copilot in Edge:

      Note: You can change your permission selection at any time by going to Settings in Copilot in Windows and turning the toggle on or off.

      Microsoft Edge page content

      Enable or Disable Let Copilot use Content from Microsoft Edge in Windows

      1 user thanked author for this post.
      • #2607623

        Actually that’s changed and now it’s “Share Microsoft Edge content with Bing Chat”

        They keep moving the settings around.

        Susan Bradley Patch Lady/Prudent patcher

        1 user thanked author for this post.
    • #2607587

      Examples shown are Win 11. Assume same for Win 10 Pro, including reg key link?

    • #2607868

      Do you run reg key file separately from within EACH User Account if you have more than one?  (as the Hkey says “Current User”…)

      • #2607874

        The .reg file is a text file. The one linked above is for both HKCU (current user) and HKLM (local machine). Run it from an Admin ID. You only need the HKLM setting once. If you have multiple users, you can copy this to Notepad and “save as” DisableCopilotUser.reg (be sure the file is not .txt) to run from the other User IDs.

        Windows Registry Editor Version 5.00
        
        ‘[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\WindowsCopilot]
        “TurnOffWindowsCopilot”=dword:00000001`
        
        3 users thanked author for this post.
    • #2608021

      I’m running Windows 10 Home 22H2, so I want to know if the link ‘here is the registry key to disable Copilot in Windows’  in Susan’s  introduction (#2607335) will work for Win 10 Home, or only for Win 10 Pro.  I can see comments regarding Win 11 Pro and Win 10 Pro above, so I’m unsure as to whether the link will work for Win 10 Home, although this topic 9000001 is called ‘Blocking Copilot in Windows 10 and 11 Home sku’.

      Appreciate your guidance on this.

      regards

      GeoffB

      1 user thanked author for this post.
    • #2609753

      Thank you very much.

    • #2610430

      can you give me a link to the policy (gedit) change?
      Sorry.
      Thanks!
      Never mind:

      Windows key + R and enter gpedit.msc

      In Group Policy Editor, Navigate to the User Configuration > Administrative Templates > Windows Components > Windows Copilot > Turn off Windows Copilot. You should see multiple policies.

      In the Windows Copilot Settings, locate the policy, Turn off Windows Copilot, and Double-click on the policy to open and get the detailed view.

      - Thinkpad P15s Gen1 20T4-002KUS, i7-10510U, UEFI/GPT, 16GB, Sammy 500GB M.2. others. Mint 21.2 Xfce w Vbox-win10. Mint 21.2 Cinn Edge w wine. Win 11 Pro 23H2 WU(local, no Copilot, no Edge). HP laserjets M254dw & P1606dn, Epson 2480 scanner. External monitor Dell S3221QS.

      • #2610474

        can you give me a link to the policy (gedit) change?

        Hi krism:

        The title of this  KB article is “9000001 Blocking Copilot in Windows 10 and 11 Home sku“.  Susan has posted a separate KB article at 9000002 Blocking Copilot in Windows 10 and 11 Professional sku that includes instructions for disabling Copilot using the Local Group Policy Editor (gpedit.msc) in Pro editions of Win 10 / Win 11.
        ————
        Dell Inspiron 5584 * 64-bit Win 10 Pro v22H2 build 19045.3693 * Firefox v120.0.1 * Microsoft Defender v4.18.23110.3-1.1.23110.2 * Malwarebytes Premium v4.6.6.294-1.0.2201 * Macrium Reflect Free v8.0.7690

        1 user thanked author for this post.
      • #2641588

        Using Windows 10 home. gpedit.msc does not exist. No group policy edit anymore.

        • #2641637

          The Group Policy Editor has never been available in the Home Edition of Windows, only in the Pro Edition.

        • #2641670

          As @PKCano pointed out, the Home version doesn’t have Group Policy Editor so, to disable Copilot, you need to use the registry file which Susan provided a link to in her initial post.

    • #2610489

      So I downloaded and installed Susan’s link to disable Co-Pilot in Windows 10 and 11 in the registry before December updates. Easier than doing it myself.

      Will wait for all clear to update for December. Currently on pause until 1/5/2024.

      Expect all will be fine.

      Thank you Susan for no worries.

       

      HP Pavilion Desktop TP01-0050 – 64 bit
      Windows 10 Home Version 22H2
      OS build 19045.3930
      Windows Defender and Windows Firewall
      Microsoft Office Home and Business 2019
      -Version 2311(Build 17029.20108 C2R)

      1 user thanked author for this post.
    • #2610505

      Yes, we keep needing to come back to this and here it is!

      - Thinkpad P15s Gen1 20T4-002KUS, i7-10510U, UEFI/GPT, 16GB, Sammy 500GB M.2. others. Mint 21.2 Xfce w Vbox-win10. Mint 21.2 Cinn Edge w wine. Win 11 Pro 23H2 WU(local, no Copilot, no Edge). HP laserjets M254dw & P1606dn, Epson 2480 scanner. External monitor Dell S3221QS.

    • #2617724

      I downloaded the .reg file and when I ran it just got error message. See screen capture

      • #2617759

        If you have never opened the registry editor before, or have installed a fresh copy of Windows, it is possible that the Registry Editor may not have the necessary permissions to enforce its import/export capabilities.

        If that is the case, you can open the Registry Editor with admin privileges and use the import menu to merge the files.

        The steps to import a registry file with administrative privileges are:

        1. In the search bar, type the entry Registry Editor and right-click on the search entry, select Run as Administrator.

        2. At the UAC Prompt, select ‘Yes’ to grant the aforementioned Administrative Privileges to Registry Editor.

        3. Inside the registry editor, click on File. Select Import.

        4. Use this import menu to navigate to the location of the file you want to merge with your registry. Once you select the file, click on Open to merge it with your current registry.

        ‘Error Accessing the Registry’- How To Solve The Issue?

        3 users thanked author for this post.
        • #2617761

          2. At the UAC Prompt, select ‘Yes’ to grant the aforementioned Administrative Privileges to Registry Editor.

          For those who run routinely as a Standard User, a dialog box will open presenting the opportunity to enter the password of a member of the Administrators group.  Just selecting “Yes” will not suffice for a Standard User.

          Always create a fresh drive image before making system changes/Windows updates; you may need to start over!
          We were all once "Average Users". We all have our own reasons for doing the things that we do with our systems, we don't need anyone's approval, and we don't all have to do the same things.

          2 users thanked author for this post.
        • #2617801

          That worked – many thanks!

          1 user thanked author for this post.
          b
    • #2637582

      The Copilot appeared in my taskbar this morning, and now it’s gone thanks to this info — thank you!

      1 user thanked author for this post.
    Viewing 10 reply threads
    Reply To: 9000001 Blocking Copilot in Windows 10 and 11 Home sku

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: