• A bug with UBlock Origins 1.45

    • This topic has 28 replies, 6 voices, and was last updated 1 year ago by Picky.
    Author
    Topic
    #2497420

    I thought you would like to know that there is a bug with UBlock Origins 1.45.0, perhaps a regression.

    Similiar to 1.40 (I believe), filter list does not seem to work other than default. So an asset like Fanboy’s Social Annoyance will not work.

    The work around is to open the dashboard and either to add or remove an assert. Then apply the change and update. Then it seem to work as normal for a few hours.

    The bug may only shown up in older firefox (as in 1.40) such as Firefox ESR 68.

    Could anyone here please do me a favor and let the Raymond Hill know? I don’t have an account at Github. Thank you!

    Viewing 17 reply threads
    Author
    Replies
    • #2497493

      I use uBlock Origin with Chrome, Firefox esr, Edge.
      The latest version is 1.44.4

      https://ublockorigin.com/

      https://chrome.google.com/webstore/detail/ublock-origin/cjpalhdlnbpafiamejdnhcphjbkeiagm

      2 users thanked author for this post.
    • #2497494

      The latest version is 1.44.4

      Alex., your uBO link shows 1.45 as Picky & I do.

      On Filter Lists tab All my clock icons said out-of-date, clk to update ….ย  and all produced red triangles. Then Clk of — Update Now button — at top updated them all. Per Github posting, HOW .. does one confirm the Filter Lists aren’t working?

      W10 Pro 22H2 / Hm-Stdnt Ofce '16 C2R / HP Envy Desk-Ethernet - SSD-HDD/ i5(8th Gen) 12GB / GP=2 + FtrU=Semi-Annual + Feature Defer = 1 + QU=0

    • #2497511

      Version 1.45 only shows as available for Firefox. For all Chromium-based browsers it shows as 1.44.4.

      uBlock Firefox

      uBlock Chromium

      BTW, if you click the “Source Code” button (which takes you to Github) the latest version is 1.45.2 which was released yesterday.

       

      1 user thanked author for this post.
    • #2497557

      The easiest way of confirming that the filter list does not work is to open a browser (must closed the browser first) and go to any site using a bookmark. On the first page, it will looks like the filters are working fine. Then you go anywhere else on that site, you will notice that the non-default filters no longer work. For instance, the Fanboy’s Social Annoyance asset on the filter would no longer block any of icons for facebook or twitter.

      I hope this helps you ๐Ÿ™‚

      Oh, you don’t have to add or remove an assets if you could still update the filter list (you still need to do that if there is nothing to update). That would be sufficent to get it work as normal for a time.

      1 user thanked author for this post.
      • #2497623

        Oh I almost forgot.ย  If you updated the filter list before you close the browser, the filter list could still work when you reopen the filter.ย  It seems to vary from either the next time you open the browser (after you closed the browser) to about a hour.ย  I am uncertain how long it last if you keep the browser opened as it is my policy to close the browser at most after a few hours.

    • #2497638

      My Fx 102.4.0 ESR (latest version) on Windows 10 shows an available update to uBlock Origin from 1.44.4 to 1.45.0 released five days ago. uBlock Origin on my Fx was last updated on Oct 29.

      Edge shows that I ALREADY HAVE version 1.45.0. I have full control of extension updates when using Firefox but Edge updates extensions automatically (one reason Fx is my default browser).

      On Brave (which I use even less than I do Edge) current version of uBlock is 1.44.4 showing an available update to 1.45.

      The filter lists seem to work correctly on Fx and on Edge. However, I don’t use Edge unless I have a problem at a site when using Fx (unfortunately, that is fairly often) so there could be a problem with uBlock 1.45.0 on Edge that I am not aware of.

      • #2497673

        My Edge browser still has uBlock Origin 1.44.4.
        Chrome browser still has uBlock Origin 1.44.4
        Portable FF esr 102.4.0 updated to uBlock Origin 1.45

        • #2497686

          My Fx ESR is Portable Fx also. uBlock is the only extension showing an available update (to 1.45.x) when I tell Fx to check for updates to extensions.

          Gee….I left Edge open and minimized while I watched TV for an hour. Came back to the computer and uBlock has been updated on Edge to 1.45.2! I don’t like Edge and usually turn it off as soon as I have finished what I needed to do on it but this time I left it open for an hour while I watched TV.

          Since when did Fx ESR Portable start updating certain extensions withOUT Fx needing to be restarted? I went to about:addons to UBlock and saw a popup saying update available. The popup said I would need to reboot to finish the update. I hate that as I have a lot of tabs open.

          I switched to another tab for a short time, came back to Fx extensions tab and saw a NEW popup that said UPDATE NOW for uBlock. I clicked on that and it updated to 1.45.0 (NOT 1.45.2 that Edge auto updated to) and the instruction to reboot disappeared. That’s odd….why no need to reboot and why did it not update to 1.45.2?

          Aha! The uBlock update for Edge is a BETA version! And it is by Nick Rolls not Raymond Gorhill. And someone complained that the uBlock for Edge does not disable ads on MSN! I never visit that site so I have no idea what uBlock does there on Edge (or FX for that matter).

    • #2497689

      And someone complained that the uBlock for Edge does not disable ads on MSN!

      You can add your own filters to uBlock.

      I didn’t get any pop-ups on FF esr for uBlock. Just checked and it was 1.45.0

    • #2497759

      Like I said, I think the bug is for the older versions of Firefox like Firefox ESR 68. I believe Firefox 90s and above should be fine.

      I just wanted to report this bug as it is a regression of a same bug back in UBlock Origins 1.40 (I can’t recall the exact version number but I think was that) before it was fixed. I dunno if it is already fixed in the pending releases, neverthless I think Raymond Hill would like to know. I ask for a favor, please let Hill know as I don’t have account with Github or the support site for UBlock Origins?

      I hope that my instruction in mid-thread helped you ๐Ÿ™‚ I hope you will have a great day!

      1 user thanked author for this post.
    • #2498158

      My UBlock Origins was updated to 1.45.2 and sadly the bug was not fixed ๐Ÿ™ I even closed my browser and tried again. There are icons for social media displayed (as I have Fanboy’s Social Annoyance asset enabled that should have it blocked). I even then updated the filter list in case and closed the browser once more. I then reopened the browser and no joy.

    • #2498166

      My sincere apology for posting few posts in a short time ๐Ÿ˜ฎ

      The reason for me to post this now is that I finally found an issue on the support site.ย  The issue numbered as 1978 and titled as “1.41.2 update ignores my filters”.ย  Short into the comment section, especially to a poster named writting my ticket.ย  That is exactly the issue I am talking about.

      So this looks like a regression of a bug. Hopefully this will be easily resolved. Please let raymond Hill know.

      If you are curious, my filter list list stopped working the day my UBlock updated to 1.45.0.

    • #2498423

      Not seeing any issues here on FF 107 with uBlock Origin 1.45.2.

      But I have to manually update my filter lists on Chrome 107 using uBlock Origin 1.44.4.

      Windows 10 Pro 22H2

    • #2498494

      Hello guys ๐Ÿ™‚

      You know when I said this is a regression of a bug? I just want to let you know that I have found the thread https://github.com/uBlockOrigin/uBlock-issues/issues/1978 on github that described the things I have talked about.ย  You should also look a bit into comments especially those posted by anew742, one-way-ticket and fluffymormgeil.

      I thought you would like to know.

    • #2498666

      I do have admit to being frustrated with this bug/regression that has the filter list stopping work and it looks to be generic cosmetic filter related as it no longer hides any of blocked elements on the website. It works fine on the first page of any website after you open a browser but not afterward. While there might be a workaround via either updating the filter or adding/removing an asset, applying the change and then updating, it is annoying.

      This is in Firefox ESR 68 and any versions older than Firefox 90s. So it is likely that most people would not know of this issue. Hence me begging you to please let Raymond Hill know of this issue.

      I suspect the issue to be in removeparam commit as it was listed in release note of 1.45.0 and it is the same thing found to be an issue back in Feb in the thread I posted above. Something that Hill implied that Firefox 91 and above will handle fine but not below 91.

      I truly hope that this is of help to narrow in on the issue.

      I apologize for annoying you ๐Ÿ™ I do hope that you will have a great day! ๐Ÿ˜€

    • #2498771

      I am begging you to please at least post a link to this thread either on Github or at ublock origins section of reddit.

      I looked around in reddit and Github and I saw that a few people had similiar problem, especially on Firefox 78 ESR and Waterfox based on that esr. However, they seem to be off-tracked as their problems were unable to be reproduced. I believe I know where the problem may be and I believe this thread may be helpful to Raymond Hill and other people working on UBlock origins.

      Like I said, I believe the problem is mostly on older versions still supported by UBlock origins such as Firefix 68 ESR. This issue would be easily reproduced especially on 68 esr.

      So, please at least post a link to this thread I am begging you.

      My apology for annoying you. ๐Ÿ™

    • #2499838

      latest ublock version for Firefox and MS Edge should now be 1.45.2 instead of 1.45.0

      for Google Chrome & other certain Chromium browsers (like Opera), it’s still 1.44.0

      https://github.com/gorhill/uBlock/releases/tag/1.45.2

      Chromium: Submission pending

      The 1.45.2 version of Ublock origin for Chrome/Chromium did finally make it into the Google Chrome web store as of Sat. November 19, 2022.

      just got posted several days later on there

    • #2499996

      A wonderful news for you guys with older Firefox or Chromium, it looks like the cause to the bug is found. Here is the site,ย https://github.com/gorhill/uBlock/commit/9b3ad0702cbfadb586c251da6005d125e3567ad4 but unfortunately it is not released in stable channel yet ๐Ÿ™ still, it is relieving to know it has been fixed and work around found for now ๐Ÿ˜€

      Thank you for hearing me out! ๐Ÿ˜€

    • #2499999

      Oh I forgot to add for those who are not in mood of looking into the link I posted or the link from there (that has the workaround to be added to myfilter in UBlock dashboard), the problem seem to be a specific filter in AdGuard Base. So you could either disable that asset until the update, or add a filter in myfilter.

    • #2500262

      I would like to ask the mod of this forum, to please tag this thread as solved. The bug is no more, through either upcoming update or an effective workaround presented.

      Have a great day to you guys! ๐Ÿ˜€

    • #2500579

      I am begging you to please at least post a link to this thread either on Github or at ublock origins section of reddit.

      I looked around in reddit and Github and I saw that a few people had similiar problem, especially on Firefox 78 ESR and Waterfox based on that esr. However, they seem to be off-tracked as their problems were unable to be reproduced. I believe I know where the problem may be and I believe this thread may be helpful to Raymond Hill and other people working on UBlock origins.

      Like I said, I believe the problem is mostly on older versions still supported by UBlock origins such as Firefix 68 ESR. This issue would be easily reproduced especially on 68 esr.

      So, please at least post a link to this thread I am begging you.

      My apology for annoying you. ๐Ÿ™

      do you have an account with Reddit?
      their ublock reddit page is here

      edit – I also use Opera web browser and the Opera addons site still had offered the older 1.44.4 version of Ublock and recently posted the newer 1.45.2 version earlier today Nov. 23 on their addons page

      • #2500719

        No, I don’t have an account with reddit.

        I hope that your updated UBlock goes good for you. If you have a problem, try disable an asset known as Adguard Base and see if it resolve your issue.

        Have a great day! ๐Ÿ˜€

    Viewing 17 reply threads
    Reply To: A bug with UBlock Origins 1.45

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: