• a video is popping up when I click on a link in my e-mail, despite FF block

    Home » Forums » AskWoody support » Questions: Browsers and desktop software » Questions: Browsers and desktop software – other » a video is popping up when I click on a link in my e-mail, despite FF block

    Author
    Topic
    #2441434

    I am hoping that someone can give me some clues as to how I can keep a video from popping up when I click on a headline link in the e-mail that my local newspaper sends me.

    When I click on the link in the e-mail, I am taken to a page for the news article and at the same time a video pops up in the lower right-hand corner. I cannot play it, because my Firefox autoplay permission is set to block audio and video. Nevertheless, although this blocking is in effect, the video still pops up and covers part of the page that I would otherwise be able to read.

    Here’s the odd thing. If I access the newspaper URL in the FF address bar, a video never pops up because of the Firebox autoplay permission, which blocks audio and video.

    I am viewing my e-mail in Firefox and the e-mailed newpaper-headline link is also accessed via Firefox. But, there must be something in the headline link in the e-mail notification that triggers the video to pop up, even though it can’t be played. In other words, the FF autoplay permission blocking audio and video in this circumstance does not keep the video from popping up; it just keeps one from playing it.

    This has started happening recently … with the latest FF update.

    Is there an answer to keeping a video from popping up when clicking on a headline link in an e-mail?

    Viewing 4 reply threads
    Author
    Replies
    • #2441454

      You would need to block the code that loads the video and that is very specific so it may not be possible. I would try one of the blocking add-ons to see if it can block it, or use a bookmark that doesn’t have the video, then navigate to the page you want.

      cheers, Paul

    • #2441462

      I would try one of the blocking add-ons to see if it can block it,

      What blocking add-on (s) do you suggest to try?

      • #2441472

        Enable block pop-up setting.

        use add-on :
        Popup Blocker Ultimate

        Strict Pop-up Blocker

        • #2441520

          Enable block pop-up setting.

          use add-on :
          Popup Blocker Ultimate

          Strict Pop-up Blocker

          I already had the FF pop-up setting enabled. It wasn’t blocking the video though.

          I am using UBlock Origins, but I have not used it heretofore for tailoring blocking at a specific website. Flying by the seat of my pants, I tried a few things by clicking on the rogue video (which FF had blocked from playing) and then selecting “UBlock Origin’s Block Element” from the drop-down menu. I could select the video and by going through the list of elements and creating a filter, the video eventually went away.

          I think that selecting the ones that had ‘teal player’, ‘teal’, and ‘tavp’ in the name were the ones that worked.

          I’ll have to read more about UBlock Origins Block Element to better understand what I did. I can see the filtering that took place by going to the add-on, clicking on the 3 dots, clicking Options, and then selecting the “My Filtering” tab.

          All I can say at the moment is that it worked in that particular instance. And, when I went to the website later by clicking on a differnt link in my e-mail (which took me to a different news article at the same site), there were no pop-up videos then either.

          1 user thanked author for this post.
    • #2441560

      @WCHS

      What’s happening when you click the link for the story/stories in the email is that you’re taken to the story via a bit of redirection through a deal that the paper has probably made with a marketer in order to increase advertising revenue. The deal probably lets the paper insert code in the link in the email that makes FF display the ad from an external source. That coding is absent when you go directly to the story from the paper’s own web page.

      That coding may also allow the paper to track just how many clicks they’re getting from the emailed headlines, thereby helping them decide if it’s a worthwhile venture or just a waste of time and resources.

      One way I can think of aside from what you’ve already done with UBlock is to allow FF to only accept first party cookies when you know you’re going to be looking at articles via links in emails from the paper. The way to do that is to set FF’s Privacy & Security tab’s Enhanced Tracking Protection to “Custom”, put a check mark in the “Cookies” box and then select “All third-party cookies” from the drop down box that is next to the “Cookies” check box.

      In my experience, blocking all third party cookies has been a great way to also block ads from outside sites to the site I’m going to. On the other hand, it has occasionally “broken” some of the functionality of a few sites I’ve visited, but just a few. That’s why there’s the statement in parenthesis after the “All third-party cookies” about the fact that it may break some sites.

      2 users thanked author for this post.
    • #2441625

      @Bob99
      Yes, I am sure it was some kind of deal to increase the newspaper’s revenue. I clicked on the padlock next to the URL, clicked on arrow to the right of “Connection Secure”, clicked on “More information,” clicked on the icon for Media, and read there that the video had “Kanye West” in the title. And, that’s when I realized that the video had nothing to do with the headline I clicked on in my e-mail nor the text of the newspaper article, but was, instead, a way to get me interested in one of West’s recent albums. Of course, FF had blocked the video for playing, but it became apparent that my eyeballs were in demand!!

      Now, about the Custom setting and blocking third-party cookies. It looks like it applies universally to all websites one might view. I know that one of my health insurance websites displays a popup which says “Firefox prevented this page from automatically redirecting to another page” (which I allow). This ‘other page’ (is it a third-party cookie??) asks me a question (the question is not the same one each time) to verify my identity, when I log in. Unless there were a way to enter this URL as an exception, I don’t think the “Custom” setting will work.

      Or does the Browser Privacy > Enhanced Tracking Protection > Exceptions work no matter whether in Standard, Strict, or Custom mode?

      I still have your directions for setting up a FF block list and specifying the level, but so far, UBlock Origins is working and I don’t want to rock the boat.

    • #2441967

      Try the NoScipt add-on for Firefox, and set to allow only top-level site scripts. You may have to manually allow other scripts to get full functionality. Using AdBlock Plus will also help catch those annoying digital pestilences.

      "War is the remedy our enemies have chosen. And I say let us give them all they want" ----- William T. Sherman

      1 user thanked author for this post.
    Viewing 4 reply threads
    Reply To: a video is popping up when I click on a link in my e-mail, despite FF block

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: