• After 1709 the cursor stops blinking


    After updating to 1709, most of my applications will display a blinking cursor for about 6 or 7 times and then show it solid (e.g. notepad, Excel)

    However, Firefox will blink the cursor forever.

    Is there a registry fix that will allow the cursor to blink continuously for all applications?

    I have tried adjusting the blink rate and any mouse settings to no avail.

    Viewing 1 reply thread
    • #312359

      Perhaps it would help to update the mouse drivers to be sure they are compatible with your version of Win10.

      • #312420

        Oops! I thought clicking the email link would bring back my Forum ID. Anyway the Anon response was from me.


      • #312416

        PK, I use a Logitech mouse and have the same problem on all my computers with models: LX6, m510, m325 and m310. I have tried several versions of the Logitech Setpoint software, including the latest Logitech Options software for the m510 mouse I just purchased.

        I experience the same problem on all computers including 1 laptop.

        I have Googled the problem and tried all suggestions that were found to no avail.


    • #316804

      I just installed Windows 1803 on my laptop and the Cursor stops
      blinking in about 5 seconds just like it did with Windows 1709.

      I did some more investigation and found that there are a few
      registry entries that control the cursor. They are found at:

      [HKEY_CURRENT_USER\Control Panel\Desktop]

      The first is the “CaretTimeout”. It is the time in milliseconds that the cursor will blink.
      The default is 5000 milliseconds (i.e. 5 seconds).

      “CaretTimeout”=dword:00001388 (5000)

      I changed it to 720000 milliseconds (12 hours) and now it blinks continuously.

      “CaretTimeout”=dword:000afc80 (720000)

      Another cursor function of interest is the “CursorBlinkRate”
      The default cursor blink rate is 530 milliseconds between blinks.


      I like a faster blink of 300 milliseconds between blinks so I set it to:


      This can also be set from the Control Panel – Keyboard applet by moving the
      slider to set the blink rate.

      Another cursor function is “CaretWidth”. The default is 1 pixel wide.
      Setting it to 2 or 3 can make the cursor stand out more.

      “CaretWidth”=dword:00000001 (1)

      I created a .reg file with these new entries so I can patch any new Windows release.

      I hope this will be of value to others.

      3 users thanked author for this post.
    Viewing 1 reply thread
    Reply To: After 1709 the cursor stops blinking

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: