News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • AOMEI Backupper

    This topic contains 3 replies, has 4 voices, and was last updated by

     Ascaris 2 months, 4 weeks ago.

    • Author
      Posts
    • #330768 Reply

      Barry
      AskWoody Plus

      Wondering if anyone out there uses this software? I just discovered it a while back and it seems to work great. Pro’s and Con’s ?

      never been a fan of Macrium and AOMEI seems far simpler.

       

      Barry (Seeker)

    • #330770 Trash | Reply

      PKCano
      Da Boss

      I use Aomei Backupper File Sync function for non-image file and folder backup. I backup to a NAS drive, The files and folders are not in an image and are accessible from any computer even without the software installed.

      I use Acronis for image backup and restore. I always image from the boot media and do not install the software on the computer.

    • #330790 Trash | Reply

      Rick Corbett
      AskWoody_MVP

      I used Redo Backup for a long time up to Nov. 2014. I was pleased with its simplicity, less so with its speed and size of the backups (they were massive!). I looked around, tried CloneZilla then quickly settled on AOMEI Backupper.

      I loved its simplicity and ease-of-use. I used it for just over 2 years to backup/restore no end of devices but then ran into a series of problems trying to get it to work with a couple of HP netbooks. It worked with the HP Mini 2133 but, no matter what I tried, I could not get my USB boot stick to work with later models like the HP Mini 2140 (and Samsung NC-10).

      At the time I found some of the documentation a little hard to understand and – whilst they tried very hard – I found myself explaining the same things over and over again to different  Backupper support via email. The emails got longer and longer because each time I sent an email a different support person answered and I went through “So-and-so asked me that 4 emails ago and my reply at the time is attached…”. It was obvious that each new support person just attempted to answer my latest email without reading any of the earlier attachments. I spent ages writing detailed emails with screenshots trying to explain the issues simply, not easy when the screenshots (of BIOS settings, etc. of differnet devices) were taken with a camera and the time it took to edit them.

      There was also a fair amount of ‘Do you mean…”. That’s fair enough… I don’t speak a word of Chinese so the support staff I was in contact with did fantastically well in conversing with me. Unfortunately we didn’t appear successful at the time in understanding each other, I was under pressure, impatient and not making any progress towards increasingly tight deadlines… so I looked around for an alternative.

      I tried Acronis True Image and quickly realised that I didn’t understand it. Everything just seemed too complicated and I was too lazy and in too much of a hurry to study. After a recommendation by RetiredGeek in the Windows Secrets Lounge forum I tried Macrium Reflect… and all of a sudden I could backup/restore the netbooks that I couldn’t with Backupper. Yay!

      I’m used to Macrium now and wouldn’t change. It handles everything I throw at it and I’m fully confident in its restores. However, if Macrium was no longer available for whatever reason then I would head back to AOMEI Backupper as my first port of call. I have very fond memories of its simplicity – I like simple – and have no doubt it has overcome the issues I experienced so long ago. My lasting impression was that, when it worked – and it did 95% of the time flawlessly – it was great, better even than Macrium IMO for ease-of-use. It was just that 5% support problem that I found insurmountable at the time.

      Hope that goes a small way to answering your question, even though I don’t have current experience of Backupper.

      1 user thanked author for this post.
    • #330847 Trash | Reply

      Ascaris
      AskWoody_MVP

      Macrium Reflect’s UI is needlessly complex and unintuitive.  Still, it works, and since I am not actually in there using its UI all that often, I can live with the bad UI.

      That said, I’ve used Aomei in conjunction with Macrium Reflect, for one specific reason: Reflect’s free edition does not enable the backup encryption function, and I wanted encrypted backups.  That feature has been removed from Backupper Free now too, so there’s not much point to me using it now.  It does still allow incremental backups, which is another thing Reflect Free won’t do (it does only full and differential), but that’s a fairly minor thing for me.

      I’ve used Backupper to create and restore backups numerous times, and it has generally worked okay.  There have been minor issues, but I haven’t tried backing up a purely Windows system for some time.  Both Backupper and Reflect are supposed to be compatible with Linux filesystems, and indeed, they do work, but after restoring, it’s sometimes taken a little jiggling to get things working again with Backupper.  Things like messing around with the UEFI settings, reinstalling GRUB, or other such things.  It’s not a huge deal for me, and it was worth it to get the encrypted backups, but now that they’ve removed that, I can only use the older Backupper free versions (I think prior to 4.5) or skip that feature. Without the encryption or updates, I’d rather just use Reflect.

      Aomei Backupper has had a few rough edges that I did not see in Reflect.  If the backup has to stop because the target device is full, it gives only a short time (a minute?) before it decides that the entire backup is a failure and cancels it.  Or, I should say, that’s how it was with the versions I used, prior to 4.5, I believe.  There have been other failures to complete the backup process on those older versions for various reasons, and when it failed, it just gives an obtuse error code (whose meaning doesn’t get much clearer once I looked it up at the Aomei site) rather than a description of what happened.  Whether this is still an issue in newer versions is a question I cannot answer.

      I’ve also had some issues with Acronis True Image, which I have been a user of for many years, having bought at least six or seven licenses over the years.  It got so buggy that I looked for alternatives, and that’s why I ended up trying Reflect and Backupper in the first place.  As with the other two programs, I have used it as a fully installed program from within Windows to create the backup images, not from the bootable USB/DVD.

      As I see it, there are three classes of errors in a backup program.  All are serious, but the first two can be somewhat forgivable.  The first one is when the program fails to create a successful backup, and lets you know about it.  If you can eventually work around the error and get it done, and if the image it eventually creates is usable, I can let that go.

      The second one, failing to restore perfectly from what appears to be a valid image, can be tolerable to me if it happens in a predictable way and I can eventually make it work.  The thing I had where I had to mess with the bootloader and GRUB to get the system working again after a restore was this kind of error.  I knew what to do, and the kind of issue it produced was predictable, so it wasn’t an instant-rule out.  Backupper was the only backup program I tried where the backup speed didn’t slow to a crawl with encryption on, so I was willing to tolerate a few predictable, fixable issues while that feature existed.

      The worst kind of error, the one that is totally unacceptable, is for a backup program to appear to have succeeded with a backup, but where that backup image is actually corrupted and unusable.

      I did have my first failure with Reflect on restore the other day that may have been of that type.  It was nothing serious, fortunately… I wanted to restore the Windows 10 image I’d taken of my Swift laptop when it was new (keeping in mind that the only thing I use Windows 10 for is to run Reflect to back up Linux drives), and when I plugged in the external HDD containing the image, it failed to restore.  I was able to copy the image to another drive and verify the hash, indicating a successful copy, but Reflect insisted that the image was corrupt.  I don’t know how it happened, whether Reflect messed up on the image write or whether something else happened, but it didn’t work.  Had that been for something important, I would have been pretty angry.

      That’s an anomaly, though, as I’ve been using Reflect (and restoring pretty frequently) for some time without seeing that before.  I didn’t have any indication of it being a disk error, but I’m still leaning toward that being the most likely explanation.  There were errors on the volume that were corrected, but the image is still corrupt.  I just don’t know for sure what happened.

      Had that backup been important, I would have made other backups on another drive, which I do regularly for my normal backup routine.  I have 11 TB of storage in my backup server and another 5TB in external drives (with another 4TB that was supposed to be available for pickup yesterday at a certain big box retailer, but wasn’t) that I use for that purpose.  I keep backups on multiple drives in the backup server and also on an external drive, which is unplugged and offline when not in use.

       

      Group "L" (KDE Neon User Edition 5.15.5 & Kubuntu 18.04).

      2 users thanked author for this post.

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: AOMEI Backupper

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.