• AT&T Router “Can’t connect to this network”

    Home » Forums » AskWoody support » Windows » Windows 10 » Windows 10-other » AT&T Router “Can’t connect to this network”

    Author
    Topic
    #2528285

    I hope this is the correct place to post this.

    Title too long- This error message for a device that previously was connected to that network.

    I recently (~2 months ago) upgraded from DSL to Fiber thru AT&T which resulted in a new AT&T router model BGW 320. All settings from old router were transferred to the new router including my WiFi access password. All WiFi devices connected to the new router using the old preset password including this laptop. Not all devices connect on a daily basis.

    About two weeks after the switch, my wife’s Windows 7 lost WiFI connection and all attempts (restart network adapter, delete and manually create a connection) to set up the connection result in message. All other devices connected to the router via WiFi were working and the WiFi on the Windows 7 was working as it was able to connect to the WiFi hotspot on my iPhone. Thus the router was the only thing preventing connection to specifically this device. I resolved this by hooking the Windows 7 vis Ethernet cable. Never got the WiFI to connect.

    About 2 weeks after that my MSI Windows 10 (Home 22H2) laptop did the same thing. I did a search for fixes and came across an article that said to push a “connect” button (two curved arrows making a circle under the white connection light) while manually setting up the WiFi connection. That worked or it just started working and connects every time I boot it up.

    Now my Dell Windows 10 (Home 22H2) laptop which I don’t boot up very often and used to auto connect when I boot up is doing the same thing and giving the “Can’t connect to this network” message. All attempts including pressing the connect on the router while manually connecting.

    When this happens all other devices are still connected. I’ve checked the connected setting in the connected laptop and they are the same. The Dell that can’t connect to the network can connect to other WiFi networks. I have the Smart Phone App from ATT and it shows both the Windows 7 and the Dell as a previous connection but with no way to reconnect in that app (which is the only reason I installed it).

    This is clearly the Router preventing connection to previously connected to devices.

    I would appreciate any help to resolve this as after a long time with AT&T support and their prompt screen of what to do next I got the contact the laptop’s manufacturer for help because the “router is working since my other devices are connected.”
    I need to find out why the router won’t allow these devices to connect and how to correct that problem.

    Thanks for any help.

    HTH, Dana:))

    Viewing 7 reply threads
    Author
    Replies
    • #2528295

      I need to find out why the router won’t allow these devices to connect and how to correct that problem.

      How about looking through the unit’s manual to see how to disable its built-in WiFi and use your own WiFi router behind the ONT?

      I seem to recall several folks here doing just that when their ISP gave them a modem/router combo device. Doing so would obviously entail figuring out the RIGHT way to connect the router behind the ONT through the correct configuration of the router’s settings and using a cat6 cable connected to the correct port on the back of the ONT and the WAN port on the router.

      It almost sounds like AT&T is pushing out updates to the ONT that are messing with the wireless network capabilities of it, thereby dumping a different one of your computers from the wireless connection it’s enjoyed.

    • #2528296

      I like @Bob99 ‘s idea of using your own router if you can log in to the Att one and turn off WiFi. But otherwise….

      Just throwing out some ideas you’ve probably already checked.

      Sounds like the Router has WPS enabled (push the button to connect).

      I assume you tried setting a fixed IP address in the Router’s range for the ones having trouble?

      Also compare the IPv4 and IPV6 settings on the ones do connect and the ones that do not. In the past (probably not the case with a new Router) IPv6 had to be turned off. Also, while in the network card info, compare the Status\Detail info.

      Can you ping the Router from the non-connects?

    • #2528351

      How about looking through the unit’s manual to see how to disable its built-in WiFi and use your own WiFi router behind the ONT?

      AT&T doesn’t provide even a downloadable manual but did get one from the actual manufacturer’s web site.  I don’t have a WiFi router to hook behind the ONT.

      Sounds like the Router has WPS enabled (push the button to connect). I assume you tried setting a fixed IP address in the Router’s range for the ones having trouble? Also compare the IPv4 and IPV6 settings on the ones do connect and the ones that do not. In the past (probably not the case with a new Router) IPv6 had to be turned off. Also, while in the network card info, compare the Status\Detail info. Can you ping the Router from the non-connects?

      Yes, the router has WPS.  Not sure what to do on the Dell LT to get it to respond to the WPS.  When I try press Connect on the PC when the WPS is active, it fails to connect.  Maybe I’m pressing the wrong thing during the WPS cycle.

      I don’t know how or what IP address I should assign.  Currently set to Automatic (DHCP).

      I’m not sure how to ping a router (what IP address do I use?).

      New development:  In investigating the router’s connection I found that the Windows 7 PC is now connected via WiFi in addition to its Ethernet connection.  It appears that the automatic connect settings which were still there are now suddenly accepted by the router.  Follow up by AT&T support (they called me) and because of the erratic behavior of 3 different PCs, they will be sending me a new router.  Will post back if the new router fixes the problems.

       

      HTH, Dana:))

      • #2528365

        You should get them to send you a “modem only” so you can purchase a Router and manage your own network.

        BTW, WPS is not secure.

    • #2528463

      BTW, WPS is not secure.

      But if you only use the push button and check that only your device made a connection it is fine. Do NOT use a PIN for WPS.

      cheers, Paul

    • #2529138

      The device ATT gave you is a computer. Log into it and look for any logs it may have. There may be error messages in these logs. ATT should be able to tell you how to log into the box. Its often at 192.168.100.1, but not always. Probably need a password too.

      Guess: It could be that the ATT box is enforcing a max number of connected Wifi devices. A number of routers offer this feature.

      WPS comes in multiple flavors which is why you are getting confused. They are all best ignored. In fact, it is best to disable WPS in the ATT box.

      For the long term, I agree with others here, getting your own router is the way to go. ATT will always provide cheap software and cheap software is never good software.

      Get up to speed on router security at RouterSecurity.org and Defensive Computing at DefensiveComputingChecklist.com

    • #2529655

      Thanks for everybody’s help. I will relate how I resolved this problem. At least it appears to be resolved.

      I had tried:
      Resetting the network adapter on the Dell laptop
      Deleted and manually setup up the Wi Fi connection settings
      Reset the modem/router – several times

      None of the above worked. Accessed the router’s history which showed that all the devices that had problems did have a prior connection. I did not look at the router logs at that time and viewing the logs now only goes back since the problem has been fixed so no errors listed in the logs. ATT did not know what the problem was so agreed to send me a new router (because they didn’t know what else to do).

      The next day before the new router arrived the Dell automatically connected to the router when booted up.. Thinking this was a fluke, I performed several power off/on which resulted in the Wi Fi connecting sometimes and many times not connecting. With the Auto connect set the Dell connects to the Wi Fi before the logon screen appears. I notice that once the connection fails in the boot process you can’t manually connect and it even removes that Wi Fi source from available sources to select from (I have to go into the Settings to show all available networks to see the router Wi Fi). I disabled the auto connect so the Dell could boot up and not try to connect to the router. When I manually click Connect to the router I noticed it took a long time for the connection to connect. When it took longer the connection would fail. When I observed this the little light bulb above my head clicked on. I had solved this for someone else a very long time ago only that was with a single device.

      The 3 devices that had trouble with Wi Fi connecting are 2 laptops and 1 desktop using an USB Wi Fi adapter. Laptops by default set the performance of a Wi Fi adapter to the lowest level to conserve the battery to have a longer “on battery” time for the laptop. The poor performance of the Wi Fi adapter was close to “timing out” causing the router to block this connection if it timed out. I checked the network adapter’s performance setting on the MSI laptop which no longer has the connect problem which caused me to remembered that this is one of the many settings I changed on the MSI to fix its connection problem. I had thought is was one of the other changes I made that fixed the problem. Thus, increasing the network adapter’s performance to maximum had corrected the connection problem with the MSI laptop.

      I changed the network adapter’s performance setting on the Dell laptop. Since then thru many power off/on bootups (auto connect and manual) it connects every time. I also noticed that the manual connect is a lot faster.

      Appears that the Wi FI connection on the desktop using the USB Wi Fi adapter (very old and a cheap one) is still erratic with connect and not connect on boot ups. Not concerned as I have that desktop hooked up with Ethernet.

      It appears that the performance of the network adapter affects the time it takes to make the connection and if it takes too long the router will time out and not allow a connection. I don’t know this for a fact…just drawing conclusion of what I observed.

      Anyway, changing the performance setting of the Wi Fi adapter to maximum has resulted in a Wi Fi connection each time I boot the laptop up.

      BTW: ATT sent me a different model (which was a older, lower quality).  I sent it back unopened.

      HTH, Dana:))

    • #2530544

      Anyway, changing the performance setting of the Wi Fi adapter to maximum has resulted in a Wi Fi connection each time I boot the laptop up.

      Where did you find this setting?

    • #2530576

      Where did you find this setting?

      In Windows 10:
      Open the Power Options control applet – Open a Run box (WinKey + R) enter powercfg.cpl and press the Enter key.
      The current selected power plan will have have the radio button filled in with a black dot. To the right of selected plan click Change plan settings which will open the Edit Plan Settings window.
      In this Edit Plan Settings window click Change advanced power settings which open the Power Options Advanced setting window.
      In the Advanced settings box click the + sign next to Wireless Adapter Setting and then click the + next to Power Saving Mode to expand that setting.
      Under the Power Saving Mode you will see Setting: with the current setting in blue.
      Click this current setting and a drop down list will show the various settings to choose from Maximum Power Saving (weakest) to Maximum Performance. Select the setting you want, click OK, and close the control applet.
      You will need to reboot for the changes to take effect.

      If you have problems with my instructions , let me know and I’ll do a screen shot set of instructions. This setting is really deep.

      Also similar to the Adapter performance setting on laptops, there is a setting to increase the signal reception of the wireless adapter which also uses more power but increases the reception of the Wi Fi signal.   Not an issue in my situation but helps a lot when you are on the edge of a Wi Fi range and helps stop lost connections due to weak signals.  Let me know if you desire instructions to change that setting (in a different place).

       

      HTH, Dana:))

      1 user thanked author for this post.
    Viewing 7 reply threads
    Reply To: AT&T Router “Can’t connect to this network”

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: