• Attempt to start Office 2016 programs fails with error 0xc0000142

    Home » Forums » Newsletter and Homepage topics » Attempt to start Office 2016 programs fails with error 0xc0000142


    I’m stumped. Any time I try to start one of my Office programs, I get I’m running Office Pro Plus 2016 version 16.0.13029.20344 on Win10 version 1909.
    [See the full post at: Attempt to start Office 2016 programs fails with error 0xc0000142]

    2 users thanked author for this post.
    Viewing 13 reply threads
    • #2290937

      I usually uninstall and reinstall when these annoying issues happen. Best of luck sir.


      1 user thanked author for this post.
    • #2290940

      Why use Google Docs and not LibreOffice (portable) ?

    • #2290945

      looks like you’re not the only one with office issues..
      MS Office 365 issues

      Win8.1/R2 Hybrid lives on..
      2 users thanked author for this post.
    • #2290954

      Is there an internet infrastructure problem today in the US? The maps of Zoom and Office outages look pretty similar. Maybe it’s just coincidence and that most users of both are clustered in the same places, but still…

      3 users thanked author for this post.
      • #2290963

        Those maps always look the same to me…

        1 user thanked author for this post.
        • #2291146

          It is known, that Zoom has serious problems nowadays, seems that its infrastructure was not ready for such large numbers of users. Dunno what is happenning to maps to be honest.

          Dell Latitude 3420, Intel Core i7 @ 2.8 GHz, 16GB RAM, W10 22H2 Enterprise

          HAL3000, AMD Athlon 200GE @ 3,4 GHz, 8GB RAM, Fedora 29

          PRUSA i3 MK3S+

          1 user thanked author for this post.
    • #2290972

      Any idea that this may be related to some recent Office 2016 patches?

      This issue might concern all users of Office 2016, regardless of which OS they are running. I have Office 2016 in my Mac working just fine, but have not installed, yet, this month’s patches. I usually do this a week before the following month’s Patch Tuesday. The patches might not be always quite the same for both versions (Mac and Windows with Intel CPUs) but they should have plenty in common.

      Office 2016 for Macs reaches EOL this October 13th, but not Office for Windows PCs, so this problem should be unrelated to that.

      Ex-Windows user (Win. 98, XP, 7); since mid-2017 using also macOS. Presently on Monterey 12.15 & sometimes running also Linux (Mint).

      MacBook Pro circa mid-2015, 15" display, with 16GB 1600 GHz DDR3 RAM, 1 TB SSD, a Haswell architecture Intel CPU with 4 Cores and 8 Threads model i7-4870HQ @ 2.50GHz.
      Intel Iris Pro GPU with Built-in Bus, VRAM 1.5 GB, Display 2880 x 1800 Retina, 24-Bit color.
      macOS Monterey; browsers: Waterfox "Current", Vivaldi and (now and then) Chrome; security apps. Intego AV

      1 user thanked author for this post.
      • #2290974

        That’s the main reason why I posted here. I haven’t heard any additional cries of pain, so assume it was just some odd one-off thing.

        1 user thanked author for this post.
    • #2290976

      A quick check, starts up Office 2016 Pro; Word and Excel; also I am on 1809 Pro.

      You are on the Current Channel 2007 while I am Semi-Annual Enterprise Channel 2002 (currently same as Semi-Annual Enterprise Channel Preview) . I was on Current Channel 1910 until I found out about the commands below.

      This will change you to Semi-Annual Enterprise Channel which should be more stable but I think it is a modification of your version of Office. I think it is a semi-re-install. I did this change on a relative slow high-speed connection (guessing less than an hour.)

      Here are the commands from Susan Bradley’s article – execute 3 command lines:
      cd C:\Program Files\Common Files\Microsoft Shared\ClickToRun\
      OfficeC2RClient.exe /changesetting Channel=Broad
      officec2rclient.exe /update user updatetoversion=16.0.12527.20988

      updatetoversion=16.0.12527.20988 get you to Office 2002 (2020-02)
      updatetoversion=16.0.11929.20934 get you to Office 1908 (2019-08)

      You can choose the Microsoft Office version at https://docs.microsoft.com/en-us/officeupdates/update-history-microsoft365-apps-by-date

    • #2290996

      I have Office 2016 Pro Plus 16.0.13029.20232 and it’s working fine.  I don’t have much bandwidth so don’t update it often but it always works so I see no reason to.

    • #2291039

      Woody, the 0xc0000142 error code is listed as STATUS_DLL_INIT_FAILED:

      {DLL Initialization Failed}
      Initialization of the dynamic link library %hs failed. The process is terminating abnormally.

      Office programs attempt to load multiple libraries upon execution and may fail to start during the process if one of those libraries in the memory chain is unable to load.

      The “corrupted” library (“restored” by the sfc /scannow command) might be an older version (included in a botched update that incorrectly replaced a newer one) or a library tied to the online licensing verification mechanism (which would explain why an Office365 outage could cause the issue and then suddenly, out of the blue, everything starts to work again with no apparent reason).

      Your C:\Windows\Logs\CBS\CBS.log file contents (recorded after the sfc /scannow execution) might shed some light to identify the culprit and, eventually, the reason why that specific .dll file failed to load successfully.

      • This reply was modified 3 years, 3 months ago by Speccy. Reason: Fixed bold tag
      1 user thanked author for this post.
    • #2291046

      Office Professional Plus 2019 (Version: 2007 – Build: 13029.20308 Click-to-Run)
      Windows 10 Professional (1909 – 18363.959)

      I have what appears to be a very similar problem which has been intermittent over the last few months.

      On occasion when I open up something like Excel or Word, I initially have the orange box telling me that it is trying to update.  This I can guarantee will end up with the same error message you described.  Nine times out of ten, if I reboot… the program will start fine – rarely will I need to do a second reboot.

      I have tried the ‘Quick Repair’ and ‘Online Repair’ by going through Settings and then Apps which makes no difference whatsoever – the problem will eventually occur again.

      My next attempt will be a complete uninstall and reinstall of Office probably on the first day of the month when I normally create images of my system.

      What puzzles me though is that within Office, I have specifically switched off ‘Enable Updates’ so why is this trying to run an update anyway?!

    • #2291141

      I read somewhere (can’t find it now) that a Microsoft update was causing some issues. Not sure if it was an Office update or Windows. Seems like Office just got some updates recently?? As for using Google docs, I think that model has as many potential issues being a cloud based service. I don’t think anyone of these services claims 100% uptime or has provided a perfect record of stability to all customers. As the old saying goes Stuff Happens!

      [Moderator edit for language]

      1 user thanked author for this post.
    • #2291145

      Did you try to launch it in “safe mode”? CTRL+doubleclick to launch Excel?

      Dell Latitude 3420, Intel Core i7 @ 2.8 GHz, 16GB RAM, W10 22H2 Enterprise

      HAL3000, AMD Athlon 200GE @ 3,4 GHz, 8GB RAM, Fedora 29

      PRUSA i3 MK3S+

    • #2291232

      I too see this error on a semi-regular basis.  I open an Office app, I get the orange updating box and then the error.  Or sometime it cuts out the middle man and goes straight to the error.

      When it happens I fix it as follows:

      • open Task Manager
      • look under ‘background processes’
      • find the entry for ‘Microsoft Office Click-to-Run (SxS)’
      • end task / stop service
      • open an office app, which is a bit slower than usual  because it is restarting the service that’s just been stopped
      • app opens as normal
      • all is well – until the next time it happens


      Win 10 1909 (build 18363.959) and Office 2016 Pro Plus Version 2007 (build 13029.20344 click to run)


      1 user thanked author for this post.
      • #2303665

        Thank you very much!!! This not only worked but was a FAR better solution than “reformat your hard drive” and similar such answers.


    • #2292082


      next time you do the restart, try to use CMD and “shutdown -r -t 0 -f”

      This will avoid the use of “fast startup” which can mess things up if it stores a invalid application state.

      Never the less my problem for several weeks is that after some up-time (days) the RPC services stop responding and I am not able to start things like services.msc while other “old style” programs do run just fine.


    • #2292083

      Oh and for those who dont know how to disable Fast startup, watch Mike’s video:


    Viewing 13 reply threads
    Reply To: Attempt to start Office 2016 programs fails with error 0xc0000142

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: