News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Audio issues in Windows 10 1909

    Posted on MarcVRML Comment on the AskWoody Lounge

    Home Forums AskWoody support Windows Windows 10 Windows 10 version 1909 – November 2019 Update Audio issues in Windows 10 1909

    Topic Resolution: Not a Question

    This topic contains 1 reply, has 1 voice, and was last updated by  MarcVRML 1 month, 2 weeks ago.

    • Author
      Posts
    • #2014967 Reply

      MarcVRML
      AskWoody Lounger

      I’m resigned to the problem as there is an annoying workaround, but I wanted to share my experience in the forum anyway.

      Windows 10 1903 and 1909 both suffered from audio issues related to Dolby Atmos when combined with the nVidia High Definition audio device used when you link an external a/v amplifier up to your PC via HDMI.

      If you have set Atmos up, it requires the following to work:

      1. Compatible HDMI connection to an ATMOS capable receiver.
      2. Audio Enhancements to be activated, with “channel phantoming” set to on.
      3. Atmos selected in both the Spatial Sound tab and the Advanced tab in audio properties.

      Note that the above is set up automatically upon first-install of Atmos and introducing the Dolby Access Windows Store App.

      And it works. All well and good.

      However, if you resume from sleep, or shutdown and restart, the audio settings are silently changed upon rebooting, so that audio enhancements become automatically disabled. This has the effect of turning off Channel Phantoming, and thus turning off Dolby Atmos. However, this also has the nasty side effect of turning OFF all audio, despite showing it to be working.

      The workaround to this is as follows. Upon experiencing this problem :

      1. Right-click the windows desktop and open the nVidia control panel.
      2. Click on the “set up digital audio” option on the left panel.
      3. The page that appears will show the name of your a/v amplifier in the pulldown. Select the pulldown and choose “turn off audio”.
      4. Wait a few seconds.
      5. Now click the panel and re-select your device.
      6. Right-click the windows audio icon in the system tray bottom right of your desktop.
      7. Choose “Dolby Atmos” from the list of modes.
      8. Right-click the windows audio icon in the system tray again.
      9. In the flyout for speaker setup, click “advanced setup”
      10. When the advanced setup dialog opens, select the external receiver your HDMI is connected to (mine is shown just as AV Receiver).
      11. Click “properties”.
      12. Verify that spatial sound and Advanced are both now set to Atmos.
      13. Verify that Enhancements are enabled, and Channel Phantoming is set to “on”. If they aren’t, make these corrections by removing the checkbox in the “disable all enhancements” setting, and then put a check in channel phantoming.
      14. Click OK.
      15. Now click the device again and choose “configuration”. It will show a top down plan of your speaker setup.
      16. Click a speaker to verify it works. For me, this now resolves things (until the next sleep or reboot).

      A final note about that horrible delay that occurs when using HDMI audio which tends to clip off the start of the audio prior to playback whilst it wakes up your a/v amp with live data. Windows SHOULD be generating a keepalive signal on the HDMI which prevents the amp sleeping. It doesn’t. This is a bug. However, there are a couple of applications that can be installed which address the problem.

      1. Soundkeeper
      2. SPDIF-KA

      If you choose to use either of these solutions to keep the audio channel open, bear in mind that you will need to kill their processes BEFORE executing the steps above to restore your audio.

      I can report that this problem ONLY occurred after the update to 1903 / 1909. I was on 1803 for a few months and didn’t see this issue, and on 1709 prior to that for a couple of years (thanks Woody) whilst chaos erupted in future updates around me and experienced zero problems. In fact, for my setup, I have yet to see a more stable windows build than 1709 – it just did everything I needed it to, and I miss it!

      I hope this helps others suffering as I am, and also brings awareness to the issue, as I feel it’s an underlying problem with the audio subsystem itself and is doubtless responsible for several other audio-related issues perhaps unrelated to Atmos, but nonetheless frustrating for several users.

      Best,

      Marc

      1 user thanked author for this post.
    • #2014968 Reply

      MarcVRML
      AskWoody Lounger

      One additional note which may be important : In my case, I use Dolby Atmos in a 5.1.4 configuration. That is to say, 5 main speakers, 1 subwoofer, and 4 height speakers.

      Hence why channel phantoming, to redirect the missing back surrounds, is necessary. If someone else is still experiencing issues with a full stack and without the need for phantoming at all, then this would indicate an even more mainstream audio glitch with the 1909 code.

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Audio issues in Windows 10 1909

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.