News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • Battery, Power Management Questions

    Home Forums AskWoody support Windows Windows 10 Questions: Win10 Battery, Power Management Questions

    • This topic has 39 replies, 5 voices, and was last updated 1 month ago.
    Viewing 15 reply threads
    • Author
      Posts
      • #2347759
        LHiggins
        AskWoody Plus

        Hello,

        This is a followup to the discussion about my USB mouse/ Sleeps issue on my HP Win 10 V1909 laptop. After that discussion here and one with my computer tech, I still have a few battery and power management questions.

        In short, the issue was a black screen/not waking from sleep till the USB mouse adapter was either removed or plugged in – triggering the wake up.This is a relatively new issue – possibly since the last MS updates in early Feb – before that it worked fine for both sleeping and waking.

        To try to correct that, both my tech and here at AW, it was suggested that I just disable the sleep function as that seemed to be the cause – some glitch in the wake part of the sleep setting.

        So – I have turned off all sleep functions – just have the display set to turn off after inactivity. But this has brought up several battery/power related questions that I hope someone can help with.

        1. Will keeping the laptop on the charger for long periods – like overnight – or other times when I would usually let it sleep, cause battery issues?
        2. Is there any difference between setting up the sleep options in power management versus just manually clicking sleep in the start button? Would doing it manually change anything in the way it responds to waking up?
        3. I believe I had it set to wake when either the keyboard or the mouse were disturbed – should that possibly be changed?
        4. Are there settings to check to minimize the battery draining when idle but not sleeping?
        5.  Is there any other “trick” anyone knows for waking a laptop that is sleeping and will not respond?
        6. Could this issue be caused by KB4535680? I was just checking the installed updates, and saw that it is listed twice in my update list. I am very careful to only install the recommended ones, and have that KB on my NOT list for February – but it is there already installed twice. At the beginning of Feb, I thought I had installed the Jan updates: KB4598229 and KB4598479, but only 4598229 is listed along with 4535680. Should I uninstall that one? Might it have been the cause of this issue all along?

        I am concerned about allowing the laptop so just sit there, but not sleep, for the times when I am not using it during the day – sometimes several hours at a time. I don’t mind keeping it plugged in overnight, but I don’t want to have it run on AC power all of the time.

        I appreciate any ideas on this issue. I know that sleep can cause problems, and just want to be sure that I am not doing more harm than good by turning off sleep completely.

        Thanks!

      • #2347777
        RetiredGeek
        AskWoody MVP

        L.H.,

        If you don’t have a long boot time I’d suggest you just shut it down when you’re going to be away from it for a while. That way you don’t have to keep it plugged in except when you’re using it.

        HTH 😎

        May the Forces of good computing be with you!

        RG

        PowerShell & VBA Rule!
        Computer Specs

        1 user thanked author for this post.
        • #2347908
          LHiggins
          AskWoody Plus

          My boot time is fairly quick- much faster on that Win 10 than on my old Win 7 for sure! Maybe I’ll try turning it off at night and just recharging it when I need to during the day.

          Thanks!!

      • #2347784
        Alex5723
        AskWoody Plus

        I am concerned about allowing the laptop so just sit there, but not sleep, for the times when I am not using it during the day – sometimes several hours at a time. I don’t mind keeping it plugged in overnight, but I don’t want to have it run on AC power all of the time.

        My laptop is on AC power 24/7/365. It is set to High Performance with sleep and hibernation.
        Never shut it down accept when I am on vacation.
        It is a 4 years old laptop and the battery is still in good health.

        Attachments:
        1 user thanked author for this post.
        • #2347856
          Ascaris
          AskWoody_MVP

          My Acer Swift is used on battery at least a couple of times a week (and right now is one of those times!) for at least an hour, and it has been that way for ~3 years. It’s been run down to zero a bunch of times,though I do avoid that now to preserve the battery. It spends the rest of the time plugged in.

          The battery is still at 93% health, through all that.

          As Krism noted, the battery won’t be overcharged if the laptop is functioning as intended. The charging circuit takes the battery off of charging power when it reaches the “full” threshold (usually nominally 100%), and it won’t charge it again until it gets below the begin-charging threshold.

          My Dell G3 is another story. Its battery was (and is) declining much faster than the Swift, even though the G3 is only ever used on battery for a few minutes at a time, and even then quite rarely. I have it set in the UEFI firmware to “mostly AC power,” but it’s still dropping much faster than the much harder working Swift battery. It’s around 69% now, if I recall, if not a bit lower, even though it is about 6 months newer than the Swift, and with far fewer charge cycles. That and the omission of 4 important screws on the heat sink when the unit was built have soured my perception of Dell a bit, while Acer is now better in my mind than when I bought mine. Dell’s firmware is still far better than the Swift’s, though!

           

          Group "L" (KDE Neon Linux 5.21.4 User Edition)

          1 user thanked author for this post.
        • #2347910
          LHiggins
          AskWoody Plus

          Thanks! Since my issue is with the sleep/hibernation, leaving it on is really on all the time. I am still uneasy letting it run that much, but guess I’ll see what work arounds I can find.

      • #2347806
        krism
        AskWoody Plus

        My issue on linux was a spontaneous restart after power-off -IF- suspend/sleep had been used (for me that was close laptop cover), so it probably has nothing to do with your problem. Replace mouse, or use a wired mouse for a bit.

        1.what battery issues? My laptop is perhaps 7 years old. In the 2 years or so that I have had it it has always been on charger. If the electronics in your laptop – re power supply – are working correctly it will not over charge. You may occasionally notice it charging, usually not. I just unplugged the charger and clicked on battery and it said about 1 1/2 Hr remaining(I’m running a test just for you…). I would expect that – If I were to need to use this laptop solely on its battery, I would need to get a new battery. Turn sleep back on!
        2. I would be surprised if there is any difference, but you could easily run a few tests.
        3. Sounds good. Check settings in BIOS.
        4. No. use sleep.
        5. Yeah but I forgot. Once I had a situation that repeated and only one key, like enter, would wake it up, but I forget what key it was. But again, that was linux so probably simply a linux problem(it has lots!!!). Check settings in BIOS. (thinking about this more it may have been that I needed to plug in a wired mouse to wake it up – again, a linux problem, NOT windows.)
        6. I don’t know but I doubt it. I apply updates a month late just before update Tuesday, or simply when askwoody says defcon2 which reminds me. I use wuMgr, -NOT- windows update.

        For now, I would ignore the advise to turn sleep off. Use it and get a new mouse and test it. —–>>>Be aware of your laptop. My T530 has one USB2 port on the back that only has power when shut off (or sleep) -IF- the BIOS tells it to. I’m using that port for my coolermaster fan pad thing that the laptop sits on.
        Be well!

        - ThinkPad T530-2394-3J8, i5-3380M 2.9GHz, UEFI/GPT: (Win10 20H2 Pro x64), 8GB(15GB/s), Sammy 500GB SSD. -

        1 user thanked author for this post.
        • #2347810
          krism
          AskWoody Plus

          after 45 minutes it said it had 25 minutes remaining. I plugged charger back in(note, laptop was in use this whole time.). Very weak battery.  I never use this portable.

          - ThinkPad T530-2394-3J8, i5-3380M 2.9GHz, UEFI/GPT: (Win10 20H2 Pro x64), 8GB(15GB/s), Sammy 500GB SSD. -

          • This reply was modified 1 month, 1 week ago by krism. Reason: typo
          1 user thanked author for this post.
        • #2347913
          LHiggins
          AskWoody Plus

          Thanks for the comprehensive answer, krism – lots to think about, for sure!

          I appreciate your advice about turning sleep back on – I may try that again and note when I run into the “won’t wake up” issue. As to the mouse – I have so far used three different mice (maybe a 4th?) and in each case, even with my Bluetooth mouse, either removing, or in the case of the Bluetooth, inserting a USB adapter would be the only way to wake the laptop up. When I was using the Bluetooth mouse – I plugged in an adapter from a different mouse and that brought it out of sleep. It was that process of “jolting” the USB port with the adapter that seemed to be what worked. I will try the adapter(s) in my other USB port – maybe it is still something wonky in the port itself, but everything else seems to run fine in it.

          As to checking BIOS settings – I am not sure just how to do that – I can look into it. Would settings in the BIOS override settings that I make in the power management page? Maybe something there is set wrong and there is a conflict.

          Finally – as to the updates – this issue seems to have started only since the beginning of February when I installed the January updates – which was why I was asking about that KB that I didn’t knowingly install. It has always worked fine for more than a year and a half – always sleeping and waking without issue, until something caused it to have this problem. Maybe once I do the February updates – probably today – it may correct itself – guess I’ll need to test that as well.

          I guess that as long as I can get it to wake up with that USB adapter trick (which I HOPE will continue to work) I can test the sleep again and see what happens after the updates.

          And as I noted elsewhere in this discussion – guess I can always just turn it off at night – which has always been where the problem is anyway – waking up after sleeping all night.

          Thanks for the help and suggestions!

          Lily

          PS – I ran Linux on my old Thinkpad for a while in the fall – it was a full install that ran from a USB SSD – ran great and I love it until it developed just the opposite sleep problem – it suddenly would NEVER stay asleep. I tried a variety of things, and finally gave up on it and am back to Win 7 on a wing and a prayer. Mine’s a Thinkpad X230 – love it!!

           

          • This reply was modified 1 month, 1 week ago by LHiggins.
      • #2347911
        LHiggins
        AskWoody Plus

        As Krism noted, the battery won’t be overcharged if the laptop is functioning as intended. The charging circuit takes the battery off of charging power when it reaches the “full” threshold (usually nominally 100%), and it won’t charge it again until it gets below the begin-charging threshold.

        Thanks! Maybe it is something with the battery itself, too – though it seems to charge and discharge OK. As to the way the charging circuit works – I know it is charged to 100% when plugged in overnight, but I can see hard drive activity even after it has been “charging” all night – so something is running. But it isn’t charging, so that’s good!

         

      • #2347941
        krism
        AskWoody Plus

        ” It was that process of “jolting” the USB port with the adapter that seemed to be what worked.” – so “plug and pray” is waking it up. I assume you are using a different USB port for your mouse each time – speaking of which I found I had to use a USB2 port for my logitech wireless M510 dongle for things to work correctly – wouldn’t work right on a USB3 port.

        I also assume in control panel/device manager/either Human Interface devices OR Mice and other pointing devices – Power management tab is set to “Allow this device to wake the computer”. Interestingly I just checked and my Logitech mouse appears in the Human interfaces group and is shut off – go figure – but I wake my laptop by either raising the cover, or pressing enter.

        One might check the USB/USB3 drivers for your laptop and assure latest from your manufacturer……… depending on how you update, your drivers could have been changed…

        - ThinkPad T530-2394-3J8, i5-3380M 2.9GHz, UEFI/GPT: (Win10 20H2 Pro x64), 8GB(15GB/s), Sammy 500GB SSD. -

      • #2347968
        LHiggins
        AskWoody Plus

        ” It was that process of “jolting” the USB port with the adapter that seemed to be what worked.” – so “plug and pray” is waking it up.

        Exactly!! Not the best approach, I’m sure. But pray indeed, since there is a lot stored on that laptop and I’d hate to not have access to it!

        I’m in the process of checking those wake settings – but I think they are all set to “allow to wake” – will check and report back.

        As to ports – I have 2 regular USB 3.0, and one USB-C, I believe. I use an adapter for the USB to USB-C connection. I have tried the two USBs, but not the one with the adapter. Wish there were more.

        I guess I keep coming back to the fact that it all worked well till just a month or so ago – not sure what changed, but something has interfered with the wake/sleep function. I can check on the drivers – maybe it is something there, though not sure where to start – at HP?

        Thanks again!

         

        • #2347991
          krism
          AskWoody Plus

          I have no experience with HP for laptop drivers. With Lenovo I can just go to their site, my model, and download whatever.

          - ThinkPad T530-2394-3J8, i5-3380M 2.9GHz, UEFI/GPT: (Win10 20H2 Pro x64), 8GB(15GB/s), Sammy 500GB SSD. -

        • #2347993
          krism
          AskWoody Plus

          I was just typing something, hit backspace and lost it all.

          I believe a lot of that HID stuff pertains to laptop hardware like pad, buttone, track-ball-type-thing, etc that serve as a mouse for the laptop when not using an external mouse – I shut all that stuff off in BIOS.

          My mouse is identified as logitech. I can not remember if I ever installed a logitech driver.

          I did discover that my mouse is turned OFF. But then I do not wake my laptop with mouse – I raise cover or press enter. I will try to test. – prob is I never sleep day time when connected to charger because if I do, I lose connection to my brokerage account.

          - ThinkPad T530-2394-3J8, i5-3380M 2.9GHz, UEFI/GPT: (Win10 20H2 Pro x64), 8GB(15GB/s), Sammy 500GB SSD. -

          Attachments:
          1 user thanked author for this post.
          • #2348016
            Ascaris
            AskWoody_MVP

            I was just typing something, hit backspace and lost it all.

            I have had that happen many times. I loathe that “feature” in various browsers. It’s so easy for the text field to lose focus, and you hit backspace and away it goes when the browser goes back to the previous page.

            Firefox has a pref to change that, if that is what you are using.

            Otherwise, in Vivaldi (Chromium variant) or Firefox, I use Textarea Cache (extension) to record everything I enter into any text entry field on any site, so if it is lost, I can go back to the site, press the button, and my message will appear in a modal popup, and with one click it is copied to the clipboard and ready to paste into the text window.

             

            Group "L" (KDE Neon Linux 5.21.4 User Edition)

            • This reply was modified 1 month, 1 week ago by Ascaris.
      • #2347984
        LHiggins
        AskWoody Plus

        One might check the USB/USB3 drivers for your laptop and assure latest from your manufacturer……… depending on how you update, your drivers could have been changed…

        OK, another question about the drivers. I looked in my device manager and see a lot of Human Interface Devices – 4 of which look like they may be related to the USB.

        Device-manager-2

        I also see several mice listed under Mice.

        Device-manager-3

        All of these can have drivers updated – how do I know which might be drivers actually related to the USB ports?

        Thanks!! Hoping to have a more specific testing plan for all of this after my updates.

        Attachments:
        • #2348015
          Ascaris
          AskWoody_MVP

          The PS/2 mouse is almost certainly the touchpad. The “HID-compliant mouse” should be the one. I would try not just updating the drivers, but (unless someone already suggested this, in which case I apologize) going to the power settings for each of the devices in question and unchecking the “allow Windows to turn off this device to save power” button.

          If it has worked before, it is possible that it might be related to an update, as you mention. It could be a system update or a driver update Windows slipped in there. Will Windows allow you to roll back some of the recent updates to find out?

          Have you tried waking the unit with the power button? Just a momentary press, not a force-off. My Dell G3 requires this… the keyboard or mouse won’t wake it. I like it that way, so I haven’t tried to “fix” it. I may have even changed something to make it behave that way on purpose at some point in the past. I make so many changes that I don’t always remember them all.

          I had something much like your issue happen in Linux before with my desktop PC. When I give the sleep order, it does go to sleep, but I can’t wake it up. When I look at the system log or diagnostic messages (dmesg), I can see that despite it obviously going to sleep by all the usual signs, it doesn’t actually reach the target of system standby (sleep)… it’s still waiting for some device on the system to report that it is entering sleep, even though the whole system does actually sleep.

          Because of that, the “go to sleep” command is never fully completed, and it never wakes up because it is too busy waiting for the “go to sleep” command to finish before it can begin listening for the wake event.

          If the device causing the issue is unplugged, it no longer exists as far as the PC is concerned, so the system no longer needs to wait for it to confirm it is entering sleep mode. With the blocking device gone, it is able to get on with things and process the “wake up” command you already gave.

          If this is what is happening for you, it could very well be from the update that most recently happened. It could also be a driver update, if there was one. I haven’t had this issue happen on my desktop for some time, fortunately, and I am not really sure what fixed it. For me, it was not a consistent thing… it usually went into standby (sleep) when I told it to, along with waking normally. Every now and then, it would do just like what you describe.

          If you were using Linux, I would suggest trying a newer kernel (or booting with the old one, if there had been a recent update… the old kernel remains installed after the new one is installed, so all you have to do is select it from GRUB), or perhaps changing the boot parameters, or changing the sleep method (there are a few different ways to initiate it), but in Windows 10, I don’t know.

           

          Group "L" (KDE Neon Linux 5.21.4 User Edition)

          1 user thanked author for this post.
          • #2348105
            LHiggins
            AskWoody Plus

            Thanks so much for the reply and your many ideas and suggestions!!

            The “HID-compliant mouse” should be the one. I would try not just updating the drivers, but going to the power settings for each of the devices in question and unchecking the “allow Windows to turn off this device to save power” button.

            OK a question about that – it is the one under “Mice” that would need the driver update – not the USB port itself? In the course of this, I did try several different USB mice, and also one Bluetooth mouse that was not connected at all, which was making me think that perhaps the port itself needed the driver update? But if it happened with the Bluetooth, then no port is involved, right? So something else?

            Also, I did uncheck the “allow Windows” boxes, but it seemed that right after I did that, the battery went dead overnight (not plugged in – thought it was a full enough charge to last the night) – so I rechecked that option. I did think that perhaps the mouse had been turned off that way and then didn’t come back to life, causing the issue, but the dead battery in the midst of figuring this all out was just another thing to try to figure out.

            I can say that we had noticed a slowness of the mouse resuming after sleep at times all along – like it couldn’t wake up and needed to be turned on and off a couple of times. It was worse with the Bluetooth mouse – occasionally it just wouldn’t come back to life since the Bluetooth was somehow off, and that needed to be worked with till it connected again. That was why I had tried several mice, which seemed to lead to this general not waking after sleep thing with the laptop itself.

            Have you tried waking the unit with the power button? Just a momentary press, not a force-off.

            I did try that both ways, and neither worked. But I am wondering now if maybe limiting what can wake it might be a good idea – like just the power button or just the keyboard.

            Your explanation of something blocking completion of the sleep command is also insightful, and makes me wonder if maybe turning the mouse off before I try to initiate sleep might be something else to try.

            As to updates, this did start after the January updates that I got in February – but all I did get were KB 4598229 and apparently unintentionally, KB 4535680.  I had thought that I also got KB 4586787, but I don’t see that on my update list. At this point, I am thinking that it wasn’t the Cumulative update, since I’d guess there might be more reports of issues if that had caused something like this. But maybe something in that Secure Boot update (which I really know nothing about). Since then, I did get the Feb updates – KB5001028, KB4601065, and the Flash removal one, and since I haven’t done any trials, I can’t say for sure if the problem was helped by those updates.

            Would it be too late to try to remove just KB4535680 at this point? I have never done that, and in truth, would be reluctant to try since I am not sure that it had anything to do with the problem. I did search around a bit for that KB plus sleep issues and didn’t find anything specific to this issue, but most reports of any update/sleep issue seem to involve the computer waking on its own, not being unable to wake.

            For me, it was not a consistent thing… it usually went into standby (sleep) when I told it to, along with waking normally. Every now and then, it would do just like what you describe.

            Yes – it wasn’t consistent for me either – but was becoming a more persistent issue as it went along.

            At this point, I haven’t tried it again since getting the Feb updates – so maybe something in one of them overrode the problem and it might work fine? And with so many variables, it is hard to isolate just one to see if that is the culprit – so maybe I need to try to narrow it down and “test” one thing at a time.

            I know that sleep can be an issue at times. I had another HP laptop years ago that wouldn’t wake, and finally gave up on it. And when I was using Linux on my Win 7 laptop, it was the sudden inability to ever sleep that caused me to go back to Win 7.

            Thanks for the ideas and help. Hopefully I can start a process of elimination and if not find the cause, perhaps some work around!

             

             

            • #2348116
              Ascaris
              AskWoody_MVP

              OK a question about that – it is the one under “Mice” that would need the driver update – not the USB port itself? In the course of this, I did try several different USB mice, and also one Bluetooth mouse that was not connected at all, which was making me think that perhaps the port itself needed the driver update?

              All of the mice probably used the same Microsoft HID driver, so if there is an issue with that, it could happen on different mice. It’s just a guess at this point, though, so if one thing doesn’t help, then you’ve at least eliminated that item from the list, and you can try something else.

              Also, I did uncheck the “allow Windows” boxes, but it seemed that right after I did that, the battery went dead overnight (not plugged in – thought it was a full enough charge to last the night) – so I rechecked that option. I did think that perhaps the mouse had been turned off that way and then didn’t come back to life, causing the issue, but the dead battery in the midst of figuring this all out was just another thing to try to figure out.

              Let’s figure out the sleep issue first, then attack the battery drain issue. Does it wake from sleep with the boxes unchecked?

              Would it be too late to try to remove just KB4535680 at this point? I have never done that, and in truth, would be reluctant to try since I am not sure that it had anything to do with the problem.

              I really don’t know. I have not done anything but the most basic stuff with Windows 10. If a given change is suspected as a possible cause of a problem, you can confirm or eliminate the possibility by trying it.

              At this point, I haven’t tried it again since getting the Feb updates – so maybe something in one of them overrode the problem and it might work fine?

              If Microsoft discovered a new bug in one of the updates, it is quite possible that the fix would be in a subsequent patch.

              And when I was using Linux on my Win 7 laptop, it was the sudden inability to ever sleep that caused me to go back to Win 7.

              As you can see, it’s by no means a Linux-only issue. Problems with sleep mode are pretty common in general.

              The firmware of the PC plays a substantial role in these kinds of power management things, and the implementation is notoriously spotty from model to model.  Bugs and incomplete implementations of standards are common, and sometimes workarounds have to be sent by the OS vendor or other OEMs for certain models of PCs or some of the bits within them to work properly with the buggy code within the firmware. It would be nice if we could always count on the PC or motherboard manufacturers to fix these issues, but very often, they don’t. I’m not saying that is the case now, only that this is a big part of why sleep mode is so problematic.

              If your particular PC’s firmware did happen to have a bug in it, it’s possible that a change in some of the drivers or power management code in Windows made that bug come to the surface where it previously remained hidden. Other models of computers might not have any problems with the same Windows build, because even though the problem may have started when Windows updated, it doesn’t necessarily mean Windows is where the bug is.

              Group "L" (KDE Neon Linux 5.21.4 User Edition)

      • #2347999
        krism
        AskWoody Plus

        I tried to answer this but lost everything – re did and post wound up above. Ask if more questions.

        - ThinkPad T530-2394-3J8, i5-3380M 2.9GHz, UEFI/GPT: (Win10 20H2 Pro x64), 8GB(15GB/s), Sammy 500GB SSD. -

        1 user thanked author for this post.
        • #2348012
          LHiggins
          AskWoody Plus

          Thanks! Will check more into the devices and also see if I can get into the BIOS as well. Will check back later on if I find anything useful!

          • #2348027
            krism
            AskWoody Plus

            also fwiw, check settings of control panel/power on the left side actions for lid.

            - ThinkPad T530-2394-3J8, i5-3380M 2.9GHz, UEFI/GPT: (Win10 20H2 Pro x64), 8GB(15GB/s), Sammy 500GB SSD. -

            1 user thanked author for this post.
      • #2348119
        krism
        AskWoody Plus

        Another thing you could consider is if you took an image before you put those updates on, just restore that image and see if prob goes away. 🙂

        - ThinkPad T530-2394-3J8, i5-3380M 2.9GHz, UEFI/GPT: (Win10 20H2 Pro x64), 8GB(15GB/s), Sammy 500GB SSD. -

        1 user thanked author for this post.
        • #2348127
          LHiggins
          AskWoody Plus

          I always make an image before updates. Strange though – when i checked again, I see that there were updates on 2/1 – KB4535680, 2/2 – KB4598229 and 2/3 – again KB4535680. I don’t recall getting updates more than once – would have been on 2/2, so the two instances of KB4535680 “may” have somehow been done on their own? Not sure, but I do know that since we were warned not to get that one, I wouldn’t have voluntarily done it.

          Anyway – I’ll try a few things first since I did just update to the Feb updates yesterday (KB46001056, KB4577586 and KB5001028) – and really hope not to have to use the image to restore it back to before 2/1, since that may not really tell me what was wrong.

          Thanks for your suggestions!

          • This reply was modified 1 month, 1 week ago by LHiggins.
          • #2348131
            krism
            AskWoody Plus

            I apparently never took 680:

            I am guessing you are not on 20H2?

             

            - ThinkPad T530-2394-3J8, i5-3380M 2.9GHz, UEFI/GPT: (Win10 20H2 Pro x64), 8GB(15GB/s), Sammy 500GB SSD. -

            • This reply was modified 1 month, 1 week ago by krism. Reason: further comment
            Attachments:
            • #2348137
              krism
              AskWoody Plus

              screen shot should have been: (ignore)

               

              - ThinkPad T530-2394-3J8, i5-3380M 2.9GHz, UEFI/GPT: (Win10 20H2 Pro x64), 8GB(15GB/s), Sammy 500GB SSD. -

              • This reply was modified 1 month, 1 week ago by krism. Reason: dup post - remove
              Attachments:
            • #2348141
              LHiggins
              AskWoody Plus

              I am guessing you are not on 20H2?

              No – still on 1909. I was planning to let it go to 2004 after the updates in early Feb – but when this sleep issue started, I didn’t do that. Maybe that upgrade will help as well?

              • This reply was modified 1 month, 1 week ago by LHiggins.
              • #2348146
                krism
                AskWoody Plus

                No idea, sorry. My first thought was to force re-install MS 10 USB drivers, but not sure you can do that. Doubtful that’s the problem anyway. (since you’re on 19)This more likely a suspend problem screwed up by some update as you initially suspected. – – – I think “current” – never thought 19. take no offense – just me.

                You could restore image and see if it works correctly – if you don’t want to lose where you are, you could:

                take image1-of-now,

                restore image-of-before,

                try it and see if problem gone,

                restore image1-of-now.

                - ThinkPad T530-2394-3J8, i5-3380M 2.9GHz, UEFI/GPT: (Win10 20H2 Pro x64), 8GB(15GB/s), Sammy 500GB SSD. -

                • This reply was modified 1 month, 1 week ago by krism. Reason: add clarification comment
              • #2348151
                LHiggins
                AskWoody Plus

                And I’m wondering now if maybe I should just go to 20H2 instead. Might save me the upgrading headache of doing it twice – once ror 2004 and then again for 20H2.

              • #2348161
                krism
                AskWoody Plus

                Of course I would encourage that, but take an image before you do it, -always- just in case! There is always the question in my mind these days (with the smaller updates) as to how much of the opsys it replaces – iow if opsys is hosed will it fix it or will you need a clean install. Just don’t know. Try and see.

                - ThinkPad T530-2394-3J8, i5-3380M 2.9GHz, UEFI/GPT: (Win10 20H2 Pro x64), 8GB(15GB/s), Sammy 500GB SSD. -

      • #2348124
        LHiggins
        AskWoody Plus

        Let’s figure out the sleep issue first, then attack the battery drain issue. Does it wake from sleep with the boxes unchecked?

        Thanks for the info. I am going to start a hopefully somewhat organized test – and I’ll start with your idea of the boxes unchecked. Since it was an intermittent issue, and there are a lot of things in play, I guess it is going to be somewhat trial and error till I see what causes it – rather than when it seems to be OK.

        Since I have sleep turned off, I’ll also need to turn it on for at least one thing – lid, keyboard, or manually with start button. Not sure which might be best – it originally had both lid and keyboard. Or will just setting the power option to sleep after a certain amount of time with nothing else set as far as lid or power buttons be sufficient?

        Will make changes, and report back. Thanks!

      • #2348211
        LHiggins
        AskWoody Plus

        Quick update: I’ve set it up to test a few different sleep/wake scenarios. I did not turn on any kind of sleep timer – just set the power button to put it to sleep, and the lid, mouse and keyboard to be able to wake it. Tried sleep/wake several times. So far – not very long really – so good.

        The PS/2 mouse is almost certainly the touchpad. The “HID-compliant mouse” should be the one. I would try not just updating the drivers, but (unless someone already suggested this, in which case I apologize) going to the power settings for each of the devices in question and unchecking the “allow Windows to turn off this device to save power” button.

        However, this option is greyed out in both the HID mouse and the HID keyboard, which seem to be the only ones that have power management. Not sure how I had this checked or unchecked earlier.

        In any case, I’m going to try waking it several times this evening, and then turn it of for the night, and continue some checking tomorrow. Maybe the updates did resolve whatever the issue was.

        • #2348227
          krism
          AskWoody Plus

          “However, this option is greyed out in both the HID mouse and the HID keyboard, ”

          LOL – yeah I noticed that –  on the mouse I am using. However, again, I tend not to sleep because it causes my brokerage app to log off(it’s important that I know how much money I’ve lost! 🙂 ). When I close lid, it sleeps and logs off that app, but to wake it I raise lid – no chance to use mouse. If lid is open and display goes of after 10 min or something, it is not asleep – just waiting for me to hit enter, key in my password and hit enter again.

          I set it to sleep in 1 min, left lid up. It went to sleep. I wiggled mouse and it gave me the lock screen. (To get a lock screen, the screen saver time must be set to that time and set to give you a lock screen.)(assuming that is what you want.)

          So my laptop wireless mouse wakes my laptop from sleep (lid open) if I wiggle mouse, EVEN THOUGH that option is greyed out on control panel/devices/ HID/ logitech mouse/ power settings tab.

          - ThinkPad T530-2394-3J8, i5-3380M 2.9GHz, UEFI/GPT: (Win10 20H2 Pro x64), 8GB(15GB/s), Sammy 500GB SSD. -

          • This reply was modified 1 month, 1 week ago by krism. Reason: clarify
          1 user thanked author for this post.
        • #2348289
          Ascaris
          AskWoody_MVP

          If they are grayed out, there is probably another related driver somewhere in Device Manager where the power saving setting is for the mouse. I remember having seen that with past versions of Windows too.

          Group "L" (KDE Neon Linux 5.21.4 User Edition)

          1 user thanked author for this post.
      • #2348306
        krism
        AskWoody Plus

        nothing extant in this case.

        - ThinkPad T530-2394-3J8, i5-3380M 2.9GHz, UEFI/GPT: (Win10 20H2 Pro x64), 8GB(15GB/s), Sammy 500GB SSD. -

      • #2348335
        LHiggins
        AskWoody Plus

        Still testing various scenarios – and again, so far so good. Sleeps on command, wakes on command, seems to have no issues at this point.

        I did find one interesting thing though – seems that a change in the the battery charging state also may wake it. I had the battery charging while the laptop was asleep. It reached a full charge, so I turned off the power strip to the charger, and it woke up on its own. Again, maybe like the USB adapter – the change in the charging status jolted it, and woke it. But this time, it wasn’t stuck in sleep – but something else to try if it ever does that again!

        Thanks for all of the help! Hopefully sleep and wake will work properly from now on.

        • #2348337
          krism
          AskWoody Plus

          EXCELLENT!!! – we like things that just work!!! 🙂

          - ThinkPad T530-2394-3J8, i5-3380M 2.9GHz, UEFI/GPT: (Win10 20H2 Pro x64), 8GB(15GB/s), Sammy 500GB SSD. -

          1 user thanked author for this post.
      • #2348374
        LHiggins
        AskWoody Plus

        Yes, we do!! Hope it lasts. I have a few more tweaks to try, but hopefully it is fixed – or at least won’t come back!

        Thanks for the help! 🙂

      • #2348487
        LHiggins
        AskWoody Plus

        …seems that a change in the the battery charging state also may wake it. I had the battery charging while the laptop was asleep. It reached a full charge, so I turned off the power strip to the charger, and it woke up on its own.

        After giving this some thought, it does bring up a question though. If this has been the behavior all along, and I never noticed it (doesn’t seem to be any light on the closed laptop to indicate sleep like on my Lenovo) – then it is possible that it has not been in sleep mode on many occasions when I think it is sleeping and unplug it, and unbeknownst to me, it woke up. Before this whole wake issue, I had it set to sleep after 5 minutes of inactivity, so maybe that would let it sleep again on its own if the power/charger change did wake it.

        Getting more involved by the minute it seems.

        • #2348519
          krism
          AskWoody Plus

          That’s possible…  Yes, my lenovo has a little moon light so when the lid is closed, I know whether it is in sleep state.

          - ThinkPad T530-2394-3J8, i5-3380M 2.9GHz, UEFI/GPT: (Win10 20H2 Pro x64), 8GB(15GB/s), Sammy 500GB SSD. -

          1 user thanked author for this post.
    Viewing 15 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, no politics or religion.

    Reply To: Battery, Power Management Questions

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.