News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • BCD error 0xc0000098 after reboot

    Home Forums AskWoody support Windows Windows 10 Questions: Win10 BCD error 0xc0000098 after reboot

    Topic Resolution: Resolved
    Viewing 13 reply threads
    • Author
      Posts
      • #2379903
        WS441FnD
        AskWoody Plus

        I recently built a new PC, re-using only my SSD, PSU and HDD.

        I then restored an image of the ‘C’ drive to the original (cleaned) SSD, using Macrium Reflect (MR) v8.

        I have had to repeat this process several times as each time I get the system functioning correctly and start to update drivers etc., all goes well until I need to do a reboot – eg. after updating Windows 10 from build 19042.1052 (in the image file), to build 19042.1110.

        As soon as it is installed and configured and specifies a reboot, the PC becomes un-bootable.   I get the “BCD does not contain valid information for an OS”.  “File:\BCD”   “Error Code: 0xc0000098”.

        The same thing happens no matter what has been done beforehand – eg. uninstalling a program – anything requiring a reboot.   I have had the system run normally for over two days, shutting down each night and re-opening in the morning without issue – as long as I don’t reboot it seems.

        I tried going through a cmd fix routine to repair the BCD, (one contained in joep517’s collection on this forum), but I ran into a complicated string of commands that I didn’t understand, so I bailed out.

        I would appreciate anyone’s thoughts on this as I’m fed up with chasing my tail trying to find the answer.

        Any help greatly appreciated.   Thank you.

         

      • #2379905
        PKCano
        Manager

        Boot from your MR rescue disk/USB.
        Macrium has a facility to fix Windows boot issues, rebuild the bcd, using the Recovery USB.

        1 user thanked author for this post.
      • #2379927
        WS441FnD
        AskWoody Plus

        Thanks PKCano, for responding.

        I have tried that so many times I’ve lost count.   In the “Fix windows boot issues” it always comes up with a missing SATA/AHCI driver, which it searches for and finds.   It then says it will be installed.   I’ve tried adding driver files (off the Gigabyte discs, but they are scattered everywhere throughout).   So, I copied the discs to USB and added that to the “Add drivers” field.   It then came up with a list of ?dozens? of files and supposedly installed them.

        It comes up with the list of actions with a red X next to ‘Old BCD’ or similar, and then says something like rebuilding BCD.

        Once I re-boot I end up with the same end result.

        I tried the restore from scratch, and got it to boot to the OS, and then the first action was to install the drivers and utilities for the new MB and Graphics card.   That went well, with no reboot required afterward.   Then I upgraded Windows, at the end of which a reboot was required and then got the BSOD.

        But I always end up with the same end result – whether that is almost immediately or in a day or two.

        I don’t know if I’m doing something wrong in  following the procedure, but there’s not a lot of places to go wrong.

        Regards

        • #2379930
          Alex5723
          AskWoody Plus

          What partitions do you have on SSD C: and your HDD ?

        • #2379932
          PKCano
          Manager

          + If Fast boot is turned on (Control Panel\Power Options\Choose what the power button does), turn Fast Boot off.
          + Reinstall the drivers. Restart the computer.
          + Look in Device Manager and be sure there are no errors. If there are resolve them.
          + Read about Microsoft’s SetupDiag then download and run it. (Download link) It may give you a clue where the problem lies.
          + Clear up any problems it points to
          + In an elevated Command Prompt (right click on cmd.exe and Run as Admin) run the following commands:

          DISM /online /cleanup-image /restorehealth
          sfc /scannow

          + Restart the computer
          +
           Try again

          1 user thanked author for this post.
          • #2380144
            WS441FnD
            AskWoody Plus

            Thanks again PKCano.

            I will work my way through your suggestions and see what I can achieve.  Will post back results.

            Regards

             

          • #2380761
            WS441FnD
            AskWoody Plus

            Hi, PKCano,

            I’m sorry it has taken me so long to get back to you in response to your suggestions.

            I finally managed to get into Control Panel yesterday (see reply to alejr, above), and found that Fast Boot was on – now off.

            I could not re-install the drivers as it said they were installed, and would give me no options.

            Device Manager showed absolutely no errors.

            I downloaded and installed MS SetupDiag.   It was way above my head, but it did repeatedly show up a missing ‘.inf’ file.

            This first appeared in the following section –

            “setupapi.offline.log

            Could not find include INFfile “ks.inf”.   Error = 0x00000002″

            Then went on to say – ‘might exist in missing included INF – KS.Registration.

            All sections of the log file finished with the word success or something – sorry forgot the precise word.

            I then ran the Command Prompts as you gave them, and nothing was reported.

            I restarted the computer, without issue (bear in mind that I had not done any upgrades etc. at this time).   Then when I tried to Upgrade Win 10 ……….

            See my answer to alejr above, please.

            Regards, and many thanks.

             

            1 user thanked author for this post.
            • #2380851
              WS441FnD
              AskWoody Plus

              Since I can’t go back to  the above post and edit it, I’ll reply to my own post.

              The ‘reply’ to alejr that I mentioned in post #2380761, seems to have vanished (not posted).

              I’ll have to re-do it. Sorry.

               

      • #2380141
        WS441FnD
        AskWoody Plus

        Hi Alex, and thank you for responding.

        screenshot_5

        GPT Disk 2 is my SSD, which until a couple of days ago was the only one that had anything on it.   I then tried a Restore of a different (more recent) Backup on to the HDD, as an experiment.   That backup was made from the SSD once I restored an image from 4 July, installed the Gigabyte drivers and utilities as I thought that was where the problem lay (installing onto new hardware).   It said the Restore completed successfully, but then the same BSOD occured – before I had done anything else.    I plan to clean that disk if I don’t find an answer to the BCD issue.

        Regards

         

        • #2380189
          Alex5723
          AskWoody Plus

          Can you please upload Disk Management disk/partition layout ?

          Sorry, but I don’t use nor know anything about Macrium. I use Acronis for years and never has a problem after restoring from image.

          • #2380195
            WS441FnD
            AskWoody Plus

            Hi Alex, sorry if I misunderstood your previous request.

            Is this what you meant?  Ooops! I’ll try  that again.

            PC-screen-1

            Sorry, best I can do.   I’m accessing Command Prompt through Macrium Reflect, but every screenshot I tried came out as a black screen.   In desperation (running out of time), I had to resort to this photo.

            I hope it is what you wanted (the info), and you can read it.

            Regards

             

        • #2380659
          anonymous
          Guest

          When you backed up the SSD, was the boot partition included in your SSD image backup and the data (builds of Windows 10) presently on the HDD is the exactly same as the SSD?

          There is an an experiment to try which is much easier if you are using the Macrium Reflect Rescue media environment : If you do have that partition you can try to restore the boot partition from the SSD image to the first drive. (Please search the Knowledge base on Macrium’s site for “Restore and Clone Partition Layout”, the spam filter will not let me insert the link.)

          If you are properly nervous about a terrible mistake just unplug your SSD (second disk’s) data cable so you only see the first drive.

          • Open the SSD image file and uncheck the other partitions
          • Select the HDD (first drive) to restore to…
          • Select the damaged boot partition on the HDD (first drive) and delete the partition.
          • Macrium is smart enough to guess where to restore the boot partition from the SSD (second drive), but double check it has selected to first block of empty space and you should be able to copy to the HDD (first drive).

          If you have an a complete smaller clone of your SSD image now, try updating only windows to see if it destroys the boot partition on the HDD (first drive).

           

          • #2380752
            WS441FnD
            AskWoody Plus

            Thanks Anonymous.   I really appreciate you providing this input to the problem.

            At the moment I have more than enough on my hands, answering the other respondents, and have moved on slightly from where I was when you posted.

            I don’t mean to brush you off.   I will come back to your suggestion if I need to in future.   Thank you.

             

      • #2380220
        alejr
        AskWoody Lounger

        A few things I noticed in the Macrium Reflect image you posted.

        Drive 1 (your HDD) is shown as being Windows 10 C: while Drive 2 (your SSD) is shown as being Windows 10 D:

        Drive 1 (the HDD) doesn’t contain any files in the system reserved partition (the 1st partition) while Drive 2 (the SSD) does.

        Unless you changed it, the BIOS on your motherboard will try to boot the drives in the order they’re plugged into the SATA ports (i.e. 1, 2, 3, etc.)

        The fact the BCD and files required for Windows to boot up properly are missing from Drive 1’s system reserved partition would explain why you’re having problems when you reboot (hard start) but not restart (soft start.) Soft starts always boot from the currently active drive while hard starts always boot the drives in the order they’re plugged into the SATA ports.

        Since you indicate you built this PC yourself, I’d suggest you open it up and swap the SATA cables on the 2 drives so the SSD is Drive 1 and the HDD is Drive 2 and see if that fixes your problem.

        If not, then try your Macrium Reflect restore to the SSD again.

        FYI…

        When I replaced my own HDD with an SSD I used the “clone” option to transfer the contents of the HDD to the SSD to avoid the sort of boot problems you’re encountering.

        Cloning duplicates the older drive’s entire contents (including it’s ID) onto the new drive so, as long as you connect the new drive to the same SATA cable the old one was using, the system will “think” it’s still using the same drive when you power it up the first time.

        Once Windows is up and running on the new drive, you can make whatever adjustments needed (update drivers, expand/change the partitions on the new drive, etc., etc.) to meet you particular requirements.

        • #2380411
          WS441FnD
          AskWoody Plus

          Hi, alejr.   I really appreciate your input and will do as you suggest regarding the drives, just to try anything at this point.

          For most of the past 3 weeks or so, that I’ve been battling this issue, the SSD has been the only drive connected.   The HDD was my Win XP main drive, from back in the day.   I kept it during Win 7 years, just in case there was a program I wanted to use – but don’t think I ever did.   After the problems started with the new PC, I formatted it (now correctly called cleaned I think), and left it blank + disconnected.

          As mentioned, last weekend I think, I tried installing one of my images on to it, just to see if it was an SSD issue of some sort.   That experiment bombed as well – probably because as you pointed out there are no files in the system reserved partition.

          Whenever I had the HDD connected it was in SATA port #2.   I had the SSD connected to SATA #5, purely for physical convenience.   The Case that I purchased – a wonderfully designed case IMHO – does make it very difficult to run cables to the 1 and 3 SATA ports, so that’s why (in my ignorance) I used the ones I did.   Not realising there was a technical reason not to – and not mentioned in the manual.

          Anyway, now I have switched the cables to 1 and 2, I’ll try another restore as you suggest.

          I will also clean the HDD and leave it that way for the time being.

          Thank you sincerely.

           

          • #2380602
            alejr
            AskWoody Lounger

            The way the BIOS works is it’ll scan “all” available SATA ports on the motherboard, starting with #1, until it finds a bootable drive. If you only have one “bootable” drive plugged in, then it doesn’t really matter which SATA port you use, the BIOS will find that drive and try to boot the OS on it.

            However, if you have multiple “bootable” drives plugged in (like your HDD in port #2 & SSD in port #5), the BIOS will try to boot the OS on the 1st one it finds when it scans the ports (which in your case was the HDD without a proper BCD on it.)

            The trick to using multiple drive is to have the “bootable” OS drive plugged into a lower numbered port and all the other drives in higher numbered ports or go into the BIOS settings and change the “boot order” so the BIOS scans the bootable drive first.

            BTW, my own self-built PC has 3 “bootable” drives plugged in as follows:

            • SATA port #1 – 500GB SSD with Windows 10 Pro.
            • SATA port #2 – 1TB HDD used for videos/music.
            • SATA port #3 – 128GB SSD used for backup copies of downloaded programs/apps.

            My Asus motherboard also has 3 unused SATA ports and an unused M2 SATA port.

            • #2380861
              WS441FnD
              AskWoody Plus

              Thanks alejr for the follow-up explanation, and I apologise for the delay in responding.  (I  actually typed a long response yesterday afternoon, but it has disappeared – I probably clicked the wrong ‘submit’ button I think).

              Anyway, here we go again.

              I cleaned and disconnected the HDD, and switched the SSD to SATA port 1.   I cleaned the SSD and restored my image file to it.   I was then able to boot normally into Windows.

              So, before doing anything else, I went through PKCano’s suggestions (see post #2379932 and #2380761 above).

              I then tried to install the Gigabyte driver & utilities disk, but it showed all entries as “installed”.   When I clicked the “Install” tab anyway, it just blinked and stayed on the same window  – obviously thought about it for a m/s and decided they were all there.

              Next, I went into Windows Update and found 3 updates.   I selected ‘Update Now’ and it did the first 2 and got to 20% on the third one – which I assumed was the 20H2 build 19042.1110 update.   (sorry, didn’t take a note of the KB numbers).

              At the point where the third one stopped at 20%, it came up with restart required, so after waiting for a while to see if the download would continue, I told it to restart.   It went through the configuring windows for a fair while and then went to restart.   I ended up with the ever circling dots, and eventually turned the PC off.   When I got back to it yesterday afternoon, I got a BSOD with the error message about unable to boot –

              winload.efi-error-0xc0000225

              I tried an online fix for this error, but I’m not sure of the results, if any.  However, I now get the earlier – BCD does not contain valid information for an Os Error code:0xc0000098.

              I have been contemplating a ‘clean install’ of Windows 10, as this issue has been going round and round for over a month, but that would remove all of my data.   As I only have a mirror image file to work from I would have to find out from Macrium if there is any way to retrieve just the data – I think there is.   Anyway, that reminded me that at the very start of all of this saga, I decided – in my wisdom – to do a clean install to the formatted SSD.   I went through the process download/install/obtain validation and then restored my image to it – yes I know, in hindsight that bit was stupid.

              Anyway, this leads to my question – Could all of this issue be caused by a Microsoft conflict of some sort, over the wrong Win 10 installation, authentication, validation?   I know there are a lot of intricacies about that which I don’t understand.

              For example – during this saga, when I have been able to get into Windows (eg. to upgrade), I have noticed in settings>update & security>OS build info>change product key.   I have never been game to try this step.

              Your thoughts on this new slant would be appreciated.

              Thank you.

               

      • #2380937
        alejr
        AskWoody Lounger

        First things first…

        NEVER turn off a PC while it’s in the process of installing an update. Doing so will cause all sorts of problems (such as your BCD error.)

        Some updates can take quite a while to finish so just be patient and wait until the desktop is backup and visible.

        There are users who’ve “complained” it’s taken multiple hours for their PCs to complete an update (a few even indicated they had to wait overnight and the update was done by the next morning) but, if it’s been more than ~3 hrs and it hasn’t finished, then something probably went wrong and it’d be OK to shut your PC down and start over.

        That said, here’s how I’d suggest you proceed.

          1. Restore the image to your SSD that let you boot into Windows and, before you do anything else, verify there’s no BCD error by completely powering down and restarting your PC.
          2. Follow the steps PKCano suggested and verify there’s no BCD error by completely powering down and restarting your PC.
          3. You’ve already verified the image you’re using has the necessary Gigabyte driver & utilities installed so there’s no need to try that step again.
          4. Open Windows Update and “record” the KB numbers of the 3 updates you see ready to download (do not select Update Now.)
          5. Open your browser, go to the Microsoft Update Catalog, and “download” those 3 updates for your version of Windows (take notice of the date each was issued.)
          6. Manually install each update from the downloaded files, one at a time, in the date order they were issued. If multiple KB’s have the same issue date, install them one at at time by KB# (note: the KB# will be part of the file name.)
          7. If all 3 updates install successfully , verify there’s no BCD error by completely powering down and restarting your PC.

        Notes:

          1. Even if a particular update doesn’t “prompt” you to restart your PC when it’s done, do so anyway and verify there’s no BCD error.
          2. KB5004237 will pause for a long time at 20%, 45% and 75% before it finally finishes and prompts you to restart.
          3. I know it’ll take a while but, if you successfully make it all the way to step 6, I’d “suggest” you do a full backup before installing any of the updates and after a successful reboot of each one. That way, if a particular update is causing your problem, you won’t have to go all the way back to step 1 for further T/S.

        With any luck, this will get you up-to-date and running.

        If not, at least it’ll tell you exactly which step is causing your BCD error and you can proceed from there.

        BTW…

        An “inactive” Windows 10 wouldn’t cause the BCD error you’re getting (Windows would simply show it’s not activated and enter a “reduced capability” operating mode similar to Windows 10 S.)

        You can find “your” Windows activation status by opening a command prompt (not a powershell prompt) and entering explorer.exe shell:::{BB06C0E4-D293-4f75-8A90-CB05B6477EEE} to open the old style system info window.

        The Windows Activation section at the bottom will show whether your windows is or isn’t activated.

        1 user thanked author for this post.
      • #2381064
        WS441FnD
        AskWoody Plus

        Firstly, thank you very much for the detailed guide.   It is really appreciated, however I will understand if you tell me – especially after reading this post – that it is taking up too much of your time, and you want to cease.   I will totally understand.

        Step 1:   Cleaned SSD and restored the image including the “Restore to new hardware” step.   Upon reboot it failed to do so, with the “winload.efi” file missing or corrupt error.

        I selected F1 (Go to Recovery Environment), and got Error …..98, BCD missing.    I then selected F1 and booted back into the Macrium Rescue DVD, and then ran the “Fix Windows Boot Problems” tool.   This reported a SATA AHCI driver missing, searched for and found – Standard SATA AHCI Controller from Intel Corporation.   “A driver for this device is currently installed and will load at boot”   “File : storahci.sys   Version : 10.0.19041   Date : 8/05/2021”.   I selected ‘reboot’ and it booted into Windows.

        I turned off the PC once it had completely booted.   I then turned it on again, and whilst it was very slow to boot, it did so.

        Then I did what PKCano suggested:   Fast Boot was on, so turned it off.   Device manager showed no errors.   I ran MS SetupDiag.   Whilst the result is way over my head, I saw no glaring errors. (log files available if required).

        Ran the DISM . . . . restorehealth command.   It said it had found and fixed some errors successfully.    Ran sfc/scannow command.    Turned off the PC.  (End of PKCano steps).

        Turned on PC and waited 15 minutes while dots circled – Turned OFF – Turned ON – waited 6 minutes watching dots – turned OFF  – turned ON and booted into UEFI > selected Rescue disk.   Ran “Fix Windows Boot Problems” step again.   “Running Tasks” window showed a list: EFI Partition found on disk 1, Removing old BCD, Creating BCD for C:\Windows.   Each item had a green tick before it.   Prompt – “Restart your PC? . YES.

        Received BSOD “Your PC couldn’t start properly”   Error code: 0x0000001.   Pressed ‘ENTER’ (try again).   After 5 minutes of circling dots I turned off the PC, and then back on again and booted into UEFI > changed boot order to Rescue DVD > BSOD again > BCD Error 98 > F1 (Recovery Environment) > it then booted into Rescue.

        I ran the “Restore to new hardware” step again – it found the SATA AHCI driver missing (as it always does), and repeated the same ‘found/installed’ message as above.   I then ran “fix Windows boot problems” again, rebooted, got BSOD BCD Error 98 again.   I selected F1 (go to Recovery Environment),  removed the Rescue DVD from the drive, entered UEFI menu and selected SSD as 1st boot.   It failed to boot – no BSOD, just ever circling dots.

        I hope you can get something out of that long-winded narrative.   I started making notes in the hope I wouldn’t need them, but ended up at a dead end, so hope it tells you something.

        MY only choice at this point – as I have done many times before – would be to start from scratch, with a new restore.

        As I said, if you want to opt out – no hard feelings – just my sincere thanks for your efforts so far.

        Regards

         

      • #2381069
        Paul T
        AskWoody MVP

        You should perform a fresh Windows install, to see if the hardware works. If it does you can go back to trying to fix your image.

        When you restored the image, did you align the SSD?
        http://reflect.macrium.com/help/v5/how_to/conversions/convert_to_a_solid_state_disk.htm

        cheers, Paul

        • #2381095
          WS441FnD
          AskWoody Plus

          Hi Paul T thank you for taking the time to help.

          That link does not seem to be applicable to my case, as I’m trying to install Windows 10, but it does point to the ‘Cloning disks and converting disk types.

          <span style=”color: #0000ff;”>The procedure presented in this topic applies to Windows XP, Windows Server 2003, and earlier operating systems. You can clone Windows Vista, Windows Server 2008 and later operating systems to a solid state disk (SSD) automatically by following the instructions in Cloning disks and converting disk types.</span>

          I have been using the following :

          <span style=”color: #0000ff;”>https://knowledgebase.macrium.com/pages/viewpage.action?pageId=23396929&src=contextnavpagetreemode</span&gt;

          This KB article was recommended to me on the Macrium forum in the early days of my problem – seems a very long time ago now!

          Anyway, thank you again.   I intend seeking further help from Macrium and part of that is tied to doing a clean install of Win 10.

          Regards

           

      • #2381085
        alejr
        AskWoody Lounger

        In your very first post you indicated this was a new PC build and in several of your followup post indicated you used Gigabyte discs to install the drivers so I “assume” it has a Gigabyte motherboard.

        Hate to bring this up but, with all the problems/symptoms you’ve encountered, it’s something you might consider.

        I helped my cousin built a new gaming PC in Sept of last year with a Gigabyte Z490 Aorus Master motherboard in it.

        After numerous attempts to get it to boot into Windows 10 failed (including some of the same steps you’ve tried) we finally determined the motherboard itself was defective by checking its status LEDs.

        With only one stick of memory in place and only the OS drive connected to a SATA port, as soon as we applied power, the BBIOS_LED came on (indicating it was booting from the Backup BIOS even though we had the BIOS_SW switch set for Main and the SB switch set to Single BIOS) and both the CPU and BOOT LEDs came on. Pressing the RST_SW button (reset everything back to default) didn’t help.

        While googling his problem I discovered it’s very common for “new-in-the-box” Gigabyte motherboards to have issues so we RMA’d his motherboard (wish I’d know that before I recommended he buy that particular make.)

        Anyway, the new motherboard we received a few days later worked fine right out of the box and he’s had no further problems with his setup.

        Since yours does boot (at least sometimes) with the problem “appearing” to simply be the missing BCD on the OS drive, your motherboard’s probably fine.

        • #2381091
          WS441FnD
          AskWoody Plus

          Thanks alejr , apologies for not detailing the build, but I’d been ‘using’ it for about 3 weeks in trying to solve this, so I omitted that, in trying to keep my initial post short and to the point.

          You are correct though, it is a Z590 UD AC Aorus MB.   I probably may have gone for a different brand if I had read about their out-of-the-box history.   Anyway as you mentioned, it seems to be software related, as it has worked on and off for periods from an hour to 3 days.

          I will try to see if Macrium can suggest a way for me to do a clean install, and then get my files and folders (but not the OS) from the image file.

          I really appreciate the time and trouble you have taken on my behalf – along with the other responders.   If I get it solved I will post back here, to possibly help someone else.

          Very best wishes to you, and the best of health and happiness.

          • #2381104
            alejr
            AskWoody Lounger

            I’d suggest you try Paul T’s idea and do a “clean” install of Windows 10, but do it on the HDD instead of the SSD (leave the SSD unplugged) and verify it actually boots into Windows as expected with no errors.

            If so, then use Macrium to backup the system reserved partition (the 200MB 1st one that contains the BCD files) and only that partition so you’ll have a “known good” BCD setup that boots into Windows.

            Restore the working image you used in step 1 of my T/S steps to the SSD and then restore the “know good” system reserved partition (and only that partition) from the HDD “over” the one on the SSD.

            Proceed with the T/S steps I outlined above but at step 2 (PKCano’s recommendations) do each item one at a time with a restart/reboot after each one to try and isolate exactly which one causes the BCD to get corrupted.

            BTW, those spinning dots indicate Windows is doing stuff in the background (like fixing the damaged items DISM and/or SFC found) that can only be replaced/updated prior to Windows actually booting all the way up.

            I know 15 mins “seems” like a long time to wait, but you should give it a bit longer to see if the desktop comes up before shutting down your PC (if it’s been +1 hr, then something went wrong and you can shutdown.)

            Also, it’s just personal preference, but I always run SFC first (with a restart if it found any problems) before running DISM (with a restart if it found any problems.)

            Good luck!

            1 user thanked author for this post.
            • #2381234
              WS441FnD
              AskWoody Plus

              I’ve been following the steps in the combined posts, as you suggested.

              I’m sorry, but I’m not in a position to report, except to say that after approx 14 hours working on this today, I appear to be no further advanced.

              I will have to report back tomorrow, after I’ve tried to prove/disprove a theory.

              Regards

      • #2381507
        WS441FnD
        AskWoody Plus

        After reading your post #2381104, I started the suggested process.   (I’ll keep this as brief as possible).

        I did a clean install to the HDD, Booted into it and checked that it was working properly.   Then turned it OFF.   Later I turned it on, booted correctly.   I then made a backup of Partition 1 and saved it to an external HDD.   I reconnected the SSD and disconnected the HDD.  I then cleaned the SSD, set it up as per the Macrium KB article and restored the image file to it.   I then restored partition 1 over top of the one on the SSD (got warned about overwriting).

        Exited Rescue environment and into UEFI menu to make sure SSD was 1st boot.   Got BSOD error (missing boot files) 0xc0000225.   Booted rescue DVD again, Ran “Restore to new Hardware” and got the usual ‘missing SATA/AHCI driver’ etc..   Ran “Fix Windows Boot Problems” with usual pop up windows.   When finished > asked if I wanted to Reboot – said YES.

        Booted into Windows and when completed, I shut down (START>Shut Down).   Your step 1.   Powered up and started to boot, then went into brief ‘Configuring Windows’ period, then completed the Boot.

        Followed PKCano’s steps:   1.   Turned off fast boot.   2.   Reinstalled drivers (Same story as before – said they were all installed, however I selected “Xpress Install” and it took a couple of seconds and window appeared “Install completed” > “Restart Required”).  Selected Restart **.   In Gigabyte logo screen with circling dots for one and a half hours.   Turned PC off.   Turned on to try reboot – same thing – logo screen, circling dots.

        A half hour later I tried again – got Error 0xc0000001.   Booted into Rescue media again, Ran “Redeploy . . . .” again.   (Got the same SATA AHCI  messages).   Ran “Fix Windows Boot . . .”.    Booted into UEFI menu and selected SSD.    Logo and dots again.   Waited 30 minutes and turned off PC.

        Booted Rescue media again and Restored the System Reserved Partition again, without re-restoring the whole image.   Exited Rescue and Booted SSD.   BSOD Error 98 > select ‘ESC’ to UEFI menu > checked SSD is set as boot > BSOD .efi Error 02.   PC turned off as I didn’t respond in time.    Boot into Rescue media again > run both ‘fixes’ again > asked if I wanted to reboot > selected yes.

        No boot, just logo and dots.   Turned off PC 8 PM Monday.

        Today – (Tuesday).

        Tried for normal boot – Gigabyte logo and dots.   Booted Rescue DVD.

        .    I installed it into the PC case in place of the HDD.   I cleaned it, set up the partitions as GPT and restored my original image to it, ran “Deploy” and “Fix” steps as before, at the end of which, upon reboot, Windows opened.   Shut down and turned back on successfully.   Turned off Fast Boot.   ‘Installed’ drivers as before > “Requires Reboot“.   Turned OFF** PC (START> Shut Down).   PC spent 3 to 4 minutes ‘configuring Windows’ and then shut down.

        Turned on again – booted correctly.   Checked Device Manager – no flags.   Ran sfc /scannow and it said found and fixed corrupt files.   Ran DISM – “restore completed successfully”.

        Restarted** PC.   Logo and dots again!   After 70 minutes turned it off.

        **By this stage I had begun to suspect that Reboot/restart may be causing the fail to start issue.   Whether that is feasible, I have not a clue.

        So, I started the whole process over again by cleaning/partitioning and restoring the Image to SSD2.   I repeated all of the steps exactly as last time, up to and including the ‘Ran DISM’ step.   Then I selected – START > Shut Down, instead of Restart.

        When I powered up the PC again, no boot, just Logo and dots!!!!   Still going 75 minutes later.   Powered down.   That’s it for today!

        Hope you can follow enough of this to get something out of it.   If you need any elaboration of any point I’ll oblige where I can.   If I get enthusiastic tomorrow, I may try repeating the overwrite of partition 1 on SSD2.   I guess one thing has been achieved today, and that is I guess I’ve ruled out an SSD hardware issue, as both of them are doing the same thing.

        There’s my Restart theory blown.

        Regards,  and thank you again.

      • #2381530
        alejr
        AskWoody Lounger

        I installed it into the PC case in place of the HDD.   I cleaned it, set up the partitions as GPT and restored my original image to it, ran “Deploy” and “Fix” steps as before, at the end of which, upon reboot, Windows opened.   Shut down and turned back on successfully.   Turned off Fast Boot.   ‘Installed’ drivers as before > “Requires Reboot“.   Turned OFF** PC (START> Shut Down).   PC spent 3 to 4 minutes ‘configuring Windows’ and then shut down.

        Turned on again – booted correctly. Checked Device Manager – no flags. Ran sfc /scannow and it said found and fixed corrupt files. Ran DISM – “restore completed successfully”.

        Since it booted successfully before you ran SFC/DISM, I’d very strongly suggest you get it back to this state and then make a full backup of the SSD so you’ll have a “working” Windows installation and won’t have to go all the way back to step 1 again.

        Also, it “appears” either SFC or DISM is causing your problem so do not run both of them before restarting/rebooting!

        Once you’re back to where Windows boots up and have made your backup, then run SFC and do a restart/reboot to see if it boots up to the desktop.

        If so, then run DISM and do another restart/reboot.

        If it fails after running SFC, then restore the “working” image you just made and run DISM with a restart/reboot to see if it boots up properly.

        BTW, the SFC and DISM commands are intended to fix problems when either Windows isn’t working properly or a Windows update fails to install. If a Windows installation is working as expected (as it seemed to be before you ran those 2 commands), there’s really no need to use either of them until something goes wrong.

        Just FYI…

        I googled the issue “Gigabyte logo with spinning dots” and the most common fix was:

          1. Power down the PC
          2. Remove the power cord
          3. Open the case and remove the CMOS battery
          4. Wait 2 mins
          5. Reverse the above steps
          6. Power up the PC and go into the BIOS
          7. Select “Load Optimized Defaults
          8. Save settings and restart into Windows

        While you could just go into the BIOS and select the “Load Optimized Defaults” option, the above steps actually clear all the bits in the CMOS memory, even the ones that can’t be accessed using any of the BIOS menu options.

        • #2381533
          WS441FnD
          AskWoody Plus

          Thank you.   I will try that tomorrow (10:15 PM here now).   I really appreciate your ongoing support.

          Thank you also for the tip about clearing the CMOS.   I actually tried that a week or so back.   It possibly could have helped, but I would not have known – too many big issues going on.

          Regards.

           

          • #2381548
            alejr
            AskWoody Lounger

            A big part of properly T/S a complicated issue such as yours is to only apply one fix at a time as the fixes themselves can interact with other in unexpected ways (sometimes exacerbating the problem you’re trying to fix.)

              Is your system stable and working as expected after applying a fix?

              If so, there’s no need to apply further fixes unless/until the same or a new problem pops up.

              If the problem’s still there, try the next fix.

              Wash, rinse, repeat.

            Remember, if an OS works just fine for 3 days straight and then suddenly experiences a problem (even if it’s the “same” problem you experienced before), it’s much more likely something changed “during” those 3 days than that the problem was there all along.

              Unless it’s actually an “intermittenthardware problem (which are a real PITA to T/S.)

            Another tip is to always make a full backup once you have a “stable, working” OS so you don’t have to go all the way back to the beginning if the same or another problem crops up later.

            1 user thanked author for this post.
      • #2382027
        Paul T
        AskWoody MVP

        If it boots happily before SFC, do not run SFC.

        Get a Windows install ISO and burn to USB – you can use the MS Media Creation Tool.
        Install over the top and allow Windows to fix things.
        Got a misbehaving Windows 10? @ AskWoody

        cheers, Paul

        p.s. sorry it this has already been tried.

        1 user thanked author for this post.
      • #2382851
        WS441FnD
        AskWoody Plus

        Finally  .  . .!!   I have something to report.

        I won’t bother going into the details of what I have tried over the last 4 days or so – it feels like longer than that to me!   Suffice to say, that I tried numerous times restoring the image I’ve been using, and changing one step at a time.   I have experienced BSOD’s at virtually every stage – right up to and including having Windows 10 ‘clean’ installed over the old version via the MS Media Creation Tool (MCT).   Several times it got to 75 – 80 % “updating” and then came up with a ‘Stop Code – you can reboot,’ and “Driver PNP Watchdog”   Trouble is there was no reboot facility, so I had to power off/on, and then the PC would not boot.

        Finally, I decided to ‘clean’ the SSD and using the MCT I did a clean install of Windows 10.   Prior to doing so, I made a backup of my Files and Folders from the old restored image, using Macrium Restore.   Once the ‘new’ Win 10 was up and running, I went to restore the files and folders, only to find there was nothing on the external drive.

        I then reinstalled the other SSD into the case, and started transferring everything manually from old to new.   I have spent a day and a half doing that and installing the Apps that I need.   I now have a functioning – reasonably close – copy of my system on the new PC.

        So far nothing has gone wrong.   I will make a full backup now that it is done, as well as another restore point.

        I want to thank those who helped with this issue – most especially alejr, who gave so much of his time and knowledge toward solving this issue.   I am extremely grateful.

        One last question, as I can’t find the answer – should I/do I need to, mark this Thread solved or ended or something?   What is the convention please?

         

      • #2383428
        Paul T
        AskWoody MVP

        do I need to, mark this Thread solved

        There is no option for marking a thread solved.

        cheers, Paul

        1 user thanked author for this post.
        • #2383458
          b
          AskWoody MVP

          There is no option for marking a thread solved.

          What’s wrong with using the Resolution drop-down menu at top left of the thread to select Resolved (followed by clicking the Update button)?

          Windows 10 Pro version 21H2 build 19044.1237 + Microsoft 365 (group ASAP)

          1 user thanked author for this post.
          • #2383749
            Paul T
            AskWoody MVP

            Thanks for finding that for me – eyes or brain not up to scratch on that day.  🙂

            cheers, Paul

            1 user thanked author for this post.
            b
    Viewing 13 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, no politics or religion.

    Reply To: BCD error 0xc0000098 after reboot

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.