• Bluetooth audio not working on older Lenovo T420 with Win 10

    Home » Forums » AskWoody support » Windows » Windows 10 » Questions: Win10 » Bluetooth audio not working on older Lenovo T420 with Win 10

    • This topic has 7 replies, 3 voices, and was last updated 4 months ago.

    I have pretty much given up on this, but I will ask anyway.

    My Thinkpad came with Windows 7 pre-installed and has been upgraded to Win 10 way back when.

    At first, the Bluetooth worked as well as it ever has.  I believe it quit working after a Win  update prior to the whole Covid thing.  During the Covid lockdowns, I tried to use Bluetooth headphones and got in this whole circular thing.  At one point I may have even had a Bluetooth mouse connected before I got frustrated with the thing falling asleep too quickly.

    I can PAIR the headphones.  This is a WYZE headset right now, but they all behave the same.  After pairing, they appear in the Device Manage and on the Sound control panel, but only as PAIRED.  When I try to “connect” — it tells me: “That didn’t work.  Make sure your Bluetooth device is still discoverable, then try again.”  Of course it isn’t discoverable — it just paired.  Making it discoverable does not help.

    At this point, I try to “Remove device” (headset) only to be told “Remove failed.”

    At certain times (possibly with an external Bluetooth dongle) I DID get Bluetooth to CONNECT to the headset, but there was no connection to the audio path.  The PC thought it was sending audio out Bluetooth, but there was no audio coming out other than the “beeps” for connecting and disconnecting (i.e. local to the headset).  The headset does work on my iPhone, etc.

    I have tried all the tricks deleting the Bluetooth Device(s) from the Device Manager and even driver updates.  Nada.

    Any thoughts?  Other than it is time to retire this PC.



    Viewing 4 reply threads
    • #2562543

      Have you tried updating BT driver from OEM site (not Microsoft) ?
      BT is now on version 5.3.
      There could be compatibility problem between the BT version of your hardware and BT version of your headphones.

      • #2562749

        I will try that, but the issue isn’t with just one set of headphones.  I have another set of MPOW headphones, some Soundcore earbuds, some Raycon earbuds, and some Soundcore headphones.

        This USB Bluetooth dongle is an MPOW 5.1 Bluetooth adapter.  It uses the Microsoft drivers by default, but I just ran the install disk.  I will need a reboot to see what happens.



    • #2562759

      Well, now I have a Realtek Bluetooth 5.1 adapter listed in Device Manager, but it doesn’t work any better.

      I did disable and uninstall the ‘Generic Bluetooth adapter’ also, but that didn’t do much.

      I freshly paired the Soundcore Q30 headset, and it shows PAIRED, but I cannot CONNECT for the same reasons listed in my original post.  At least this allows me to Remove Device.

      I can delete all the Bluetooth items in Device Manager and reboot.  This does seem to be a repeat of my circular debugging steps though.



    • #2562777

      Yeah, so, after PC reboot, the new Realtek Bluetooth 5.1 Adapter shows disabled and the Generic Bluetooth Adapter is enabled and “working properly” according to the Device Manager.

      However, in the Bluetooth Settings, no devices show up as Discoverable … where they did prior to installing the Realtek driver (and reboot).

      So, installing the Realtek Bluetooth 5.1 driver broke the Bluetooth feature more than not having it installed.  If I remember correctly, uninstalling the Realtek Bluetooth 5.1 drivers and Adapter will return the system to what it was before.

      Thanks for trying, but I think I have been here before.


    • #2562779

      Updated firmware?  I think I have the latest installed.  Since this was shipped with Windows 7 pre-installed, there weren’t really any Win 10 specific updates.

      I will check again though.



    • #2562810

      Going down the rabbit hole again …

      My laptop is: T420 Laptop (ThinkPad) – Type 4178

      The device appears to be: HardwareID USB\VID_0A5C&PID_217F&REV_0748

      Broadcom 43142 Bluetooth 4.0 driver

      The “Lenovo Vantage” program/tool says my drivers are up to date.  The driver that Lenovo has on their website ( g4wb12ww.exe ) redirects to:


      It suggests that I go to the manufacturer’s website:

      https://www.broadcom.com/support/bluetooth :

      “Windows drivers for Broadcom Bluetooth devices are no longer posted here. They should be available through Microsoft’s Windows Update service. If drivers were not downloaded automatically by Windows Update, use Device Manager to refresh the driver from Windows Update, or contact the device manufacturer.”

      And of course, the Microsoft website and Windows Update all give me the same:

      “The best drivers for your device are already installed”

      I get that it is old hardware, and maybe, just maybe, the hardware is broken.

      But how come I cannot install a different (USB) Bluetooth Adapter?

      I did add one of those AudioJack -> Bluetooth transmitters, but there is too much static even after I cleaned the contacts with DeoxIT.

      It may just be time to buy a new laptop.

      Thanks for all your help.


    Viewing 4 reply threads
    Reply To: Bluetooth audio not working on older Lenovo T420 with Win 10

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: