News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • Bob’s 20H2 Topic

    Home Forums AskWoody support Windows Windows 10 Bob’s 20H2 Topic

    • This topic has 39 replies, 6 voices, and was last updated 3 weeks ago.
    Viewing 25 reply threads
    • Author
      Posts
      • #2362986
        rebop2020
        AskWoody Plus

        You might have read my loooong topic on not getting offered Win 10 Updates while on 1909. That is fixed with a little help from my new friends here at AskWoody.

        Sunday I changed the TRV to 20H2. Monday it popped up in Update Alerts. I took a little time fro fresh image, a few tweaks. exporting some registry keys, etc as I have never had a Feature Update that did not change some settings and preferences and defaults, etc. I would love for this one to be the exception.

        I clicked download at 12:12 PM PST today
        It downloaded from 12:12-12:20
        Then started installing and a few returns to “getting things ready”.
        Install completed at – 100% at 1:20. Restarting now. Several times in fact…

        Completed at 1:30 to desktop

        Lots of things sending messages about configirations.

        I am now going through a pretty long list of things Feature Updates have changed since 1703 (?) though some continued to change from at 1909 and some did not. It should take an hour or so to run down the list unless I find lots of changes and have to recall how to fix them like not adding “shortcut” to a new desktop shortcut or not changing my Recycle Bin Icon (reg tweak).

        So whether I come out of this unscathed or with issues I resolve, I thought the advent…err experience might be informative.

        To be continued….

        2 users thanked author for this post.
      • #2362995
        rebop2020
        AskWoody Plus

        A number of things that the update to 1909 changed that this update did not. But here is what has changed:

        1. Recycle Bin Icon changed
        2. 26 GB of drive space used – Windows.old is 33 GB. Does not make sense, but… Wondering what was deleted?
        3. Two desktop Icons gone. Can not remember what it was!
        4. Adds the word shortcut to desktop shortcuts again
        5. Slightly changed my preferred column widths in File Explorer
        6. Touchscreen re-eenabled even though i set to disable
        7. Task manager columns deleted and changed sizing

        OK, this is tedious. I will not share my entire list to check but only post what M’soft changed. Need a little air so off for a walk. Back with more.

        • #2362999
          PKCano
          Manager

          26 GB of drive space used – Windows.old is 33 GB. Does not make sense, but… Wondering what was deleted?

          Perhaps there was a bunch of the old system that was not necessary to the new version.

          • #2363010
            rebop2020
            AskWoody Plus

            Possible Will know more as I continue to check.

            I can already say that this Feature Update has changed less than the 1909 did. But only 20% through my list. I hate when it changes the Shortcut and Recycle Bin, etc. Why? Makes no sense. But no big ones  – at least yet.

            I had thought one of the capture tools was to be deleted like Snip and Sketch. But I see to have that plus a snipping tool.

            Back later. Hope this is informative when done. I really do check pretty thoroughly.

             

        • #2363009
          Bob99
          AskWoody Plus

          …Windows.old is 33 GB…

          Don’t forget, you’ll get those 33 gigs of space back when Windows deletes the Windows.old folder in either 10 or 30 days from the date you made the jump to 20H2 from 1909!

          However, for now, I believe the priority should be getting your update settings right in Group Policy that you used to have available in the Windows Update screens so that you don’t wind up being an unwilling and unpaid beta tester for Microsoft. Remember, the settings are described very well in AKB2000016 here on AskWoody. Look in Section 5 for the instructions specific to 2004 and 20H2.

          1 user thanked author for this post.
          • #2363027
            rebop2020
            AskWoody Plus

            The thing about space is Windows.old is33 GB, but the drive is only down 26 GB. SO 7 GB of something has been removed. A lot. But no issues found yet to relate to that Bob99.

            Good news:

            Telemetry was not reeanabled.
            TRV and associated Update Settings not changed

            System Protection wasDisabled AGAIN!
            Connected User Experience Service was reset to enabled
            Removed MaxCachedIcons DWORD in Registry again

            At about 50% of checking. Time for another break.

             

      • #2363078
        rebop2020
        AskWoody Plus

        Making more progress. Its a very long list of things that *might* be changed or reset.

        1. Defragment task was reenabled
        2. 21 updates to be hidden from Intel, Lenovo, NVIDIA, etc – Maybe 3 to keep for Flash, etc
        3. KB4023057 AGAIN – Hidden
        4. Changed photo folders to display as details rather than large icons. Having a a very difficult time getting all general items and all pictures folders to display the same way using all the tool for folder options
        5. Changed highlight colors again
        6. I had cmd set to always run as administrator. Had to reset the shortcuts
        7. Update deleted all photo viewers. Really. Gone.
        8. I KNOW I had changed 2 settings in DCOMCNFG. Cannot find what they were.
        9. I really dislike the black background on start menu tiles. Looking for a way to change that.

        That’s it. So a total of 19 changes I had to revert (in 3 posts here). But, I did check several hundred setting in a number of control panels, apps, setting, etc. So took a realistic 4-5 hours after the install. But I know where I am .

        Open to suggestions on 8 and 9 above.

         

      • #2363079
        rebop2020
        AskWoody Plus

        Found the DCOM.

        Two other issues:

        1. Emptying the recycle bin does not change to empty icon immediately as it used to. Now takes until something else is clicked.
        2. Macrium reflect has an option to register a dll that will add columns to file explorer. Updates unregister them so expected. But when registered again, and chosen in file explorer they are fine until a reboot and then the chosen column is gone even though its still available to choose.

        I think that’s it.

      • #2363081
        rebop2020
        AskWoody Plus

        Fixed the recycle bin. Forgot about the registry hack needed when using a custom recycle bin icon. Works again.

         

        You can see why I love Windows 10 Feature Updates and avoid them as long as I can.

      • #2363132
        rebop2020
        AskWoody Plus

        Today’s Oddities:

        1. Action center was missing. Gone. Showed back up on reboot.
        2. Things running now in apps that had never run at startup before (nor are they in Startup or in Registry Run’s)
          Lenovo Vantage
          Microsoft Store
          Microsoft Text Input

        Working on these.

        Some folders claim I no longer have permission to them. Simple fix but annoying.

        I think coming to an end of the changes.

         

      • #2363138
        rebop2020
        AskWoody Plus

        Not yet. New error I am researching:

        Failed with 0x57 retrieving AppModel Runtime status for package NonImmersivePackage.

         

      • #2363148
        joep517
        AskWoody MVP

        Re: your space issue. If you had System Restore enabled before the update it was disabled with the upgrade. So, any restore points would be gone.

        --Joe

      • #2363150
        Alex5723
        AskWoody Plus

        Lenovo Vantage
        Microsoft Store

        I have a Lenovo laptop and don’t run / never installed Lenovo Vantage.
        Don’t remove Microsoft Store as the only way to restore is to perform re-install/repair of Windows.

        • #2363154
          rebop2020
          AskWoody Plus

          No intention to uninstall, just stop from running on boot.

          And Joe, likely right that my diskspace “gain” was the restore points. Good call!

          A few reg tweaks that were working have stopped. The reg entries have not changed. So something odd. Tipped off by highlight color changing back.

           

          What fun….not.

      • #2363213
        rebop2020
        AskWoody Plus

        OK, I think time for a summary:

        20H2 from 1909 caused the following:

        1. The Recycle Bin Icon changed to default
        2. Two desktop Icons gone. Can not remember what it was!
        3. Adds the word shortcut to desktop shortcuts again
        4. Slightly changed my preferred column widths in File Explorer
        5. Touchscreen re-enabled even though I set to disable
        6. Task manager columns deleted and changed sizing
        7. System Protection was Disabled AGAIN!
        8. Connected User Experience Service was reset to enabled
        9. Removed MaxCachedIcons DWORD in Registry again
        10. Defragment task was reenabled
        11. 21 updates needed to be hidden from Intel, Lenovo, NVIDIA, etc – Maybe 3 to keep for Flash, etc
        12. KB4023057 AGAIN – Hidden
        13. Changed photo folders to display as details rather than large icons.
        14. Changed highlight colors again
        15. I had cmd set to always run as administrator. Had to reset the shortcuts
        16. Update deleted all photo viewers. Really. Gone.
        17. Emptying the recycle bin does not change to empty icon immediately as it used to.
        18. Macrium reflect has an option to register a dll that will add columns to file explorer.

          All of the above have been fixed.

        Broken Still:

        1. Error: Failed with 0x57 retrieving AppModel Runtime status for package NonImmersivePackage. RESEARCHING
        2. Action center was missing. Gone. Showed back up on reboot. NO EXPLANATION
        3. Things running now in apps that had never run at startup before (nor are they in Startup or in Registry Run’s)
          Lenovo Vantage (2)
          Microsoft Store (2)
          Microsoft Text Input
          Researching these.
        4. Highlight reverts to default blue after computer sleeps. I tend to recall a fix for this. Researching
        5. Some of the icons in Show in Notifications settings page are wrong. Not for the apps listed. (would someone check theirs? Thanks)
        6. Even though Windows Update reflects the recently hidden items in wushowhide, I have not yet seen a notification I need Updates. Waiting for that before installing the last 3 updates.

        So that is a bit cleaner to read and see what I have found. Will update if I find more (hopefully not) and if I fix the last 6.

      • #2363235
        rebop2020
        AskWoody Plus

        Wow. I had another couple of posts that are not here now. Hmmmm..

        Well,:

        2. Action Center – fixed after COLD boot. Restart was not the cure.

        3. Lenovo Vantage and Microsoft Store fixed. Both had advanced options allowing them acces to Background apps. Clicked off, rebooted, not longer running at startup.

        4. Highlight needed one more registry tweak in another spot to stick. Done.

        Four more to go.

      • #2363291
        rebop2020
        AskWoody Plus

        Again, post has vanished!!!



        @sb
        , @PKCANO and anyone else – now I need help.

        Let’s go right to it. I KNOW I need three updates. After 20H2 I got a notification from ESET Updates were needed. I looked and there were I think 4 including KB4023057, so I hid that in wushowhide. I then decided I would wait for the notification in the action center that I needed updates, check to be sure it was only the 3 that I agreed I needed, and install. I expected to see this Thursday – yesterday.

        I have not seen that, but I have had occasion to visit the Updates settings page and indeed, it shows only the three I choose to install. But again, even now, not Alert to Update.

        I strongly suspect it is because of the Event Viewer error:

        Failed with 0x57 retrieving AppModel Runtime status for package NonImmersivePackage

        Here is more of it:

        Log Name: Microsoft-Windows-AppModel-Runtime/Admin
        Source: Microsoft-Windows-AppModel-Runtime
        Date: 5/6/2021 1:17:12 AM
        Event ID: 65
        Task Category: None
        Level: Error
        Keywords: Process
        User: xxxxxxxxxxxxxxxxx\Bob
        Computer: xxxxxxxxxxx
        Description:
        Failed with 0x57 retrieving AppModel Runtime status for package NonImmersivePackage.

        It just threw this event again, no Update Notices.

        I am down to this and 1 other issue that is really nothing – the running Microsoft Text Input with Tablet and Onscreen Ink and Keyboard turned off which I can live with. But this is full circle now back to where we started together, but with an error (likely) to help. I have run SFC Scannow and no issues. I could install the updates which are two related to Adobe Flash and one for Cumulative .NET Framework, but if I do then will have to wait for the next Patch Day to see if this is working, and clearly it is not now. So, I’m reaching out.

        Would appreciate help. Thanks.

         

         

        • #2363296
          Alex5723
          AskWoody Plus

          Try some of the solutions here : Fix: Event 65, AppModel-Runtime

          • #2363297
            rebop2020
            AskWoody Plus

            I shall look. Thanks. Would be nice (actually not) to know if that is the cause of the lack of update notifications. I have reading to do. And this is the only one that really is mission critical and I have not yet been able to fix from this major update. Keeping me awake 🙂

            Off to read.

          • #2363302
            rebop2020
            AskWoody Plus

            Great article. Thanks Alex. I do not do any games, all turned off. So I think at worst its the video driver and other than the event does not seem to cause an issue. After the Updates Issue is solved, I’ll update the driver. I do not think they are related. But will search more in case I find something.

            Thanks again.

      • #2363298
        rebop2020
        AskWoody Plus

        BTW mods, I think my posts go missing when I post, look and see and error and edit. Then they are gone. Just FYI I think the forum may have that bug.

        • #2363299
          PKCano
          Manager

          Your posts are getting caught in the spambucket on Edit. Slow down on the Edit/Submit/Edit/submit sequence and let the system complete each action.

          I use Firefox. The indication that the system is still processing is a “-” in the tab that moves back and forth. When it’s done. then the next operation. Don’t know which browser you use, but there may be an indicator.

          • #2363301
            rebop2020
            AskWoody Plus

            Never noticed one. What I have been doing is submit, reread the post, edit of needed, submit and “gone”. Now I know. Have not seen this elsewhere. Will look on the tab. Using Waterfox, btw. Thanks.

             

      • #2363300
        rebop2020
        AskWoody Plus

        Ahhh, it is 2:30 AM :). The error mentioned is an NVIDIA issue, of course. I do not believe it is the cause of not seeing the Updates Needed Alert. Good and bad news. I think I need to update my NVDIA driver from Lenovo – once I have updates working. As a matter of fact, I am sure I hid an NVDIA update from M’soft, so not surprised 20H2 might want that.

        So now need to find out why no Alerts….

        Maybe after some sleep….

         

         

      • #2363358
        rebop2020
        AskWoody Plus

        Good morning 🙂

        OK, No update alert this morning. An aside, maybe of interest, I did get two of the Event ID 65 errors this morning at 1:00 AM. I went through every task to see what ran then. Nothing. Interesting.

        But also interesting is that I checked the Windows Update Service and it was not running. Set to manual. There is a task to run it about 1:30 PM daily. I do not recall ever seeing it not running, but that could be coincidence. Does it stop?

        So, what I know:

        It appears that Win Update does run as after hiding an update in wushowhide (albeit two days ago) the Update Settings page does not show that update. BUT, I have not gotten an alert that Updates are available.

        Would appreciate knowing that the update service not running is normal and ideas why I am not seeing the alert.

        Thanks.

        • #2363360
          PKCano
          Manager

          That’s OK. The task to check for updates will turn it on.

          • #2363361
            rebop2020
            AskWoody Plus

            Yup. Thanks. I just found that Googling.

            I also checked Windows Logs for Update service and it seems it had run roughly every half hour all night – yet still no alerts.

            I did start Windows Update Service when I saw it was not running (should not hurt?) and the log has no update in 30 minutes….watching it. OK, just ran.

            So I know it is checking, why no alert? Hmmm.

            The task to run is scheduled for 1:46PM today. But we know that has some latitude. If I have no alerts by perhaps 6PM there is likely an alert issue.

             

      • #2363362
        rebop2020
        AskWoody Plus

        Is there a notification setting for Windows Updates? I am not seeing one.

      • #2363373
        rebop2020
        AskWoody Plus

        JUST got the Update Available Notification!!

        Not sure why. I did two things in the last 24 hours:

        1. Turned off and on 2 in GPEDIT for updates
        2. Started Windows Update Service as mentioned above when i saw it not running

        Go figure.

        So, on to the 0x57 error 🙂

      • #2363377
        rebop2020
        AskWoody Plus

        OK, installed updates, rebooted and noticed the following:

        1. Unused taskbar notification icons have the wrong icons on maybe half of them again. Not a big deal, but noting.
        2. The new .net framework did NOT fix my Dolby .net error.
        3. A new application now runs on startup called Windows Shell Experience Host. Was never there before. Will research.

        All else look good!

      • #2363474
        rebop2020
        AskWoody Plus

        OK, the notification settings icons for app are still 20% worng. Must be a windows bug and not an issue.

        BUT, I have the Event ID 65 error 4 times each night. I now understand it happens EXACTLY when Macrium Reflect runs a definition file and ends the same file. Since I do two different backups in the middle of each night, this error occurs at the start and end of each.

        Any idea what causes this and a fix?

        Log Name: Microsoft-Windows-AppModel-Runtime/Admin
        Source: Microsoft-Windows-AppModel-Runtime
        Date: 5/6/2021 1:17:12 AM
        Event ID: 65
        Task Category: None
        Level: Error
        Keywords: Process
        User: XXXXXXXX\Bob
        Computer: XXXXXXXX
        Description:
        Failed with 0x57 retrieving AppModel Runtime status for package NonImmersivePackage.

        Thanks.

        • #2363588
          Paul T
          AskWoody MVP

          That doesn’t look like a serious error and as long as your backups are working I would ignore it.

          cheers, Paul

      • #2363589
        rebop2020
        AskWoody Plus

        Folks at Macrium think that 20H2 might have broken their scheduler. They wrote one to replace M’soft Task Scheduler as that caused backups to run twice on daylight savings!!:)

        So tonight I am trying the M’soft. If not error, we know its the Macrium Scheduler. SO sleuthing.

      • #2364037
        rebop2020
        AskWoody Plus

        Cannot find a thing on the net about package NonImmersivePackage.. Like it does not exist. Any ideas? Does not show in getappx… or any other package listing I can find.

        • #2364048
          PKCano
          Manager

          Here are some clues for your midnight searching:
          Listing the Apps in 20H2 with PowerShell, I find the “ImmersiveControlPanel” which is, I think, the Settings App.

          Screen-Shot-2021-05-10-at-7.34.23-PM

          I also found the “nonimmersife” term in the Registry under Spybot AntiBeacon, which is set to run on login.
          Also did a Google search for “nonimmersivepackage” which Google split into “non immersive package”

      • #2364055
        rebop2020
        AskWoody Plus

        Thanks. I have the immersive control panel, but no way to run it?

        Google Search: I have read well over a hundred links to no avail.

        Regedit search for immersive shows:

        accountpicturefile linked to a @windows.UI.immersive.dll      hmmm

        A bunch of packagermoniker’s

        A server for microsoft.windows.immersivecontrolpanel

        A telemetry entry

        A bunch under Activatable Classes Packages

        A bunch more, but nothing that helps understand. I think its there but not yet active perhaps. And might be the settings app itself renamed and with d=features to come? But would not explain the error when Macrium runs.

         

        Mystery gets bigger, but more “stuff” to Google.

      • #2364064
        rebop2020
        AskWoody Plus

        OK, Immersive Control Panel IS system settings. Some oddities like it connects to Microsoft servers. OK, but does not answer the nonimmersive package error.

        Still looking.

         

         

         

      • #2364295
        rebop2020
        AskWoody Plus

        Just got my first Event ID 65 not related to Macrium, but this time in package windows and occurred when Windows Update ran and found the CU.

        So there is something going on. Not sure what.

         

        One another note, just found that Windows thought having the Apple iTunes app installed was wrong and replaced it with the Microsoft Store App. And most works as expected but I can no longer find my iPad on the network, thought it finds the iPhone. Feh. More to fix.

      • #2365194
        rebop2020
        AskWoody Plus

        Just an interesting note: This is the first time EVER for me that  windows.old actually and totally removed itself as claimed. I had a complicated cmd script for renaming a poorly named folder that would allow me to do it manually when stuck, but now vanished! Cool.

      • #2367212
        rebop2020
        AskWoody Plus

        Did KB5003173  and here are my results:

        1. My Internet was disconnected as well as a network drive after update. Easy to restore.
        2. Speaking of, seems like restore points are working again
        3. Checked my list of possible breaking items and found none reset
        4. Notifications icons are now correct
        5. I do not see ANYTHING on News and Interests anywhere??? I am now on 19042.985

        There is a GP for News and Interests that was set to not configured. I tried enabled and no change. Still not on taskbar right click.

    Viewing 25 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, no politics or religion.

    Reply To: Bob’s 20H2 Topic

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.