News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • C drive full with system files?!

    Home Forums AskWoody support Windows Windows 7 Questions: Windows 7 C drive full with system files?!

    This topic contains 5 replies, has 5 voices, and was last updated by  the_Unforgiven 5 months, 4 weeks ago.

    • Author
      Posts
    • #1845374 Reply

      Cthru
      AskWoody Plus

      Opening Windows Explorer, just now, I was shocked to see that my C drive is almost completely full, mostly with Windows system files. I have run drive cleanup twice, once including system files, but that removed only a few GB, mostly my recycle bin. Wiztree analysis is shown (partially) in attached image file.

      My 500GB C drive is usually only about 25-35%full; something is terribly wrong here. What can I delete, and what could be causing this? What other info might I provide to give you insight into this?

      Thanks.

       

      File-tree

      Attachments:
    • #1845388 Reply

      NetDef
      AskWoody_MVP

      Looks like you need to remove older system restore checkpoints.

      Open that Disk Properties dialog box, click Disk Cleanup, then click “Clean up System Files.”

      diskcleanup1

       

      After the second scan, click on the second tab on that new box, labeled “More Options.”

      Click the second Clean up button under System Restore and Shadow Copies.

      diskcleanup2

       

      What this does: deletes all but the most recent System Restore snapshot.  Note that there is no dialog/progress bar for this process, and depending on your system it may take a LONG time with zero indications.  Don’t force close it, wait it out.  The best way to know when it’s done is to click the first tab (disk cleanup) and then wait for it to change back to that tab on it’s own.

      After that, go ahead and do the System disk cleanup as well, then REBOOT if you selected old windows updates as part of the cleanup.

      After the reboot, login as an Admin and go into the C: \ Windows \ Temp folder (you may have to add yourself with permissions to get into this.) and select ALL files and delete them.  If you get errors about some files being open, skip them and don’t worry about it.

      Finally, empty your recycle bin.

      ~ Group "Weekend" ~

      • This reply was modified 6 months ago by  NetDef.
      • This reply was modified 6 months ago by  NetDef.
      Attachments:
      1 user thanked author for this post.
    • #1845420 Reply

      Cthru
      AskWoody Plus

      Netdef, thank you for you quick response. That was easy, and I’m back to a comfortable 130GB used. Checking the configuration just now, I found that restore had somehow been set to 100% max. I recall increasing it to about 25% from 5% after a major problem last year had occurred, apparently, just prior to my earliest system restore about a month before. Anyway, now I know what to do.

      Thank you again!

      1 user thanked author for this post.
    • #1845422 Reply

      Rick Corbett
      AskWoody_MVP

      What can I delete, and what could be causing this?

      In addition to @netdef‘s advice, you may need to reduce the space allocated to System Restore to stop the available free disk space falling to a level where automatic disk defragmentation just stops. (IIRC there needs to be at least 10% free space available.)

      Start > Control Panel > System > System Protection (in the left-hand navigation pane) > Configure (button) > Disk Space Usage

      Win-7-system-protection-allocation

      Hope this helps…

      Attachments:
      1 user thanked author for this post.
    • #1846163 Reply

      Paul T
      AskWoody MVP

      You should be creating backups on an external disk instead of relying on system restore points. Also protects against drive failure.

      cheers, Paul

      1 user thanked author for this post.
    • #1849529 Reply

      the_Unforgiven
      AskWoody Lounger

      get windirstat – https://windirstat.net/ – and run it

      if you have hibernation enabled – get rid of of it with – Click Start, and then type cmd in the Start Search box.  In the search results list, right-click Command Prompt, and then click Run as Administrator.  When you are prompted by User Account Control, click Continue.
      At the command prompt, type powercfg.exe /hibernate off, and then press Enter.
      Type exit, and then press Enter to close the Command Prompt window.

      if you have an SSD with 32GB of RAM like I do, change the virtual memory to – 8192

      have a good 1 🙂 cheers

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: C drive full with system files?!

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.