News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • Cannot unset read-only attribute

    Home Forums AskWoody support Windows Windows 10 Windows 10 version 20H2 – October 2020 Update Cannot unset read-only attribute

    Viewing 6 reply threads
    • Author
      Posts
      • #2359553
        Tom
        AskWoody Plus

        Windows10 20H2, 2nd March Update.

        I’ve just discovered that my computer has my folders and files set to read-only. I’ve just run into problems modifying and saving numerous different types of files because suddenly they’ve been set to read-only. Using Explorer, selecting a folder, going in to properties shows read-only set. Unchecking read-only, applying and answering yes, looks like it’s working. But closing explorer, going back in and verifying shows the read-only property still set. I’ve checked security and permissions, and the user I log in as has full permissions on the folder.

        Can anyone help? I need to do some work.

      • #2359554
        Tom
        AskWoody Plus

        I can open the files, see the content, move them around at will. I just can’t modify them.

      • #2359559
        joep517
        AskWoody MVP

        The read-only property on a folder is does not mean the same thing as it does on files. It has been like this for a long time. See You cannot view or change the Read-only or the System attributes of folders in Windows Server 2003, in Windows XP, in Windows Vista or in Windows 7 (microsoft.com) for an explanation.

        --Joe

        3 users thanked author for this post.
        wavy, Tom, b
      • #2359593
        Paul T
        AskWoody MVP

        After the update did your desktop or folders change? It’s possible you have a new user ID that doesn’t have correct permissions.

        Open Explorer
        Navigate to one of the files that you can’t change
        Right click on the file and select Properties > Security
        Select your user ID
        The permissions should be as shown in the attached pic

        If the permissions are OK you may have controlled folder access turned on but not set correctly.

        cheers, Paul

        Attachments:
        1 user thanked author for this post.
        Tom
      • #2360116
        Tom
        AskWoody Plus

        I got it sorted. User hasn’t changed because of an update. Everything as it was except the read-only setting. So I just used attrib -r -s *.* on the folder containing the files. That worked.

      • #2363127
        dhdoyle
        AskWoody Plus

        Just wanted to add here that I updated my 20H2 PC yesterday and found this same thing this morning. In my case, the read-only bit would immediately reset. I discovered that my security settings didn’t include my user account anywhere – even in my user folder. After looking at the security/advanced/permissions and rebooting, my security settings returned to normal.

      • #2363338
        wavy
        AskWoody Plus

        The read-only property on a folder is does not mean the same thing as it does on files. It has been like this for a long time. See You cannot view or change the Read-only or the System attributes of folders in Windows Server 2003, in Windows XP, in Windows Vista or in Windows 7 (microsoft.com) for an explanation.

        Its amazing that MS still does it this way even though they admit it causes problems.

        🍻

        Just because you don't know where you are going doesn't mean any road will get you there.
    Viewing 6 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, no politics or religion.

    Reply To: Cannot unset read-only attribute

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.