• Can’t change email font size, Thunderbird for Macs stuck in tiny letters.

    Home » Forums » AskWoody support » Apple » Apple operating systems » macOS » Can’t change email font size, Thunderbird for Macs stuck in tiny letters.

    Author
    Topic
    #2382466

    I have upgraded to Big Sur from Mojave. Before this upgrade, my mail client had been “Mail” for more than four years (since I got my first and present Mac) and I was very satisfied with it.

    But after the upgrade it started to glitch, then stopped downloading recently received emails, then downloading of all of them at once after hours of doing nothing to get them. Whether the problem was all on my side, the ISP side, or both, I would not know.

    So I have switched to Thunderbird, that works fine, so far. Except that after increasing the default tiny font size of the emails I write from 15 to 20 (so “15” is either not true, or it is a measure given not in points but in microns — or something like that) this has had no effect whatsoever, and the font when I write an email remains tiny. Which is frustrating.

    Of course, I can use “Command+” repeated times to get the size on display to change to what I need, but this is temporary, so it has to be done every time I start to write another email, and there is no earthly reason why this should be so. And more importantly, test messages I have sent to myself display in the same tiny letters when received, even if I used Command+ to zoom in the text while writing them.

    By the way: this is a problem when I write an email message. Messages sent to me by others display with reasonably large font sizes without my having to intervene.

    How have I tried to change the font?

    First by going to Thunderbird/Preferences/General, where one sets the desired font size, then clicking on “Advanced”, that displays the whole setup, including the change I just made to the font size, then clicking “OK”.

    After that, back to writing a test email, back to getting tiny letters as if I had done nothing at all to  change that.

    I have tried closing Thunderbird and reopening it, force closing Thunderbird and restarting it, restarting the Mac: no effect, still tiny letters.

    If anyone has some practical advice that works on how to solve this problem, I am going to send him or her a birthday card, or some other token of my appreciation.

    Ex-Windows user (Win. 98, XP, 7); since mid-2017 using also macOS. Presently on Monterey 12.15 & sometimes running also Linux (Mint).

    MacBook Pro circa mid-2015, 15" display, with 16GB 1600 GHz DDR3 RAM, 1 TB SSD, a Haswell architecture Intel CPU with 4 Cores and 8 Threads model i7-4870HQ @ 2.50GHz.
    Intel Iris Pro GPU with Built-in Bus, VRAM 1.5 GB, Display 2880 x 1800 Retina, 24-Bit color.
    macOS Monterey; browsers: Waterfox "Current", Vivaldi and (now and then) Chrome; security apps. Intego AV

    • This topic was modified 1 year ago by OscarCP.
    Viewing 6 reply threads
    Author
    Replies
    • #2382469

       

      The following advice is based upon an installation of Thunderbird 78.12.0 on a Windows machine, however some settings are probably quite similar from OS to OS.

      Instead of the “General” heading, look in the next one down, the one that should be labeled “Composition”.

      In there, go to the area labeled “HTML Style” and make sure it’s set to a variable width font (says “Variable Width”) AND that the font size is set to at least “Medium” or larger.

      Now, see if that makes a difference in your composed emails. Hopefully you’ll no longer need a microscope to see the font.  😉

      I hope this helps!

      EDIT: One more thing to check is that the setting under Account Settings>Composition & Addressing is set to “Compose messages in HTML format” under the heading of “Composition” that’s in bold on that page for each email account you’ve got set up in T’Bird. The Compose messages setting is just a check box that needs to have a check mark placed in it.

      • This reply was modified 1 year ago by Bob99. Reason: Added EDIT paragraph
      • #2382474

        Bob99: Thanks. Unfortunately, in “Composition” I already have the font set to “Variable Size” and “Large” in  what I believe to be the latest version of Thunderbird for Macs, since I downloaded if from Mozilla two days ago.

        I was trying to define the actual font size in “General”, because I find the choices of “Medium”, “Large” etc. in “Composition” much too limited. This happened before I decided to use “General” to do that. And is still happening.

        Ex-Windows user (Win. 98, XP, 7); since mid-2017 using also macOS. Presently on Monterey 12.15 & sometimes running also Linux (Mint).

        MacBook Pro circa mid-2015, 15" display, with 16GB 1600 GHz DDR3 RAM, 1 TB SSD, a Haswell architecture Intel CPU with 4 Cores and 8 Threads model i7-4870HQ @ 2.50GHz.
        Intel Iris Pro GPU with Built-in Bus, VRAM 1.5 GB, Display 2880 x 1800 Retina, 24-Bit color.
        macOS Monterey; browsers: Waterfox "Current", Vivaldi and (now and then) Chrome; security apps. Intego AV

        • #2382481

          Wow, bummer that the setting is somehow being ignored! Even with your settings for the email account(s) you have established in T’Bird set to “Compose messages in HTML format”??

          Sound like Mojave is overriding the settings within T’Bird somehow. I wonder if there’s a somewhat obscure system setting for email app font(s) that’s being overlooked? It’s as if T’Bird is trying to use a certain set of fonts installed on the system, but Mojave isn’t letting it do so properly for some reason.

          I also wonder if what caused the native email app in Mojave to start working erratically is also causing issues with T’Bird’s configuration files? To me, it sounds just like the config files that help T’Bird work correctly are not being read properly by T’Bird when it’s launched.

           

          1 user thanked author for this post.
        • #2382504

          I do not know if Mojave also was overriding the settings of TB, because I never used TB until I changed, the other day, to Mojave’s successor, Big Sur, because of unexpected failings of Mail under Big Sur.

          Ex-Windows user (Win. 98, XP, 7); since mid-2017 using also macOS. Presently on Monterey 12.15 & sometimes running also Linux (Mint).

          MacBook Pro circa mid-2015, 15" display, with 16GB 1600 GHz DDR3 RAM, 1 TB SSD, a Haswell architecture Intel CPU with 4 Cores and 8 Threads model i7-4870HQ @ 2.50GHz.
          Intel Iris Pro GPU with Built-in Bus, VRAM 1.5 GB, Display 2880 x 1800 Retina, 24-Bit color.
          macOS Monterey; browsers: Waterfox "Current", Vivaldi and (now and then) Chrome; security apps. Intego AV

      • #2395070

        Thank you. Solved the problem.

    • #2382483

      Looking around in the Web, it turned out that there are lots of complaints about the tiny fonts.

      I found a solution, it is not exactly perfect but certainly gets around the tiny font size problem:

      https://support.mozilla.org/en-US/questions/1297871

      It means using “About Config” by clicking on “Config Editor”  at the very bottom of the page in: Thunderbird/Preferences/General, then accepting the “risk” (I understand there is no such risk, just a sort of in joke), then searching for “pixel” in the search field there, and clicking twice on this line: layout.css.devPixelsPerPx .

      In the window that opens change the default “-1” to something bigger, but not too big, then click OK. In my case “3” works. Make sure that the “-” has been removed when changing the value from -1 to some multiple 0f 0.5, while keeping in mind that larger than 3, going by my own experience, might be too large and inconvenient, as changing from -1 on up increases all the font sizes everywhere in Thunderbird (and only in “Thunderbird”), including the “Inbox”, so everything there gets crowded and some goes out of sight if one chooses a number that is too big. The moment you click OK, you’ll see the effect of the change in the very “Config Editor” page you are in.

      Ex-Windows user (Win. 98, XP, 7); since mid-2017 using also macOS. Presently on Monterey 12.15 & sometimes running also Linux (Mint).

      MacBook Pro circa mid-2015, 15" display, with 16GB 1600 GHz DDR3 RAM, 1 TB SSD, a Haswell architecture Intel CPU with 4 Cores and 8 Threads model i7-4870HQ @ 2.50GHz.
      Intel Iris Pro GPU with Built-in Bus, VRAM 1.5 GB, Display 2880 x 1800 Retina, 24-Bit color.
      macOS Monterey; browsers: Waterfox "Current", Vivaldi and (now and then) Chrome; security apps. Intego AV

      2 users thanked author for this post.
      • #2382489

        OMG, I totally forgot about the Config editor, probably because I haven’t had to use it in T’Bird in so long. I DO remember seeing something about having to change that default font setting for a certain malady quite some time ago, but forgot about it since I wasn’t affected by that malady.

        GREAT to hear that you found it, and that you’ve got it set so that you can read what you’re typing without having a single letter taking up the whole screen!  😳

        1 user thanked author for this post.
    • #2382540

      Absolutely Great Find OscarCP, thank you for playing detective and sleuthing out a workable solution, AND sharing it with us, like you noticed, many complaints, Good Job, Gold Star for OscarCP 🙂 – – (works in Windows 10 Pro x64 bit version 21H1 1110 updated thru July 2021.)

    • #2383503

      Really brilliant – thank you so much.  I was tearing my hair out, having just bought a new 27″ i Mac and the font was too small to read.  3 worked perfectly.

    • #2399661

      cant believe we gotta still mess with about.config after all these years to adjust the font- unreal- thank you very much for posting the fix- i use 1.5 seems to be about perfect-  I’ve now got the instructions written down in my “Fix Thunderbird” notebook for future

    • #2401187

      on my iMac 27″ big sur, this doesnt seem to work. is there any other thing i can do?

      thanks

      D

       

       

       

    • #2455735

      Using the above instructions the font increases when I connect to an external monitor, even the  TB inbox is larger on my 13″MBP but when I disconnect the monitor the font on my 13″ MBP reverts back to microscopic.

    Viewing 6 reply threads
    Reply To: Can’t change email font size, Thunderbird for Macs stuck in tiny letters.

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: