News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Carboni: Jittery mouse when controlling Win10 version 1903 via RDP? There’s a solution.

    Home Forums AskWoody blog Carboni: Jittery mouse when controlling Win10 version 1903 via RDP? There’s a solution.

    Tagged: ,

    This topic contains 5 replies, has 5 voices, and was last updated by  Noel Carboni 3 months, 2 weeks ago.

    • Author
      Posts
    • #1994790 Reply

      woody
      Da Boss

      From Noel Carboni: Have you seen a jittery mouse or black screen when controlling a Windows 10 v1903 or newer system via RDP?  I’ve discovered a worka
      [See the full post at: Carboni: Jittery mouse when controlling Win10 version 1903 via RDP? There’s a solution.]

    • #1994828 Reply

      b
      AskWoody Plus

      Most of this was covered more than three months ago:

      The Group Policy workaround for the RDP black screen sounds simple and effective:

      Use WDDM graphics display driver for Remote Desktop Connection = Disabled

      (And gpedit should be available on any edition which can enable RDP host locally.)

      Windows 10 Pro Version 2004: Group ASAP (chump/pioneer)

      1 user thanked author for this post.
    • #1994839 Reply

      MrJimPhelps
      AskWoody_MVP

      Thanks for the info, Noel. One of my customers has several computers at 1809 right now. They will probably want me to move them to 1903 before long. I do a LOT of remote support, so this may be a lifesaver for me.

      Group "L" (Linux Mint)
      with Windows 8.1 running in a VM
    • #1994889 Reply

      woody
      Da Boss

      I just added this to the main post:

      UPDATE: Interesting. There’s a post on the Microsoft Answers forum from KevinMarchant that complains about the “high CPU after disconnecting” problem on Win10 1903. That post is now marked “*** PROBLEM RESOLVED BY KB4522355 RELEASED OCTOBER 24TH 2019. ***”

      Any chance that the latest optional, non-security update actually fixes the mouse jitters, too?

      The KB article says:

      Addresses an issue with high CPU usage in Desktop Window Manager (dwm.exe) when you disconnect from a Remote Desktop Protocol (RDP) session.

    • #1994951 Reply

      anonymous

      Nope, Microsoft has not fixed anything in this regards, and certainly won’t be able to do until they hire some skilled developers.

      Beside erratic mouse cursor behavior when entering the RDP session, the new WDDM GFX driver introduced in 1903 also is heavily leaking memory (several GiBs in a couple of days), just monitor the memory usage of the WUDFHost.exe process.

      However, Noel’s advice to disable the group policy is the only available workaround; and the new WDDM GFX driver is utterly useless junk anyway.

    • #1994975 Reply

      Noel Carboni
      AskWoody_MVP

      Yeah, the same workaround apparently helps with black screen issues too, but if you don’t have those then it was a good bit more difficult to find a fix for the mouse jumpiness. Just posting this with the term jittery mouse in the title may help others find the workaround.

      -Noel

      5 users thanked author for this post.

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Carboni: Jittery mouse when controlling Win10 version 1903 via RDP? There’s a solution.

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.