News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Computer won’t sleep since March updates

    Home Forums AskWoody support Windows Windows 10 Windows 10 version 1909 – November 2019 Update Computer won’t sleep since March updates

    Viewing 6 reply threads
    • Author
      Posts
      • #2224043 Reply
        mpw
        AskWoody Plus

        I installed KB4551762 and KB890830 on Sunday, April 5, 2020.  I have not been able to get my computer to stay asleep since.  It looks like it is going to sleep when idle, but comes back on.  Sometimes the screen display comes back on too, but not always.

        I tried Start>Power>Sleep and the screen only goes out for a second and then come back on.  So, I also can’t get it to sleep manually either.

        Last night I just turned it off.

        Shut down and restart still work.  Sleep does not.

        Is this a known bug?

        Any ideas?

        Thank you.

        HP Pavilion Desktop TP01-0050 – 64 bit
        Windows10 Home v1909 – Build 18363.778
        Windows Defender and Windows Firewall
        Microsoft Office Home and Business 2019

      • #2224078 Reply
        EP
        AskWoody_MVP

        “Wake on LAN” option enabled? (assuming you are using a wired/ethernet LAN connection with a network LAN adapter), turn this option off

        also check this site for other solutions:

        https://windowsreport.com/windows-10-wont-stay-in-sleep-mode/

        2 users thanked author for this post.
        • #2224089 Reply
          mpw
          AskWoody Plus

          I don’t know what “Wake on LAN” is.  Where is this setting?

          Another site referred to the same link you do but that seems to be about wanting to be able to wake the computer.  My problem is getting it to stay asleep.

          Could you just point me to the setting in Windows 10 that turns on “Wake on LAN”.

          Thank you.

          HP Pavilion Desktop TP01-0050 – 64 bit
          Windows10 Home v1909 – Build 18363.778
          Windows Defender and Windows Firewall
          Microsoft Office Home and Business 2019

          • #2231783 Reply
            Bundaburra
            AskWoody Plus

            In case you haven’t already found it, Wake on LAN can be disabled in one or two places:

            In your BIOS/UEFI setup, there may be an option under POWER or POWER SETUP (or similar) to disable it.

            In Windows, open Device Manager, right-click on the network adapter, select Properties, then Advanced.  You will see a drop-down list of various items;   scroll down to “Wake on Magic Packet” (or similar) and set its value to Disabled.

             

            Windows 10 Pro 64 bit 2004

            1 user thanked author for this post.
            mpw
      • #2224087 Reply
        mpw
        AskWoody Plus

        Well Sunday night until I found it awake and shut it down here is a sampling from the Event Viewer:

        –Background Intelligent Transfer Service keeps going back a forth from demand start to auto start

        –Hardly seems possible but there are even more DistributedCOM event 10016’s than usual

        –I uninstalled Xbox app but it won’t go away from the start menu so uninstalling app on windows 10 (Start>Settings>Apps>Xbox Game Bar> uninstall) does not work and Sunday night the computer was also awakened for this: Installation Successful: Windows successfully installed the following update: 9NBLGGH537C2-Microsoft.XboxGameOverlay

        –Also, this happened: Kernel-General event 16  The access history in hive \??\C:\ProgramData\Microsoft\Provisioning\Microsoft-Desktop-Provisioning-Sequence.dat was cleared updating 0 keys and creating 0 modified pages.

        –Several times “The system is entering sleep event 42” would be followed one second later by “The system has resumed from sleep event 107.”

        –The Power-Trouble Shooter event 1 reported: Wake Source: Device -Realtek Gaming GbE Family Controller several times.  Other times it reported source unknown.

        –I tried right click Start>Shut down or sign out>sleep. That did not work either, it signed me out.

        –I ran sfc scan and it was good, “Windows Resource Protection did not find any integrity violations.”

        –Using Device Manager, I uninstalled Realtek Gaming GbE Family Controller, which was identified as the wake source.

        –I also uninstalled my display adaptor, Intel(R) UHD Graphics 630, because several places on the internet said this is often the cause of problems getting the computer to stay asleep.

        –I restarted the computer and the drives were reinstalled on these two devices.

        –I discovered that the Realtek Gaming GbE Family Controller was set to wake the computer under Device Manager>Properties>Power Management tab.  I unchecked, “Allow this device to wake the computer.”

        TA DA that last was the problem.  I do not know how “Allow this device to wake the computer” got checked in the first place and don’t know how an update would cause that to happen but my computer has been able to go to sleep and stay asleep when the computer is idle. That is the sleep function I use.

        But still Start>Power>Sleep seems to sign me out and not put the computer to sleep.  I never used that until idle-to-sleep stopped working so I won’t miss it.  Don’t know why can’t just click sleep and it sleep.

        If anyone has any ideas about that I could use some help.

        Thank you.

        HP Pavilion Desktop TP01-0050 – 64 bit
        Windows10 Home v1909 – Build 18363.778
        Windows Defender and Windows Firewall
        Microsoft Office Home and Business 2019

        • This reply was modified 1 month, 3 weeks ago by mpw.
        • #2229371 Reply
          anonymous
          Guest

          “Allow this device to wake the computer” got checked in the first place…;

          Allowing devices to wake computers from sleep is the default setting for most peripherals, upon (re)installation of driver your preferences are reset to the manufacturer’s preset.

          Another helpful thing to do for a sleepless computer is to disable wake timers,

          You should also open Task Scheduler and look for tasks which request to wake the computer out of sleep (or hibernation).

          1 user thanked author for this post.
          mpw
      • #2224108 Reply
        Bundaburra
        AskWoody Plus

        In Device Manager, look at the Properties of your mouse, keyboard, network adapter (possibly other devices?).  Within Properties for each device, open Power Management and ensure that “”Allow this device to wake the computer” is not checked.  If the mouse, for example, is “allowed”, then someone walking past and accidentally touching it could wake the computer.

         

        Windows 10 Pro 64 bit 2004

        1 user thanked author for this post.
        mpw
      • #2231789 Reply
        Paul T
        AskWoody MVP

        But still Start>Power>Sleep seems to sign me out and not put the computer to sleep

        Under Power settings, edit the power plan and select “Advanced settings”. Turn off “Require a password”.

        cheers, Paul

        1 user thanked author for this post.
        mpw
        • #2232613 Reply
          mpw
          AskWoody Plus

          I do not find that setting under advanced power settings.  I have windows home.  Maybe only windows pro has that setting.  I can’t find anything about password in the power settings section.

          HP Pavilion Desktop TP01-0050 – 64 bit
          Windows10 Home v1909 – Build 18363.778
          Windows Defender and Windows Firewall
          Microsoft Office Home and Business 2019

      • #2232992 Reply
        mpw
        AskWoody Plus

        Paul T,

        Thank you.  I had my computer set that way.  I had several sites bookmarked from the very beginning with settings recommended by different folks for Windows 10 and that was one I set when I when first turned this computer on.  I never wanted to have to sign in because I never had to with Windows 7.

        I have always just let my computer go to sleep when idle.  I also have always let the mouse wake it up.  I like to just sit down, touch the mouse and in a nano second the desktop appears.  That is working fine again now since I changed the setting on the network adapter so it does not wake the computer.

        The only remaining mystery is why I can’t manually put the computer to sleep using one of the menus that appear from the START button.  One menu appears when I left click and a different menu appears when I right click on START, both have a sleep option and neither works.  The computer just restarts when I click on sleep.

        It doesn’t really matter I guess.  I just thought someone might know why it broke.

        HP Pavilion Desktop TP01-0050 – 64 bit
        Windows10 Home v1909 – Build 18363.778
        Windows Defender and Windows Firewall
        Microsoft Office Home and Business 2019

        • #2233133 Reply
          anonymous
          Guest

          Have you looked in Event Viewer > Windows Logs > System for critical errors related to power or sleep after the unexpected restart?

          1 user thanked author for this post.
          mpw
      • #2240594 Reply
        mpw
        AskWoody Plus

        Have you looked in Event Viewer > Windows Logs > System for critical errors related to power or sleep after the unexpected restart?

        Excellent suggestion.  Unfortunately, when I tried to follow through, sleep worked.  I am now able to manually put my computer to sleep from START.  I can choose sleep from the left click or right click menu from START.  Choosing sleep works from either menu. I have no idea why.

        Still your suggestion was spot on.  Thank you.

        HP Pavilion Desktop TP01-0050 – 64 bit
        Windows10 Home v1909 – Build 18363.778
        Windows Defender and Windows Firewall
        Microsoft Office Home and Business 2019

    Viewing 6 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Computer won’t sleep since March updates

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.