• Could somebody please explain the new Win7 and 8.1 Meltdown/Spectre “unbootable” AMD patches to me?

    Home » Forums » Newsletter and Homepage topics » Could somebody please explain the new Win7 and 8.1 Meltdown/Spectre “unbootable” AMD patches to me?


    Whotta mess. Patches are flying all over and they don’t make any sense. Win7 and 8.1 get new Security-only AMD patches to replace the old ones, but th
    [See the full post at: Could somebody please explain the new Win7 and 8.1 Meltdown/Spectre “unbootable” AMD patches to me?]

    5 users thanked author for this post.
    Viewing 16 reply threads
    • #159636

      The Security Only patches were updated – Win7 had three versions, Win 8.1 had two.
      Was the security-only component of the Rollups updated as well?
      The Rollup for Win8.1 was delayed possibly long enough to be changed, but how about Win7’s Rollup

      4 users thanked author for this post.
    • #159642

      Yes, this all is quite a mess if one is seeking definitive information on these patches. It is even more difficult to predict what processors will ultimately have BIOS/microcode updates released as many motherboard OEMs tri to EOL support at 3 years. Actually, this really should be quite thought provoking when one observes how tech companies are trying to force feed hardware/software into products like automobiles. The average ticket on a new car is currently around $36,000 and higher end vehicles support stickers above $60,000. The support practices we are talking about here for PCs and other devices might be annoying but after all, the investment most people have in their systems is under $2,500. If you are prematurely obsoleted relative to the physical life of your system, you may have been treated poorly but you eat the cost and life goes on. When you start artificially obsoleting products like autos for ridiculously short EOL support policies, you are entering an entirely different paradigm. We are nearing a time when these companies are going to have to put on their ‘big boy pants’ and start conducting themselves like most other product manufacturers have for years. Excuse me for drifting a bit off topic but we have been putting up with an awful lot of cr$p from MS and others the last few years.

      6 users thanked author for this post.
    • #159659

      The digital signature of all files now available at http://www.catalog.update.microsoft.com/Search.aspx?q=KB4056897 is dated January 2. The digital signature of all files now available at http://www.catalog.update.microsoft.com/Search.aspx?q=KB4056898 is dated January 4. The digital signature of all files now available at http://www.catalog.update.microsoft.com/Search.aspx?q=KB4056894 is dated either January 2 or January 3. The digital signature of all files now available at http://www.catalog.update.microsoft.com/Search.aspx?q=KB4056895 is dated either January 4 or January 5.

      1 user thanked author for this post.
    • #159663

      Here’s my take on this: If your computer has been rendered unbootable by the one of the old updates, Microsoft wants you to remove the faulty update via methods discussed already in other threads, and then install the new update. If you have installed one of the old updates, and your computer remained bootable after a restart, there is probably no compelling reason to install the new update, but there probably is no harm in doing so either.

      2 users thanked author for this post.
    • #159668

      From An Update on AMD Processor Security (January 11) (my bolding): “Microsoft is distributing patches for the majority of AMD systems now. We are working closely with them to correct an issue that paused the distribution of patches for some older AMD processors (AMD Opteron, Athlon and AMD Turion X2 Ultra families) earlier this week. We expect this issue to be corrected shortly and Microsoft should resume updates for these older processors by next week. For the latest details, please see Microsoft’s website.”

      • #159701

        Right but, as far as I know, Microsoft hasn’t said which processors were blocked, which were lifted, and which remain blocked. Nor have they said if the new Security-only patch fixes some, all, or none of the ones that are currently blocked.

    • #159709

      OK, I have a Win 8.1 system on AMD Bobcat (Fusion) processor machine. When I installed the 8.1 monthly roll-up KB4056895 it locked up my machine.
      I unlocked by doing a system restore to before the roll-up install.
      MS says that KB4073576 (111.3 MB size!) resolves the lockup issue but MS doesn’t say how to handle the two updates. Which do I install first, KB4056895 that previously locked up my machine or KB4073576?
      Do I have to install both or can I just install KB4073576?
      Please provide advice and explanation.
      Of course, it would have helped had MS made this clear.
      Also, how do I know if my AMD processor is covered by these updates?

      Edit to remove HTML
      Please convert to plain text before copy/paste

      • #159727

        All updates can be installed together before reboot

        or in your case, installing KB4073576 first would be better (because it has newer components)

        2 users thanked author for this post.
    • #159721

      12/11/17 is that last update I did to my Windows 10, version 1709 based on Woody’s recommendations. That must have been the 11/2017 update. Is that the last one that Woody recommended we do?

    • #159729

      The new Win 7/8.1 patches KB4073578/KB4073576 replaces security-only updates

      those who rely on WU’s Monthly Rollup and hit by “unbootable” issue and was able to restore/recover, will recieve the fix in the next Monthly Rollup

      i was suspecting it to be this tuesday, but the whole spectre/meltdown mess delay it

      4 users thanked author for this post.
      • #159731

        security-only updates, yes.
        security-quality rollup updates, no.

        KB4073576/KB4073578 must be installed on top of the “quality” updates KB4056895/KB4056894.

        I actually downloaded & installed the KB4056894 and KB4073578 updates on my Win7 x64 computer recently (not thru WU but thru MS Update Catalog) that uses an old Intel Pentium D 945 CPU, rebooted and things seem to work okay; no serious performance penalties with the updates. I’ll have to download & install the 32bit/x86 equivalent patches on my aunts old Compaq PC with 32bit Win7 Pro using an old AMD Athlon XP 3200+ (an AMD K7 processor) and see how things go (that’s the real test, heh!).

      • #159744

        Any guess when we’ll see it?

    • #159765

      From Woody’s ComputerWorld article:
      To recap, we have patches for Win7 and 8.1 AMD computers that officially only apply to bricked AMD computers, but still install on Intel computers, and come up with a newer hvax64.exe file.

      Could it be that the new patches are “2-in-1” & meant for both bricked AMD & Intel PCs ? Some PCs with older Intel CPUs also got killed by the same BSOD that hit older AMD PCs, after installing Meltdown patch v1.


      and that’s all of the description on offer […] but there’s exactly zero advice on how to use the patches, or what fixes they include.

      The mysteriousness is not just restricted to the mysteriously updated Meltdown kernel patches. Maybe Microsoft is trying to become millennial — & succeeding quite well.

      A few years ago, I read a couple of IT articles that explained why modern software & mobile smart hardware (especially those released since 2011 or so) are deliberately designed to be functionally obscure — & of course, shipped with zero official guidance descriptions or even a proper user manual.

      The purpose is to maximize the discovery & co-sharing quotients of the software or hardware. Meaning: User A discovers via trial & error how to access/use a certain function of the software/ hardware, & then teaches User B online or in person how to access/use the said function. User B repeats the process to User C — & so on.

      Right now, for those of us who find the whole millennial-style design & user experience mystifying (& unnecessarily frustrating), I think the hint to us is that we need to upgrade our Jurassic style of using software & hardware.

      The trade-off of the millennial style is that it takes a much longer time to do anything properly. I wonder why the solving & sharing of obscurely-designed software/hardware are valued more highly than precious time & obvious elegant solutions.

      Perhaps it all boils down to commercial priorities. The more people twiddle with & discuss (“share”) a certain software or hardware in an effort to get answers, the more publicity it gets & the more popular it seems.

      1 user thanked author for this post.
    • #159832

      Martin Brinkman has a rundown on his website posted 17/01/18


      No problem can be solved from the same level of consciousness that created IT- AE
      2 users thanked author for this post.
    • #159835

      For those that have an affected CPU and want to install the January 2018 Windows monthly rollup, I think this would probably work:

      1. If your machine is unbootable, get rid of the January 2018 Windows monthly rollup using one of the techniques already mentioned elsewhere.
      2. Install the new update (KB4073578 or KB4073576). Restarting the computer is optional.
      3. Install the January 2018 Windows monthly rollup. Restart computer.

      4 users thanked author for this post.
      • #159850

        As a test, on an Intel CPU (I don’t have an affected AMD CPU to test) Windows 7 x64 virtual machine, I installed KB4073578, and without restarting the virtual machine, then manually installed the January 2018 Windows monthly rollup KB4056894, and then restarted the virtual machine. After the restart, I inspected a few of the files that differ between these two updates. In all cases that I checked, the newer file version 6.1.7601.24009 from KB4073578 was in effect, not the older file version 6.1.7601.24000 from KB4056894. This was the expected behavior, but nonetheless is good news :).

    • #159841

      “To recap, we have patches for Win7 and 8.1 AMD computers that officially only apply to bricked AMD computers, but still install on Intel computers, and come up with a newer hvax64.exe file.”

      To clarify, there are many executable files that differ between the two Windows 7 x64 updates KB4056897 and KB4073578 (contents unpackaged with CBS Package Inspector), but file hvax64.exe is the only one that changed in size. I don’t know whether any of the other changed executable files have changes beyond version numbering. According to http://hvinternals.blogspot.com/2015/10/hyper-v-debugging-for-beginners.html hvax64.exe is the Hyper-V hypervisor for AMD CPUs. I am curious if the unbootable AMD computers all had Hyper-V installed.

      3 users thanked author for this post.
    • #159853

      Hi, many thanks for all the info.

      I have a bricked AMD machine.  I don’t remember which update was the culprit, the roll-up or the security update.  I’ve searched but can’t find a simple description of the rescue procedures.

      1.  How do I identify and uninstall the bad update on an unbootable machine (I have XP on dual boot on the same PC)?

      2.  I’ve downloaded both new MS fixes, 4056897 and 4073578.  How do I install?

      Many thanks

      • #159856

        I assume you have Win7, since the patches you mention are Win7 updates.
        KB4056894 is the 2018-01 “Security Monthly Qulaity ROLLUP” installed through Windows Update.
        KB4056897 is the 2018-01 “Security Only Quality UPDATE” – manual download/install from MS Update Catalog.
        KB4073578 is the security-only fix for unbootable AMD – manual download/install from MS Update Catalog.

        Boot your computer from a bootable Rescue Disk. This can be made on any Win7 computer with the same bitedness (32-bit or 64-bit) as yours. (All programs\Maintenance)
        Choose System Restore.
        Restore your computer to before the update was installeda day.
        Reboot and install both KB4073578 and KB4056897 (in that order) by double clicking on the .msu files. It is not necessary to reboot in between – choose “Close” on the box when the first installation completes. Reboot your computer after the two installs.

        • #159858

          Thanks.  Unfortunately system restore from the recovery console finds no restore points.  I gather that the update didn’t create any, although I’m surprised not to find others that I know were made.

          Any thoughts?

          • #159859

            There is sometimes a check box that says “show other restore points” (or something like that). Did you check that?

            Otherwise, there are removals from the Command Console using DISM or PowerShell commands.

            1 user thanked author for this post.
          • #159863
            1 user thanked author for this post.
          • #159866

            Elevated command prompt
            wusa.exe /uninstall /quiet /norestart /kb:4056897

            Or whatever kb you want to uninstall.
            Reboot after the uninstall.

            2 users thanked author for this post.
            • #159992

              I’ve got DSIM.exe working ok, but I get various errors.  The drive letter I’m using was checked with DIR and it’s correct.  I’ve checked syntax on the various attempts to get DSIM to work, and all seems ok.  The errors are as follows for the various attempts:

              Revertpending actions – error 32
              get-packages – error 32
              get-mountedwiminfo – error 87
              get-wiminfo – error 87

              Unfortunately  don’t know how to read the generated log files.

              I was hoping to use removepackage after getting the right package name with get-packages



            • #159996

              See @MrBrian ‘s more detailed description here
              or more instructions on ghacks.

              1 user thanked author for this post.
            • #160000

              The MrBrian fix gives error32.  The other demands the full name of the package, which I haven’t been able to get as ‘get-packages’ gives me an error.

              Thanks for your help.  What a nightmare this is.

            • #160002


              Elevated command prompt
              wusa.exe /uninstall /quiet /norestart /kb:4056897

              Or whatever kb you want to uninstall.
              Reboot after the uninstall.


              1 user thanked author for this post.
            • #160006

              That was the first thing i tried.  I get ‘not recognised as internal or external command.


            • #160009

              C:\Windows\System32\wusa.exe /uninstall /quiet /norestart /kb:4056897

              1 user thanked author for this post.
            • #160015

              Running wusa.exe from the windows 7 system32 as you suggested gave no error and seemed ok for both bad KBs.  No fix though.
              It didn’t report any result, presumably because of the quiet switch?

              The system hangs of the black ‘Starting Windows’ screen.

              Anything else to try?


              Thanks again, and apologies for all the trouble I’m putting you to here.


            • #160017

              I’ll have to stop now, I’m afraid.  I’ll try again tomorrow.



            • #160019

              Since it won’t boot, it most likely didn’t complete the install.
              The most likely would be one you say didn’t work:

              dism  /image:d:\  /cleanup-image  /revertpendingactions

              or c: – Whichever drive letter works

              1 user thanked author for this post.
            • #160218

              Thanks.  I’ll try again.

              Can I confirm how to elevate privileges from cmd?  I’m using net user administrator /active:yes  but have no confirmation that’s working.

            • #160221

              If you are logged in as administrator, that should work

              1 user thanked author for this post.
            • #160222

              I’m not logged in as anything.  I’m running cmd either from the recovery console on boot disk or  via the unbootable system32.

            • #160225

              Try this:

              Move to the Windows\System32 folder on the OS drive. Execute the DISM command there.
              Do C: then dir, D: then dir, etc till you find the drive if the PC.

              cd windows\system32

              1 user thanked author for this post.
            • #160242

              I suspect the problem is I may not be getting elevated privileges when I run DISM from the win 7 windows/system32.  Alternatively DISM may not be finding its binaries.

              Curiously, if I run with definitely elevated privileges from inside XP (dual boot), targeting the Win 7 image (on drive F:) I get an error 126 =failure to locate DISM binaries.  If I check their path, I find they’re in  a DISM folder within the system32 folder, but the dism.exe is in the root of the system32 folder.

              I can’t see why I shouldn’t be able to run DISM from inside an XP elevated CMD.

            • #160245

              XP? Where did XP come from? I thought you were booting from a Win7 Rescue Disk, or using the F8 key on the Win7 computer.

              1 user thanked author for this post.
            • #160248

              I did mention in the original post that this was a dual boot machine with XP.  It shouldn’t matter, in that I always check the drive letter for the Win 7 partition hasn’t changed, and that’s the one I’m using for these operations.

              The question mark over whether i’m getting a true elevated cmd led me to try running the DISM from inside XP, where I know I can get elevated privileges.  Just an experiment.

              Incidentally, I’ve since seen a reference to dual boot XP and Win 7 deleting Win 7 restore points when XP is booted.  A bug seemingly. So that may explain the lack of earlier restore points I found puzzling.


            • #160249

              Start over.
              On the Win7 computer that has the problem
              Either boot from a Win7 Rescue Disk or press F8 on bootup
              Choose repair the computer
              Choose Command prompt
              Using dir d:, dir e: etc verify OS drive letter
              Perform (using the OS drive letter)

              dism  /image:d:\  /cleanup-image  /revertpendingactions



              1 user thanked author for this post.
            • #160280

              I’ve done this several times, always checking the drive letter.  I suspect it’s not working because I’m failing to get elevated privileges.

              I’ll try again

            • #160303

              It worked this time!

              Many, many thanks.  I’m convinced I did nothing different this time (but then i would say that 🙂 )

              I really appreciate your patience and willingness to stick with the problem.

              Best regards,


              1 user thanked author for this post.
            • #160307


              1 user thanked author for this post.
            • #160348

              “It worked this time!”

              Great :). Here is a reference on this command: Getting out of a no boot situation after installing updates on Windows 7-2008R2.

              1 user thanked author for this post.
            • #161579


              looks like the /revertpending actions didn’t sort everything.  On each reboot, I get ‘failure configuring updates’ ‘reverting changes’ ‘Update 3 of 14259’
              I’ve used dsim again, including specifying a scratch folder as I got a message saying the temp might not be big enhough.   Now I get error 0X8000ffff

              I’ve attached the DSIM log file if that helps.

              I’m still not certain I’ve successfully elevated priviliges.  I ran cmd from the installation disk console using crtrl/cmd/del.

              Any ideas I should try?

              Many thanks again.


            • #161603

              Have you tried this DISM command today?

              1 user thanked author for this post.
            • #161613

              I’ve just tried that and it says ‘dism doesn’t support windows vista or earlier…’

              and ‘Check that ssshim.dll is present’

            • #161619

              If you type


              at the command prompt in the last instructions (i.e. after pressing F8 during boot) instead of DISM, what version does it give?

            • #161806

              Winver 6.1 build 7601


              1 user thanked author for this post.
            • #161823

              The version from winver looks good. You may wish to try post #161603 again just in case you typed the command wrong the last time. If that doesn’t work, and if nobody else here responds, you may wish to ask at https://www.sysnative.com/forums/windows-update/?s=cf0e2111cfe99ada8a18739992656d25.

              1 user thanked author for this post.
            • #161846

              I copied and pasted form a text file into the cmd line, so i’m confident it was correct.
              All a puzzle.


              Thanks again

              1 user thanked author for this post.
        • #159864

          Many thanks for that.  I didn’t know that I could use a Rescue Disk created on one machine to rescue a different machine.  I thought that the Rescue Disks (I have a collection of DVDs, for experimental machines, to match their associated system images on USB hard drives) were specific to the target machine, and possibly even to the particular rescue operation which might be envisaged (and so had to be refreshed fairly frequently).

          • #159868

            To make this clear:

            This is RESCUE Disk, NOT Restore Disk.
            Has to be the same version of Win and the same bitedness.

      • #159886

        There should be no need for a rescue disk if pressing F8 during the boot sequence works. See Fix Windows 7 BSOD 0x000000c4 after installing KB4056894.

        1 user thanked author for this post.
      • #159893

        After your machine becomes bootable again, I gave a procedure that you could try at https://www.askwoody.com/forums/topic/could-somebody-please-explain-the-new-win7-and-8-1-meltdown-spectre-unbootable-amd-patches-to-me/#post-159835. You can skip the “Install the January 2018 Windows monthly rollup” part of step 3 if you don’t want the January 2018 Windows monthly rollup to be installed.

        • #159895

          If you don’t want to install the January 2018 Windows monthly rollup in step 3, then you should install the latest Cumulative Security Update for Internet Explorer instead.

          1 user thanked author for this post.
    • #159905

      Ok I may have the answer for your question.

      History: I have an amd athlon 64×2 (tk-53) with win7 32bit. When I firstly installed the kb4056894 a BSOD appeared and I had to restore windows. Since then, no update was offered via windows update.

      So I was as confused as you about which update I had to install first. I decided to install the new one first. I have to mention that non of them was being offered via windows update.

      So I installed from catalog the update KB4073578 and restarted the machine. I  run windows update and still nothing was being offered (though i had the reg key). Then I installed from catalog the KB4056894 and restarted again. Everything seems ok and I did not have any BSOD (so far).

      So I believe that only the 1st assumption of Martin Brinkmann is valid (AMD devices need the newly released patches before the previously released security updates are installed on the devices.”)

      EDIT html to text

      1 user thanked author for this post.
    • #159916

      Need clarification please- the new patches are for AMD procs only? If so, why are people installing on intel procs?  I have an intel i5 2500k on an asus board with kb4056894 in WU.  should i be concerned about these new patches or just install the rollup when we come off of defcon 2? Also, the .net framework patch is there(unchecked).

      Many thanks to you all who are helping to get to the bottom of this mess and advising the rest of us.


      Win 10 Pro v.20h2

      • #159917

        Just wait and install the Rollup when we come out of DEFCON 2.
        The .NET Rollup is unchecked so it won’t be installed. THere have been problems with it.

        1 user thanked author for this post.
        • #159973

          I have been getting updates for a long time on my antique computer and none are checked , no matter what category they fit into. HP, 2009 Win7 SP1 x64.

      • #159920

        The new updates (KB4073576 and KB4073578) probably work fine on Intel processors (I tested two Intel processors) but are probably only needed for those AMD processors that have the issue.

        1 user thanked author for this post.
    • #159969

      MrBrian, PKCano , Woody and others:  I have a HP p6520y Desktop with (4) AMD Athlon II X 4 635 Processors and 6 GB RAM, running the original October 2009 Win 7 SP1 x 64 System . I have had no BSOD’s, or any other related problems, yet the updates to remedy the AMD processor problem appeared on Windows update as important. Hope this bit of info helps rather than muddies the water.

      1 user thanked author for this post.
      • #160134

        Brian L – I have HP desktop with AMD Fusion (Zacate) Bobcat processor and Win 8.1  The monthly rollup KB4056895 appears in my Windows Update list but the KB4073576 update (AMD fix for KB4056895) does not appear in my Windows Update list.  Does that mean my AMD processor doesn’t have (or need) a fix?  When I installed the monthly rollup my computer locked up.  Still unclear which AMD processors need fixing.

        • #160140

          KB4073576 isn’t available via Windows Update. It’s in the Microsoft Update Catalog.

          You could also try KB4057401, which from my analysis has the fixes in KB4073576.

        • #160143

          KB4056895 is the Monthly Rollup that is delivered through Windows Update.

          KB4073576 is a Security-only patch that must be downloaded from the MS Catalog and manually installed. I does not come through Windows Update. If you install this patch, you will also need the IE11 Cumulative Update. Both patches are available through AKB2000003 on this site.

    • #160052

      From https://www.askwoody.com/forums/topic/windows-patches-are-rolling-out-now/#post-160050: “[…] Therefore I believe that KB4057401 will probably not cause boot problems with AMD processors.”

    Viewing 16 reply threads
    Reply To: Could somebody please explain the new Win7 and 8.1 Meltdown/Spectre “unbootable” AMD patches to me?

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: