News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • Cyper Power Power Panel V2.2.1 Software and Windows 10 2004

    Home Forums AskWoody support Windows Windows 10 Windows 10 version 2004 – May 2020 Update Cyper Power Power Panel V2.2.1 Software and Windows 10 2004

    Topic Resolution: Resolved
    Viewing 9 reply threads
    • Author
      Posts
      • #2281999
        arbrich
        AskWoody Plus

        Hello All.

        Been noticing an issue with installing the latest Cyper Power Power Panel V2.2.1 Software and Windows 10 2004.

        Whether you use it on a system that has been updated to 2004 or a brand new build it seems you cannot install this version of the software and it locks the PC up bad and you have to restart then you need to use a 3rd Party utility to uninstall the software as the built in uninstaller will lock the PC up as well. I have contacted Cyber Power and am trying some older version to see how they do.

        Has anyone else seen this behavior. I work mostly with Dell PCs.

        Thanks for any Feedback

      • #2282654
        Microfix
        AskWoody MVP

        You’d be better contacting ‘Cyber Power’ directly or even cyper power but can’t find them anywhere 😉

        PowerPanel® Personal 2.2.1 for Windows Released

      • #2282691
        arbrich
        AskWoody Plus

        Upon further investigation I determined that the problem was Symantec Endpoint Protection 14.3 Even though we only use the Antivirus component. If you disable Symantec you can install the power panel and then re-enable Symantec and everything seems to work fine. Must be a change in Symantec. Will need to see if affects any other installs.

        Sorry about the typo above – Cyber Power.

         

         

        4 users thanked author for this post.
        • #2283532
          CADesertRat
          AskWoody Plus

          Upon further investigation I determined that the problem was Symantec Endpoint Protection 14.3

          Thanks for posting that, it’s good to know. I haven’t used Symantec in many years so I shouldn’t have a problem with my CyberPower UPS’s when/if I decide to go to 2004.

          Don't take yourself so seriously, no one else does 🙂
          3 Win 10 Pro at 2004 (3 Desktops, 1 Laptop).

      • #2283505
        anonymous
        Guest

        I have an issue too after a day or so uptime the software says lost contact with USB.  It does not comeback until reboot.  Even with restarting services.

        • #2283534
          Elly
          AskWoody MVP

          Go to Device Manager/Universal Serial Bus controllers/ and go through the USB Devices and hubs, click Properties, select Power Management, and uncheck ‘Allow the computer to turn off this device to save power’…

          For some reason my keyboard and mouse never had problems, but anything else that uses a USB connection seems to get aggressively turned off unless this is unchecked.

          Non-techy Win 10 Pro and Linux Mint experimenter

          1 user thanked author for this post.
      • #2283513
        CraigS26
        AskWoody Plus

        I’ve used the ancient app forever ( UPS 825AVRLCD-G )  as the modern app was always flaky. I also have a note that after an App install in — Run/services.msc — PowerPanel Personal Service line was Blank & I assume I clk’d it to show Started. Other Users with issues might visit there as part of trouble-shooting.

        W10 Pro 20H2 / Hm-Stdnt Ofce '16 C2R / HP Envy Desktop-Ethernet/ 12 GB / 256G SSD + 1 TB HDD / i5-8400 CoffeeLake-S / GP=2 + FtrU=Semi-Annual + Feature Defer = 1 + QU=0

        • This reply was modified 8 months, 2 weeks ago by CraigS26.
        • This reply was modified 8 months, 2 weeks ago by CraigS26.
      • #2283852
        Kathy Stevens
        AskWoody Lounger

        We use PowerPanel to manage our battery backup power supply to bridge the gap between the time that we lose power and our generator kicks in.

        I was having a problem with Cyber Power’s PowerPanel personal edition 215 that I had installed in March.  After Windows 10 Pro, Version 1903, Build 18362.900 went to sleep PowerPanel would not reconnect with the battery backup after it woke up. The result was that our work station would shut down at the beginning of a blackout and before the generator kicked in.

        We uninstalled PowerPanel 215 edition and installed an old version (1.5.2 a 2015 edition) and all appears to be well.

        • #2283884
          Kathy Stevens
          AskWoody Lounger

          I spoke to soon.

          We are having the same problem with the earlier version of PowerPanel.

      • #2346375
        anonymous
        Guest

        Yes, i have exactly the same issue. Just bought the UPS and installed the software and face exacttly the same thing

      • #2346461
        rexr
        AskWoody Plus

        No problem here with Cyberpower Power Panel Personal v2.2.2 with Win10 20H2 19042.746.

        It is correctly monitoring a Cyberpower CFP1000PFCLCD  UPS, and did on Win10 2004 (i don’t remember the PPP version number used then.). I did nothing special for the install, just download and install.

        Win10 Pro 20H2 19042.804
        Backups with Macrium Reflect home edition
      • #2346510
        Kathy Stevens
        AskWoody Lounger

        We are operating Windows 10 Pro 1909 and find that Cyber Power POWERPANEL Personal version 2.2.3m works fine at boot up and when the PC is rebooted but does not reengage after the PC wakes up from sleep mode.

        It is interesting that when we click open About in our POWERPANEL it indicates that we are using version 2.2.3 but when we go to the website the only Windows 10 version available for download is version 2.2.2.

      • #2346551
        ClearThunder
        AskWoody Plus

        I’m using v2.1.7 with Win10 Pro 20H2. I don’t allow the software to access the internet since it really doesn’t need to once it’s installed.   But I am curious to hear if the newest versions have any features that the old versions didn’t have.

        "Censorship is thought control" ----- Ronald Reagan

        • #2346627
          anonymous
          Guest

          I can not see any difference.

        • #2346693
          rexr
          AskWoody Plus

          No, a basic monitor with few options but that’s fine. If opened, it’s light on the resources at about 50MB RAM and “very low” power draw.

          It does have an email notification for power events. Auto shutdown which I haven’t tested by offing the circuit breaker.

          This CFP1000PFCLCD has taken the load several times during powerouts the past three years with no problem. I’ve been home to shut down the computer after a few minutes.

          PowerPanel® Personal Windows

          Win10 Pro 20H2 19042.804
          Backups with Macrium Reflect home edition
    Viewing 9 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, no politics or religion.

    Reply To: Cyper Power Power Panel V2.2.1 Software and Windows 10 2004

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.