• Did Aug updates make AnyDesk go bonkers?

    Home » Forums » AskWoody support » Windows » Windows 10 » Windows 10 version 21H2 – November 2021 Update » Did Aug updates make AnyDesk go bonkers?

    Author
    Topic
    #2469815

    Is it possible that the August updates to Win 10 Pro 64-bit v 21H2 are causing AnyDesk to go kablooey?

    The two new Dell Optiplex 7000s and one Precision 3660 in my wife’s mini-office have Dell Command Update, which updates quickly when updates are available – no AskWoody delay.  It installed updates as follows:

    Installed KB5015730 on Aug 1.
    Removed KB777778 on Aug 7.
    Installed KB5012170 on Aug 9.
    Installed KB5015895 on Aug 9.
    Installed KB5016616 on Aug 9.

    Then starting Aug 11, I start getting HUNDREDS of Event Viewer Errors for my much-loved AnyDesk.  Those errors are all like the following:

    Log Name:      Application
    Source:        AnyDesk
    Date:          8/12/2022 6:31:43 PM
    Event ID:      0
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      DESKTOP-[Deleted]
    Description:
    The operation completed successfully.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="AnyDesk" />
        <EventID Qualifiers="0">0</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2022-08-12T22:31:43.4142752Z" />
        <EventRecordID>6685</EventRecordID>
        <Correlation />
        <Execution ProcessID="0" ThreadID="0" />
        <Channel>Application</Channel>
        <Computer>DESKTOP-[Deleted]</Computer>
        <Security />
      </System>
      <EventData>
        <Data>  error 2022-08-12 22:31:43.413       back  12608  15896
        base.data.file_config_layer - File config layer update failed.
    </Data>
      </EventData>
    </Event>

    Connected?

    • This topic was modified 1 month, 3 weeks ago by glnz.
    Viewing 12 reply threads
    Author
    Replies
    • #2469817

      Not seeing it on the only one I’ve updated but will keep an eye out as we do more and post back. Is it still working for you?

      Never Say Never

    • #2469975

      @glnz Have updated 3 more machines and after multiple reboots not seeing any errors. Are you seeing errors on the host or remote machine?

      Never Say Never

    • #2470014

      cyberSAR – I’m seeing this on the Remote machines – more than one – and the flood of Error messages starts when I remote in from my host machine.

      All my AnyDesks are the latest version 7.0.14,  What version(s) do you have?

      Thanks for looking.

      • #2470017

        I only have 1 at 7.0.14 the rest are between  6 and 7.0.13. I haven’t installed anydesk on my machine. I run it as portable as I prefer v4.

        I’ll keep an eye out as we do more machines the coming weeks. The error makes me think it may be due to video settings. I have all of mine to fastest reaction time

        Never Say Never

      • #2470052

        You’ve uninstalled the August patches to test?

        Susan Bradley Patch Lady

        • #2470077

          Susan –

          I just UNinstalled both 2022-08 updates, KB5016616 and KB5012170, but the Anydesk Error flood continues, and it is a flood.

          So, this does NOT seem to be caused by the 2022-08 updates.

          And over the last 24 hours I’ve learned that the flood of Error messages occurs when I use AnyDesk to remote in to the machine on which the floods are occurring.  The “Remote” machine gets flooded with Error messages when I connect to it from “home”.

          And this whole thing started just a few days ago.

          Bother!

    • #2470051
    • #2470122

      AnyDesk includes a trace log which shows program usage and includes warnings and errors.

      Check the ad.trace (portable version) or ad_svc.trace (installed version) log files on both source and destination devices for errors. It may tell you when the issue happens, e.g. during the authentication handshake with the AnyDesk relay server or once the relay server drops into monitor mode to allow direct communication between source and destination devices.

      If you’re using an *installed* version of AnyDesk then you should find an ad_svc.trace log file in the %programdata%\AnyDesk folder, e.g. C:\ProgramData\Anydesk.

      If you are using a *portable* version of AnyDesk then you should find an ad.trace log file in the %appdata%\Roaming\AnyDesk folder, e.g. C:\Users\<username>\AppData\Roaming\AnyDesk.

      For example:

      AnyDesk_logs

      The trace log file can be opened in any text editor, e.g. Notepad, Notepad++, etc.

      Look at the first column. Most entries will be marked info but IME with AnyDesk it’s also normal to also see a few warning entries. What you’re mainly looking for are the entries marked error, particularly if there’s a group of them together.

      For example:

      AnyDesk_errors

      PS – I’m going to assume that you downloaded it directly from the AnyDesk website (e.g. https://anydesk.com/gb) rather than obtained elsewhere?

      Hope this helps…

    • #2470164

      Rick – thanks very much for your very informative post.

      From the remote machine that’s generating the gazillion EventViewer Errors when I remote into it,  I am attaching a copy of my ad_svc.trace from which I have [deleted] the particular AnyDesk address.

      There are “errors”, but I’m not knowledgeable enough to understand whether they are relevant or what to do about them.

      Any ideas?

      Right now, I am again going to “soft” uninstall AnyDesk (leaving behind its name, settings, etc.) and install an older version to see if that helps.  But it will take time to see.  Please do let me know what you think about the attached.

    • #2470166

      @glnz Is it possible for you to have one or two of the remote machines log into the other(s) and see if they cause the errors?

      Never Say Never

    • #2470167

      Rick and cyberSAR – Update –

      I’ve soft-uninstalled AnyDesk version 7 something and reinstalled with old version 6.2.3, which I’ve set NOT to do any updates.

      So far (after 30 minutes), so good.  I’ve remoted in once from a different PC (that has version 7 something), and I am NOT seeing new AnyDesk errors in Event Viewer here (on the 6.2.3 machine).

      I’ll continue to test and let you know if things go south again.

      But very curious if my ad_svc.trace copy attached above says anything interesting to you.

      Thanks for your interest !!!!!

      • #2470170

        Looks to me like it could possibly have been a firewall issue????
        https://support.anydesk.com/knowledge/firewall

        From your log

        error 2022-08-14 07:49:56.142 gsvc 3568 5620 8 anynet.dns_resolver – DNS name “boot.net.anydesk.com” couldn’t be resolved (win32_11001, result_aborted).\par
        error 2022-08-14 07:49:56.142 gsvc 3568 5620 8 anynet.relay_connector – Could not resolve DNS name boot.net.anydesk.com (anynet_no_dns_entry).\par
        error 2022-08-14 07:49:56.142 gsvc 3568 5620 8 anynet.relay_connector – Connection failed (anynet_no_dns_entry)\par
        warning 2022-08-14 07:49:56.142 gsvc 3568 5696 os_win.upnp_config – No port mapping collection (0x00000000).\par
        error 2022-08-14 07:49:56.142 gsvc 3568 5732 anynet.dns_resolver – DNS name “boot.net.anydesk.com” couldn’t be resolved (11001).\par

        Never Say Never

    • #2470191

      cyberSAR – well, maybe.  I’ve never played with my Windows firewall but might try at some point.

      Also, all our routers point to Cloudflare’s 1.1.1.2 (No Malware) for DNS lookups – might that be a problem?  Maybe Cloudflare doesn’t have the latest DNS lookup for the latest version of Anydesk.  (Seems unlikely.)

      But so far my down-grading to AnyDesk 6.2.3 is working – the flood of AnyDesk Errors has stopped.

      • #2470205

        Just a guess on my part as I’m assuming your IP hasn’t changed during reinstall. I know when we install it I always get a prompt to allow through windows firewall. I always allow it through both public and private in case my client ends up on a public network. I was just guessing that you allowed it during the reinstall. Your logs were loaded with dns errors so I just took a guess.

        Never Say Never

        • #2470218

          cyberSAR – no, on the reinstall (of version 6.2.3) earlier today, I did not get a prompt.  Keep in mind that that was preceded by a soft uninstall of the 7 version, so lots of settings were retained behind the scenes, such as my AnyDesk identity.

          I may be wrong, but I recall that the installation of AnyDesk does NOT trigger that prompt.  Only the use of AnyDesk.exe as a portable app without installation triggers that prompt, and only once.

          Of course, that’s from memory and I might have that wrong.

          I didn’t check but it’s unlikely my LAN IP address changed, as that PC is always on (except for reboots), and the router tends to keep the same IP addresses going.  I’m also confident that the WAN IP on the other side of our router did not change.

          • #2470223

            I have always been offered the prompt to open firewall on every install. By chance are you or the remote machines on Verizon Business internet? Log is loaded with failures from the IP address. Not sure what the anynet.punch_connector is exactly
            anynet.punch_connector – [108.27.38.XXX:50XXX] Connect failed (result_timeout)).\par

            Also looked and noted your version seems to have updated on the 12th
            info 2022-08-12 00:25:24.365 gsvc 3924 5564 35 app.auto_update – Newest version 7.0.14, Timestamp 20220808112342, File ID anydesk-7.0.14-109b03ffc452\par

            Never Say Never

    • #2470219

      Sorry – I just mistakenly deleted my ad_svc.trace copy above.

      Here it is again — attached.

      Reminder it was taken while I still version 7 something before downgrading to version 6.2.3

    • #2470222

      The trace log shows multiple ‘Could not resolve DNS name’ entries.

      Lines 62-79 refer to ‘relay-b8f8a0be.net.anydesk.com’

      Lines 84-104 refer to ‘boot.net.anydesk.com’

      Both these addresses appear to refer to ‘anynet.relay_connector’ so it looks like the AnyDesk server on the destination device cannot contact an AnyDesk relay server to authenticate/handshake.

      After waiting (line 106), a change is made to the Windows Firewall (line 107) which is successful (line 108), after which connection is established to an AnyDesk relay server using IP address 5.188.124.23, not DNS. (line 124).

      I didn’t try interpreting any further because it’s clear that AnyDesk reverts to keep on trying (and failing) to resolve DNS names to IP addresses.

      On the remote device I suggest you clear the DNS resolver cache and try again.

      For example, if it’s a Windows device, use ipconfig /flushdns from a command prompt.

      Hope this helps…

      (PS – The trace log shows you were using AnyDesk 7.0.13 before reverting.)

    • #2470973

      Update to this. I am seeing numerous errors on remote machines with
      The operation completed successfully.
      Event ID 0 – Couldn’t impersonate (000003f0).

      Most after a reboot go away but I’m fighting a stubborn one with 4 monitors right now. I think AnyDesk update to 7.0.14 may have video issues.

      – <Event xmlns=”http://schemas.microsoft.com/win/2004/08/events/event”&gt;
      – <System>
      <Provider Name=”AnyDesk” />
      <EventID Qualifiers=”0″>0</EventID>
      <Version>0</Version>
      <Level>2</Level>
      <Task>0</Task>
      <Opcode>0</Opcode>
      <Keywords>0x80000000000000</Keywords>
      <TimeCreated SystemTime=”2022-08-17T23:38:03.7688396Z” />
      <EventRecordID>61051</EventRecordID>
      <Correlation />
      <Execution ProcessID=”0″ ThreadID=”0″ />
      <Channel>Application</Channel>
      <Computer>ComputerName</Computer>
      <Security />
      </System>
      – <EventData>
      <Data>info 2022-08-17 23:38:03.768 back 2860 3584 desk_rt.capture_component – Focused monitor changed: 3 (\\.\DISPLAY2)</Data>
      </EventData>
      </Event>

      Never Say Never

      • #2470984

        Rolled this one back to a 6+ version and no more errors flooding event viewer

        Never Say Never

        • #2470985

          cyberSAR – sorry to admit it, but I’m happy I’m not the only one.

          I fixed it the same way as you – rolled back to version 6.2.3, with auto-update off.  No more flood of Errors.

          • #2470987

            @glnz Just curious. Do the machines that gave you errors have multiple monitors? Seems the ones I have with single monitors aren’t throwing the errors after a reboot. BTW not all have had Windows update applied so I think it is an anydesk issue.

            Never Say Never

    • #2470989

      Two are single monitors, the third started as single and went to double.  The worst flood of errors was single only.

      1 user thanked author for this post.
    Viewing 12 reply threads
    Reply To: Did Aug updates make AnyDesk go bonkers?

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: