• Disabling a CPU feature: Intel Turbo Boost

    Home » Forums » AskWoody support » PC hardware » Questions: How to troubleshoot hardware problems » Disabling a CPU feature: Intel Turbo Boost


    Hi.  My motherboard uses a CPU that has the ability to use Intel’s turbo boost 3.0. It’s my understanding that this involves two things. First in the Motherboard BIOS there is a switch or switches that turn the feature on. Second, is the operating system and a driver for the Intel turbo boost app.

    What I have found out is simply disabling or uninstalling the software app for the turbo boost doesn’t work. Windows 10 simply downloads the driver again.   I’ve actually tried removing the driver, disabling the the task and the service. Regardless, windows will still download the driver, install it, and schedule it to run automatically.

    It’s extremely irritating.

    One possible solution would be to turn off the turbo feature in the Bios, but I have no idea what settings those might be (see image). Another solution could be to keep windows from automatically downloading and updating the driver. I have done that, at least I thought, in Windows settings.

    I would appreciate any help or ideas.  Mike

    MB: Asus Prime x299 Deluxe 2




    Viewing 6 reply threads
    • #2212865

      I use Windows’ own Power plan settings to control CPU speed on the fly. Try reducing the Maximum processor state to somewhere between 60 – 80% or calculate the speed/% based on the CPU specs.

      1 user thanked author for this post.
    • #2213338

      If you go into Device Manager, you should see the device Windows keeps downloading the driver for.  If you set that to disabled, it might accomplish what you want.  This kind of active effort on the part of the OS to do what it wants instead of what the hardware owner wants is the whole problem with Windows 10 in a nutshell.

      It would help to know what you are trying to accomplish by disabling Turbo Boost 3.0. Is it not working properly, causing too much heat, fan noise, power consumption, or some other thing?

      Are you trying to reduce it to an earlier form of Turbo Boost, or are you trying to eliminate all Turbo Boost and simply operate at the maximum base clock?

      Turbo Boost 3.0 is apparently a feature on higher-end CPUs, but Turbo Boost (in non 3.0 form) is an intrinsic performance feature of Intel CPUs going way back.  My Sandy Bridge CPU from ~2012 has it, a fact that caused some confusion when I first upgraded from my overclocked Phenom II and began the process of overclocking the Sandy.

      Disabling Turbo Boost completely would reduce the performance of the CPU, which is not what people who shelled out four a high-end CPU would usually want… that is, if that is actually what you want!  It’s your computer, of course, and you should be able to do what you want, but maybe there’s some other way to attack whatever the root issue is for you.


      Dell XPS 13/9310, i5-1135G7/16GB, KDE Neon
      XPG Xenia 15, i7-9750H/16GB & GTX1660ti, KDE Neon
      Acer Swift Go 14, i5-1335U/16GB, KDE Neon (and Win 11 for maintenance)

      2 users thanked author for this post.
    • #2213588

      Thanks for both replies.

      The reason why I don’t want the Turbo Boost is for a couple of reasons.  1) It’s throttling the CPU low in the middle of editing video and causing some glitching.  I can probably take care of that in the power settings.  2) Temperature.  This i9-9900x CPU is a hot little beast and while I have adequate air flow, overclocking is not necessary and just consumes more power and puts out more heat.  That’s the biggest issue.

      Also, I may be able, somewhere to set processor min and max states.  Not sure about that and currently that’s beyond my head.

      If you glance back up in my first post, you’ll see several other settings for this MB.  I’m trying to figure them all out.  My understanding is a combination of these settings will disable the hardware function of Turbo CPU mode.  It seems obvious that it might be the “Turbo” setting, but it more probable that there is another setting in combination with that?

      SpeedStep is an older Intel CPU feature that I think was replaced by SpeedShift for the X generation processors, which I have.  Core C-State and MPC Mode are totally confusing.



      • #2213613

        It’s too high a temperature that throttles CPU speed, but perhaps it’s the data throughput that’s slowing during processing (SATA/SSD/NVMe? How many, which is System drive, storage, scratch, how are their temps?).

        Changing the power plan min/max settings on the fly negates the need for multiple reboots to change UEFI settings during testing.

        Disabling virtual CPU cores might give similar temp/power reductions, again a UEFI setting, so one test per boot.

        1 user thanked author for this post.
      • #2213677

        Throttling under really heavy loads is a normal function of turbo mode, and it should not cause any glitching in operation.  There’s probably another problem lurking inside there.  I’ll freely admit to knowing nothing about video editing, but I don’t think it’s the throttling causing the glitching.

        Still, if you wanted to disable turbo mode completely, the second option in the screenshot will do that.  That will reduce the maximum frequency to the base 3.5 GHz.  That is the highest frequency, under maximum load, that the CPU will not exceed its TDP (thermal design power) specification, which in the case of your CPU, is a massive 165 watts.  That’s the minimum amount of heat that a cooler used with that CPU should be able to dissipate continuously.

        Turning off turbo mode is like permanently throttling the CPU to the highest degree it would ever throttle itself in use with an adequate cooler.

        The function of turbo boost is to make use of any headroom in the thermal and power draw limits of the setup when the CPU is under a high (but not maximum) load.  If the CPU is under a high load and is at the baseline frequency, and if the CPU temp is not close to the maximum, and the power being drawn is below the short power limit, it will enter a turbo state.  It will increase the clock rate as much as possible until it reaches a limit… either the 4.5 max turbo frequency (which also depends on how the various cores are loaded), the short or long power limit, or the temperature limit.  It will remain at that clock speed as long as none of the limits are reached.

        The short power limit is the maximum amount of power the CPU is allowed to draw for the length of time specified (called tau by Intel).  If the short power limit is 200w for 20 seconds (I have no idea what it actually is; that’s just an example), and the long power limit is 165w (the same as the TDP), the CPU will be allowed to draw up to 200w for up to 20 seconds.  If it’s still pulling more than 165w at the 20 second mark, the CPU will then throttle as much as it has to in order to get the total power draw down to the long power limit of 165w.

        On a really massive load that truly maxes the cores out, like running Prime95, and quite possibly video rendering, it might throttle all the way back to the baseline frequency, since that’s the point where the heaviest load will result in the power draw guaranteed by as the TDP.  At that point, you’d be at the same level of performance, temperature, and power draw as you would if you’d turned turbo mode off, but you’d have had the benefit of greater performance for the length of time defined as tau.

        Most loads are not as brutal as those, though, and it is for these lesser loads that Turbo Boost is designed.  Even if the Task Manager reports that the CPU is at 100% load, it’s not usually 100% for every core and for every single clock cycle.  That means that even under a high load, the CPU can be under the long power limit (usually TDP), which in turn means the temperature should be under the maximum temperature (assuming the cooler is capable of dissipating the amount of heat specified by the TDP).  In that case, the CPU can enter a turbo state, possibly all the way up to the boost limit of 4.5 GHz, and still be putting out no more heat than a really heavy load like Prime95.  The whole point of Turbo Boost is to make use of the extra power left on the table when the CPU is below its TDP.  It can only exceed its TDP for a short time, by a specified amount, and only as long as the temperature is below the maximum.

        Under a very heavy load like Prime 95, and probably video rendering, Turbo Boost normally won’t even be in play except for the first 20 or so seconds.  Under these loads, the CPU will reach its TDP limit (long power limit) and throttle back to the base frequency once tau is exceeded, and that’s only if the temperature limit isn’t reached first.

        If the cooler is up to the 165w specification, the temperature should not exceed the Intel specified maximum under maximum load at the maximum base frequency.  (That’s a maximum number of uses of the word maximum!)  The PC should be capable of keeping the temperatures below the maximum all day at 3.5 GHz under the worst real-world load you throw at it … if not, the cooling isn’t cutting it.  Turbo boost being off won’t change that, since Turbo Boost only engages if there’s power and temperature to spare.

        Undervolting may be an option too, though if done improperly, it can cause glitching or instability (testing will be required to make sure that’s not happening).  It can simultaneously reduce the power drawn by the CPU and the heat it produces.  I’m experimenting with it on my Dell G3 (gaming laptop) right now (i7-8750H 6-core), and it’s been pretty impressive.




        Dell XPS 13/9310, i5-1135G7/16GB, KDE Neon
        XPG Xenia 15, i7-9750H/16GB & GTX1660ti, KDE Neon
        Acer Swift Go 14, i5-1335U/16GB, KDE Neon (and Win 11 for maintenance)

        • This reply was modified 3 years, 5 months ago by Ascaris.
        1 user thanked author for this post.
    • #2213722

      Thanks Ascaris and satrow for your comments and educating me.

      : All drives are below heat limits.  OS and Programs are on two different NvME SSD’s.

      I’ll eat my words, which were poorly stated.  I don’t currently have an issue with overheating, but I don’t want it to happen, because my cooling design doesn’t allow for overclocking heat.  That’s the risk I took with the core i9x series, air cooling and case. But, it sounds like things are managable.

      I also misspoke about throttling down. What I meant to say was that the CPU was in a lower idle state..or..whatever the proper term is during editing video. Now, from what you’ve told me, that sounds like a power setting issue.

      Any ideas on the Core CState and MPC mode setting.  Just curious. BTW, You are both 1000x better than Asus support

      I really appreciate you help.


      • This reply was modified 3 years, 5 months ago by Mike.
    • #2213812

      C-states are power saving features that allow the CPU to shut down bits of itself that are idle in order to save power.  When the CPU(or a piece of it!) is active, it’s in C0.  Each core can have its own C-state, and so can other bits of the CPU, like what is sometimes called “uncore” because it’s the part of the CPU that is not one of the cores.  The onboard GPU also has its own version of C-states, and these are called RC states by Intel.

      When any of these bits of the CPU are idle, they can be shut down to save power, even for a fraction of a second.  The lowest C-state is C1, but there are more.  My i7-8750H lists up to C10, though I’ve never seen it actually use it.  Each higher number of C-state represents a deeper sleep state, saving more power (but also requiring more time before they can wake up and resume doing work).  This is a similar concept to the S3 suspend-to-RAM state, colloquially known as “sleep mode,” but not the same thing.

      The C-states have to be enabled in the UEFI for them to be available, but the actual idling of a bit of the CPU is handled by the OS and the idle driver (kind of weird that doing nothing requires a driver, but it does).  If the C-states are causing problems, the first place to look would be what the OS is doing with them.  I’ve never messed with them much in Windows… on my overclocked Sandy Bridge i5, I disregarded the advice to disable them in the UEFI when overclocking (I didn’t do a thing with them at the OS level), and they work fine.

      In Linux, I use Intel’s Powertop program to get a picture of what the C-states are doing even on my Sandy desktop.  Powertop is intended as a tool to diagnose excessive power consumption on laptops, with the intent being to extend battery life, but it has a realtime C-state display that is useful even on the desktop.

      If the C-states are working properly (as they should), there’s no reason to mess with them.  If, for some reason, they are causing issues, you can turn them off in UEFI (kind of a “nuke it from orbit” solution), or you can fine tune it from within the OS, since it is the OS (and more specifically, the idle driver) that requests these power saving states.  There are a bunch of options in the power settings as @satrow has mentioned, and with some registry edits (I don’t know offhand what they are, but I remember that they exist!), you can access more of them.  The C-state tuning may be possible within that context.

      If you think the C-states are causing a problem, you can try turning them off in UEFI and see whether anything changes, and if it improves things, you can then turn C-states back on and try to fix the bit that is not working well without completely turning off C-states.  Of course, if you like how it acts with the C-states off, you can leave it like that– it’s your computer, after all!  Just be aware that not having them enabled can disrupt other things that expect them to be available… things like not being able to wake from suspend (S3) have been reported when C-states are off.

      With things like this, especially on computers that were not prebuilt, trial and error is often the only way of knowing for sure what works and what does not.  Just keep track of the changes you make (and where) so you can revert them later… memory of just what changes you made can fade, and when circumstances change down the road, requiring different settings, it’s easy to forget that you changed something months or years ago.

      Dell XPS 13/9310, i5-1135G7/16GB, KDE Neon
      XPG Xenia 15, i7-9750H/16GB & GTX1660ti, KDE Neon
      Acer Swift Go 14, i5-1335U/16GB, KDE Neon (and Win 11 for maintenance)

      • This reply was modified 3 years, 5 months ago by Ascaris.
      3 users thanked author for this post.
    • #2259086

      Simple approach to disabling Turbo: set max CPU to 99% instead of 100%
      All CPU Power Management settings are under:
      You can disable C states for example by configuring:
      It is very dangerous to tweak some of those settings though and I am not giving you any direction here as this depends on your specific configuration. The main danger as mentioned is that you can easily burn your CPU/motherboard by setting CPU to run too high without any Power Management. C states can be disabled safely based on the condition to keep P-states enabled.
      The settings which can be configured in the default GUI are generally safe and my preference is for the Balanced scheme with max set to 99%. Min should stay on 5% which represents the min frequency of the CPU. However, in general there is hardware min limit which is higher than 5% and which can be measured with various tools.

    • #2259123

      It does not sound like you are actually getting overheating or CPU throttling warnings or instability during editing.

      I have found video-editing and especially transcoding to be the most CPU intensive task I do, well beyond any gaming. I am running an i7-9700K (8 cores, no HT, and no OC) from a Samsung NVMe PCIe SSD and have not had the CPU or individual core temp go over 62 C. Idle and web browsing is usually 26-28 C. That is with an air cooler, a Gammamax GTE in a smaller mid-tower case using an ASUS Prime Z390-A MB. The GPU is an nVidia GTX-1660Ti.

      I have a CPU utility that reads all the cores and during a transcode it appears that the hottest core rotates, but to date has yet to have throttling kick in. The turboboost only kicks in rarely, mainly during large throughput like loading programs or huge files, but you do hear the fan increase a bit for a short while and then drop when the turboboost stops.

      I personally prefer to let the MB and CPU and OS do their thing and let the cooler handle the exhaust. I have experimented with OCs, but beyond benchmarks I have not seen or felt noticeable real world improvement in what I do, so I leave the settings at non-OC for the CPU.

      I suspect, but do not know from personal experience, that disabling the turboboost might be something that you might feel as a lag.

    Viewing 6 reply threads
    Reply To: Disabling a CPU feature: Intel Turbo Boost

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: