News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Download speed

    Posted on Larry B Comment on the AskWoody Lounge

    Home Forums AskWoody support Windows Windows 7 Questions: Windows 7 Download speed

    • This topic has 23 replies, 9 voices, and was last updated 1 month ago.
    Viewing 15 reply threads
    • Author
      Posts
      • #2278076 Reply
        Larry B
        AskWoody Plus

        Just replaced an older router with a new 1.5 GB/S router.  My ISP  provides 200MB/S and I have gotten >230 with a direct modem to NIC connection.  My old router was only good enough for fast ethernet and I would get around 90 MB/S so about 90% of maximum of the router.

        With the new router, I am only getting around 130 MB/S.  When I tested in Ubuntu, I got around 100 MB/S faster speed.  This was close to the direct connected speed.

        I found this article which suggested turning off heuristics, but that did not work.  So I set it back.

        https://superuser.com/questions/871353/http-download-speed-difference-in-windows-7-vs-linux

        Another person suggest installing a 12 year old MS patch KB2675785.  I did a search for it in WU and it did not show up, but I am sure my update history has been deleted at some point or other and I do not believe that I avoided that update based on how I trusted anything MS put out back in those days.

        You would think I could do better than <10% of the routers capacity.

        Any suggestion appreciated, thanks

      • #2278086 Reply
        GLingner
        AskWoody Plus

        Hi Larry,

        Congrats on the speed from your ISP.

        You said 

        This was close to the direct connected speed.

        which was a little confusing.  You’re wired to the modem or WiFi?

        I also looked at the provided link and searched for KB2675785.  No lovee.
        Now I’m certain someone will come up with the answer.

        Your situation did inspire a bit of “art”.  Enjoy.

        Cheers,
        Gary

        Attachments:
        1 user thanked author for this post.
      • #2278100 Reply
        anonymous
        Guest

        KB2675785 is no longer officially available from Microsoft, as you’ve discovered. The KnowledgeBase bulletin for it is still around on their site, however. The bulletin has a link to allegedly download the hotfix but, when you click it, you’re taken to a page that says the hotfix is no longer available:

        “This hotfix has been discontinued. Instead, you can upgrade to Windows 10 and get the most up-to-date security and other features built right in. To get Windows 10…”

        So, I read the bulletin and found a table listing the file names and their attributes of the files the hotfix replaces to solve the problem.

        These files are located in the (your default Windows installation drive letter):\Windows\System32\drivers folder. The two files you’re looking for are “Fwpkclnt.sys” and “Tcpip.sys”, without the quotes, of course. Both files should have a version number equal to or greater than 6.1.7600.21149 or 6.1.7601.21921. On my machine, with x64 and SP1 updated to include the January 2020 patches, the version numbers are 6.1.7601.24498, so they’re much greater than what is indicated in the support article. I have a feeling your version numbers will be very close to mine.

        As long as that’s the case, you’re all set with that patch from early 2012.

        As far as anything else goes, there are some settings within Windows’ own networking settings for your networking interface (WiFi or Ethernet) that can be tweaked. There are also some settings on your router that can be changed to accommodate your type of broadband which, from the sounds of the speed level they’re giving you, is cable. There’s been a recent discussion here on AskWoody about just those settings, but I can’t for the life of me remember where that thread was located. In that thread, there is a post from someone pointing to Speedguide.net. That site has a tool that will let you tweak your Windows network interface settings to get the most out of your high speed connection.

        Hey, I just found the site, and here’s the link to their utility, called “TCP Optimizer”:
        https://www.speedguide.net/downloads.php

        The link above will take you to the page that describes the tool and some of it’s features. There’s a blue link with the tool’s name at the top of the page that will allow you to download it directly from Speedguide.net instead of from a mirror site.

        • #2278157 Reply
          EP
          AskWoody_MVP

          regarding the KB2675785 hotfix for Win7, get it from thehotfixshare.net site as Microsoft retired their MS hotfix service in 2019 and all the small hotfixes from MS are no longer available.

          don’t be surprised if attempting to install the KB2675785 hotfix says “not applicable” because a newer hotfix or update has superseded it

          • This reply was modified 1 month ago by EP.
      • #2278113 Reply
        Paul T
        AskWoody MVP

        Are you sure you are comparing apples?

        MB/sec does not equal Mb/sec.(Bytes vs bits)
        ISPs quote in Mb/sec.
        Some speed test use MB/second.
        A rough calculation is MB/sec = 10 x Mb/sec, so 200Mb/s = 20Mb/s

        Do not use TCP Optimizer, it won’t make things better on a link that fast.

        What speed test did you use?

        cheers, Paul

        2 users thanked author for this post.
      • #2278119 Reply
        Alex5723
        AskWoody Plus

        Test your speed vs Fast.com (streaming Netflix speed).

        Fast

        Attachments:
        • #2278200 Reply
          satrow
          AskWoody MVP

          If you want to check streaming speeds generally, the single-thread connection may give you more of a real-world estimate.

          NetflixFastSpeedtest

          Attachments:
      • #2278144 Reply
        Larry B
        AskWoody Plus

        Sorry for any confusion.  All of my speed test were done with wired connections on the ame PC.  I checked the 2 files listed by anonymous and they are indeed up to date (the things MS will tell you to try to get you to upgrade) .

        U have heard of TCP Optimizer before, but question whether it is still viable for today’s speeds.

        The speed tests I used are from Charter and Speakeasy.  I am now getting worse results than with my old 10/100 router.

        This result is from Speakeasy.

        speed

        • This reply was modified 1 month ago by Larry B.
        Attachments:
      • #2278178 Reply
        Paul T
        AskWoody MVP

        Is that the same PC where you ran the test in Ubuntu?

        What speed is the network card connected at? Check on the old and new router.

        cheers, Paul

      • #2278234 Reply
        GLingner
        AskWoody Plus

        Paul made me think of something…

        Is that the same PC where you ran the test in Ubuntu?

        Is there any chance that you are using two network interfaces? As in, one for windows and the other for Ubuntu?

        Also looking forward to your answer to Paul.

        Cheers (stolen from Paul)
        Gary

      • #2278235 Reply
        NetDef
        AskWoody_MVP

        @larry53715 would you be comfortable sharing with us the model of your new router? I have some ideas, but would prefer to do a reality check before posting them.

        ~ Group "Weekend" ~

        • #2278304 Reply
          anonymous
          Guest

          I am now using a TP Link AX1500 router.  I boot into Ubuntu using a USB external HDD, so this is the same PC and the router is still connected to the same NIC.

          I did call my ISP to check with them why my speeds were so slow.  They mentioned an outage that should have cleared by now, but testing in Windows I got <100 MB/s and in Ubuntu a couple minutes ago I got >225 MB/s.  I turned off WiFi to see if that would help and not sure if it did.

          • #2278315 Reply
            zasdman
            AskWoody Plus

            Does your Router have QOS turned on or are you running a “gaming” NIC in windows that runs QOS software?

          • #2278329 Reply
            NetDef
            AskWoody_MVP

            In Windows (bootup) if you check your network cards status, does it show that you’re connected on the physical Ethernet cable at 100 or 1000 and is it half duplex or full duplex?

            This is starting to look like a driver or driver settings issue.

            I understand it’s the same hardware, on the same physical connection using dual boot.

            ~ Group "Weekend" ~

            • #2278340 Reply
              zasdman
              AskWoody Plus

              Yea I agree, I had it happen to me where Speeds in windows were so much slower than Linux, it turned out the driver for my NIC included and turned on QOS.

          • #2278330 Reply
            Alex5723
            AskWoody Plus

            “<100 MB/s and in Ubuntu a couple minutes ago I got >225 MB/s.”

            You should by now know the difference between MB/s and Mb/s.

            225 MB/s = ~2000Mb/s.

      • #2278320 Reply
        Larry B
        AskWoody Plus

        I did not see QOS in my router settings.  Pretty much running the router defaults.  Once I go back into Windows, I will try running the Google server IP’s to see if that may help.

      • #2278372 Reply
        Larry B
        AskWoody Plus

        My NIC is an older on the MB variety.  I am posting the settings.  You can see from the device identified in the title bar that it is a Gigabit ethernet adapter.  The driver is old, and I am unable to update it (I tried earlier this year) and was told that I have the best drive.  I used a driver from Broadcoms web site.  I do not see a setting for QOS listed in the settings.  I saw in one of the NETSH screens that it was running at 1000.

        When I went into admin account and changed the IPV4 servers to the Google ones, I did get a speed reading of >220.  I have not been able to reproduce that since while in Windows.

        Screenshot_1

        Screenshot_2

        Attachments:
      • #2278455 Reply
        Paul T
        AskWoody MVP

        In Network and Sharing Centre click on the ethernet link to show the status – see attached.

        cheers, Paul

        Capture

        Attachments:
      • #2278509 Reply
        Larry B
        AskWoody Plus

        Here is what we know so far:

        1.  The hardware can handle the 200+ megabit speed the modem is putting out.
        2.  When the modem is direct wired to the NIC, the speed is good in Windows.
        3.   When the modem is direct wired to the router and then direct wired to the NIC and running Ubuntu, the speed is good.
        4. When the modem is direct wired to the router and then direct wired to the NIC and running Windows, the speed is dramatically reduced.
        5.  All of the speed tests I have done from the 2 sites mentioned give their results in Mbps.  Sorry for any confusion.

        Screenshot_3

        Attachments:
      • #2278516 Reply
        Paul T
        AskWoody MVP

        4 makes no sense. Windows knows nothing about connections the other side of the NIC and has no arrangement to change speed based on outside hardware.

        The only way I can see for the difference is if the router doesn’t correctly handle packets sent by Windows. Maybe you have tweaked the Windows packet size (TCP Optimizer) and they are now non-standard – it should be 1500.

        Type this in a PowerShell window: netsh int ipv4 show subinterface

        In the NIC Properties you should see these values.
        Flow Control: Tx & Rx enabled
        Jumbo Frame: Disabled
        Receive Buffers: 512 (may be different to mine)
        Speed & Duplex: Auto negotiate
        Transmit Buffers: 128 (ditto)

        cheers, Paul

        • #2278551 Reply
          Larry B
          AskWoody Plus

          Type this in a PowerShell window: netsh int ipv4 show subinterface

          In the NIC Properties you should see these values.
          Flow Control: Tx & Rx enabled
          Jumbo Frame: Disabled
          Receive Buffers: 512 (may be different to mine)
          Speed & Duplex: Auto negotiate
          Transmit Buffers: 128 (ditto)

          I do not hace3 of the settings you listed.  The 2 I have are already set to the values you stated.  I posted screenshots of all of my NIC properties earlier in the thread.

          Here is my powershell screenshot with the netsh command added.  Looks like my MTU is 1500.

          Screenshot_4

          Attachments:
      • #2278521 Reply
        Microfix
        AskWoody MVP

        Another Windows suggestion you could try is:

        Go to Control Panel/ Network Connections/ Ethernet Properties Page.
        Highlight Internet Protocol Version 4(TCP/IPv4)
        then click [properties]
        In the General Tab; Click the [Advanced button]
        Click on WINS tab
        I’ve noticed that Netbios is usually at ‘Default’ by default on Win7/8 and 10!

        Change the radio button to: ‘Disable Netbios over TCP/IP’
        then hit [OK] button.

        Netbios

        Also, as previously mentioned, try Disabling the ‘QoS Packet Scheduler’ for your NIC.

        QOSoff

        Reboot the system and check if the download speed has improved.
        Changing these settings had improved throughput for me a whiles back on a Win7-ADSL system.
        YMMV

        | Win8.1 Pro x64 | Linux Hybrids x86/x64 | Win7 Pro x86/x64 Offline |
        Attachments:
        • #2278555 Reply
          Larry B
          AskWoody Plus

          I found the QoS setting where you said it would be and disabled it and rebooted.  No change or possibly even worse.  I was looking for that setting in the NIC properties ad it was not there.

          BETBIOS was already disabled.

          I do not think I have any malware, but will run some scans.  I do have Kasperski security cloud AV set to check for update at log on.

          I also run EMET and Zone Alarm free firewall.  I tried a speed test with Zone Alarm temp disabled and no real difference.

          Going to update the June MS security patch now.

          • This reply was modified 1 month ago by Larry B.
      • #2278627 Reply
        Larry B
        AskWoody Plus

        After updating Windows to June updates, I seem to be getting better numbers now, knock on wood.  I seem to do a little better while in admin mode.  There have been several reboots and log offs since I disabled QoS.  No malware was found except a couple PUP’s which I had quarantined.  I also defragged my drives after the WU update.

        I got 143 while in admin mode and 103 while in user mode.  Better, but still not as good as Ubuntu.  Knock on wood again.

        Thanks for all of the help up until now

    Viewing 15 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Download speed

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.