News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Drive has 2 drive letters for the same partition

    Posted on WSCheck Marc Comment on the AskWoody Lounge

    Home Forums AskWoody support Windows Windows Vista, XP and earlier Questions: Vista, XP back to 3.1 Drive has 2 drive letters for the same partition

    This topic contains 8 replies, has 4 voices, and was last updated by

     WSrjdegraff 7 years, 12 months ago.

    • Author
      Posts
    • #476896 Reply

      WSCheck Marc
      Subscriber

      Everything is fine in “Device Manager”. How do I correct this?

      Marc

    • #1281141 Reply

      WSchowur
      Subscriber

      How to change, assign and remove drive letters on computers running Windows XP or Windows 2000
      Note: you can’t change the drive letter of your OS
      Run Disk Management, for this:
      Click Control Panel > Click Performance and Maintenance > click Administrative Tools > Computer Management > and in left panel click Disk Management
      Or right click on My Computer and select Manage and then select Disk Management.

      In right panel right click your drive and select “Change Drive Letter and Path”.
      To change: in dialog box click change and finally change the letters assigned to your drive.
      To add: click add and browse for drive path
      To remove: click remove, windows will display a warning message, click ok to continue.

      • #1281148 Reply

        WSCheck Marc
        Subscriber

        I know how to do that and how to change the drive letters using the registry. FYI using the registry you can change the boot drive letter. My question is how do I correct having the same drive but two different drive letter “D” and “I”.

    • #1281157 Reply

      Paul T
      AskWoody MVP

      Use Disk Management to remove one of the drive letters, preferably I. You don’t need to edit the registry.

      cheers, Paul

    • #1281186 Reply

      WSCheck Marc
      Subscriber

      Paul the “I” drive only shows up in Explorer. I tried deleting the registry key in both regular Windows and Safe mode and when I open up Windows again the key is recreated.

    • #1281199 Reply

      Paul T
      AskWoody MVP

      Something is creating it, do you have TruCrypt loaded?
      When did it start happening? After you loaded new software?

      cheers, Paul

    • #1281214 Reply

      WSCheck Marc
      Subscriber

      Paul it started yesterday. I’ve been having one hell of a time migrating the partitions, including “C”, from one drive to another larger drive. I haven’t been able to get the PC to boot from the new drive. I changed all the drive letters on the new drive, which includes a partition for Program Files and one for My Documents, to the correct drive letter including “C”. When I couldn’t get the drive to boot I changed the new “C” to “R” and the old “C” back to “C” and everything worked fine. Here’s a link to the thread about those problems.

      http://windowssecrets.com/forums/showthread.php/136595-I-can-t-get-my-cloned-quot-C-quot-drive-to-start-Windows.

      I had some big blocks of time so I decided to try it again. I moved everything back to the old drive and changed all the drive letters and this is when the problem started. I deleted all the partitions on the new drive and was going to use the WD version of Acronis to clone the entire drive manually setting up the partitions and ran into and error problem with Acronis and it telling me that there is still data on the drive an it can’t moved the data.

      I decided I needed to get the drive letter problem resolved before I do anything else with the cloning.

    • #1281282 Reply

      Paul T
      AskWoody MVP

      Personally I’d clone first. Then you have a backup.

      I would expect multiple drive letters if you had multiple disks with multiple partitions. Windows then sets a drive letter based on the order in which it “sees” the partitions.

      cheers, Paul

      • #1281526 Reply

        WSrjdegraff
        Subscriber

        Is it possible that somewhere along the line a subst command got executed? If you do the following:

        subst m: d:

        Then you will see two drive letters in Explorer for your D drive, but not in the disk management console. To check if this is your problem then unsubst the bogus drive letter as follows (assuming the bogus letter is M)

        subst m: /d

    • #1281595 Reply

      WSCheck Marc
      Subscriber

      Do I run that command line?

    • #1281620 Reply

      Paul T
      AskWoody MVP

      Yes, open a Command Prompt.

      cheers, Paul

    • #1281689 Reply

      WSmikelane2
      Subscriber

      A while back, I had a similar problem. Except over a period of time, every available drive letter would map itself to the same network drives. Turned out it was Findfast from MS Office 97 that was the culprit. Once I disabled the useless memory hogging Findfast, the problem went away.

      • #1281851 Reply

        WSmetrognome
        Subscriber

        Just a question about this.
        Would giving each ‘drive’ a distinctive name cure this?
        Or at least prevent such a quandary in the future?

        • #1281872 Reply

          Paul T
          AskWoody MVP

          Would giving each ‘drive’ a distinctive name cure this?

          No. You would still have multiple drives pointing to the same disk.

          cheers, Paul

    • #1591783 Reply

      WSAACTech
      Subscriber

      Everything is fine in “Device Manager”. How do I correct this?

      Marc

      I had this problem on my Windows 7 system. Explorer showed drive (partition) C: with both “C:” and “T:” drive letters. Change name, name changed on both, etc. I tried every suggestion I could find on the web. Even searched the registry for “T:” but found nothing.

      Then, the other day, I was copying TV shows from my Freeview box’s external USB drive with the “Ext2fsd” program to my Windows system:

      https://sourceforge.net/projects/ext2fsd/

      While looking around the menus I saw that it had the ability to remove drive letters. I highlighted the “T:” letter and deleted it. Voila! No more “ghost” drive letter in Explorer.

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Drive has 2 drive letters for the same partition

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.