News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Dual boot with Linux Mint

    Posted on Slowpoke47 Comment on the AskWoody Lounge

    Home Forums AskWoody support Windows Windows 7 Dual boot with Linux Mint

    This topic contains 41 replies, has 7 voices, and was last updated by  anonymous 3 weeks ago.

    • Author
      Posts
    • #1957950 Reply

      Slowpoke47
      AskWoody Plus

      After some bumps in the road, succeeded today in installing Linux Mint on a dedicated (2nd) HDD in our desktop, Dell 519.  Needed and received some crucial help from the Mint forum- and already looks like a good move.  Between now and end of support for W7 we plan to get comfortable with Mint and add it to our other W7 machine, an Acer laptop.  Eventually we’ll use Mint to go on line and as our go-to OS, keeping W7 for a couple of programs not available in Mint.

      No W10 here!

      Slowpoke (group B)

      2 users thanked author for this post.
    • #1958078 Reply

      Ascaris
      AskWoody_MVP

      Congrats on the successful installation.  The more, the merrier, over here in Linux world!

      As far as the Windows 7 installation… you may be able to run the things you need in WINE, or perhaps a VM will work.  Between those two, I really never need to go through the hassle of shutting down, rebooting, selecting Windows, doing whatever it is, then going back to Linux.  My games run beautifully in WINE (using Lutris to configure DXVK), and for those things that need lower-level hardware access, like the software to program the keybinds or macros in my mouse, I use a VM.  I still have Windows (8.1 on my desktop, 10 on my G3 and Swift laptops, which are too new to be allowed to play nice with any other version of Windows) installed bare-metal in case I do need it, but I seldom do.

      I bought the Swift and the G3 with the intent of putting Linux on from the start, so when I set Linux up, I gave it the lion’s share of the drive space from the start, but my desktop and my older (Core 2 Duo) laptop started out as Windows machines, with no inkling that Linux would ever play a role.  Then Windows 10 came, along with the warning that it was the last version of Windows ever (so don’t bother waiting for a newer, better version).

      Windows started with nearly all of the drive space, with Linux given just a little bit of space (which is all it needs out of the box).  Eventually, Windows had its partitions cut back to the bare minimum it needs to run, with the Linux partitions growing by the same amount, while Windows was moved from my fastest SSD to the slowest, so that Linux could have the fast one.  It’s been a gradual process, but an interesting one.

       

      Group "L" (KDE Neon User Edition 5.16.5).

      2 users thanked author for this post.
    • #1958362 Reply

      MrJimPhelps
      AskWoody_MVP

      I started down the Linux path by running Ubuntu Linux in a virtual machine in my Windows 7 computer. To make a long story very short, I boosted my computer to 12 GB of RAM, installed Linux Mint as the host OS, and installed Windows 8.1 in a vm in my (now) Linux Mint computer.

      I leave the vm open all the time, and I freely click between Linux and Windows as needed. My wife always works on the Windows side.

      I can do just about everything in Linux; for the few things I can’t do in Linux, I can easily do them in Windows.

      This set up works very well for me.

      Group "L" (Linux Mint)
      with Windows 8.1 running in a VM
      2 users thanked author for this post.
    • #1958394 Reply

      OscarCP
      AskWoody Plus

      For what it is worth: I had a friend, that is an experienced system administrator and very familiar with Windows and Linux, install Linux Mint 19.1 some months ago in dual boot with the OEM-installed Windows 7 Pro, SP1, x64 in my PC. He reduced the size of the Windows partition by allocating 80GB for Linux on the HD, leaving Windows with just about 550 GB of space in there, minus some 250 GB of the OS, of programs I need to have and of general junk and applications’ bloat acquired over the 8.5 years I’ve had this PC. That allocation is what I wanted, because my intention, at this time, is to become more familiar with the maintenance, update and general being-in-charge-of-running-the-Linux-OS-myself, something that, so far, has always been done for me by system administrators in those jobs where I used, first Unix and then Linux.

      Creating a connection to move files from Windows to Linux and vice versa turned out to be quite easy. This connection looks like one more folder on the Linux Desktop that, when open, shows inside the folders (directories) on the Windows side. I can take files from any of those folders by copying and them pasting then on the Linux side, and vice versa. Interestingly, one of those folders gives me access to my Mac, that I have white listed for remote access (some people might write here saying this is a bad idea, and I agree 65% with that opinion. The thing is that, through the link to the Mac’s file system, that also looks as another folder on the Windows side when looking there from Linux, I cannot only copy files on the Mac side to Linux, and vice versa, but even run videos I have saved in the Mac’s SSD on the Linux desktop, both their sound and their images. Interesting and weird, but also possibly useful, as I might avail myself of this unexpected connection to run software on the Mac from the Linux side of my PC and vice versa. That could be convenient, in some situations, if, probably, just a little dangerous.

      Windows 7 Professional, SP1, x64 Group B & macOS + Linux (Mint) => Win7 Group W(?) + Mac&Lx

      1 user thanked author for this post.
      • #1958460 Reply

        Ascaris
        AskWoody_MVP

        Glad to have you aboard the dual-boot train!  I seem to remember you had some trepidation about that in the past, but it’s really nothing to fear, IMO.

        I’ve got dual-boot set up on all of my Linux machines except one, and that is my Dell Inspiron 11, whose internal storage (32GB eMMC, not upgradeable) is too small for Windows (10) alone, let alone Windows and Linux.  The rest of them started life as Windows machines, so I’ve opted to keep it on there rather than wiping it, since I don’t need the space Windows occupies on any of them, for now.

        My dual-boot machines consist of my main i5-2500k desktop, my 10 year old Asus F8Sn Core 2 Duo laptop, my Dell G3 laptop, my Acer Swift laptop, and even my 12 or 13 year old Compaq (HP) Presario M2000z (which runs XP and Mint Xfce 32-bit… I have so many PCs that I really have no use for the M2000z, but if I did, I would not use XP for anything internet).

        I’ve also had another desktop running 10 and Linux in a dual-boot config, but that PC is currently not in working order (I’ve pilfered its SSD and hard drive for other tasks; otherwise, it’s ready to go).

        I’ve run this gaggle for four years now, and I don’t find dual boot (even with a single hard drive, which a lot of people seem to fear) to be worthy of all of the fear people have over it.  That’s not to say that nothing has ever gone wrong, but because I have good backups, I often throw caution to the wind and try things I know are risky.  All of the issues I’ve had with dual-boot setups have been the result of these kinds of self-inflicted wounds, and they’ve been quite easy to repair without having to resort to restoring backups (which you can also do– you can run Timeshift from a live session and use it to repair a Linux installation).

        Even single-boot Windows can get messed up, and it’s often more of a faff (as my British friends would say) to get it working again than with Linux.  The dual-boot configuration is just a normal function of the Linux bootloader (GRUB), which is used to boot Linux even if Windows is not installed on the machine, so a dual-boot Linux machine is really just a regular Linux machine that also happens to have Windows installed.

        I almost like it when things break, because it gives me a chance to learn about how to fix it, like a puzzle of sorts.  I don’t try to break things, but I often don’t try not to, either.  Had it not been for that tendency, I wouldn’t have ever had any issues with the dual-boot, and I would not know how easy it is to get GRUB working once a Windows program (like Aomei Backupper, which faithfully restored Linux partitions even though it is a Windows program, but it always broke the bootloader during a restore) borked it.

         

        Group "L" (KDE Neon User Edition 5.16.5).

        1 user thanked author for this post.
    • #1958678 Reply

      Slowpoke47
      AskWoody Plus

      Thanks to all who posted.  As a non-tech, I’m not familiar with 100% of the terminology and procedures mentioned, but I also see that there is some good and valuable info, which will be of help as I “move in” to the Linux Mint OS, v. Mate 19.2.  The new OS is installed on a new, added 1-tb HDD, seemed a better move than partitioning the W7 disk.

      Good to know that there are others here who have moved to Mint, especially since it is obvious that those who responded have a reservoir of knowledge and experience with Mint.  I hope you won’t mind if I occasionally pick your brains during my initiation.  It looks like there are ready answers to several questions that have come to mind.  I’ll ask those questions in the coming days and weeks as I settle in.

      Slowpoke (group B)

    • #1959010 Reply

      Slowpoke47
      AskWoody Plus

      Intro to Mint going reasonably well; of course, an ongoing process.

      The BIOS recognizes both HDD’s with the default bootup being W7 (after removable media).  Mint boots readily if I choose it from the boot options menu.   Back when we dual-booted W7 and Vista, there was a black screen at bootup offering a choice between the two and defaulting to 7.  At that time, just as now, the different OS’s each had a dedicated HDD, but when we removed the Vista HDD I had advice on how to eliminate this then-redundant step, and the system booted directly to 7.

      Now I want to see that same black screen at bootup, allowing me to choose between 7 and Mint without going through the F12 sequence.  I realize that this change has to be within the BIOS and I poked around there for awhile but couldn’t figure out how to do it.  Can someone help?

      Slowpoke (group B)

      • #1959043 Reply

        Ascaris
        AskWoody_MVP

        It should automatically be giving you that menu when you select the Mint boot option in BIOS (or UEFI).  Since it isn’t, it appears that Mint was installed at a time when the Windows installation was not available, so it was not able to recognize it and set it up for you.  That is the correct boot option for a dual-boot setup.

        To fix that, go into Linux, then start a terminal window, and copy/paste this in:

        sudo update-grub

        and hit enter.  It will ask for your password, so enter that. The update-grub command tells it to set grub up again, including looking for operating systems that are not yet known to Linux.

        After you enter the password, it should then show a few lines of text, and one will hopefully be about discovering Windows on (whatever the designation of the drive is).  If so, you should then be able to start the PC normally and get the GRUB menu that gives the option of Mint, Mint (with recovery options, or whatever it says), and Windows.

        If not, copy/paste what it did say, and please let us know here so we can assist in the next step.

        Group "L" (KDE Neon User Edition 5.16.5).

        1 user thanked author for this post.
    • #1959101 Reply

      Slowpoke47

      I believe I followed these instructions correctly, all went as you predicted.  Once the lines of text were finished generating, last line said “done.”  Not sure if I should have taken any other action at this point, so restarted and BIOS defaulted to W7 as before.  Repeated this sequence but after seeing “done” I pressed enter, but that just repeated the last line of text.  Again defaulted to 7 with no black screen.  What am I doing wrong?

      • #1959120 Reply

        Ascaris
        AskWoody_MVP

        If you set it to boot from the Linux drive, it should give you the black screen with the options of Windows or Linux.  If the option is set to Windows, it will just go to Windows, as Windows 7 isn’t aware that Linux is there.  Don’t use the boot override menu; that is a one-time override of the default option (which is evidently set to Windows), and after that, it will go back to its default setting each time.  If you do that now, it should give you the menu you are looking for.  If so, all you will need to do is get it to boot from that drive every time instead of just when you select it with boot override.

        You will have to set the first boot priority in the UEFI/BIOS to the Linux boot drive (if it is MBR) or to the Ubuntu or Mint boot option (probably it will say Ubuntu).  Some laptops use F2 to enter that,  while others use the Del key (like my desktop).  I can’t see the BIOS/UEFI screen to be able to guide you to where it is in there, but surely there is some way in there to tell it ti use the other drive to boot.  It may be under a “boot” submenu or tab in the BIOS/UEFI.

        Group "L" (KDE Neon User Edition 5.16.5).

        1 user thanked author for this post.
    • #1959174 Reply

      Slowpoke47
      AskWoody Plus

      This is the menu generated from F12 at bootup.  Mint disk highlighted.  IMG_0915

      This screen is generated when starting Mint, lasts less that 1 sec., unable to act on it or even read it.IMG_0916

      Here’s the terminal window in Mint:IMG_0917

      Slowpoke (group B)

      • This reply was modified 3 weeks, 3 days ago by  Slowpoke47.
      • This reply was modified 3 weeks, 3 days ago by  Slowpoke47.
      • This reply was modified 3 weeks, 3 days ago by  Slowpoke47.
      Attachments:
    • #1959876 Reply

      Slowpoke47
      AskWoody Plus

      Update to previous post- center photo, grub screen, now displays long enough to read and select.  Either OS will open from this screen.  Looks like if I can make Linux the default OS, and this screen displays before loading Mint, I’ll have a choice of either OS on startup each time.  So… how do I make Mint the default OS?

      Slowpoke (group B)

      • #1959885 Reply

        PKCano
        Da Boss

        Click on “Enter Setup” will take you to the BIOS setup
        Find the section on boot order.
        The instructions will be there (use arrow keys)
        If mint is on the WD1001, move it to the top of the list.
        If Mint is on the WD3200, move it to the top of the list.
        Be sure the other HDD is the second on the list – or make the rest of the order whatever you want it to be.
        Save the settings and exit setup (F10).

        1 user thanked author for this post.
    • #1959881 Reply

      NightOwl
      AskWoody Plus

      @ Slowpoke47

      So… how do I make Mint the default OS?

      I see you figured out how to make the Grub boot loader wait for a longer time so you can select which OS you want to use. That was going to be my first recommendation to you, but now we need to move to the next step.

      You need to change the default hard drive (HDD) to boot from. Right now, your BIOS is set to default to your Win7 HDD, and not the Mint HDD.

      In the past, you were using the Microsoft Windows boot loader, so the Win7 HDD. Now, you need to switch to the Linux boot loader that is on the Mint HDD.

      So see here:

      Boot-Settings-Priority

      This is a screenshot you made for a different forum thread, but this is where you need to make a change.

      Use the *down arrow* to switch the focus to the *Hard Disk Boot Priority*, and then press *Enter*. You should then be here:

      HDD-Priority-List-In-BIOS

      The top *1st Drive* is your Win7 HDD. The next drive down, *2nd Drive* should be your Mint HDD. (In the screen shot–this might be your old Vista HDD, which I think you have removed, and have now installed your Mint HDD)

      Use the down arrow to select your Mint HDD, and then press *Enter*.

      Your Mint HDD should now be the *1st Drive* and on the top. When you are at the *Boot Settings* screen, the *3rd Boot Device* should be your Mint HDD, and not your Win7 HDD.

      Save your changes, and reboot. You should now get the Linux Grub boot loader during boot, and you can select which OS to boot.

      NightOwl

      No question is stupid ... but, possibly the answers are 😉 !

      Attachments:
      1 user thanked author for this post.
    • #1959955 Reply

      Slowpoke47
      AskWoody Plus

      Thanks to both PKCano and NightOwl.  I’ve actually looked at this screen beforeSetup-screenshot-9-21-19
      But unable to reverse the boot order shown (Mint= 1001, Win7= 3200).  I can highlight one or the other, but tried various keys- +/- disables or enables the disk, up/down cycles only between the two disks.  I need to reverse the boot order of these two disks.  On bootup, the only two options, F2 and F12, both bring me to this screen.

      Slowpoke (group B)

      Attachments:
    • #1959967 Reply

      PKCano
      Da Boss

      Screen-Shot-2019-09-21-at-11.24.25-AM

       

      Attachments:
      1 user thanked author for this post.
    • #1960019 Reply

      Slowpoke47
      AskWoody Plus

      Screen-Shot-2019-09-21-at-11.24.25-AM

       

      “Hard Disk Boot Priority” brings me to the screen in my last post.  Once there, the up/down arrows will only highlight the two HD’s, no other text on the screen can be selected.

      Slowpoke (group B)

    • #1960027 Reply

      NightOwl
      AskWoody Plus

      @ Slowpoke47

      But unable to reverse the boot order shown (Mint= 1001, Win7= 3200). I can highlight one or the other, but tried various keys- +/- disables or enables the disk, up/down cycles only between the two disks. I need to reverse the boot order of these two disks.

      Sometimes the BIOS key strokes that are needed are less than intuitive!

      Try this: On the screenshot above that you have just posted, your Mint HDD is highlighted (Mint= 1001). So get back to that screen, and *highlight* that HDD again, then press *Enter*, and then use the *Up Arrow*–press it, and see if that changes the position of the *Mint = 1001* HDD for the *2nd Drive* position, to the *1st Drive position.

      If *Yes*, then hit the *Escape* key, and see if your *Mint = 1001* HDD is now listed on the *Boot Settings* page as the *3rd Boot Device*.

      If *Yes*, then use the F-10 key to save and exit the BIOS setup, and reboot to see if you have successfully changed that boot order.

      Waiting for your report back.

      NightOwl

      No question is stupid ... but, possibly the answers are 😉 !

      1 user thanked author for this post.
    • #1960103 Reply

      NightOwl
      AskWoody Plus

      @ Slowpoke47

      So, your BIOS is different than mine–so I can not give you the *exact* keystroke(s) needed to change the *Hard Disk Boot Priority* position.

      So, just for the record, I just re-booted and entered my BIOS. Went to the Hard Drive Boot Priority listing and had to press *Enter* to bring up the list of HDD boot options.

      In my BIOS, I use the up/down arrows to change which HDD is highlighted. Once I highlight a drive, in the far right column, the *Help Item* changes, and states that I should use either the PU (page up key), and PD (page down key), or use the + key and – key in order to change the highlighted item’s position in the list.

      And, once the position has been changed, I can either use the *Esc* (Escape key), or the F-10 key to save that new priority list. The *Esc* takes me back to the *Priority List* showing the selected HDD now at the top of the list, and from there I can use the F-10 to save and Re-boot. If I use the F-10 key while still on the page where I used the PU/PD or +/- keys to re-order the list, then the system saves that new order for the list, and immediately re-boots. So, either option works.

      So, as an alternative if my above posting of suggested keystrokes to use (and it did not work), you could try highlighting the Mint HDD, press the *Enter* key, and then press *Esc* to see if the Mint HDD is now listed on the *Boot Settings* page as the *3rd Boot Device*.

      Let us know if anything has worked so far.

      NightOwl

      No question is stupid ... but, possibly the answers are 😉 !

      1 user thanked author for this post.
    • #1960104 Reply

      Slowpoke47
      AskWoody Plus

      The sequence was not exactly as you laid out, a couple of extra steps needed.  But, I may be good to go, I’ll know better after a few more bootups.  All help here greatly appreciated, and I realize the challenge of providing off-site help to a non-tech and with different computer makers not always using the identical sequences.  The only possible footnote is that the grub screen in Mint may be a little unstable, i.e. showing just momentarily before defaulting to Mint.  I’ll have a better handle on that in a day or two as well.

      Once again, my thanks!

      Slowpoke (group B)

    • #1960150 Reply

      NightOwl
      AskWoody Plus

      The sequence was not exactly as you laid out, a couple of extra steps needed.

      So … , how about sharing–what were the *couple extra steps needed*?

      The only possible footnote is that the grub screen in Mint may be a little unstable, i.e. showing just momentarily before defaulting to Mint.

      Your Mint boot loader screenshot at the bottoms says: “Select enter to boot the selected OS, “e” to edit the commands before booting or ……”

      In theory, if you press *e* to edit, you should be given a list of items you can alter–one of the items should be the number of seconds to delay before executing the default setting and booting that item. Change it to something like *10 seconds* and you should have plenty of time to select the Win7 item.

      The screenshot says the time delay is set at *0* (zero), which is a very short delay time–i.e. “The highlighted entry will be executed automatically in 0s.”

      Why do you say you think the Grub boot loader is *unstable*?

      NightOwl

      No question is stupid ... but, possibly the answers are 😉 !

      1 user thanked author for this post.
    • #1960165 Reply

      Slowpoke47
      AskWoody Plus

      So … , how about sharing–what were the *couple extra steps needed*?

      Unfortunately, I didn’t write them down, fearing they would time out.  But I had a small red pop-up after following your steps that basically had me repeat them.

      Why do you say you think the Grub boot loader is *unstable*?

      Mostly because it would sometimes show for a split second (0 seconds?) and sometimes remain displayed.  This whole OS addition has been at (sometimes past) my comfort zone and level of understanding- couldn’t have done it alone with a gun to my head.  I’ll use your “e” command next time I boot up.  Your help as well as that of the others who posted has saved the day.

      Yet again I have earned my screen name!

      Slowpoke (group B)

      • #1960182 Reply

        anonymous

        ? says:

        or you can edit ect\default\grub with Nano or Gedit and change it there if you want:

        GRUB_DEFAULT=0
        GRUB_HIDDEN_TIMEOUT=0
        GRUB_HIDDEN_TIMEOUT_QUIET=true
        GRUB_TIMEOUT=2
        GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
        GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash”
        GRUB_CMDLINE_LINUX=””

        my timeout is set to 2 seconds since i don’t dual-boot.
        and thanks for yet another askwoody sucess story!

    • #1960204 Reply

      NightOwl
      AskWoody Plus

      @ Slowpoke47

      Unfortunately, I didn’t write them down, fearing they would time out.

      I’ve never heard of the BIOS setup routine to *time out*. One has to use the F-10 key to *Save and Exit* to close out the setup routine. It’s the Mint boot loader software that has been *timing out* on you.

      Maybe if you have time later, you can enter the BIOS again, and see if you can change the *boot priority* again, recording the steps–if for no other reason to put the information into a notebook for your system so you can deal with the problem in the future if need be.

      But I had a small red pop-up after following your steps that basically had me repeat them.

      I’ve not heard of that happening before. But, *never say never*!

      Mostly because it would sometimes show for a split second (0 seconds?) and sometimes remain displayed.

      That’s weird! One would expect there to be some consistency–don’t know how that could vary? One can hit the *Shift + Break/Pause* key combination to make either the boot process, or the software program to *pause* until you hit another key–but, I don’t know how the program would do things differently on subsequent boots on its own.

      Yet again I have earned my screen name!

      Don’t be so hard on yourself! We are all learning!

      NightOwl

      No question is stupid ... but, possibly the answers are 😉 !

      1 user thanked author for this post.
    • #1960281 Reply

      Slowpoke47
      AskWoody Plus

      I’ve never heard of the BIOS setup routine to *time out*.

      Me neither, but after what I’ve been through the last few days with this- I wasn’t taking chances!

      Maybe if you have time later, you can enter the BIOS again, and see if you can change the *boot priority* again, recording the steps–if for no other reason to put the information into a notebook for your system so you can deal with the problem in the future if need be.

      Yes, I could do that- when my anxiety level cools down…

      That’s weird! One would expect there to be some consistency–don’t know how that could vary? One can hit the *Shift + Break/Pause* key combination to make either the boot process, or the software program to *pause* until you hit another key–but, I don’t know how the program would do things differently on subsequent boots on its own.

      No idea- I’m just along for the ride.

      No question is stupid …

      Flattery will get you nowhere…

      Yesterday I couldn’t even spell “user”… and today, I are one!

      Slowpoke (group B)

    • #1960527 Reply

      NightOwl
      AskWoody Plus

      @ Slowpoke47

      Flattery will get you nowhere…

      Really! Not even a little bit? And here I thought it would 😉 !

      I will be interested to hear if hitting the *e* key gives you the option to change the delay time easily.

      As soon as you think the Grub boot loader is about to show up, start hitting that *e* key repeatedly, and fast. It’s hard to know exactly when the Grub program will be *listening* to respond to that key stroke–especially given that it has a *0 delay* setting as of now–that goes by quickly–so give it every opportunity the *hear* your request.

      Good job getting things sorted this far …

      NightOwl

      No question is stupid ... but, possibly the answers are 😉 !

      1 user thanked author for this post.
      • #1960880 Reply

        Ascaris
        AskWoody_MVP

        In GRUB. when I want to cancel the countdown timer, I just hit the space bar.  It cancels the timer without doing anything else.  I’ve never seen the behavior described where sometimes it would continue without waiting and sometimes not, except when I have done something silly like set the keyboard down and later found something is pressing one of the buttons.

        Also, if you are using Mint Cinnamon, you can use ‘xed’ wherever any Ubuntu guides suggest ‘gedit’.  Each desktop environment comes with its own editor… xed for Cinnamin, gedit for Gnome, Pluma for MATE, kate or kedit for KDE, and I don’t remember what Xfce uses.  Nano should work for any of them, as it is not a graphical editor, though it’s a bit more primitive also.

         

        Group "L" (KDE Neon User Edition 5.16.5).

        1 user thanked author for this post.
    • #1960543 Reply

      NightOwl
      AskWoody Plus

      ? says:

      or you can edit ect\default\grub with Nano or Gedit and change it there if you want:

      GRUB_DEFAULT=0
      GRUB_HIDDEN_TIMEOUT=0
      GRUB_HIDDEN_TIMEOUT_QUIET=true
      GRUB_TIMEOUT=2
      GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
      GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash”
      GRUB_CMDLINE_LINUX=””

      my timeout is set to 2 seconds since i don’t dual-boot.
      and thanks for yet another askwoody sucess story!

      I did a Google search on *edit ect\default\grub with Nano or Gedit* and got this as the first link: How to Configure the GRUB2 Boot Loader’s Settings

      Should be fairly easy to follow, and shows what lines need to be changed to get the behavior you probably want.

      Here’s the relevant information to control the basic use of the Grub loader:

      Choose Whether GRUB is Hidden: With only one operating system installed, Ubuntu defaults GRUB to automatically boot to the default OS with the GRUB_HIDDEN_TIMEOUT=0 option. This option specifies GRUB will be hidden and it will automatically boot to the default OS after 0 seconds –immediately, in other words. You can still access the menu by holding Shift as your computer boots. To set a higher timeout, use something like GRUB_HIDDEN_TIMEOUT=5 — GRUB will display an empty screen or splash screen for five seconds, during which you can press any key to view the menu. To prevent GRUB from being automatically hidden, comment the line out — just add a # before it so that it reads #GRUB_HIDDEN_TIMEOUT=0 .

      Control GRUB’s Menu Timeout: If GRUB isn’t automatically hidden, you’ll see the menu each time your computer boots. GRUB will automatically bot the default operating system after a period of time, usually ten seconds. During that time, you can choose another OS or leave it be to automatically boot. To change the timeout period, edit the GRUB_TIMEOUT=10 line and enter any number of seconds you like. (Remember, this is only used if GRUB isn’t hidden.) To prevent GRUB from booting automatically and always wait for you to choose an OS, change the line to GRUB_TIMEOUT=-1

      But, I would try seeing what happens when you hit the *e* key during the boot sequence, and see if that gives you an easy way to change things. The above two paragraphs explains what you should change to get the behavior your want.

      NightOwl

      No question is stupid ... but, possibly the answers are 😉 !

      1 user thanked author for this post.
    • #1960726 Reply

      anonymous

      ? says;

      thank you, NightOwl for going the extra mile. on ubuntu if i make changes at the grub on boot using e (edit) they apply to the current boot and revert on the next boot. i use e to change boot parameters while troubleshooting eg removing “(quiet splash)” from GRUB_CMDLINE_LINUX_DEFAULT=, allows me to follow the acticve boot process rather than the default (Plymouth) srceen before arriving at the desktop. the howtogeek page is just the ticket for Slowpoke47 to use and attain the desired dual boot results. if he wants to go to etc\default\grub and post the current setup someone here can help build what he wants and then he can make the changes. after changing the grub remember to do sudo update-grub before rebooting.

      2 users thanked author for this post.
    • #1961259 Reply

      Slowpoke47
      AskWoody Plus

      I will be interested to hear if hitting the *e* key gives you the option to change the delay time easily. As soon as you think the Grub boot loader is about to show up, start hitting that *e* key repeatedly, and fast. It’s hard to know exactly when the Grub program will be *listening* to respond to that key stroke–especially given that it has a *0 delay* setting as of now–that goes by quickly–so give it every opportunity the *hear* your request.

      Booted a couple more times yesterday and this morning, currently that Grub screen has stabilized, although I haven’t changed anything.  Haven’t waited to see how long it will persist, but it’s at least several seconds, enough time to make an unhurried selection.  Yesterday I did try hitting “e” (just once) when the screen came up, but from what you say here I was likely too late, since nothing by way of a time delay setting appeared.  I’ll follow up on that shortly.

      Really! Not even a little bit? And here I thought it would 😉 !

      I tried patting myself on the back once, but I hurt myself…

      Good job getting things sorted this far …

      Couldn’t have done it without help from you and others here- much appreciated!  I had thought that, with our switch to Mint, my questions would be off-topic here- believed this forum was basically a Windows forum.  Relieved to find out otherwise, as I know I’ll have more questions.

      Slowpoke (group B)

    • #1961269 Reply

      Slowpoke47
      AskWoody Plus

      In GRUB. when I want to cancel the countdown timer, I just hit the space bar.  It cancels the timer without doing anything else.  I’ve never seen the behavior described where sometimes it would continue without waiting and sometimes not, except when I have done something silly like set the keyboard down and later found something is pressing one of the buttons.

      Also, if you are using Mint Cinnamon, you can use ‘xed’ wherever any Ubuntu guides suggest ‘gedit’.  Each desktop environment comes with its own editor… xed for Cinnamin, gedit for Gnome, Pluma for MATE, kate or kedit for KDE, and I don’t remember what Xfce uses.  Nano should work for any of them, as it is not a graphical editor, though it’s a bit more primitive also.

       

      Your help and patience greatly appreciated- many thanks!

      Mint forum advised me to use Mate 19.2 as it would be more compatible with our creaky old (2009) desktop- a Dell 519.  In due course I’ll use the same flash drive to dual boot  our newer Acer laptop- hoping the second time around will be at least a little easier.  I try not to make the same mistakes twice- unfortunately I can always find new ones as substitutes!

      Slowpoke (group B)

      • #1961330 Reply

        Ascaris
        AskWoody_MVP

        Mint forum advised me to use Mate 19.2 as it would be more compatible with our creaky old (2009) desktop- a Dell 519.

        So is that what you are using now, or are you saying the people on the Mint forum suggested switching to it?

        In either case, you seem like what you have now, so I’d suggest keeping it!

        Group "L" (KDE Neon User Edition 5.16.5).

        1 user thanked author for this post.
    • #1961336 Reply

      Slowpoke47
      AskWoody Plus

      So is that what you are using now

      Yes, right from the get-go, and from what I see so far, looks like friendly territory

      Slowpoke (group B)

    • #1961534 Reply

      Slowpoke47
      AskWoody Plus

      Just restarted- this is the Grub screen I’ve seen the last few times on startup:9-22-19-Grub-screen
      I didn’t see a reference to input “e” displaying anything related to time duration.  Before seeing this screen, I followed NightOwl’s suggestion and began pressing “e” multiple times.  This move generated this screen:9-22-19-Grub-screen-2
      Notice the line of “eeeeeee” at the top.  Looks like a primal scream to me.

      Neither one of these screens timed out in the 15 seconds or so that I waited.  No idea what most of the text there means, but maybe I don’t have to know.  The fact that the first display persists long enough for a choice from the boot menu is sufficient.

      EDIT- just timed the Grub screen to the start of default boot to Mint- went 12 sec.

      Slowpoke (group B)

      Attachments:
    • #1961608 Reply

      Slowpoke47
      AskWoody Plus

      Just restarted to go from Mint to W7, the second or third time I have done this without shutting down the computer.  The same Grub screen displays as with a “cold” start.  When doing this, the time-of-day display on W7 adds 4 hours to the time shown at the right end of the tray.  The time zone (in the pop-up generated by a right click) remains correct.  If I start the computer and boot directly to 7, the time remains accurate.  Any thoughts from the dual-booters out there?

      Slowpoke (group B)

    • #1961609 Reply

      anonymous

      ? says:

      read the bottom of your screen. on ubuntu you press f6 and that opens up the screen where you can make temporary changes to your current boot (to troubleshoot problems) if you want to watch the boot sequence you can remove “quiet splash” and then continue booting. if you want to chech your grub file for current settings, boot to desktop then go to computer>etc>default>grub. the howtogeek page shows how to input the settings you desire (Nano is easy and the howtogeek page shows how to do it using Nano) then do “sudo update-grub.” before rebooting to set your new changes. if you like just copy and paste your current grub here and one of the helpers will help…

    • #1961624 Reply

      Slowpoke47
      AskWoody Plus

      ? says:

      read the bottom of your screen. on ubuntu you press f6 and that opens up the screen where you can make temporary changes to your current boot (to troubleshoot problems) if you want to watch the boot sequence you can remove “quiet splash” and then continue booting. if you want to chech your grub file for current settings, boot to desktop then go to computer>etc>default>grub. the howtogeek page shows how to input the settings you desire (Nano is easy and the howtogeek page shows how to do it using Nano) then do “sudo update-grub.” before rebooting to set your new changes. if you like just copy and paste your current grub here and one of the helpers will help…

      Thank you.  Note that this time issue arises in the W7 OS only.  The Mint OS time remains correct.

      Slowpoke (group B)

    • #1961660 Reply

      anonymous

      ? says;

      on your “time,” question maybe this page will help:

      https://www.howtogeek.com/323390/how-to-fix-windows-and-linux-showing-different-times-when-dual-booting/

      on the grub question, a picture of your etc\default\grub may offer some additional suggestions…

    • #1961688 Reply

      Slowpoke47
      AskWoody Plus

      on the grub question, a picture of your etc\default\grub may offer some additional suggestions…

      Thanks for your response.  re the Grub, photos posted above in this thread.

      Slowpoke (group B)

    • #1961689 Reply

      anonymous

      ? says:

      ok, what controls the screen shots in 1961534 is the etc\default\grub as shown in 1960182 from one of my single os boot ubuntu machines and NightOwls’ reproduction and additional comments shown in 1960543. your etc\default\grub should reflect what you’ve got going on right now…

    • #1962455 Reply

      Slowpoke47
      AskWoody Plus

      https://www.howtogeek.com/323390/how-to-fix-windows-and-linux-showing-different-times-when-dual-booting/

      Time issue resolved using this link, thank you.

      Re Grub screen at bootup, system defaults to Mint after 8-12 seconds, varied on several starts.  But this is workable and no need to pursue it further.

       

      Slowpoke (group B)

    • #1962457 Reply

      anonymous

      ? says:

      Great news Slowpoke47! glad it is working the way you want it to. another sucess story at askwoody!

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Dual boot with Linux Mint

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.