• Edge isn’t working


    Hi, All.

    My Windows 10 2 year old computer just updated to Windows 11 a few days ago. All went well. Restarts, more restarts. All is well. Day or so later Dell’s Command update insisted on doing a bios(?) update. Restarts, more restarts. All is still well. Edge decided it needed to install a new version. The install completed fine. My other apps all seem to work properly. I try to open Edge and it opens in a postage stamp size next to the taskbar. No way to get it to full size. Only possible action is to close it. I’ve tried many of the solutions on the web. Microsoft store repair. Settings, repair Edge did no good. Restarts does no good. Task manager end task doesn’t help. Troubleshoot no good.  I’m ok with Firefox for the time being, but I’m old and familiarity is my friend. Anyone had this happen?  I could use fresh ideas.

    Viewing 3 reply threads
    • #2534932

      Give Edge the focus.
      Press Alt Space. This should bring up the window menu.
      Select Maximize.

      Does that work?

      cheers, Paul

    • #2535221

      Have you tried resetting Edge settings?
      Settings > Reset Settings


      cheers, Paul


      1 user thanked author for this post.
      • #2541291

        My apologies I am going off-topic for one post; but while searching for answers I thought I would try this. The Edge Reset fixed it so it might help others with future problems too.

        My circumstance:
        Win 8.1 upgrade to Win 10
        created new standard user
        Microsoft Edge, Read Aloud has no sound while reading. Edge is not muted.
        Edge can play sounds on YouTube videos
        An old existing standard user can Read Aloud with sound
        reset fixed the sound in the new standard user

    • #2535347

      Went to Settings/Apps/Installed Apps/Edge … Modify, and it reinstalled Edge. Still no luck. The postage stamp view above the taskbar does not allow me to get to the … settings. If I move the mouse onto the postage stamp, the only thing I can get there is close. Frustrating if reinstall doesn’t even work. Should I go to Settings/Apps/Installed Apps/Edge and select uninstall? Thanks.

      • #2535354

        Had a similar issue on a machine a few months ago. Created a new admin user, repaired edge in that user and it started miraculously working on the other 2 users (both admins). Deleted the new user account and it has been fine since.

        Never Say Never

    • #2535357

      type sfc /scannow within cmd prompt (as admin)
      have a liquid refreshment and let the pc finish then restart.
      trying to fix something that may be broken elswhere is a likely culprit

    Viewing 3 reply threads
    Reply To: Edge isn’t working

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: