• Elementary OS


    Elementary OS is a distro of Linux which is based on Ubuntu. I just installed it on my old computer:

    eMachines W5243
    AMD Athlon 64 Processor 3800+
    2 GB of RAM
    238 GB hard drive
    Originally came with Windows Vista.

    I wasn’t given the choice of going with 32-bit or 64-bit; there was only one download. Apparently there is no 32-bit version.

    I ran Elementary OS as Linux Live for a little bit, and found that I liked it, so I installed it to my hard drive, choosing to wipe the drive in the process.

    I found that it was very simple to attach to my shared drive. And every time I have tried to access my shared drive, it has worked; so I’m satisfied that there are no issues there, such as there were with Linux Lite (sometimes I could mount the shared drive, but most of the time I couldn’t).

    So far, my flash drive works without a problem, except for when I want to run Linux Live from a flash drive. (That wasn’t always the case with Linux Lite. Like with the shared drive, I often couldn’t mount my flash drive in Linux Lite.) I believe my issues with running Linux Live from a flash drive have to do with the computer, not with the Linux distro I am trying to run, because Linux Live from a flash drive has failed every time I have tried it on this computer except once, with several different distros.

    It takes less than a minute from power on to the Elementary OS login prompt; and as I recall, it takes about three seconds to shut down when I choose that option!

    If you like using a MAC, you will love Elementary OS!
    * There is a dock at the bottom of the screen which holds the icons you have mounted to it, as well as those for open programs.
    * When a program is open, you click on its docked icon to minimize it.
    * When you click on a docked icon, it bounces for a second.
    * The setup screen is exactly like a MAC.
    * The ‘x’ that you click on for closing a window is in the upper-left corner of the window.

    I haven’t fully tested Elementary OS; but so far, I really like it. It is fast and smooth in the way it runs. You can get it here: https://elementary.io/

    Group "L" (Linux Mint)
    with Windows 8.1 running in a VM
    3 users thanked author for this post.
    Viewing 2 reply threads
    • #181005

      Update: While using Elementary OS, it is such a nice experience that I forget I am using a very old computer!

      Group "L" (Linux Mint)
      with Windows 8.1 running in a VM
      2 users thanked author for this post.
      • #181024

        Good to know!  I was curious about it and had tried a demo a couple years ago.  But didn’t dig in very deep.

        Just recently read about how the Elementary desktop environment was custom built by their developers, called Pantheon.  So by combining that DE with a carefully curated set of applications, they can trim a lot of bloat that some distros have that include everything.  I can see how that would help keep it lightweight.

        Also learned that since it is Ubuntu based, you can use the command line to install any additional apps that you need as DEB packages.

        Windows 10 Pro 22H2

      • #181041

        Ran across this blog post regarding the Elementary product roadmap, and the version history:

        Let’s talk about elementary OS 5.0 Juno


        Windows 10 Pro 22H2

        1 user thanked author for this post.
    • #181123

      I finally found a problem with Elementary OS — We had a power failure at the house today, which shut down all of the computers, including (1) the Linux Mint box with my shared drive, and (2) my Elementary OS box.

      When the power came back on, I powered everything on. But now I can’t access my shared drive from the Elementary OS box.

      I’ll bet there is a file corrupted somewhere on the Elementary OS box, and if I knew which file, I could delete the file, reboot, and be back in business with the shared drive.

      Group "L" (Linux Mint)
      with Windows 8.1 running in a VM
      • #181369

        Sorry to hear of your troubles, Jim!

        How is your shared drive connected?  Is it USB?

        Before you start chasing down corrupted files, it might be worthwhile to boot from a live distro that you know has been able to access the shared drive.  This would rule out any damage to your hardware from the power outage.

        I hope that it’s not a hardware issue, but it is simple to rule it out.

        Windows 10 Pro 22H2

        1 user thanked author for this post.
        • #181509

          I run Samba on the computer that has the shared drive, then access the drive from all other computers simply by searching for it on the network.

          Speaking of running a live distro to test the hardware, I could reboot with the Elementary OS live disk that I used to install Elementary. Not sure why I didn’t think of that — I always advise everyone else to do that! Also, Mint never had any trouble accessing the shared drive from that computer.

          The computer is 10 years old. When I bought it, it was a bottom-of-the-line computer that I got cheap at Walmart, my kids’ first computer. They have long since moved on to other computers; but I’ve tried to find a way to keep it going rather than throw it away. Elementary OS has been the most promising OS — it runs well with Elementary installed.

          If it has finally given up the ghost, I have definitely gotten my money’s worth out of it! But it is handy as a test machine, to see which Linux distros are good for an old, slow computer.

          Group "L" (Linux Mint)
          with Windows 8.1 running in a VM
          • #181522

            OK, then it’s not a USB port issue if you are using a network connected share.

            If your network is connecting, then your network adapter is fine.

            Like you said, something in your configuration may have changed when the OS took a power fail.  I wouldn’t know where to look, as I never connected to a share at home.  There are probably some resources in the Ubuntu forums that might be helpful.



            Windows 10 Pro 22H2

            1 user thanked author for this post.
            • #182122

              I installed all available updates via the Terminal, then rebooted. My shared drive has returned!

              Group "L" (Linux Mint)
              with Windows 8.1 running in a VM
            • #182286


              It sounds like Elementary may be an ideal choice for a ‘light’ Linux distro. 🙂

              Windows 10 Pro 22H2

            • #182434

              I’ve lost the shared drive again.

              This is really getting aggravating.

              Maybe the “light” distros are light on networking.

              Group "L" (Linux Mint)
              with Windows 8.1 running in a VM
            • #182912

              Shared drive is back!

              Group "L" (Linux Mint)
              with Windows 8.1 running in a VM
    • #181126

      Might have to give Elementary OS a try sometime (that’s the advantage of having spare solid state drives sitting around here).

      My  nearly 12 year old HP laptop would be a good candidate for this. I did have Linux Lite on it for a while but I was having problems with both Firefox (version 52 ESR) and Pale Moon crashing regularly for some strange reason – Pale Moon would just close without any notification at all. Disabling hardware acceleration in both browsers cut down the amount of crashes but I was still getting a few.

      I was thinking it might just be the age of the laptop – motherboard parts getting old, etc. but the same 2 browsers work perfectly (so far – and again with hardware acceleration disabled) with Linux Mint 18.3 which I’ve had on the laptop for several days now.

      Edit: Oh, I see there isn’t a 32 bit version which I would need for my old laptop 🙁

      I’ll have to get the 64 bit version and give it a spin on my main PC.

      PC1: Gigabyte B560M D2V Motherboard, Intel i5 11400 CPU, 16GB RAM, NVIDIA GeForce GTX 1650 Graphics Card, 1x Samsung 870 EVO 250GB SSD, 1x Samsung 860 EVO 250GB SSD, Windows 10 Professional 22H2 64bit.
      PC2: Asus H81M-PLUS Motherboard, Intel i3-4160 CPU, 16GB RAM, NVIDIA GeForce GTX 1050 Graphics Card, 1x Samsung 870 EVO 250GB SSD, 1x Samsung 860 EVO 250GB SSD, Windows 10 Home 22H2 64bit.

    Viewing 2 reply threads
    Reply To: Elementary OS

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: