• External HD My Passport Drive Letter changed to E: from D: post July updates

    Home » Forums » AskWoody support » Windows » Windows 10 » Questions: Win10 » External HD My Passport Drive Letter changed to E: from D: post July updates

    • This topic has 12 replies, 6 voices, and was last updated 1 month ago.
    Author
    Topic
    #2470180

    I have 2 external WD My Passport drives. They have always shown up as D:\ automatically when plugging into PC. I only plug in one at a time.

    Suddenly, one of them has been renamed as E:\, and is stuck there. renaming does nothing.

    How do I get the now “E:\My Passport” to show up as D:\ My Passport? It’s urgent, as that drive is my backup drive for Imazing backups, Itunes, and all backups on drive are mapped to D:\ and thus I no longer have access to any files on the drive! Help!

     

    • This topic was modified 1 month, 3 weeks ago by Deo.
    Viewing 11 reply threads
    Author
    Replies
    • #2470189

      Look in disk management if there is a D drive/partition.

      1 user thanked author for this post.
      Deo
    • #2470192

      Open Disk Management (diskmgmt.msc)

      Right-click on your E: Passport drive and select the Change Drive Letter and Paths… option

      DiskManagement

      Select the Change button in the window that opens and then reset the drive letter to D using the drop-down on the right of the window that opens.

      DriveLetters

      You’ll get a “Some programs that replay on drive letters might not run correctly. Do you want to continue? message.

      Note: if D: has already been assigned to another drive, it won’t be available in the drop-down!

      To fix that you’ll need to remove drive letter D: from whatever drive is currently using it.

      3 users thanked author for this post.
    • #2470200

      Alex: There was no other D:\ listed.

      alejr: Thank you! Worked perfectly, D available to select. I now have access to that drive.

      My next test will check what occurs when the other Passport is plugged via usb at the same time as this one to see what drive letters show up for 2nd one, should default to E…

      Update: 2nd did default to E. Able to xfer files between the two backup drives. Unsure if/why July updates would have caused the drive letter to permanently have changed.

      I assume the change to D:\ via diskmgnt will now be permanently  assigned to 1st ext drive, and will have to remember to have no other thumb drives etc in usb slots to preserve a ‘D’ ltr avail for this one now?

    • #2470229

      I name all Ext Bkup Drives ( R,U,W currently) toward the rear of the alphabet as I recall long ago postings that Windows often messes with the up-front letters like D-E and does what happened to you. One of the experts can clarify or refute as appropriate.

       

      W10 Pro 21H2 / Hm-Stdnt Ofce '16 C2R / HP Envy Desk-Ethernet - SSD-HDD/ i5(8th Gen) 12GB / GP=2 + FtrU=Semi-Annual + Feature Defer = 1 + QU=0

      2 users thanked author for this post.
    • #2470283

      I name all Ext Bkup Drives ( R,U,W currently) toward the rear of the alphabet as I recall long ago postings that Windows often messes with the up-front letters like D-E and does what happened to you. One of the experts can clarify or refute as appropriate.

       

      That’s a reasonable approach. It can sometimes take a bit of shuffling to organize drives with lower letters on removable drives, because Windows tends to auto assign the lowest available letter when you plug a drive in.

    • #2470341

      Just FYI, since PCs no longer come with floppy drives, it’s also possible to use drive letters A & B for external drives (i.e. my “NAS drive” is A: and my “backup drive” is B:)

      ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

      I assume the change to D:\ via diskmgnt will now be permanently assigned to 1st ext drive, and will have to remember to have no other thumb drives etc in usb slots to preserve a ‘D’ ltr avail for this one now?

      Actually, D: is now “permanently” assigned to that specific drive. In fact, if you were able to “internally connect” that drive to your PC, it’d still show up as drive D: in Windows.

      Drive letters set using disk management (or diskpart) are tied to the drive’s “unique ID” and get stored in the registry; which means that drive will always show as that letter regardless of how it’s connected to your PC.

      Other USB drives you plug in “should” show up as drive E: just like your second passport drive (unless you also assigned E: to the second drive, in which case they’ll show up as F:)

      1 user thanked author for this post.
      Deo
    • #2473237
      Thanks all, yet problems persist. (I still don’t understand why the drive letters changed post July updates).
      As I prepare for attempting Aug CU updates today, I performed my usual process:
      3 separate WD passport drives – 1 for itunes (now supposedly “permanently D:/); 1 for Macrium Reflect Free backups; 1 for manual user drag/drop doc/pics backups. One at a time.
      1. Plug in Macrium wd passport- it suddenly shows ‘E:\ backup files not available’. This drive  now showed up as D:\? (Default next avail drive ltr?) Thus can’t backup. I did NOT use disk management to assign drive letter as I did above for itunes drive. Eject drive.
      2. Plug in my wd passport ‘Drag & drop’ back up drive, no problems! Eject.
      3. Plug in my wd passport ‘itunes’ back up drive, works, no problem (is D:\). Eject.
      Troubleshooting steps: thought I’d try plugging in a blank thumb drive, then plug in Macrium passport. Success, passport shows as E:\ and M/R finally reads b/up files. Ejected thumb drive, M/R drive still in= it held as E:\ and was able to do a backup! Did not have to use disk management and change drive letter.
      This is beyond puzzling. Any ideas? Something is going on with drive mapping? Of which I no nothing about, as I’ve never had these issues. All WD’s are only 5 months old, all formated as NFTS as is my PC, no problems until my orig post, after July updates. At a loss-registry didn’t retain D assignment?
      Ruled out different usb ports, different cords.
    • #2473238

      ( Sorry. Tried to put spaces for paragraphs for ease of read, but any edits won’t hold the new spacing?)

      * Doing the above backups offline or online makes no difference.

    • #2473249

      You would expect the drive letter to change to E if you already have a D drive.

      If you manually set the MR drive to E it should retain that letter, whether you have another drive connected or not. Is this the case?

      cheers, Paul

    • #2473250

      No drives ever had an assigned letter, as per the beginning of my OP. The behaviour prompting my initial post continues, now affecting other drives.

      This time I did not change any drive to E via disk management. ( I had only changed the one drive to D as per advice in this thread to gain urgent access to itunes). My post 2473237 above states the persistent behaviour. No other drives were plugged in.

      M/R drive was never manually created as E:, no other thumb or ext drive has ever been in any port while I do backups with that drive.

      Anything else I plug in solo shows as normal D.

    • #2473272

      Ok, here’s how it works.

      When you plug in a USB drive that has not had a drive letter “manually” assigned to it, Windows will use the first available unassigned drive letter for it.

      I.e. on my PC, drive letters C:, D:, E: & F: are all “manually” assigned to specific devices.

      C: is my System drive
      D: is my Downloads drive
      E: is my DVD/Bluray drive
      F: is my work drive for video/audio processing

      Except for my external backup drive (which I “manually” assigned drive letter B:) the first USB drive I plug in always shows up as G:

      If I plug in additional USB drives without removing the existing ones, they show up as H:, I:, J:, etc., etc.

      If I unplug one of those drives, the letter it was using becomes available and the next drive I plug in will use it (i.e. if I unplug G:, the next drive I plug in will show up as G: — if I unplug H:, it’ll show up as H: — etc., etc.)

      This has been normal Windows behavior for USB drives all the way back to Win 98.

      So, if you want a particular USB drive to “always” have a specific drive letter, you mustmanually” assign it that drive letter (like you did with your iTunes backup drive.)

      Otherwise, it’ll show up as whatever unassigned drive letter is currently “available” for use.

      Note: you cannot “manually” assign the same drive letter to more than one drive (once it’s been assigned to a drive, it’ll no longer appear in the drop-down list of available drive letters.)

      1 user thanked author for this post.
      Deo
    • #2473342

      Understood. Been using PC’s since ‘98.

      Have never  been forced to manually assign a drive letter before; ext drives previously just worked properly on all PC’s.

      I guess I’m simply not explaining this sudden spontaneous behaviour well. Sorry for lack of tech terms.

      Note: last eve, M/R drive when plugged in, was assigned D. In checking,  ‘D:\’ WAS available in ‘drive letter change’ drop down menu via disk management, even though I had assigned itunes b/up drive as D? I cancelled out of that, did NOT assign any ltr to M/R drive.

      I recall long ago postings that Windows often messes with the up-front letters like D-E and does what happened to you.

      I guess I’ll chalk it up to this! Thank you kindly.

    Viewing 11 reply threads
    Reply To: External HD My Passport Drive Letter changed to E: from D: post July updates

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: