Woody Leonhard's no-bull news, tips and help for Windows, Office and more… Please disable your ad blocker – our (polite!) ads help keep AskWoody going!
Home icon Home icon Home icon Email icon RSS icon
  • External HD

    Topic Resolution: Resolved

    Tagged: 

    This topic contains 11 replies, has 5 voices, and was last updated by  DrRon 3 days, 2 hours ago.

    • Author
      Posts
    • #167082 Reply

      DrRon
      AskWoody Lounger

      I posted this question in the WS Forums but since they’re down I’m bringing it here for help.

      I’m running W7 Pro on a Gateway FX530 XM (old) with an Intel 975X Big Arm motherboard.
      I have a Seagate 2T external HD running in an Antec MS-1 enclosure, with separate power supply and power switch.
      Connecting the external HD to my old XP machine via an eSATA bridge was pure PNP with the power switch.
      Just tried the same connection setup to the W7 machine.
      Turned on the power switch, the system loaded the driver and the Autorun dialog came up.
      I selected Explorer and everything looked good.
      Transferred some data to the internal HD, then turned off the switch.
      System showed the HD was still connected….
      Powered back on and did the safely remove option.
      Powered off – no change – drive still showing.
      Control panel troubleshooter says device was prepared for “Safe Removal” but hasn’t been removed from the computer (code 47).
      Wants me to unplug the HD from the computer then plug it in again.
      Restarted computer, powered on the HD enclosure and got the Autorun dialog – good.
      Did the “safely remove” and power off again – no deal.
      How the heck should I remove the HD from the computer properly?

      Edit to remove HTML

    • #167091 Reply

      PKCano
      AskWoody MVP

      Did you try right clicking on the drive in Explorer and choose “Eject” or just using the icon in the system tray?

    • #167228 Reply

      the_Unforgiven
      AskWoody Lounger

      USB Safely Remove works on external HDD’s as well

      have a good 1 🙂 cheers

    • #167231 Reply

      Schnarph
      AskWoody Lounger

      Turn on the connected external before starting the computer.

      If the eSATA connection is on the motherboard, the BIOS should have it set correctly as hot swap/hot plug, whatever. There might not even be an option. If it’s an add-on port in one of the card slots, it might not be set correctly in the BIOS. UEFI BIOS will usually let you set any SATA drive as hot swap/hot plug. Either way, I always had a hard time with eSATA unless the external drive was on before the computer.

      Edit:

      “Eject” or “safely remove” before turning it off or disconnecting.

       

       

      • This reply was modified 1 week ago by  Schnarph.
    • #167639 Reply

      DrRon
      AskWoody Lounger

      Did you try right clicking on the drive in Explorer and choose “Eject” or just using the icon in the system tray?

      Just the system tray icon

    • #167647 Reply

      DrRon
      AskWoody Lounger

      Turn on the connected external before starting the computer. If the eSATA connection is on the motherboard, the BIOS should have it set correctly as hot swap/hot plug, whatever. There might not even be an option. If it’s an add-on port in one of the card slots, it might not be set correctly in the BIOS. UEFI BIOS will usually let you set any SATA drive as hot swap/hot plug. Either way, I always had a hard time with eSATA unless the external drive was on before the computer. Edit: “Eject” or “safely remove” before turning it off or disconnecting.

      So I tried this:
      Go to my computer, right click on the external hard drive, click properties at the bottom. Go to the hardware tab, click on the correct disk and click properties. If there is a button in the general tab that says “Change Settings” click it. Then go to the policies and select the quick removal option. This will allow you to unplug the drive at almost any time without there being errors.
      It all showed up and I selected the quick removal option.

      Does that prove the BIOS sees the eSATA connection on the MB?

      Still, power off and safely remove leave the drive showing in Explorer.  It only goes away if I try to browse it.  I haven’t tried eject in Explorer.

      I haven’t seen any signs of data corruption, but still feel anxious about it not dropping off Explorer on power off.

      Edit to remove HTML from copy/paste

      • #167752 Reply

        Schnarph
        AskWoody Lounger

        Judging by the photos I could find for the Intel 975X Big Arm motherboard, I’m guessing one or both ports under the 1394 are eSATA. Another guess is that it would be designated for hot-swap, i.e., the OS knows to use the eSATA like USB due to a permanent BIOS setting. That board runs DDR2 memory, SATA and (P)ATA, leading to another guess that it was made a few years before Windows 7. More guessing here, the latest BIOS on that board is very old. There are going to be at least a few “quirks” running Windows 7 on a PC made for XP or Vista, usually a missing driver but sometimes it’s almost benign like your issue.

        It only goes away when you try to browse it after removal. What happens when you safely remove, then power the eSATA off, then right click on the desktop and select “refresh”? Does it go away then? Even on a 3 year old PC running Windows 7, some icons like the recycle bin don’t always refresh themselves immediately.

         

        • This reply was modified 5 days, 1 hour ago by  Schnarph.
    • #167927 Reply

      DrRon
      AskWoody Lounger

      OK, bear with me here…

      • Connected Ext HD, powered it up and it showed up in Explorer and Autorun
      • Selected Eject in Device Manager, got Safe to Remove notice, Ext HD gone in Explorer.
      • Powered off Ext HD
      • Device Manager still shows Ext HD and needs troubleshooting
      • Reports Prepared for Safe Removal but not Removed
      • Powered on Ext HD – no show in Explorer

      Powered off Ext HD and computer

      Powered on Ext HD, then computer

      • Ext HD shows up as Disk 0 in Disk Manager
      • Shows up in Explorer and top of Devices and Printers CP
      • Selected Eject and it drops out of Explorer and Disk Manager
      • Got Safe to Remove notice
      • Still shows in Devices and Printers – needs troubleshooting
      • Did Desktop Refresh – no change in Devices & Printers

      So, seems like BIOS sees it as an ATA device with proper drivers

      Devices & Printers shows it fine, but doesn’t respond when it’s ejected.

      The computer properly responds to eject function but will not see it from power on without a Restart…  darn!

      • #167945 Reply

        Schnarph
        AskWoody Lounger

        Good news/bad news:

        Your eSATA troubles are not at all unique. I have had the same problem you’re having with eSATA on 2 PCs that were both manufactured after Windows 7. On one, it won’t see the drive at all unless the eSATA enclosure is on before the PC, but neither will recognize the drive after it is ejected unless the PC is rebooted. If you can get it to work at all, take that as a win.

        My only advice at this point is to always empty the recycle bin before ejecting the eSATA if you have deleted any files from that drive. That’s the only real problem I’ve ever run into, besides the inconvenience of rebooting to see the external drive.

        If that motherboard has a spare PCIe slot, getting a USB3 card and a USB3 enclosure would be ideal. I never went back to eSATA after upgrading to USB3. The speed is almost the same, averaging ~80MBps via USB3 vs ~100MBps via internal or eSATA using the same HDD with full 1-2TB transfers. However that will cost money, easily avoided if you can put up with the hassle of rebooting before re-attaching the eSATA.

         

        1 user thanked author for this post.
    • #167950 Reply

      DrRon
      AskWoody Lounger

      Sounds good just to know the MB, BIOS and HD enclosure are all probably OK.

      I’ve got 3 WD Caviar Black  HD’s ( 2 – 500GB, 1 – 750GB) internal to this desktop machine for most of my storage and backup work.  The Ext HD will probably be a Hitachi 4 TB drive to archive everything in case the world ends.

      So, I won’t need it available every day.  I can handle it coming on line when I need it and dropping off when I power it down.  I’ll need to remember to eject it first I guess.

      The machine will probably be shut down sometime before the next archive session.

      All in all, I can live with that.

      I really appreciate your generous experience sharing…

      Thanks, Ron

      • #168092 Reply

        GoneToPlaid
        AskWoody Lounger

        Hello DrRon,

        It is possible that the Windows indexing service is keeping the external drive open in Windows Explorer. If you don’t care about having the indexing service index all files on the external drive so that you can quickly search for a file, you can easily disable the indexing service for the external drive. Doing so “might” resolve your issue of the removed external drive still showing up in Windows Explorer. Following is how to do it, and you can reverse the procedure if this doesn’t resolve the issue.

        In Windows Explorer, right-click on the external drive letter and then select Properties. Under the General tab in Properties, uncheck “All files on this drive to have contents indexed in addition to file properties”. After unchecking this option and clicking on the Apply button, a popup box will appear with two choices. One choice is to apply this setting to only the drive’s root folder, for example, E:\. The other option is to apply this setting to the root folder and to all subfolders and files. Select the former to only apply this setting to the root folder. I vaguely recall that a reboot is required for this new setting to fully take effect.

        I am not sure that this will resolve your issue. If not, then you can easily reverse the procedure.

        Best regards,

        –GTP

         

        1 user thanked author for this post.
    • #168163 Reply

      DrRon
      AskWoody Lounger

      Hi GTP

      Interesting suggestion – interesting results.

      • Unchecked the index files option, hit apply, selected root folder only, said OK.
      • Selected properties again and the index box was still checked.
      • Tried all again with same result.
      • Left HD powered on, didn’t safely remove (it’s just another ATA device?), and rebooted.

      Got autorun box on External HD, closed it, checked Explorer and of course it was there.

      Checked properties and index files box was still checked.

      So – tried the other option:

      • Unchecked the index files box, hit apply, now selected all subfolders and files
      • Said OK and got the dialog box applying that setting…
      • It’s a little over a TB of data, so I just went away…
      • When it finished I said OK and closed the properties box
      • Then opened properties again and the index option was unchecked – good.

      Did the safely remove thing, powered off the External HD and rebooted.

      When Windows stabilized I powered on the External HD:

      • Got autoplay and it showed up in Explorer – good.
      • Powered off the External HD and it dropped off Explorer – good.
      • Still shows up in devices and printers needing troubleshooting – sigh.

      So here’s what I’m seeing:

      • The External HD will show up in Explorer when powered on and drop off when ejected.
      • It will always show up in Devices and Printers after eject with troubleshooting needed.
      • If I power it off and on, it won’t reappear in Explorer with a reboot.

      I guess I’ll have to live with that.

      Thanks for the help….

      Ron

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: External HD

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.

    Your information:


    Comments are closed.