News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Firefox and autoplay

    Posted on areader Comment on the AskWoody Lounge

    This topic contains 6 replies, has 5 voices, and was last updated by

     mledman 1 week, 6 days ago.

    • Author
      Posts
    • #610139 Reply

      areader
      AskWoody Plus

      If this is in the wrong forum, please move it to where it belongs.

      Last time I did a google search on this, the answers were too old to apply to modern versions of Firefox. So:

      Is there a way to globally stop Firefox from autoplaying videos? Not just YouTube, but on Accuweather and other sites? I know that on YouTube you can turn off autoplay, but it’s very annoying if you’ve clicked on several videos to watch one after another, but they’re all playing simultaneously. And after you stopped all of them, you have to reset them when you go to watch them.

      TIA

    • #613766 Reply

      Microfix
      Da Boss

      I’m assuming that you’ve tried:
      within the about:config page of firefox
      search for media and then look for the following:

      media.autoplay.enabled

      If this is enabled, disable it and try a website with videos.

      If it doesn’t work for you, then the alternative may be an extension from the mozilla get add-ons pages. (sorry can’t recommend/ know any)

      ********** Peng/Wins x86/x64 **********

      - µfix

      1 user thanked author for this post.
      • #1589291 Reply

        areader
        AskWoody Plus

        Sorry for the delay in answering. I couldn’t figure out where I’d posted my question and didn’t know how to search for it.

        Instead of

        media.autoplay.enabled

        I have media.autoplay.default and I didn’t know what to change that setting to or to delete it. Adding  media.autoplay.enabled and setting it to “false” doesn’t do anything, so I figure I have to delete my addition and change the original–but it’s set to 1 not true or false and I’m not computer-savvy enough to change things like that without knowing exactly what to do.

    • #625130 Reply

      Lars220
      Subscriber

      Starting with Firefox 66.0 there is a setting in Options / Preferences, under Privacy & Security, scroll down a little to Permissions, then check the box “Block websites from automatically playing sound” – this works for me on a lot of websites. Following links are helpful:

      https://www.ghacks.net/2019/01/28/firefox-66-with-autoplaying-sound-blocker/

      https://www.ghacks.net/?s=Firefox+Autoplay

      https://www.mozilla.org/en-US/firefox/releases/

      Firefox-Autoplay

      Attachments:
      1 user thanked author for this post.
      • #625756 Reply

        anonymous

        @lars220

        I was about to say the very same thing, but when I clicked the submit button, the page then refreshed, showing your post above, so I asked the mods to remove my post for its being duplicative, and adding no new info.

        This just goes to show that there are plenty of us still out here using Firefox, despite the staggering usage numbers routinely posted by Chrome! 🙂

        1 user thanked author for this post.
      • #1589399 Reply

        areader
        AskWoody Plus

        The videos still play automatically, but there’s no sound. That doesn’t really help. But thanks for trying.

    • #1606890 Reply

      mledman
      AskWoody Plus

      Searching for “autoplay” in firefox add-ons, I found plugins to block video from playing.  I have not tried any of them.

      Mark

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Firefox and autoplay

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.