News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • Folder naming problem

    Home » Forums » AskWoody support » Windows » Windows 10 » Questions: Win10 » Folder naming problem

    Author
    Topic
    #2402301

    Got a strange problem that maybe someone here can help with.

    On my Laptop (Win10 21H1) I can’t give a name to new folders or rename an existing folder using Explorer. When I try to, I get the following error.

    Rename Error

    Clicking Try Again keeps repeating the same error.

    Clicking Cancel causes an “unable to locate item” message to popup and then the error window closes.

    If I use a cmd prompt to create/rename a folder, everything works as expected.

    No errors found running SFC, DISM or the built-in troubleshooter.

    Searched for a solution on the internet and found these suggestions.

      • replace the Explorer\FolderDescriptions and Explorer\FolderTypes registry entries with ones from a working PC.
      • replace explorer.exe and explorer.exe.mui with ones from a working PC.
      • create a new user account.

    I used the registry settings and explorer files from my Desktop (also Win10 21H1) where this function works, but that didn’t fix it. It also occurs for a new user account on the Laptop.

    Notes:

      • Not sure how long ago this problem surfaced as I haven’t needed to create a new folder/rename one in quite a while (at least 6-8 months ago.)
      • The problem only effects folders. Using Explorer to create new files or rename existing ones works as it should.
      • I took ownership of the registry entries on the Laptop and actually deleted them before merging the settings from my Desktop into the registry.
      • I replaced explorer.exe and explorer.exe.mui on the Laptop by booting from a Windows install USB, Shift+F10 for a cmd prompt, deleted the files on the Laptop, then copied the files from my Desktop into their proper locations on the Laptop.

    So, anyone here know of a verified fix (other than reinstalling Windows) for this problem?

    • This topic was modified 2 weeks, 5 days ago by alejr.
    • This topic was modified 2 weeks, 5 days ago by alejr.
    • This topic was modified 2 weeks, 5 days ago by alejr.
    Viewing 11 reply threads
    Author
    Replies
    • #2402319

      OK, sorry, no guarantees… But that folder in your example is special, in that it’s DOS same is not it’s name in the Windows GUI, so I’m wondering if 8.3 file name generation is off, and the bizarre response is because you have a third part AV product or such which is attempting to background scan the folder as it’s “new”, and can’t make sense of the folder information from Windows, and that process causes the message when it fails and returns an error code. The indicator for this.

      When you say it doesn’t affect files, I assume you tried a file with a name longer than 8 characters, as that would also exhibit the problem if 8.3 file name generation is a potential cause.

    • #2402320

      Default values for FolderDescriptions available here seem to have worked for a bunch of people in the comments:

      Fix: Cannot Rename or Move Folders in Windows 10 – The File or folder does not exist

      And this page mentions (at solution 5 of 8) an apparent “glitch” caused by Small icons view:

      Can’t rename folders in Windows 10 [Full Fix]

      Windows 10 Pro version 21H2 build 19044.1387 + Microsoft 365 (group ASAP)

    • #2402323

      oldguy,

      Hadn’t really considered the problem might be a short names vs long names thing but, after your pointing it out, I realize the symptoms might very well point to that.

      Of course the question would be, why on the Laptop but not the Desktop since they’re both pretty much duplicates of each other.

        • i.e. same version of Win10 +updates with “mostly” (95%) the same S/W installed?

      Anyway…

      Yes, I tested long file names, and they work just fine.

      Also, even though both PC’s have the exact same 3rd party Antivirus program with the exact same configuration, I tired deactivating the Antivirus program on the Laptop and it didn’t make a difference.


      b,

      As I stated, I already tried replacing the FolderDescriptions and FolderTypes with know good ones from my Desktop and it didn’t help.

      I also tried all of the solutions in your second link (that was the 3rd result I got when I searched on-line for a solution) and none of those fixed it.

      In fact, I’ve tried multiple different solutions suggested on many different on-line sites (short of actually reinstalling Windows) and, so far, none of them have fixed my problem.

      The lack of finding a solution on the web is what prompted me to post here.

      BTW, this is more of an minor annoyance than a real problem since I don’t often need to do this and can get it to work if I use a cmd prompt instead of explorer.

    • #2402434

      Time for an “absolutely certain” backup and get 21H2 then.. and if you don’t want it? roll it back off again as if setup fixes the problem removing the update shouldn’t undo the fix unless it is a problem with a Windows file DISM isn’t finding rather than a setting.

      If it is that, given the way updates are cumulative now, the only option is to remove and reinstate the last cumulative update and see if that fixes the problem (guessing you’ve done that).

      To me the “can not find the file” indicates something is locking the folder, such that it can’t be renamed, so the new name is never valid. (I assume the AV is working..) Perhaps try stopping WDS, turning off autoplay, and try again just in case one of those services running awry? Either that or side-by-side has gone awry at some point and potentially you are entering “dll hell”.. though it would take a messed up catalogue for DISM to allow it..

    • #2402465

      My 3rd party AV is working as expected on both PC’s.

      I disabled Autoplay years ago (got tired of always having to select an option when inserting a new thumb drive/DVD) and was surprised you even mentioned it because, as far as I understand things, it’s only used when you insert new media??

      Unless I’m mistaken, WDS is Windows Deployment Services (used to deploy windows images over a network and for Active Directory management) and, as far as I can determine, it’s not installed nor running on either of my PC’s.

      I did the 21H2 update and it didn’t help. Of course, since it was just an “enablement package” that turned on features already present in the OS, I didn’t really think it would and am a bit surprised you suggested that (unless you meant I should try an “in-place upgrade” using a 21H2 ISO image?)

      I know an in-place update using an ISO image would most likely fix this, but I’m really not ready to do that because it took me 2 weeks to restore all the “personal tweaks” I have in place on my systems the last time I did it.

      Also, as I pointed out before, the folder rename thing is just a minor annoyance since I can always use a cmd prompt whenever I need to do it (which isn’t that often.)

      BTW, thanks for the suggestions and keep them coming!

    • #2402558

      Maybe AV is working from the interface but something affecting “all folders” in the background has failed..

      You may not be alone now..

      Microsoft Installer issues updating or repairing apps effecting all Windows

       

    • #2402573

      Every Sunday I use a bootable Paragon USB to create a full disk backup (saved onto an “external” drive) of both my PC’s. I figured I’d find out how old this problem is by rolling the Win10 install on the Laptop back to the oldest backup I still had on hand for it.

      Yesterday, with the Laptop “disconnected” from the internet, I restored the 06/06/21 Laptop backup and, before installing any updates or making any other changes, tired to rename an existing folder and encountered the same problem.

      I then connected it to the internet and let it fully update itself, the problem’s still there.

      So, if it’s being caused by a Windows update, it’s one that was issued more than 6 months ago.

      I’ll take the time a bit later today to completely uninstall the antivirus S/W, try to rename a folder, and post the results.

    • #2402620

      Uninstalling the Antivirus S/W didn’t help.

      I also tried a clean boot (i.e. disabled all non-Microsoft services and startup items) and that didn’t help either.

      So, whatever’s causing this, it’s either a corrupt file that SFC/DISM can’t find or, what I personalty consider more likely, a corrupt entry somewhere in the HKEY_LOCAL_MACHINE branch of the registry since it affects all users.

      Anyone know of a program that can scan for and detect corrupt registry entries?

    • #2402623

      Anyone know of a program that can scan for and detect corrupt registry entries?

      There is none.
      Microsoft had Scanreg.exe tool which has been removed.

      The best option is running repair (after creating a full backup image).

    • #2402701

      As the problem relates to explorer not the user as you tried another account, I would expect the issue to reside in HKEY_CLASSES_ROOT as per

      https://docs.microsoft.com/en-us/troubleshoot/windows-server/performance/windows-registry-advanced-users

      This hive is the “foundation” of the hive you have worked with but a sort of inheritance is at work such that altering one may alter the other if the location you are changing exists there:

      https://docs.microsoft.com/en-us/windows/win32/sysinfo/hkey-classes-root-key

      Best to start at the bottom of the pile and work up.

      Suggest trying the “uninstall tool” for your AV should one be offered before going too deep, then reinstall it and update it as indicated on the post noted previously (gives the authors two chances to fix the problem if they own it..).

      Then export small chunks of registry from the good machine and use FC to compare them to the same from the problem one. It’s a hell of a fishing trip but something in the results might jump out as plain wrong, such as a reference to a product you no longer have installed.

      Be sure to make backups and keep them- we’re discussing manually fixing the product here. No guarantees at all!

       

       

    • #2402749

      I believe I may have been a bit heavy on the issues and a little remiss on the operation – unsure as to how confident you are so I’ve filled the detail a bit.

      You need to attain the registry files when started from recovery media (to attain the “flat” form of the databases)

      That done you need to inspect these. While there are probably dozens of tools for this the ones in the box – reg, FC and regedit – are all you need for this. this also just needs a command prompt, and using a USB recovery media without system files usually means you can work from there. I haven’t actually tried SYSTEM, but DEFAULT and user (NTUSER.DAT in users folder, hidden file) hives can be reworked (unless they’ve really locked things for SeriousSam).

      lets say you have the registries as e:\machine1\ntuser.dat and e:\machine2\ntuser.dat..

      use the following to load them:

      reg load HKU\M1 e:\machine1\ntuser.dat

      reg load HKU\M2 e:\machine2\ntuser.dat

      Then export them…

      reg export  HKU\M1 e:\machine1\reg.txt

      reg export  HKU\M2 e:\machine1\reg.txt

      and compare, placing the results in a file..

      fc /l /t e:\machine1\reg.txt e:\machine1\reg.txt > e:\result.txt

      check it out with notepad – I suspect though it will be too large for FC (“files too different”) and notepad (“files too large, use wordpad instead”), and you will have to take subkeys of the hive singly at best. (copy the location from regedit for the export stage.. if there are spaces put the registry location in quotes..)

      I’m outlining this process from memory so expect you might need to check switches and play around a bit, especially as last time I went there was at version 1903..

      Alternatively select the respective branches you suspect, export from regedit and compare them likewise. This is a needle in a haystack job so if you find the cause, it’s probably really worth documenting! Also note you can manually edit the registry on disk with these techniques, so it might be worth checking what is really in the various run keys for extra peace of mind.. If you find permissions issues (which are worked with regini.exe) perhaps time to take a step back and consider a Windows repair as you can render your system subtly vulnerable without realising it by opening up permissions. I had no troubles with removing entrenched nasties and stupid things like nailing desktop wallpaper for all new users (ie working \users\default\ntuser.dat) with the technique.

       

    • #2402759

      While I was typing this appeared – might help..

      Controlled Folder Access issue

       

      • #2402762

        Controlled Folder Access is part of Microsoft Defender’s anti-ransomware protection. Since alejr has stated that a third party AV solution is in use, MS Defender should be turned off by default.

        Also, if it were a problem with Controlled Folder Access, I would think that alejr’s attempts at renaming a folder in the “DOS box” Command Prompt window would have failed just as the attempts using the GUI (explorer.exe) failed. Instead, the attempts using the Command Prompt succeeded.

        • This reply was modified 2 weeks, 2 days ago by Bob99. Reason: Added emphasis
    Viewing 11 reply threads
    Reply To: Folder naming problem

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.