• Folder permission on network share different on different PCs

    Home » Forums » Networking – routers, firewalls, network configuration » Folder permission on network share different on different PCs


    Can anyone explain what’s going on here? I have an AD environment with a share on the domain server (Windows Server 2008 Rs). For one particular subfolder of that share, its permissions are different on one of the clients just for non-admin accounts. Worse, sometimes the permissions are the same, and sometimes different.

    OK, details. On the share I have a folder “S:\AA Current.” On all other clients its permissions are:

    • Its owner is: Administrators(KUMC\Administrators)
    • Allow System: Full Control, inherited from the parent and applies to this folder, subfolders and files.
    • Allow Administrators (KUMC): Full Control, inherited from the parent and applies to this folder, subfolders and files.
    • Allow Domain Users (KUMC): Modify inherited from the parent and applies to this folder, subfolders and files.

    On one specific computer, logged on as the same domain user as for above, the folders permissions are:

    • Owner: Unable to display current owner.
    • Permissions: You do not have permission to view or edit this object’s permission settings.
    • What I try going into that irritating folder, I get the Network Error “Windows cannot access \\KUMC_Share\Docs\AA Current.” “You do not have permission to access \\KUMC_Share\Docs\AA Current.”
    • This is what usually happens. Once in a while I can get into the folder without problems.
    • Nothing is jumping out at me in Event Viewer.

    C’est what?

    This is what I’ve tried so far:

    1. Take the offending computer off the domain and put it back to get a new SID. Things looked good for an hour or so and then no permission returned.
    2. Logged on using admin accounts, I get into the annoying file easily.
    3. I ran SFC and it found stuff it couldn’t repair. I ran DISM to repair and then SFC again with no errors found. Rebooted and non-admin account could access the file just fine. This morning the non-admin account failed to open the folder.
    4. I’ve run malware scans with Malwarebytes and BitDefender without anything be found.

    I’ve run out of ideas. Any suggestions other than imaging that client?


    Viewing 2 reply threads
    • #2176641

      I’d rebuild that machine. (My standard response when it’s weird – re-image takes 20 minutes assuming you use images to build your domain machines.)

      cheers, Paul

      • #2176771

        Thanks, Paul. Reimaging is the direction I’m heading. Unfortunately we’re a church and I’m most of the volunteer IT department. We don’t have images. We are moving toward making the clients into dumb terminals and running VM’s hosted on the server, but we’re not there yet.

        But why is it just the one folder that is going bye-bye? Now let’s make things murkier. If I rename that folder from “AA Current” to “AA-Current” it works just fine. Why?


    • #2176781

      Something on that machine corrupting cached credentials?
      Have you run chkdsk on the disk?
      Does it happen with another user logged on – non admin?

      Logon as admin and rename the user profile, then logon as the user.

      cheers, Paul

      • #2177447

        I’ve run sfc but not chkdsk. Good suggestion. I have tried this with two non-admin accounts and two admin accounts. It fails with both non-admin. I went in and deleted the profile of one of the non-admin accounts and then logged in using that account to create a new profile. Made no difference.

    • #2176858

      Just a by-the-by comment –
      Although enclosing a “\File Or Folder Path Name” in double quotation marks usually works, I’ve found that \FileOrFolderPathName (optionally, with some inserted separation character) always works. I almost never define a name with an embedded space. Possibly some path-scan routine is not honoring the syntax rules and just breaking at a space.

      1 user thanked author for this post.
      • #2177448

        We have lots of folder (and file) names with spaces. They all work fine on all our other computers running Win 10 (and one still on Win 7). It’s only this one computer and one folder that is failing. I think that next week I’m going to just rebuild that computer and be done with it. (And if it keeps failing after that, you’ll probably hear my scream around the world.)

    Viewing 2 reply threads
    Reply To: Folder permission on network share different on different PCs

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: