• Further Adventures of Indiana Networker!


    Hey Y’all,
    Further adventures with Windows 2004!

    Today I restored my Win 10 Pro 2004 image on the dellxps8700 to do some more testing.

    The first thing I did was run windows update to get updated to 19041.329 in hopes that would solve some problems.

    The machine will still not enumerate properly on other machines in the network.
    On top of that it would no longer allow me to connect to any other machine on the network telling me that the network was not started.
    However, I could access the xps8700 from all the other machines! Ain’t that SPECIAL?!

    So off to do some investigating. My first thought was to check out services, so after doing some googling I fired up the Services app and checked things out. Guess what, the SMB 2.0 MiniRedirectory (mrxsmb20) was stopped! (Remember SMBv1 is uninstalled) This causes LanManWorkstation to fail as it is dependent on mrxsmb20. So I thought a quick trip into an Admin level PowerShell window and issue:

    Start-Service -Name mrxsmb20

    Well you’d think that would do it but Noooooooo, I got this instead:
    Some more googling and I found this batch file to fix the problem:

    @echo off
    sc config mrxsmb20 start= demand

    Of course even run as Admin and it still errored out.

    Well let’s see the web page I downloaded that from said the file for that service is:

    So let’s look for that file, well it was there with a date of, wait for it…, 12/7/19!
    Let’s see now, it’s working on 1909 just fine so let’s see what that file looks like, wait for it… 3/12/20!

    So I say to my self, self let’s try copying the file that works over the one that doesn’t seem to work. Great Idea until you try it and you get Access Denied!

    Then I remember that @bbearren told us about using Process Hacker with the Trusted Installer plugin to get around some of these type problems.
    So I load it up, fire it up and run CMD.exe as Trusted Installer and issue the copy command….SUCCESS.


    I once again have access from the xps8700 to the other 3 machines on the network. Really MS, getting the wrong file in the build! You’d think a multi-billion dollar company could at least master version control, bugs I can understand but putting an old file in a new build is just inexcusable in my view.

    Of course, it STILL hasn’t solved the enumeration problem as the xps8700 does not show up on any of the other machines in Network!, heck it doesn’t even show on itself.
    Yes, I can get to it by typing \\DellXPS8700 in the explorer address bar. But, I shouldn’t have to.

    While working on this process (all day I might add) I developed a little PowerShell program to list service dependencies. You just feed it a list of services and it will print out all the necessary services that service depends on. It’s attached with builtin Help.

    List-ServiceDependencies.zip: Test-ServiceDependencies
    .zip MD5 Hash: D161FDA9E0BDBB2B0D976F594F6AF1FF
    .ps1 MD5 Hash: E946F7A6A8C65E2A0A853463551CD583

    HTH 😎


    May the Forces of good computing be with you!


    PowerShell & VBA Rule!
    Computer Specs

    2 users thanked author for this post.
    Viewing 1 reply thread
    Viewing 1 reply thread
    Reply To: Further Adventures of Indiana Networker!

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: