• Great wifi adapter for Linux Mint

    Home » Forums » AskWoody support » Linux for the Home user » Linux – all distros » Great wifi adapter for Linux Mint

    Author
    Topic
    #335242

    I have a Netgear Wireless N300 USB adapter, model number WNA3100. This adapter works perfectly in Windows; it is a great adapter. But it simply will not work in Linux Mint. Netgear says on their website that they don’t offer Linux support; and when you search the web, you find that a lot of old-fashioned Linux tricks are necessary to get it to work.

    Rather than go through all that, I decided to get a wifi adapter that works with Linux. I purchased a Panda Wireless model PAU09. It has two antennas, and it works great. In fact, I created a wireless profile for the Netgear adapter, and then when I plugged in the Panda adapter, it immediately connected to my home wifi. No configuration was needed! And it has been working like a champ for about an hour!

    $35.00 with free shipping on Amazon Prime.
    https://www.amazon.com/gp/product/B01LY35HGO/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1

    Group "L" (Linux Mint)
    with Windows 10 running on a separate hard drive
    1 user thanked author for this post.
    Viewing 2 reply threads
    Author
    Replies
    • #335259

      I ran into the same thing a few years ago, That Netgear adapter uses a Broadcom chipset, which is a bear to get drivers working in Linux, and I never had any luck.

      Looked up some Linux networking info, and found compatibility specs for Linux wifi drivers.

      Seems like MediaTek Ralink was well supported. https://en.wikipedia.org/wiki/Ralink

      Drivers for MediaTek Ralink wireless network interface controllers were mainlined into the Linux kernel version 2.6.24.

      So I ended up with a $10 Panda with a Ralink chipset. Happy days, plug and play with most Linux distros I have booted with!

      The Panda works fine in either Windows or Linux.

      Windows 10 Pro 22H2

      • #335367

        I’ve found that Intel and Atheros (now Qualcomm) work quite well in Linux too.  I could have gone either way in Linux, but I chose Intel back when I was using Windows 8.1 alongside Linux, since Intel offers the Intel ProSet wifi software that allowed me to completely bypass the Metro/TIFKAM wifi UI of Windows 8.1, which I had blocked with Metro Killer.

        I’d found that both the Intel and the Atheros cards work flawlessly with Linux right out of the box, with zero configuration or fiddling around needed.   All I need to do is boot into a live session and it will let me know there are several wifi networks available, without having to install anything.

        All of my relatively recent-ish laptops (which I define here as “having more than one CPU core”) run either an Intel 7260 (Mini PCIE, in my Asus F8Sn) or Intel 7265 (M.2, in my Dell Inspiron 11, my Dell G3 gaming, and my Acer Swift).

        The Swift came with the 7265, while all the others have been swapped.  The Asus came with an Intel 4965 (dual-band draft N, no bluetooth, 2×3), which is roughly the same spec as the 7265 I bought (dual-band N, no bluetooth, 2×2), but the final 4965 Windows driver never did work right for me in any kind of consistent fashion (in either the XP or 7 flavor).  Frustratingly, someone had written about the very issue I had on the official Intel site just a month or so before Intel stopped releasing new drivers, and the final driver for 7 still had the issue that made the 4965 intermittently much slower than it should have been.  I don’t think they ever released one for Windows 8.x or 10.

        Annoyed by how Intel had cut off driver support for a still-relevant wifi card (if they’re still releasing brand new ones with the same performance specifications, it’s hard to argue that the older one is obsolete!), I avoided Intel at first when I was looking for a replacement wifi card for my Asus.  That was when I bought the Atheros, which worked just as well as the current Intels do– and despite my specific example being about as old as the 4965, the Windows drivers were still in active development.

        While their driver support was much longer than Intel’s, Atheros had discontinued their wifi client software years prior, with their site explaining that windows support for wifi was now so good that it wasn’t any longer necessary.  I don’t agree, as I’d used the Atheros client software with my single-core laptop during the XP years, since it was IMO an improvement upon the already decent Windows XP UI.  I found the native XP wifi UI to be superior to Windows 7’s, and vastly superior to Windows 8.1’s horrendous Metro/TIFCAM wifi UI, so by my estimation, Windows wifi UI support had gotten much worse than when the Atheros client software was in development.  I was able to live with the Windows 7 UI while using the Atheros card, but the Windows 8.1 wifi UI was a non-starter, so I moved to the 7260 to be able to use ProSet, which worked quite nicely.

        Both Dells came with poky 1×1 Intel wifi setups (still two antennae, though, so it was a drop-in upgrade in each case), which I quickly swapped with 7265s (dual-band AC, 2×2, with bluetooth).  There are plenty of other (often newer) Intel wifi cards, but 7265s are super cheap– I paid less than $5 each for them, shipping included. They work well, they are nearly free, and they’re easy to find… why look any further?  I like to stick with proven winners.

        Interestingly (to me, anyway), the 7265 in my Dell G3 is the same one I bought for my Dell Inspiron Gaming 7567, which I ended up returning.  That Dell, like the two others mentioned above, came with the half-speed 1×1 setup.  Almost a year later, its intended wifi card finally found a home in what amounts to the next generation of the same laptop.

         

         

         

         

        Dell XPS 13/9310, i5-1135G7/16GB, KDE Neon
        XPG Xenia 15, i7-9750H/32GB & GTX1660ti, KDE Neon
        Acer Swift Go 14, i5-1335U/16GB, KDE Neon (and Win 11)

    • #335260

      Not to be too redundant, but I have an old HP laptop with Broadcom which wouldn’t work at all with Ubuntu 16.04 LTS. Got a $10 Panda PAU06 (Ralink chipset) from Amazon, which has worked flawlessly for the last 18 months. A true plug and play device.

      • #335261

        Oops. Anonymous above is DrBonzo.

        1 user thanked author for this post.
      • #335371

        Well yes, some HP models are a bother. As well as other brands with Broadcom…

        Most (not all) of these with a builtin Broadcom wlan do start to work (in Debian and derivatives including Ubuntu) after installing either firmware-b43-installer or firmware-b43legacy-installer – the Broadcom firmware is required but not redistributable, a licensing problem.

        This still in general doesn’t work with USB Broadcom adapters.

        1 user thanked author for this post.
        • #335382

          Interestingly, when I have the PandaPAU06 plugged into a usb port on the HP laptop, BOTH the Panda and the internal Broadcom work just fine; I can switch at will between being wirelessly connected with either one. If I don’t have the Panda “plugged in”, the Broadcom is totally dead.

          • #335407

            Well that’s a weird one then. The Pandas should have Ralink chips I believe?

            Oh well, last time I saw one of this type it was rfkill weirdness (with a physically broken wifi on/off button too), but still should only be possible to enable the Broadcom chip if it can load at least sort of workable firmware from somewhere…

        • #340010

          @mn I have a Lenovo with a Broadcom, and after installing the driver recommended by Linux Mint, wifi has been working well.

          1x Linux Mint 19.1 | 1x Linux antiX

          • #340028

            That’s great that you could do that, but one shouldn’t have to install a driver just to have basic functionality. Wi-fi driver support should preferably be baked into the kernel.

            For example, if you are testing a live distro, installing a driver is a bit tricky… 🙂

            Windows 10 Pro 22H2

            1 user thanked author for this post.
    • #340189

      Windows 10 Pro 22H2

    Viewing 2 reply threads
    Reply To: Great wifi adapter for Linux Mint

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: