• Hard drive boot up problem in Windows AND Linux

    Home » Forums » AskWoody support » PC hardware » Questions: How to troubleshoot hardware problems » Hard drive boot up problem in Windows AND Linux


    Appears to be an issue where my hard drive is causing the boot up process in Windows and in Linux to freeze. I suspect it may be related to unsuccessful efforts to hibernate in Windows 10. I don’t think there’s a physical problem with the drive, though. The evidence is that the drive is accessible in the command prompt window presented in Windows Advanced Recovery options.

    Briefly, I have a DELL Inspiron 3793 running Windows 10 (ver. 22H2) with a Western Digital 1TB (931 GB) hard drive formatted as GPT with 6 partitions.

    It is currently freezing on bootup in every option: Startup Repair; System Restore; Reset PC; Factory Image Restore. It now even freezes up during boot up using a Live Linux USB boot drive when it never had before.

    Amazingly, as part of the Advanced Recovery process, it is still possible to launch a Windows command prompt! The prompt initially is at an “X:” (apparently RAM) drive, but the C:\ drive is accessible and I am able to view the contents of a log file referenced during the Advanced Recovery process: C:\WINDOWS\System32\Logfiles\Srt\SrtTrail.txt.  The end of that file currently includes the info:

    Root cause found:
    No OS files found on disk.

    Repair action: Partition table repair
    Result: Failed. Error code = 0x490
    Time taken = 1780265 ms

    I haven’t yet found info on the Error code, but I’m hoping someone here may be able to shed some light on what might be happening or suggest some resources.

    Thanks, in advance.

    Viewing 10 reply threads
    • #2590692

      Disconnect the hard disk and try to boot off a Linux USB.
      If it boots you have a disk / subsystem issue.

      Try changing the motherboard connector for the disk cable.

      Download the WD diags and test the disk – if it boots.

      Can you connect the disk to another machine and read the partition/files?

      cheers, Paul

      1 user thanked author for this post.
      • #2590834

        Hi Paul,

        Thanks for y0ur suggestions. The drive is the laptop’s internal hard drive, so disconnecting it or changing the motherboard connector is not an option without disassembling the laptop. I’m hoping to avoid that at this point, although I’m beginning to believe it might eventually be necessary.

        I believe there’s an option in the BIOS, though, to disable elements of the system and I’m going to see whether disabling the drive will permit a live Linux USB bootup.

        Since the drive is still accessible from the Advanced Recovery command prompt, I suspect if it were removed and hooked up to another system it would be readable, but it may be a while before I’m ready to try that.

        I discovered that the Advanced Recovery command prompt also recognizes USB ports and I was able to read and copy to a USB data drive. I’m going to see whether the WD diags can be run as a standalone program and if so, I will try running them from a USB drive in the Advanced Recovery command prompt.

        Thanks again for the suggestions.

      • #2591052

        Well, the mystery deepens. I discovered that the BIOS does indeed provide an option to disable SATA devices and I disabled the SATA-0 port for the hard drive. Even with the hard drive disabled (if not disconnected) all Linux live USB drives still freeze. I have a number of live Linux USB drives that I have used to preview various distributions: Garuda, Kaisen, Kubuntu, ExTix, Solus, NixOS, …  They all freeze during bootup. Could this be something unrelated to the hard drive?

        I also searched the Western Digital website for a standalone diagnostic command line program, but could not find one. The only diagnostic software options that I was able to find were Windows or macOS based, and since I’m only able to access a command prompt in Advanced Recovery, I can’t install and Windows GUI programs.

        So, what kind of condition would cause live Linux USB drives to freeze during bootup, but still permit the hard drive to be accessed in an Advanced Recovery command prompt?!?


    • #2591061

      Make a Windows boot USB to test.

      Download Rufus and run it.
      Plug a USB stick in and select it in Rufus.
      Under “Boot selection” choose “Disk or ISO image (please select)”.
      Choose “Download” from the dropdown on the right.
      Click on “Download” that is now displayed (not the dropdown arrow).
      Choose the Windows version (10) and let Rufus add it to the USB.

      Boot and let us know what happens.

      cheers, Paul

      • #2591310

        Whew! Slow progress but I haven’t yet given up.

        I downloaded and installed Rufus on a Toshiba laptop that I have as a “spare” system. (Rufus is great. It’s what I’ve used to create the live Linux USBs that I test drive.) I then used the steps you provided to use Rufus to download and create a bootable Windows 10 USB drive.  When I went to test the Windows boot USB on the laptop I couldn’t get the laptop to see the drive as a bootable device. I initially assumed the issue was with the USB drive or the downloaded iso image and kept rerunning Rufus with different copies of the iso image and different USB sticks. After quite some time troubleshooting I eventually realized the issue was with the USB port: it was USB 3.0 and apparently on this laptop, there are issues. I moved the USB drive to one of the USB2.0 ports and it booted up.

        When I took the drive to the DELL laptop, it did boot up. The first screen asked for confirmation of system configuration settings, then the second screen presented the option of installing Windows or (in tiny font in the lower left of the screen) Repairing Windows. I still have data on the C: drive that I hadn’t backed up yet, so I’m not ready to do an install yet. The repair option brought up a blue screen with the repair/troubleshooting options and I tried the Repair option. Once again, the result was that repair was not possible but other advanced options were presented. It was too late to spend more time investigating whether the results would just be a repetition of previous attempts, but seeing that the Windows install drive booted up, I’m thinking I might be able to find a different recovery image that I can boot up.

        Still not sure why the Linux drives are freezing.

    • #2591312

      If you have a good backup program you can use it to make a bootable backup USB, then connect an external drive and backup (if possible).
      Once backed up you can reinstall Windows from scratch to test the drive.

      cheers, Paul

      p.s. Aomei Backupper free will do this.

    • #2591318

      I suspect it may be related to unsuccessful efforts to hibernate in Windows 10. I don’t think there’s a physical problem with the drive, though.

      Hibernation cannot be used on a dual-boot system.  The hibernate process flags the UEFI BIOS to bypass the normal boot process and instead open the hibernation file and read/load the previous system state.  The boot options in a dual boot where one OS is in hibernation get caught up in what amounts to a race condition, and neither OS can successfully boot.

      Here is some information on your predicament.  When I had my laptop setup with dual boot, I disabled hibernation in both OS partitions.  Hibernation can be used if each OS is installed on a different physical HDD by entering BIOS and changing boot options to the non-hibernating drive, but it (usually) won’t work when the two are on different partitions of the same HDD.

      Always create a fresh drive image before making system changes/Windows updates; you may need to start over!
      We were all once "Average Users". We all have our own reasons for doing the things that we do with our systems, we don't need anyone's approval, and we don't all have to do the same things.

      • #2591342

        Thanks, bbearen. I’ll check out the link to the information.

        I ‘m still thinking that the issue started with a hibernation session gone wrong, but I’m still unsure how to repair the situation. I stumbled across the hibernation flag issue some time back. I rarely attempt to hibernate, but once after having done so, then booting up in Linux (I think it was a version of Ubuntu) I discovered that the main partition on the hard drive would not mount. Some investigation led me to realize it was because a hibernation flag had been set (somewhere).  I believe this was back when I was working on a system with and MBR drive and no UEFI so there wasn’t that complication to deal with.  I was able to reboot to Windows, shut down without hibernating, and once again was able to mount the Windows partition.

        The DELL laptop has a 1TB GPT formatted Western Digital hard drive and I’ve been hoping that if the hibernation flag is a physical bit somewhere in the beginning of the drive, I might be able to use a Windows CLI program like dd to edit and clear it. I’ve copied and restored MBRs on non-UEFI systems, but haven’t had much experience with GPT drives.

        One suggestion that I’d seen was to simply delete the hiberfile.sys file. When I was able to access the Windows command prompt in the Advanced Recovery session, I examined the root directory of the Windows partition and discovered that there was no hiberfile.sys.  I suspect that the various attempts at recovery (inlcuding the attempt to reinstall but retain user files) deleted any hiberfile.sys, pagefile.sys and swapfile.sys files. Oh well.

        I still haven’t had any luck finding out about the System Restore Trace Trail error message I posted above. Failing a partition table repair sounds serious, but I still haven’t found info on the error code for more detail.

      • #2591515

        I have used hibernation in dual-boot setups without any issues. I think the key thing isto disable fast boot in UEFI, which I do on all PCs I set up for Linux, dual boot or not. If you do that, GRUB is able to select between hibernated OSes the same way it does for non-hibernated ones, without anything being stored in UEFI NVRAM.

        To test this, I woke my dual-boot PC, my Acer Swift Go 14 laptop (which was booted into Linux) from “sleep,” selected “hibernate” from the application (“Start”) menu, and it hibernated successfully.

        From the hibernated state, I pressed the power button to turn it on and boot. The GRUB menu appeared as usual.

        From GRUB, I selected Windows 11, and it booted successfully while Linux was still hibernated.

        I selected hibernate from the Windows 11 start menu, and it hibernated successfully. At that point, both OSes were hibernated.

        I again pressed power to turn on and boot, and GRUB appeared. I selected Linux, entered my SED (self encrypting drive) passphrase at the prompt, and it resumed from hibernation successfully, with all my Linux programs I had running present.

        I selected restart from the application menu, and it shut down Linux and rebooted. GRUB appeared again, and I selected Windows 11. It resumed from hibernate successfully.

        On this setup, I have two SSDs (NVMe), with the EFI partition, /boot partition for Linux, and the original factory installation of Windows on one SSD and Linux (/root, /home, /swap partitions) on the second (whole drive encrypted) SSD.

        As for the failure of Linux live USBs to boot…

        I have seen thumb drives set up as Linux live USBs that won’t boot on one UEFI PC but will boot on another (secure boot off on both). Whether it was a function of the drive itself (seems unlikely) or the way the drive was written by the ISO software (more likely), I do not know, but it was frustrating. I would try writing the ISOs on another program besides Rufus just to make sure. I now use Ventoy for all of my live session/ISO installer stuff, where I can just copy the ISO over to the drive and boot it as an ISO. One thumb drive can take the place of a bunch of them, with the Windows installer, several flavors of Linux, and various rescue and diagnostic ISOs all being available from a single USB (selected by a menu at boot time).

        I would try disabling secure boot and trying again if it is on.

        You might also try switching the setting for the SATA mode from AHCI to RAID (also known as Intel RST) or vice-versa to see what that does. Linux should work either way, but Windows will require it to be the same as it was when Windows was set up, so remember you changed it so you can put it back when/if needed.

        So, to recap, try fast boot off, secure boot off, and toggling the SATA mode between AHCI and RAID/iRST. I would do them one at a time so you can know which effect goes with which change.

        Dell XPS 13/9310, i5-1135G7/16GB, KDE Neon
        XPG Xenia 15, i7-9750H/32GB & GTX1660ti, KDE Neon
        Acer Swift Go 14, i5-1335U/16GB, KDE Neon (and Win 11)

        • #2591693

          Thanks, Ascaris, for the dual boot/hibernate info. I think your experience confirms the suspicion I have that the problem I’m encountering isn’t due to the hibernate issue “per se” but with a system configuration/file corruption problem. I typically disable the “secure boot” and “fast boot” options, so that isn’t an issue in this case. The BIOS has been set to RAID (although I have only the one Western Digital drive, so I assume it’s RAID 0) and I don’t think that’s the issue.
          As for the USB live Linux USB drives, I had no problem booting from them on this laptop when it was also successfully booting Windows. It only became an issue when the laptop began freezing during the Windows bootup. I suspect that if I were to puzzle out where the Linux bootups hang, that might provide some insight into the problem, but so far I haven’t tried to get that info.
          I’ve seen some info on Ventoy, but hadn’t given it much attention. I do like the idea of being able to select from a menu of boot up options, so I will be checking that out!

    • #2591959

      Finally tracked down a bit more info on the error code in the System Repair Trace Trail log file (SrtTrail.txt): 0x490  Partition Table repair failure.  One suggestion was to use the bootrec.exe utility with the /FixMbr and the /FixBoot options in the Recovery command prompt to repair the boot partition. I discovered that the /FixMbr option completed successfully but the /FixBoot option resulted in “Access denied” error message. Some additional research on that situation led to a website with a recommendation to essentially reformat the ESP partition by using diskpart to assign it a drive letter, then using bcdboot to rebuild it.

      I’m still working on getting the few files I know are still on the C: drive that were created after my last backup, but I think I’ve figured out a way with xcopy to grab them without doing an entire backup, and if that’s successful, I’ll give the reformat of the ESP partition a try.

    • #2592486

      That error sounds more like a hard drive issue – the partition table describes the basic layout of the disk.

      Do you have a hard disk diags utility you can use?
      GSmartControl on https://www.ultimatebootcd.com/

      cheers, Paul

      • #2594200

        Thanks for the suggestion Paul. I checked out the Ultimate Boot CD web site and discovered that the bootable iso is MBR only, no UEFI support. Unfortunately the BIOS for the DELL Inspiron model I have doesn’t provide a CSM option so that utility isn’t available to me.

        I’ve tried a number of other (mostly Linux) utility ISOs, including the Hiren’s Boot CD (HBCD_PE_x64.iso) and they all freeze during bootup.

        I have discovered a couple of ISO images that don’t freeze and they are both Fedora based: Korora 20 and a Fedora 20 (with kernel 3.11.10 and MATE 1.6.1) so I was able to get a few screenshots of the harddrive stats. I’ll see if I can upload in a little bit. Those ISOs should provide a number of utilities, but I’m still trying to figure out which would be the most helpful.

        (BTW I tried to reply to your post the day after, but I pasted in something that didn’t agree with the upload requirements and when I got an error message I wasn’t able to find a way to re-edit the response and it apparently disappeared into the void. I haven’t been able to spend as much time on this issue as I’d like, but I still haven’t given up. Every time I boot up to the command prompt and see the C:\ drive or boot into the Fedora OS, I just know there must be some way to modify something on that drive to once again enable booting.)

    • #2594210

      I’m going to try and attach some screenshots of the problem laptop that I took with my cell phone. There’s some diskpart info for the disk, the partitions and the volumes; also some gparted, gnome-disk-utility and SMART data and self-test screenshots.

      diskpart info from the Advanced Recovery command prompt
      gparted; gnome disk; SMART data (p.1)
      gparted; gnome disk; SMART data (p.2)

    • #2594215

      A few more unsuccessful attempts:

      I mentioned in my 10/7 post that the bootrec /FixMBR option completed successfully but the /FixBoot got an “Access denied” response. One suggestion for resolving that issue was to assign a drive letter to the partition (in my case the 750MB Partition 1), reformat it then use bcdboot to recreate the boot environment. I tried that and the system still freezes on bootup. One other suggestion was to use diskpart to delete the ESP partition, create a new one, then use bcdboot to create the boot environment. That also did not work.

      I’m still looking for other suggestions and haven’t given up!

    • #2594219

      Your pics show the disk is formatted as expected, but it is only using half the space. Has is only ever had 400GB on C?

      Given you can boot to a Windows installation, but then get disk errors, I would assume the disk is unwell and try a replacement.

      Have you managed to backup the disk?

      cheers, Paul

      • #2594347

        Hi Paul. I shrank the sda3 partition some time ago and created the unallocated portion between sda3 and sda4 in anticipation of installing some version of Linux on the hard drive. It was never a problem (as far as booting is concerned). I’m still uncertain how it might affect a reinstall, but I’m not there yet.

        Given that I’m able to boot into Korora 20 (a Fedora spin)  I still don’t think it’s a hard drive hardware issue.  Also, I don’t think I mentioned yet, from the command prompt I ran “chkdsk /r” on both the C:\ drive and the ESP partition (after assigning it a drive letter; “N:\). No problems reported.


        • #2594520

          Disk errors = disk / subsystem problem.
          The only way to test is a full backup and then a complete wipe and reinstall. If it still fails it’s a hardware problem.

          cheers, Paul

    • #2595571


      Finally ran the extended BIOS self-tests and the results for the hard drive (after some four hours) PASSED. I still think the freezing on bootup is some kind of configuration issue and not a hardware issue. I’m reluctant to attempt a reinstall if the configuration issue is going to cause the reinstall to fail as well. And by configuration, I don’t think it’s OS specific since the Linux bootups (except for Fedora/Korora 20) also freeze.

      I’m still thinking partition or some disk (MBR? although this is a UEFI boot only BIOS) flag. The Korora 20 distro includes “dd” so if I knew which bits to edit I should be able to modify them. I just don’t have a clue as to where to look.

    • #2595607

      Configuration issues don’t cause intermittent hardware failures, hardware does.

      Backup, install from scratch.

      cheers, Paul

      • #2595872

        Ah, but it’s not intermittent. It’s consistent and OS dependent. The Korora (Fedora spin) OS consistently boots up (and shows the hard drive as /dev/sda) and the Windows 10 PE installation drive boots up to the Advanced Recovery environment where I can use diskpart to view and edit the partitions and volumes. (I think I mentioned in one of the earlier comments that I even deleted the ESP partition, recreated it, formatted it and used bcdboot to create new version; still freezes).  Most other OS’s, including a number of system utilities that I’ve tried in the hopes of cloning the drive all freeze during bootup. Hiren’s Boot CD PE x64 freezes after displaying its splash screen with an “Initializing …” message; Linux OS’s, both SysVinit and systemd, consistently freeze during their bootups.

        And by configuration, I’m not thinking of a system file somewhere. I’m thinking more like data on the drive in a configuration area like the MBR or ???

        Thankfully I just recently realized, Paul, that I hadn’t yet tried the Aomei Backupper that you suggested earlier. My first glance showed that it was a Windows installer and not an ISO or bootable image, so I didn’t look closely. I’ve since discovered that once installed on my backup laptop, there’s a Tools option to create a bootable image with either a Linux or a Windows10 PE environment. I created a bootable Windows10 PE USB drive and discovered that the laptop successfully boots with that image. (Still not sure why Hiren’s bootable PE image freezes.) Since the bootable image includes the Aomei backupper utilities, I’m using that to make a backup image of the DELL laptop’s WD hard drive. Then I’ll get more aggressive with the more destructive options.

        Thanks again for the Aomei link.

        1 user thanked author for this post.
    Viewing 10 reply threads
    Reply To: Hard drive boot up problem in Windows AND Linux

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: