• Have you seen this? Win10 1803 error: “C:…systemprofileDesktop is not available” and an empty desktop

    Home » Forums » Newsletter and Homepage topics » Have you seen this? Win10 1803 error: “C:…systemprofileDesktop is not available” and an empty desktop


    I’m seeing more and more reports of people who are upgrading to Win10 1803 and end up with an error message that dates back to 2009 or earlier: The me
    [See the full post at: Have you seen this? Win10 1803 error: “C:\…\systemprofile\Desktop is not available” and an empty desktop]

    2 users thanked author for this post.
    Viewing 18 reply threads
    • #193534

      Looking at the bright side, one would no longer have to deal with that ugly, flat, Aero Glassless UI…  😉



      2 users thanked author for this post.
    • #193538

      Last time I saw this error, the following was the case:

      1. In C:\Users\%username%\, there was two Desktop folders showing up. One was blank, and the other had local desktop data. One of those folders, if not the entire profile folder for that user, may have had incorrect permissions compared to a stock machine.


      2. In HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\ it is pointing to the wrong location for the desktop. In a server environment with redirected desktops, this may mean that it’s pointing at a broken UNC path or it’s pointing locally to a folder that doesn’t exist or has bad permissions.

      I’ve seen this happen on a few screwy OEM installs for an entire batch of desktops, and a few other one-off scenarios.

      2 users thanked author for this post.
    • #193540

      Same here on a home desktop last friday.  Had to revert back to 1709 via Shift-Restart command to the repair boot screen.

      ALSO – along with this “desktop not available” is a dialog about a “Hard Error”.

      1 user thanked author for this post.
    • #193546

      Seen this on sporadic clean installs of Win10 1709, generally at the first reboot after you reach the Desktop either after installing updates, changing Network ID’s, Joining a Domain, Workgroup, etc.
      One “Hard reboot” and it never occurs again” Sounds, possibly, like another ongoing issue carried over from Win10 1709. Doesent seem any “Rhyme or reason” as its happened to the best of my recollection on different brands of Machine all X64’s. Cant ever remember ever seeing that one before on any other Win OS or Ver’s. of Win10 before.

      1 user thanked author for this post.
    • #193545


      I can’t recall if it was on 1803 but I faced a similar issue 1 month ago on someone else’s computer.

      I noticed that instead of autologging the user account the computer was opening the session under the system account context hence the error message.

      I then created another admin account, created the folder C:\Windows\system32\config\systemprofile\Desktop (don’t know if this one helps), rebooted the computer then was able to open a session with this newly created account. I ran a checkdisk, rebooted the computer then was able to open a session with the original user account with its own destop back.

      Hope this could help.

      1 user thanked author for this post.
      • #193839

        Oh, that’s all you had to do?

        I wonder why they didn’t document that as the proper procedure?

        /SARC OFF

        Reminds me of a Dilbert cartoon I saw a long time ago — the programmer set up a program to require CTRL-ALT-F4-DEL to do something in the program. He was really proud of himself for that “genius” key combination. I am often reminded of that cartoon when I read about some of the things that Microsoft does that Einstein himself would have a hard time figuring out.

        Group "L" (Linux Mint)
        with Windows 8.1 running in a VM
    • #193552

      Upgrading to Windows 10 is an oxymoron.

    • #193558

      C: has been changed to X:

      1 user thanked author for this post.
    • #193560

      Strangely, I had this very error message on one of my Windows 7 home desktops just 3 or 4 weeks or so ago. I’ve never had it before or since, and it happened on powering up the PC as usual after leaving it off overnight. A simple restart failed to fix it, but powering off, waiting a moment or two, and powering it back on again did fix it.

      Now, I realise that this article is about a particular version of Windows 10, but the coincidental timing of my experience makes me wonder whether there is something Microsoft introduced more generally in perhaps the April updating across the different OS versions?

      EDIT: Thinking about it, it happened at the very beginning of April, well before the April updates were installed, and before the MSRT was installed as the only March update I ran.

      2 users thanked author for this post.
      • #193610

        I encountered the same boot-time message (for the first ever time) on one of my machines, probably Win7 Pro (group W but with IE11 updates applied), about 1-2 months ago.  I had not installed any updates just prior to shutting down and restarting (other than possibly MSE definitions updates).  After a solid power off (at the wall outlet) and restart, everything was ok;  no other repair was required.  Ho hum.


        1 user thanked author for this post.
    • #193564

      its only shows how c***** is windows 10. Ugly tool for spying users. Windows 7 is fast, nice and stable.

      According to unaccesable folders:

      Only in english versions folders like Desktop or download etc is really desktop or download. Folders in other languages like polish showed names are different than real name on disk.

      Users can change it like in windows xp (there m$ don’t do that trick)


      who test it? Do M$ dosn’t test patches before publicate it? it’s sick!
      using windows 10  without acronis true image and making backup before patching is very risky.

      I have only one laptop (dell) with windows 10 and I have always some “adventures”
      others (lenovo) are windows 7 without problems


    • #193565

      This also happened to me (Win 8.1 Group A).  It started just after I installed the March updates, and booted to a black desktop, with task bar but non functioning mouse/touchpad. I logged off via CTL+ALT+DEL, using tab key to reach logoff option, and then reverted to my system backup.  There are a few more details in the Win 7 Profiles thread.

      I haven’t had the black boot screen since then, but following applying March and April updates again, periodically, I lose the desktop icon arrangement at logon -everything is scrunched to left side of desktop.


      2 users thanked author for this post.
      • #193804

        This has just happened again!  Booted to a black screen with most icons missing, and no mouse/touch pad.  Went through the CTL+ALT+DEL routine again to logoff.  Rebooted, and system started to generate a default desktop again.  Logged off again.  Rebooted and found my userid locked.  Rebooted and now back at normal desktop, but with all icons arranged randomly on LHS of screen.

        1 user thanked author for this post.
    • #193595

      & thank Susan (the ‘Patch Lady’) again for this, please.

      Bought a refurbished Windows 10 64-bit, currently updated to 22H2. Have broke the AC adapter cord going to the 8.1 machine, but before that, coaxed it into charging. Need to buy new adapter if wish to continue using it.
      Wild Bill Rides Again...

      1 user thanked author for this post.
    • #193639

      Seems like one of a few bad things are happening…

      explorer.exe is loading under the highly privileged SYSTEM account (who’s env variable for the desktop is as pictured).

      Or some program running as system (pre-login) is throwing a fit because it can’t access it’s desktop folder (that is shouldn’t even need)

      Or maybe the current user’s env variable is messed up and pointing to the wrong place.

      If you can ctrl+shift+esc the Task Manager open it’s the third option (and you can probably fix your variables via regedit)

      • #193653

        Anonymous: In which version of Windows and after which update have you encountered this kind of problem?


        Ex-Windows user (Win. 98, XP, 7); since mid-2017 using also macOS. Presently on Monterey 12.15 & sometimes running also Linux (Mint).

        MacBook Pro circa mid-2015, 15" display, with 16GB 1600 GHz DDR3 RAM, 1 TB SSD, a Haswell architecture Intel CPU with 4 Cores and 8 Threads model i7-4870HQ @ 2.50GHz.
        Intel Iris Pro GPU with Built-in Bus, VRAM 1.5 GB, Display 2880 x 1800 Retina, 24-Bit color.
        macOS Monterey; browsers: Waterfox "Current", Vivaldi and (now and then) Chrome; security apps. Intego AV

        • #193919

          I haven’t strictly seen this scenario, just the base parts of it. (avoiding windows 10 most of the time helps not to encounter it..)

          I have seen explorer.exe launched as SYSTEM. In SYSTEM’s reg key for env variables it’s profile base dir was “C:\Windows\system32\config\systemprofile\”. explorer.exe can throw an error if some of it’s folders are missing (SYSTEM shouldn’t even need a desktop, because no shell should run as SYSTEM). (not sure how 8.0-10 would react)

          I’ve had to clear the IE temp folder for SYSTEM profile (10GB+ where malware was browsing the internet with IE). (imagine an ad clicker viewing hundreds of ads per minute in a highly privileged account with IE…) That example was XP.

          #1 So if explorer.exe is launched as SYSTEM but can’t access the desktop folder (maybe doesn’t exist for SYSTEM profile in 10?) it might throw an error rather than starting properly. But what could launch explorer.exe as SYSTEM (other than a virus or something)?

          #2 (“pre-login” on my previous post) is something new in windows 10, should just never happen.

          #3 “environmental variable is messed up” I’ve seen them missing before (doesn’t match this case), set wrong (wrong kind of reg key REG_SZ vs REG_EXPAND_SZ, hard coded wrong value, etc..) but in the case I am comparing to this one something overwrote something in “User Shell Folders” (registry, normal user) with something from SYSTEM’s registry.

          I’ve seen #1 happen, but it shouldn’t happen normally (could explain the error if it DID happen though).

          Really, #2 shouldn’t happen, but windows 10 adds (then removes or mutates) so many basic windows concepts it’s hard to tell what to expect (and we never will if we keep adding 2 new versions of windows 10 per year)

          As for #3 I’ve seen that happen (it was a few times, OS could have been XP, Vista, and/or 7). It’s an easy fix too, you just need to fix the (registry) “Shell Folders” and “User Shell Folders” for you user. If you can press ctrl+shift+esc or ctrl+alt+del and get the ctrl+alt+del screen you must already be in a user profile.

          One bizarre thing I’ve seen windows 10 do is the OOBE (out of box experience, the thing that runs on first boot to create your account) used to run under SYSTEM (no big problem there, the PC doesn’t even have any users yet). Now rather than running in system to create your first account it AUTO-creates a new (incrementing the SID counter) account. You may have heard of it:
          defaultuser0 (or defaultuser[insertNumberHere], defaultuser1, defaultuser2)

          This new account is created (and sometimes deleted after) the first time you create an account (the OOBE runs as this user). AND it is created every time you click “Forgot password” on the login screen (name conflict? increase the number and make another new “OOBE” account).

          WHY do we need to AUTO-generate a new account (before any real accounts are created) TO create the very first windows account? Maybe this whole problem is an example something going horribly wrong under “defaultuser0” and matches up with my example #2 (pre-login). If things are going that badly I would think the whole windows install is trashed. (where #3 is an easy fix)

    • #193694

      I do not have direct experience here. I have read in the past advice to setup a new installation from a local account only, in order to have the best shot at maintaining local control.

      Is this a symptom of Microsoft pushing back on that common piece of advice?

      When all installations in front of you are set the same, sometimes you will miss indication that gives the answer. And my idle thought may be incorrect as well.

    • #193693

      Good day

      I have this problem after an automatic update to Windows 10 1803 today 22nd May

      Now I cannot get into my laptop at all.

      As suggested elsewhere on I have tried the “control userpasswords2” and added a new user. However there is no sign page when starting up. So I cannot get anywhere with that.

      Using Toshiba Satellite L75D A7283
      AMD A4 quad core

      Any ideas would be much appreciated
      Thank you


      • #193697

        Your best bet is either to restore an image backup (if you made one) or boot from a Rescue Disk and roll back to your previous version of Windows.

        There are two current problems. One is a vanishing desktop. The other, if you have a Toshiba SSD, if may not be compatible with Win10 1803. See this topic about the SSD.

        1 user thanked author for this post.
        • #193701

          Thank you. Very helpful and speedy response

          I may have recovery  disk (possibly back to Win 8) and also image back up but again quite old on an external hard disk.

          Question: as there is no desk top, how do I access and use hard disk?

          Thank you


          • #193704

            You need to boot from the Recovery disk you made for Win10 and access the Recovery console. There should be a Recovery option to roll back to the previous version of Win10 (I am assuming you were running 1709 or 1703). There may also be an F-key or key combination that that you can press on startup (right after you press the power-on, before Windows loads) that will give you access to the Recovery console. I am not familiar with Toshiba, but the key or combination of keys should be Google-able and/or available on the Toshiba support site.

          • #193707
          • #193708

            As you are posting from a useable installation, and may not have current recovery images, you may be interested in reviewing this topic started by MrJimPhelps, for options in acquiring the media you need.

            This assumes you have adequate, separate, backup for important data files. These can be loaded back in after up and running again.

            1 user thanked author for this post.
          • #193902

            Does CTRL-ALT-Del let you launch Task Manger?  From there you can File->Run New Task and type “explorer” (or any other program).

            1 user thanked author for this post.
    • #193710

      Yes, I am seeing this on many machines. Only fixable by an in-place upgrade. Thanks a lot, M$. Hitting new low. :-X

    • #194215

      Here’s some info about the problem and how to fix it:

      Close the error message and open Task Manager by hitting Ctrl-Shift-Esc. Kill the explorer.exe process and then run it again as Administrator, the desktop will load normally. Then insert your Windows 10 media and run setup.exe to perform an in-place upgrade.

      This is the easiest way I’ve found to fix the problem.

    • #194838

      For information: I’ve seen this only on windows 10 1803 updates on PC running avast (Free or paid plans).
      As stated: Inplace upgrade corrects this, but you will have to reinstall all software and be careful to keep data in place

      1 user thanked author for this post.
    • #195354

      Updated to 1803 today.

      On restart ended up with black screen, recycle bin and a few items on the taskbar; clicking ‘Start’ does nothing.

      Tried various suggestions, eventually got the “Unknown hard error”.

      Tried Restore – no Restore found.

      Tried Rollback to previous version – could not be done.

      Eventually restored System Image from my backup drive so now back to 1709!

      Saw one remark – “We are aware of this problem and our software engineers are working on it, please wait for an update”!!!

    • #198803

      had the same problem on 3 machines followed all the above to no avail but what did work for me was to reapply the 1803 update again. no more problem

    Viewing 18 reply threads
    Reply To: Have you seen this? Win10 1803 error: “C:…systemprofileDesktop is not available” and an empty desktop

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: