• Help for trouble with peer networking and ransomware protection

    Home » Forums » Newsletter and Homepage topics » Help for trouble with peer networking and ransomware protection

    Author
    Topic
    #2433032

    LANGALIST By Fred Langa In this week’s first reader-submitted question, a subscriber’s peer (serverless) network simply will not allow his three PCs t
    [See the full post at: Help for trouble with peer networking and ransomware protection]

    6 users thanked author for this post.
    Viewing 5 reply threads
    Author
    Replies
    • #2433054

      I have a persistent problem with Windows 10 becoming invisible on my network, and less frequently, being unable to see others.

      I find that the following almost invariably makes everything visible again:

      C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe Restart-Service “FDResPub”

      That includes the PC it was run on becoming visible to others, and others becoming visible to that PC. It’s as though Windows 10 cannot manage to maintain Function Discovery by itself and needs a hefty boot up the backside to kick it back into action.

      I’d suggest anyone with Windows 10 local network problems try this, especially before any more drastic action.

      4 users thanked author for this post.
    • #2433120

      Hi Fred:

      Regarding Fred Ames’ problem using Windows’ ransomware protection (Controlled Folder Access), note that I run Microsoft Defender (my primary AV) and Malwarebytes Premium together in real-time protection mode. I have the Malwarebytes settings at Security | Windows Security Center | Always Register Malwarebytes in the Windows Security Center DISABLED so that Microsoft Defender is always recognized as my primary antivirus (see the Malwarebytes support article Security Settings in Malwarebytes for Windows) and I am able to access and configure Win 10’s Controlled Folder Access settings in Settings | Update & Security | Windows Security | Virus & Threat Protection | Ransomware Protection | Manage Ransomware Protection.

      MB-Premium-v4_5_6-Security-Settings-Register-MB-in-Windows-Security-Center-Disabled-21-Mar-2022

      Until a few years ago I used Norton as my antivirus and can confirm that Norton 360 has a feature called Data Protector that is almost identical to Windows’ Controlled Folder Access. Windows’ Controlled Folder Access is normally disabled when Norton is installed (i.e., even if Data Protector is turned off in Norton) because Microsoft Defender needs to be running in real-time to access the Win 10 Controlled Folder Access settings. However, if Fred Ames prefers using Window’s Controlled Folder Access over Norton’s Data Protector, user SoulAsylum posted a workaround <here> in the Norton forum where enabling Microsoft Defender’s Limited Periodic Scanning at Settings | Update & Security | Windows Security | Virus & Threat Protection | Microsoft Defender Antivirus options | Periodic Scanning | ON (i.e., to allow Microsoft Defender to perform a scheduled background scan even when a third-party antivirus like Norton, McAfee, etc. is installed) should allow Norton users to access their Windows Controlled Folder Access settings again.

      Note that I haven’t tested SoulAsylum’s workaround myself (I stopped using Norton shortly after parent company Symantec was sold to Broadcom in 2019 and NortonLifeLock became a separate company)  so I don’t know if this workaround to access Windows’ ransomware  protection (Controlled Folder Access) settings could create any conflicts or unexpected glitches for Norton users.  If Fred Ames wants to keep Norton as their primary antivirus I’d personally suggest that they disable their SUPERAntiSpyware real-time protection (which could cause conflicts, especially if Malwarebytes Premium is already running in the background) and then try Norton’s built-in Data Protector feature first and see if it suits his needs.
      ———–
      Dell Inspiron 15 5584 * 64-bit Win 10 Pro v21H2 build 19044.1586 * Firefox v98.0.1 * Microsoft Defender v4.18.2202.4-1.1.19000.8 * Malwarebytes Premium v4.5.6.180-1.0.1634

      • This reply was modified 1 year, 6 months ago by lmacri.
      • This reply was modified 1 year, 6 months ago by lmacri. Reason: Added comment RE: SUPERAntiSpyware
      2 users thanked author for this post.
    • #2433349

      Fred,

      THANK YOU, THANK YOU, THANK YOU! BTW did I say THANK YOU!

      I’ve been struggling for literally years to get File Explorer to show all the computers on my local network. You’ll find several posts right here as well as other sites. The Reset Network option fixed everything!
      FileExplorerNetwork
      Thanks again!

      RG

      May the Forces of good computing be with you!

      RG

      PowerShell & VBA Rule!
      Computer Specs

      1 user thanked author for this post.
      • #2433502

        We FINALLY got XP, Win7, Win8 and Win10 to talk to each other, with different anti-virus software running on those different Operating Systems.

        But, for the life of me, I would never in a million years be able to repeat the various paths we took, and many dead-ends we encountered, until we finally hit on a solution that “sorta” works.

        (I KNOW XP is obsolete:  but, I’m running a long-term experiment to see how long a quality motherboard will function correctly, with proper care and maintenance.  AND, XP works fine as a dedicated backup storage server, running XCOPY over a LAN.)

         

        One story I did read on the Internet, which may explain some of these truly NASTY Network Drive problems, is that Microsoft decided to disable HOMEGROUP as a way to motivate Windows users to migrate to the Microsoft cloud (OneDrive?)

        But, the programmers who made that change were woefully unaware of the enormous negative consequences that propagated from that one change.

        Add to those NASTY problems the MS “policy” of FORCING Win10 OS updates on SOHO users.

        By comparison, with XP and Win7, the “Map Network Drive” feature in the OS just WORKED!

        • #2571275

          Similar problem, but no resolution. Computer A is Windows 11 Version 22H2 (0S Build 22621.1702). Computer B is Windows 11 Version 22H2 (0S Build 22621.1848.

          On Computer A, I map one of B’s drive as L:. File Explorer shows the mapped drive. Command prompt works (e.g. dir L:) but Administrative command prompt doesn’t (The system cannot find the path specified.)

          From Computer B, everything works properly.

          This problem also breaks a utility I use all the time on Computer A (Search Everything).

          Computer A is a fairly new CyberpowerPC with an AMD Ryzen 7 and onboard NIC.

          Ideas?

           

    • #2433493

      Fred,

      Your expert analysis is MOST appreciated.  Many thanks for sharing your many secrets with us.

      Without you, these problems can and will persist indefinitely with some SOHO LANs.

      (Here’s a pledge of $100 for a U.S. Patent application to CLONE-FRED-ASAP:  no need to get fancy with this patent — just his MASSIVE BRAIN is all we need to “GO VIRAL” everywhere, Mars too.  Tell Elon.)

       

      This next one is for deposit in your BETCHA-HAVEN’T-SEEN-THIS-ONE-YET Department:

      FYI:  We recently purchased 2 x refurbished HP Z240 Tower workstations from 2 different on-line vendors.

      These workstations are gifts for a middle school student and his father, because their new house was broken into before they moved in.

      Windows 10 Pro was pre-installed on both, and both initial setups completed with no problems.  I believe both vendors are Microsoft Authorized Refurbishers (“MAR”).

      That’s when a LAN problem emerged:

      We were able to Map Network Drive, but in Command Prompt the Network Drive letter was NOT accessible when Command Prompt was “run as Administrator”. 

      However, that same Network Drive letter WAS accessible when Command Prompt was run normally (NOT as Administrator).

      I still do lots of work in Command Prompt e.g. all CHKDSK options are available.

       

      Now for the FUN part:  we installed a Rosewill brand 2.5GbE card in the x1 PCIe 3.0 expansion slot, disabled the integrated Intel 1GbE NIC, moved the CAT-6 Ethernet cable to the Rosewill 2.5GbE card, and enabled the Rosewill card in Windows 10.

      Now the Network Drive letter is accessible in both modes of Command Prompt (Administrator and NOT Administrator).

       

    • #2433793

      Will,

      Well, it looks like I spoke too soon. When I booted up my machines this morning I was back to File Explorer (FE) incomplete enumeration of the network. So I decided to run a test. I captured what FE was showing for each machine. Next I did a reset on each machine again (Don’t you hate that 5 minute wait!). Well that set everything right again, see table below. So the question is is this going to happen every time I shut things down. I’ll report back.

      CompTable

      May the Forces of good computing be with you!

      RG

      PowerShell & VBA Rule!
      Computer Specs

      1 user thanked author for this post.
    • #2433934

      Ok Y’all,

      The verdict is in the settings implemented by the Network Reset link do not survive a ReBoot! I confirmed this twice. Each time I reset all the machines (which does involve re-booting them) File Explorer enumerates the network correctly. However, as soon as I reboot the machines File Explorer can no longer see the machines on the Network.

      However, if I type the the network link in the address bar it will connect to the machine, e.g. \DellXPS8700

      AddressBarResponse

      Looks like it’s back to the drawing board unless someone knows, or knows how to determine, which settings are getting changed? And how to prevent that from happening!

      May the Forces of good computing be with you!

      RG

      PowerShell & VBA Rule!
      Computer Specs

      1 user thanked author for this post.
    Viewing 5 reply threads
    Reply To: Help for trouble with peer networking and ransomware protection

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: