News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • hidden dir after robocopy

    Home Forums AskWoody support Windows Windows 10 Questions: Win10 hidden dir after robocopy

    Tagged: 

    • This topic has 4 replies, 2 voices, and was last updated 1 month ago.
    Viewing 3 reply threads
    • Author
      Posts
      • #2363211
        wavy
        AskWoody Plus

        Ok am I missing something or is this strange. (both computers W10 20H2
        I Have a WD MyBook external drive with its original exFAt formatting. I used it to back up my old computer’s H: drive thusly:
        robocopy H:\ D:\From-H /v /e /xo /log:D:\From-H\RC-Log
        (Thanks to whoever for the robocopy commands here)

        Looked ok, 600 gigs or so. Today I connected the MyBook to my newer computer and was shocked to find no copy of my H drive showing in explorer(set to show Hidden). I reconnected to my old computer and sure enough the From-h directory showed. Examining showed the directory showed read only under properties and had a greyed out hidden attribute. I tried setting the folder to Not ReadOnly by unchecking the box I got a progress box for a few minutes but upon connecting to the new computer no luck. I could find no way to change to greyed out hidden attribute in explorer. In a command window the dir shows with the show hidden flag in the new computer. I seem to remember there was a way to change that from the command line but couldn’t remember it. I put it back in my old computer and used ZTree to change it and all seems fine.

        My questions are why were these attributes set as they were? I see no flag that tells robocopy to do this.
        Also why would explorer not let me change it?
        If I had not had ZTree for windows how could I have managed this?

        🍻

        Just because you don't know where you are going doesn't mean any road will get you there.
      • #2363333
        wavy
        AskWoody Plus

        I see now from another post that I missed that “attrib -r -s *.*” would have been the command I now remember 😁

        And that (as I now remember) Folders are always ‘read only’. Why MS would choose to add

        only applies to files in folder

        is probably beyond my ken.

        That still leaves the question that started this “Why were the folders on the WD Mybook set to hidden”?
        🤔

        🍻

        Just because you don't know where you are going doesn't mean any road will get you there.
      • #2363601
        Paul T
        AskWoody MVP

        Robocopy will copy the file / folder attributes if possible.
        To stop this add the /COPY flag.
        e.g. /COPY:DT

        cheers, Paul

        1 user thanked author for this post.
        • #2364308
          wavy
          AskWoody Plus

          But the folder attributes were not what i ended up with. Something else is going on

          🍻

          Just because you don't know where you are going doesn't mean any road will get you there.
      • #2364969
        Paul T
        AskWoody MVP

        I’ve used Robocopy a lot and never had it hide folders.

        cheers, Paul

        1 user thanked author for this post.
    Viewing 3 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, no politics or religion.

    Reply To: hidden dir after robocopy

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.