• How to change “User Account Control:Run as administrator”

    Home » Forums » AskWoody support » Windows » Windows 10 » Questions: Win10 » How to change “User Account Control:Run as administrator”


    I made an error in elevating one program to run at what I thought was the highest priority of any other program running at the same time. In effect I made it run only in the administrator mode, which I do not want.  I have tried

    (1) Right-click on the shortcut, and click Properties.

    Click Advanced, and uncheck “Run as Administrator” (but that box was already unchecked)

    (2) Check the properties of the executable itself.

    R-click > Properties > Compatibility > Uncheck “Run this program as administrator”.

    (if I am seeing the right property, that too is unchecked)

    (3) The program still elevates… maybe “the requestedExecutionLevel parameter set to “highestavailable” or “requireAdministrator” set in the manifest, which is usually embedded inside the executable.

    Can someone please advise how to change the Execution level, if that indeed is my problem?

    Viewing 1 reply thread
    • #2562895

      Open regedit and take a look at the entries, if any, in the following location:

      HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

      If there’s an entry for that particular program (i.e. C:\path to executable\??.exe) with a value of ~RUNASADMIN, it’ll cause it to always run as Admin. To stop that from happening, simply delete that entry.

      FYI, that section of the registry is where the properties/compatibility settings for programs are saved, if you’ve set any, and clearing the flags for that particular exe “should” have removed it from this section. But maybe it either didn’t properly get cleared or something keeps adding it back in?

      Just FYI, that location on my own system has 10 entries but only 7 are set to ~RUNASADMIN and they’re for programs I specifically set to “Run as Administrator” using the properties/compatibility options.

      • #2562898

        Thanks for the help. I did as you suggested but sadly, there is no entry for the program in question (Millennia Legacy 9.0 Family Tree).  I may delete the program, reinstall it  and see if that fixes my problem.

    • #2562947

      I ran the program as incompatible with latest version Win 10 but compatible with Win 8 and that seems to have fixed the issue (can now open the file as a user and not an administrator.)  Will continue to see if this is the true fix or not.

    Viewing 1 reply thread
    Reply To: How to change “User Account Control:Run as administrator”

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: