News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • How to STOP Windows Updates

    Home Forums AskWoody support Windows Windows 10 Questions: Win10 How to STOP Windows Updates

    Viewing 25 reply threads
    • Author
      Posts
      • #2370568
        kstephens43
        AskWoody Plus

        My Windows 10 refuses to update correctly.  Over the past two weeks, I have attempted 14 updates, but none have been successful.  I have tried everything I can think of, including trying to do the update through an ISO file.  Even that failed.

        Now Microsoft says that I have used up all my update delays, and every time I start the machine, Windows tries to update yet again.  I cannot do much, because when one of the updates is being attempted, resources are hogged by that process.

        Over the past two weeks, I have already spent over 50 hours of my time dealing with this, and Paul T., Susan, and others have tried to help.  Is there a way to turn off the updates, temporarily, so that I can continue to try to solve this wretched problem.

      • #2370569
        PKCano
        Manager

        Please, when you create a Topic, mention your Edition (Home or Pro) and the version/Build (nnnnn.xxx) of Windows, along with some information on you computer. OR link it to your other Topics so those that reply know what has been done previously.

        Here’s a way to stop Windows Update. How to Cheat Pause. You will need to read through the comments. But you can actually extend pause past the 35 days (5 x 7-days).

        • #2370639
          WStaiwankima
          AskWoody Plus

          I have the opposite problem today. Last week, Tom’s guide said Windows was being attacked so I checked update and security in settings, on my ASUS Windows Pro 10 computer, It started updating without first telling me which version they were updating. I panicked so I googled and paused the update. After this, I saw your article on getting 20H2 and tried to update my computer from 1909 to your recommended 20H2. It installed up to 49% and then stopped. I spent 4 hours with Microsoft support . They couldn’t figure out what happened. Finally the tech advisor said it was on pause and for me to wait 7 days and try again. By the way, I don’t live in the States so some of the tech people I get are not tops. A few years ago, one of them deleted my sound system from my computer.

          • #2370739
            Paul T
            AskWoody MVP

            Getting good support is not about what country you are in, it’s whether you are lucky today.

            If none of the suggestions here works for you, open a new thread and we will try to walk you through the update.

            cheers, Paul

      • #2370598
        Susan Bradley
        Manager

        Topic: Windows Update 20H2 Refuses to Install @ AskWoody – What Dell do you have?

        Type in the search box, type in services,  scroll down for Windows update and stop the services and set it to disabled.

        Susan Bradley Patch Lady

        1 user thanked author for this post.
      • #2370657
        doriel
        AskWoody Lounger

        The WU service starts again automatically in like 10 or 20 seconds again, doesnt it?

        wouldnt be more elegant to use TRV (Target Release Version) and set it to version, that @kstephens43 has? I did not went through her other topics, so I apologize if I bring something you already discussed here.
        But setting TRV to actual version should stop updates for a while.

        Bottom line is, that maybe you should think about upgrading your PC, or buying a new one, if updates “paralyzes” your PC.

        Dell Latitude E6530, Intel Core i5 @ 2.6 GHz, 4GB RAM, W10 20H2 Enterprise

        HAL3000, AMD Athlon 200GE @ 3,4 GHz, 8GB RAM, Fedora 29

        • This reply was modified 5 days, 21 hours ago by doriel. Reason: Link
        1 user thanked author for this post.
        • #2370664
          doriel
          AskWoody Lounger

          OH.. I forgot.. this works only on PRO and Entrprise versions of Windows 10.

          Dell Latitude E6530, Intel Core i5 @ 2.6 GHz, 4GB RAM, W10 20H2 Enterprise

          HAL3000, AMD Athlon 200GE @ 3,4 GHz, 8GB RAM, Fedora 29

          • #2370673
            b
            AskWoody MVP

            But setting TRV to actual version should stop updates for a while.

            TRV only prevents a feature update to a new version, not any other updates.

            OH.. I forgot.. this works only on PRO and Entrprise versions of Windows 10.

            The registry file for Target Release Version works on Home version too:

            Remember if you want to stay on 20H2 and ensure you are not even offered up 21H1, use this 20H2 registry key download. Merely click on it to install it in your computer and it will ensure you aren’t offered 21H1.

            Tasks for the weekend – May 22, 2021 – Status of 21H1

            Windows 10 Pro version 21H1 build 19043.1052 + Microsoft 365 (group ASAP)

            1 user thanked author for this post.
      • #2370659
        oldfry
        AskWoody Plus

        I use Wub_x64.exe (Windows Update Blocker) to enable and disable Windows Update Services with push buttons. It’s free. WUB is just an on/off switch. WUB also works on Windows 10 Home.

        I never use pause.   I only run Windows Update under highly controlled circumstances.

         

      • #2370680
        PKCano
        Manager

        If you are willing to start over  and follow instructions exactly, I have a method for trying to fix what is wrong instead of just overwriting everything. It will take a while to do this, and the computer should not be used for other things in the meantime. Also, there is no guarantee it will fix things, other than saying it has worked on occasion for me previously.

        Let me know if you want to try this. If so, here are the first few steps. Report what you find for each step.

        + Make a full disk image of your computer ans a separate file backup of your User data (if you do not have a recent one).

        + Have you ever used a third-party Windows Update controller (such as WUMgr) or Update blocker (example O&OShutup10, Windows Update Blocker, StopUpdates10, Winaero, etc)? Reason: If you use these tools and uninstall them without resetting what they have changed, some blocks that you are not aware of may still be in place.

        + Turn of Fast Startup
        Control Panel\Power Options “Choose what the power buttons do.
        You may have to look under “Settings that are currently unavailable” – be sure to save the settings. If there, it will be a check box in addition to Sleep and Lock. Reason: Fast Startup preserves the state and by doing so can disrupt update.

        + Disable your A/V before you start a series of procedures and every time after restarting the computer, if it does not have an options to “stay off till you turn it back on.” If you have Malwarebytes installed, I recommend uninstalling it until you finish these repair steps.

        + In the Settings App\Windows Update
        At the top, if you see “Some settings are managed by your organization,” click on “View configured update policies” and post a screenshot or the list. Reason: there may be some settings you are unaware of. If, for example, you have run Susan’s .reg file in the past, to hold version 1909, there will be a Registry setting blocking upgrade to 20H2.
        Screen-Shot-2021-06-11-at-8.56.34-AM

        Under Advanced options, everything should be OFF except possibley “Updates for other MS products.”
        Under “Active Hours” change the settings to active for at least the time you will be working on these repair steps.

        + In Services click on the Windows Update Service. At the top left, click on “Stop.” Double click on the WU Service and set it to “Manual” then “Apply” and OK.

        + Turn ON Metered Connections. Reason: Hopefully this will keep the updates from downloading until the cleanup is finished.

        1 user thanked author for this post.
        • #2370763
          PKCano
          Manager

          Let me know if you want to proceed with trying to fix things and I will post the rest of the steps.

          1 user thanked author for this post.
      • #2370796
        kstephens43
        AskWoody Plus

        Yes, please post the additional steps.  I am running Wiindows 10 1909 (KB4589211) on a Dell Inspiron (3 years old).  Over numerous attempts, I have done the following:

        Updated Drivers

        Confirmed 400 mb of free space on hard drive

        Uninstalled Malwarebytes (I am running no third-party antivirus, just Windows Defender)

        Removed all peripherals,

        Thoroughly checked file integrity using chkdsk, scannow, etc.

        Ran DISM

        Did a Clean Boot (not Safe Mode) before the latest update attempt.

        Tried automatic updates,

        Used ISO files to try to update 1909 (unsuccessful), and 20h2 (unsuccessful)

        I have tracked the likely main problem down to COM permissions.  In update attempt #15 (last evening), just before the Installation-Failed message, I got an Error message that said:

        The application-specific settings do not grant Local Activation permission for the COM Server application with CLSID…This security permission can be modified using the Component Services administrative tool. 

        This was the only Error message (except the Warnings that said the Finalization and Update Boot Code had failed).

        I called up the Component Services tool, where I saw options, but I changed nothing, because I am not experienced in using it.

        A few weeks ago, when Comcast stopped providing Norton Antivirus, I went with Windows Defender.  I recall at that time that there was something funny going on with folder permissions, and I had to add several apps to the permitted list, just to allow them to work.  I did no fancy patching or any Registry changes.

        Incidentally, I have done no patching, such as what Susan recommends,  involving updates.  I am not using any third-party update manager.

        • #2370834
          PKCano
          Manager

          I’m not interested in what you’ve done in the past. We may repeat some of it. I’m interested in the answers to the points I made above. And you will need to follow the instructions exactly in the order given.
          Do you have a recent full disk image backup and a User file backup? If not – make them BEFORE we start.
          Have you ever used a third-party blocker?
          Did you follow the instructions to verify there is no Fast Startup enabled (checked)?
          Did you find anything in Windows Update in the locations mentioned?
          Have you made the changes in Windows Update, Services, and Metered Connections as suggested?

          About Norton removal
          You have given me a clue with the information about Norton A/V. This may be part of the problem.
          Did you have “Protected Folders” or “Ransomware Protection” turned on in Norton?
          What specifically did you have to “give permissions to” (which folders, files, programs) for them to work? What permissions?
          How did you remove Norton? Uninstalling through the Control Panel or Settings App does not necessarily remove all of Norton.
          Look in Task Manager (you can right click on “Name” and add Publisher, command line to help identify). Disable any Norton related processes, anything listed in Startup related to Norton. Uninstall any remaining Norton Services from Control Panel.
          Go to support.norton.com. Read the instructions. There is mention of Norton from your Service Provider. There is a video. Download the Removal Tool (NRnR). Remove Norton device security completely (including VPN and any other services). Then boot into Safe Mode and try running the Removal Tool again (it may not run in Safe Mode, but it is worth the try).

          I will give you the rest of the procedure when these preliminaries are done.

          1 user thanked author for this post.
          • #2370868
            kstephens43
            AskWoody Plus

            Thank you for your efforts on my behalf.  I will start the process with what you have provided and report on the results when I can.

            • #2370877
              PKCano
              Manager

              Pardon me it I rant about Norton.
              Norton uninstallation has been a problem as far back as I can remember (and that’s FAR back).
              If they were using protected folders or ransomware protection, that could very well explain the permission problems that uninstallation did not remove.
              Hopefully the Removal Tool will take care of that.

          • #2370997
            kstephens43
            AskWoody Plus

            I have gone through all the steps you have listed above.

            I have a full disk image and a separate file backup of user data.

            I have never used a third-party Windows Update controller

            I confirmed that Fast Startup is not on.

            I uninstalled Malware bytes.  I am not using any third-party antivirus–just Windows Defender.

            I do not see “Some settings are managed by your organization,” at the top of the Windows Update screen.

            Everything is off in Advanced Options.

            Active hours are set so that your repair steps can be implemented in peace.

            Windows Update Service was stopped.

            WU Service was set to Manual.

            Metered Connections was turned on.

            I am all set for your further steps, as soon as you can send them.

            • #2371029
              PKCano
              Manager

              Have you done the Norton removal steps in #2370834?
              As I said in the post just above, Norton’s incomplete removal may be the cause of the permission problems you experienced.

              Also, please look in Defender and list the programs/folders you had to make exceptions for.

              1 user thanked author for this post.
              • #2371041
                kstephens43
                AskWoody Plus

                I forgot to indicate that I had used the Norton removal utility downloaded from their web site.  I also discovered that McAfee was still on my machine, and I uninstalled it, even though I have never used McAfee.

                For the protected folders, I had to make exceptions for the following:

                o  scanutility.exe (a utility to solve printer problems in my Canon printer)

                o  Corel Paint Shop Pro.exe

                o  soffice.bin (for Open Office word processor)

                o  setupprep.exe

                 

              • #2371044
                PKCano
                Manager

                OK, move to the bottom of the thread.
                Give me a few minutes to enter the steps.

      • #2370814
        Alex5723
        AskWoody Plus

        Confirmed 400 mb of free space on hard drive

        For updating to new Windows 10 release (2004, 20H2, 21H1) you will need at least 20-30GB of free space on Windows partition.

        1 user thanked author for this post.
      • #2371046
        PKCano
        Manager

        Let’s start by cleaning up the leftovers from past failures and verifying the system is OK.

        + If you still have the Norton Removal Tool, run it again for good measure and any restart it requires afterward. Check Task Manager before to see if you spot any Norton related processes and, if so, disable them.

        + Run chkdsk /f – verify indexes
        Right click on cmd.exe (Command Prompt) and Run as Administrator. At the prompt type chkdsk /f and Enter. You will be asked to reboot, say yes (type “Y”). Restart. Report any findings. (Yes, even even if you have an SSD).
        Allow the computer to finish bootup operations before proceeding.

        + Run “Disk Cleanup” – clean up
        Start Menu\Windows Administrative Tools
        . Right click on “Disk Cleanup” and “Run as administrator“. Check all boxes BUT these three items:1. Downloads (but check Downloaded Program Files), 2. Recycle Bin (unchecked if you want to keep your trashed files), and 3. Language resources. Delete the checked files.
        Restart the computer and give it at least 5 minutes after booting before proceeding.
        + Run Disk Cleanup as Admin again and on the “More options” tab, cleanup System Restore and Shadow Copies. This will leave the latest but remove the old ones.

        + Run checks to verify the image and the System Files
        In an elevated command prompt (type cmd.exe in the taskbar search box, right click on it and “Run as Administrator) copy/paste each of these commands in and hit enter:
        DISM /online /cleanup-image /restorehealth
        sfc /scannow

        Make a note of the results after each step.
        If you run into errors, stop after the step and let’s discuss.
        After we clean things up, We’ll work on Windows Update problems

        1 user thanked author for this post.
      • #2371064
        kstephens43
        AskWoody Plus

        I used the Norton Removal Tool, once again, after confirming with Task Manager that no Norton processes were there.  I rebooted.

        When I ran chkdsk /f, I got an error message saying

        chkdsk cannot run because the volume is in use by another process.  Would you like to schedule this volume to be checked the next time the system restarts (Y/N)

        I checked Yes and rebooted.  Chkdsk ran and appeared to be fixing something, but the only detail showing was the percent completion.  I tried to run chkdsk again (normally from Command Prompt), but got the same cannot-run message as before.

        I then ran chkdsk in read-only mode (no /F) and it disclosed no problems.

         

        • #2371083
          PKCano
          Manager

          You cannot run chkdsk on an operating volume (in use). It has to run before the OS is loaded. That is why you have to restart and let it run before Windows loads. (Have you ever tried to delete a file that is open? Same thing.)
          Running it in read only can make no changes.
          If it ran on startup, that is what is needed to repair. If so, it accomplished its purpose.

          So continue.

          1 user thanked author for this post.
          • #2371091
            kstephens43
            AskWoody Plus

             

            After chkdsk turned up no problems, I went ahead and ran the Disk Cleanup, DISM, and sfc  /scnnow steps.  Results were:

            Disk Cleanup ran fine, with no errors, and I ran it a second time (successfully) to clean-up Restore and Shadow copies.

            DISM:  “The restore operation completed successfully.”

            sfc /scannow:  “Windows Resource Protection did not find any integrity violations.”

            I believe we are ready to proceed with Windows Update steps.

            (Thank you for your patience.)

             

             

      • #2371095
        PKCano
        Manager

        OK, Windows Update.

        + Reset Windows Update
        If you haven’t restarted the computer since the last operation(s), do so now. Give it a few minutes to complete the startup before proceeding. The following will most likely cause loss of the Windows Update History, but it does not uninstall any updates. The Software Distribution folder will be automatically recreated by the system.
        Let me know the content of any error messages.

        In an elevated command prompt, copy/paste each of these commands one at a time and hit Enter:
        net stop wuauserv
        net stop cryptSvc
        net stop bits
        net stop msiserver
        Ren C:\Windows\SoftwareDistribution SoftwareDistribution.2106
        net start wuauserv
        net start cryptSvc
        net start bits
        net start msiserver

        Verify the SoftwareDistribution.2106 folder exists so we know it was successful.
        Restart the computer.

        + Run the Windows Update Troubleshooter
        Settings\Update & Security\Troubleshoot
        At the bottom, click “Additional troubleshooters”
        Run the Windows Update Troubleshooter
        Results?

        2 users thanked author for this post.
        • #2371106
          kstephens43
          AskWoody Plus

          I ran the latest steps after rebooting.

          net stop wuauserv     “Stopped successfully”

          net stop cryptSvc       “Stopped successfully”

          net stop bits                “The Background Intelligent Service is not started.”

          net stop msiserver    “The Windows Installer Service is not started.”

          Ren C:\Windows\SoftwareDistribution SoftwareDistribution.2106   Access Denied     

          I stopped at that point.  I was running all of the above as Administrator.

           

          • #2371114
            PKCano
            Manager

            OK, let’s see if we can get around this.
            Restart the computer again and let it complete startup.

            Right click on cmd.exe and “Run as Admin.”
            At the prompt type cd C:\Windows (should give you the C:\Windows at the prompt)
            Try those five commands again.
            If they work, continue with the procedure above.

            If it fails again
            Type explore.exe in the searchbox and “Run as Admin”
            Navigate to C:\Windows highlighted in the left pane
            In the right pane, try to rename or delete the Software Distribution folder.
            If that doesn’t work, inside the Software Distribution folder, try to delete the Download folder.

            1 user thanked author for this post.
            • #2371162
              kstephens43
              AskWoody Plus

              You are the MAN!  Your workaround to bypass the Access Denied worked.

              I ran all the commands you listed.  The SoftwareDistribution.2106 directory exists, as does the SoftwareDistribution directory.  Do we need to do anything with the SoftwareDistribution directory, such as delete it or delete anything in it?  If so, please give me the steps.  It has been a long time since I played with “DOS” directories.

              Nevertheless, I rebooted and ran the Windows Update Troubleshooter.  It finally said:  “Troubleshooting could not identify the problem.”

              • #2371165
                PKCano
                Manager

                Do you have wushowhide?
                When you get it, we are ready to try updating of some type.
                Let me know.

                When we finish and all is well, you can delete the SofrwareDistributin.2106 folder.
                But there’s time for that later.

      • #2371100
        PKCano
        Manager

        When you finish the above steps:

        If you do not have wushowhide.diagcab – download it from OlderGeeks (linked) or MajorGeeks and place it on your desktop. This will allow you to HIDE updates you don’t want to install.

        In the taskbar searchbox, type winver and hit Enter. Tell me the Edition (Home or Pro), version and Build number.

        Next steps will be to see if we did any good.

        1 user thanked author for this post.
      • #2371108
        kstephens43
        AskWoody Plus

        In my earlier message, I showed you the results (where the Ren C:\Windows\SoftwareDistribution…said “Access Denied.”)

        I am running:  Windows 10, Version 1909, OS Build 18363.1379.

      • #2371177
        PKCano
        Manager

        See #2371165.
        I am usually watching AskWoody from 4:00am-8:00pm CDT US (server time).
        I will be logging out around 8:00pm (gotta sleep sometime).
        If you want to do any more today, download wushowhide (linked above) and put it on your Desktop.
        Double click on it, choose “Advanced,” then uncheck “Apply changes automatically”
        Click on “Hide” and give me a list (or a screenshot) of the updates available to be hidden.

        Otherwise, it will be tomorrow before we move on.

        1 user thanked author for this post.
        • #2371183
          kstephens43
          AskWoody Plus

          I ran wushowhide as you described.  The result was a screen that said:

          “Updates are available.  Select the updates that aren’t working.  Windows will not install hidden updates.  Run this troubleshooter again to show hidden updates so they install automatically.”

          Below that was an unchecked box beside:  Security Intelligence Update for Microsoft Defender Antivirus – KB2267602 (Version 1.341.689.0.)

          ( I had earlier set Windows Updates to defer updates until June 24.  I presume we could do them manually.)

           

          You have certainly spent a lot of time with me today.  Why don’t we wait and try again tomorrow?

          • #2371184
            PKCano
            Manager

            OK, we’ll start with wushowhide again tomorrow.
            Depending what it shows then, I would like to verify that Winsows Update is working correctly in v1909 before trying an upgrade.
            My thoughts are this:
            Do what is necessary to stay on 1909 and install the May updates for 1909 (last before EOL). That will prove WU is functioning as it should. (You are sitting on a Feb Build currently).
            If that works, choose the version you want to upgrade to and move in that direction.

            1 user thanked author for this post.
            • #2371189
              kstephens43
              AskWoody Plus

              That is a good strategy.  Thank you for all  you have done today.  See you tomorrow.

      • #2371196
        PKCano
        Manager

        Just to get the terminology correct:
        I believe you have Win10 Home. DEFER updates is not available to Win10 Home. DEFER updates is a term used in Group Policy, only available to Win10 Pro/Ent to refer to delaying (putting off, postponing) updates. Deferral starts when the update is released by MS and lasts for the number of days set (0-30). Once set, you do not have to change it, it starts by default, automatically, on the date an update(s) is issued.

        What is available to all Editions of Win10 is PAUSE. In Windows Update you can set PAUSE in 7-day increments (up to 35 days) on the main page, or, Under “Advanced settings,” you can set a calendar date. PAUSE begins when you set it, and is not dependent on the update release date. You have to install the pending updates at the end of the Pause period before you can use it again, and it has to be renewed/reinitiated after the installation.

        Updates do not show up in Windows Update as long as Deferral or Pause are in effect. It essentially blocks Windows Update scans.

        Windows Update and wushowhide both use the same Windows Update Service to scan for updates. So if a Pause or Deferral is in effect, neither will see updates until the delay ends.
        The difference between WU and wushowhide is this:
        Windows Update scans on a schedule. The results of the scan are stored in a cache until the next scan. It is this cache that you see in the list in WU. It is STATIC between scans.
        wushowhide, on the other hand, scans when you run it. So the list of updates it sees is current, DYNAMIC.
        Here’s the rub. It is the static list in the WU cache that will get installed (what you see is what you get). So if you HIDE updates with wushowhide, you have to wait till the WU cache is refreshed (WU runs its next scheduled scan or you induce a scan) before the WU list reflects the hiding you have done. You have wait, because if you get in a hurry, your hiding is for naught.

        1 user thanked author for this post.
        • #2371212
          kstephens43
          AskWoody Plus

          You are correct.  I have Windows Home, and yes, I have paused until June 24.

        • #2371264
          kstephens43
          AskWoody Plus

          Is there anything I need to do before we continue the update adventure?  For example, should I leave the Windows Updates on PAUSE?

          WUSHOWHIDE is standing-by.

          I am running Windows 10 (Home), Version 1909 (OS Build 18363.1379.  The interesting thing is that with all my update difficulties, that update actually ran automatically before you joined the party.  When it ran, I got no error messages.  It might be corrupted, because when I first tried to update it using an ISO of 20H2, the update failed.  I also tried updating 1909 with an ISO at that time, and it also failed.

          Given the work you led me through yesterday, and the results, I believe all that cleanup will be productive in moving forward on the updates.

           

           

      • #2371274
        PKCano
        Manager

        Under Advanced options, everything should be OFF except possibley “Updates for other MS products.”

        You must have missed this part. You ran wushowhide, but the results were useless if you had Pause in place. So now, we have to get update scans working to test our results.
        Read this whole post before you start. There are several “if-then’s.”

        To update v1909 to the 2021-06 updates (Build 18363.1556) you need the 2021-06 CU KB5003169 and the 2021-06 SSU KB5003244 installed. If the update is done through WU, you will not see the SSU listed in the update queue or History, only in Installed Updates after the fact. You will only see it if a manual update is required.

        + Be sure you have Metered Connections in place. Hopefully that will prevent downloads when Pause is ended.
        + Download the 1909.zip file (attached) and unzip it on the Desktop. Right click on the 1909.txt and change the name to 1909.reg  We are going to use this to hold v1909 when we release Pause, so you don’t get upgraded to v21H1. It will create 2 keys in the Registry equivalent to Target Release Version (TRV) that is set with Group Policy (that you don’t have). To see what is being done, read through #2286499 in AKB2000016. The last screenshot is of the Registry settings. As soon as we’re through updating v1909 to May CU, we will change the version number here to match the upgrade version.
        The contents should look like this:

        Windows Registry Editor Version 5.00
        
        [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]
        "TargetReleaseVersion"=dword:00000001
        "TargetReleaseVersionInfo"="1909"

        Double click on 1909.reg file and give the necessary permissions. If you are familiar with the Registry, you can verify the setting. (regedit in the searchbox) Even though v1909 is EOL, hopefully MS will respect this.
        Restart the computer and give it 5 min to complete startup.

        + Remove Pause. This is necessary to make update scanning work. Disconnect from the Internet. In the Settings App, Windows Update\Advanced options move the setting to the earliest date (tomorrow?). On the main Windows Update page, click “Resume updates” – this should initiate an immediate scan for updates which will fail with “Retry” because you are disconnected from the Internet. Once it fails, close the Settings App and reconnect to the Internet. Immediately run wushowhide.
        + Run wushowhide and HIDE any updates you don’t want. Check the boxes under “Hide updates” for drivers, KB4023057, any Feature update, etc. Do you see 2021-05 CU KB5003169? That is the one we want to try to install. If so, leave it unchecked and continue wushowhide until it tells you it has hidden the updates you checked.
        Run wushowhide again and verify there are no updates you don’t want under “Hide updates.”
        + There are several possible scenarios: Disconnect from the Internet again. Open Windows Update.
        1. If it is still sitting on “Retry,” click “Retry” and it should initiate a scan (not a download). If so, immediately reconnect to the Internet. The WU queue should be refreshed and the hidden updates should be missing. If that is the case, remove the Metered connection and let it attempt the update.
        2. If there is a list of updates in the WU queue, including the ones you hid, we need to initiate a scan. On the main WU page, click “Pause” once, then immediately click “Resume updates” above. That should initiate a rescan (the list should not include hidden updates). If the scan starts, immediately reconnect to the Internet. The WU queue should be refreshed and the hidden updates should be missing. If that is the case, remove the Metered connection and let it attempt the update.
        3. If there are no updates in the WU queue, we need to initiate a scan. On the main WU page, click “Pause” once, then immediately click “Resume updates” above. That should initiate a rescan (the list should not include hidden updates). If the scan starts, immediately reconnect to the Internet. The WU queue should be refreshed and the hidden updates should be missing. If that is the case, remove the Metered connection and let it attempt the update.

        + If no updates show up with the above steps, lets try manual installation. Reconnect to the Internet with Metered Connections ON if you are not connected.
        From the MS Catalog, Download the May SSU KB5003244 and the CU KB5003169. to the Desktop or a folder on the Desktop. Install the SSU first by doubleclicking on it, then the CU. The install order is important. You do not have to reboot between the two.
        Restart the computer.

        If any of the update scenarios is successful, then we move to an upgrade. Keep your fingers crossed.

        2 users thanked author for this post.
        • #2371306
          kstephens43
          AskWoody Plus

          Thank you.  Doing what you provided above will t.ake me a while.  Stay tuned.

        • #2371317
          kstephens43
          AskWoody Plus

          I am having trouble downloading the 1909.zip you attached.  How do I download the file?

          Ignore the above sentence.  I downloaded the file successfully.

           

           

          • #2371321
            PKCano
            Manager

            Just click on it. In the box that pops up, choose “save file”

        • #2371355
          kstephens43
          AskWoody Plus

          We have LIFTOFF!  The installation of Windows 10, Version 1909 (OS Build 18363.1566) was successful.

          I confirmed it through winver, and through the Event Viewer.

          You have accomplished what I had not been able to do for over two weeks–update Windows without fatal errors.

          The process went smoothly.  I slowly and carefully followed your instructions.  There were no glitches along the way.  The automatic installation, through wushowhide, worked flawlessly.

          I am grateful for your patience and your hard work.

          Is there anything we did along the way that I should put back like it was?  Of course I will restore Malwarebytes after the next Windows Update.  (I will NOT reinstall Norton, ever!)

          Should we try an update to 20H2, or quietly bask in the glow of the moment?

           

           

          • #2371381
            EP
            AskWoody_MVP

            eventually you will need to upgrade to 2004, 20H2 or 21H1 as the home & pro editions of 1909 went EOL in May 2021, kstephens43 (either you do the upgrade to 20H2 sometime this year or Microsoft will do it for you via “force update” when checking for updates if you don’t do it at all)

            1 user thanked author for this post.
      • #2371354
        GromitD90
        AskWoody Lounger

        Is there any way in Windows 10 Home edition to configure things so that downloads and installs of Updates only occur during specified hours? Active hours doesn’t seem to prevent downloads occurring.

        I’m not trying to stop updates, only control when they can occur.

        Thanks

        Mike

         

        • #2371399
          kstephens43
          AskWoody Plus

          In the Windows Update settings, you can choose to use a metered connection.  That generally will stop Windows from forcing an update while you are using the computer.  Choosing that button will not have any adverse impact on how well your computer runs.

          The ability to DEFER or PAUSE updates depends partly on whether you are using Windows Home, Windows Pro, or Windows Enterprise.  Windows Home users have much less flexibility

          You can set your “active hours” in the Windows Update Setting.  Thus, the updates will not occur during your “active hours.”  There is no way for you to  PAUSE indefinitely.  In the ADVANCED portion of the Windows Update Settings screen, you can PAUSE for a time you specify, but you can only do that a certain number of times.  Windows is designed to force updates eventually, because without them, security problems, etc., can pile up and make your life miserable.  Philosophically, I don’t like ANYBODY forcing something beyond my control.  If I bought the operating system, I should be able to control whether I accept a risk or not.  Big brother does not always know best.

          If you want more information on that, read the messages by PK Cano in this long thread

          1 user thanked author for this post.
          • #2371419
            GromitD90
            AskWoody Lounger

            Thanks for the response. Turning on metered connection does what i want but unfortunately I have 6 PC’s, 4 of which I manage remotely, that I would have to log into each time I wanted to allow an update.

            What I’m ideally looking for is the ability to say between the hours of say 2:00 am and 9:00 am download and install your updates. I currently have Active hours set to Start 9:00am and End 2:00 am but that does not appear to stop updates during those hours. Any time I wake up one of the PC’s during Active hours Windows Update immediately checks for updates and downloads and installs them.

          • #2371541
            doriel
            AskWoody Lounger

            @kstephens43 wrote:

            …If I bought the operating system, I should be able to control whether I accept a risk or not. …

            No, you didnt bought OS. Actually, you purchased a service. You are not “overlord” of your PC, when Windows are installed. Its not the product you own anymore, as it was in the past. Its called WaaS (Windows as a Service).
            Since this was introduced it went downhill fast. I understand, that this OS needs to be improved, etc. but for me its disaster. Thas why i went to GNU/Linux with my personal PC. And my PC remains the same for few years, no issues what so ever with Fedora.

            The know-how is simple. If you introduce new function to Windows OS, bring it to all users and make this function visible. Is someone trying to disable this new function? Then show message: “Really disable this function? Do you want to continue with limited functionality? YES/NO” and I bet like 95% of regular users will leave this function ON, even if they dont need it. They are affraid.

            I dont know if they are trying to build AI or what are they really doing, but this neverending stream of updates does not seem as a good idea if I look at the HW obsolence, HW requirements or time, that it costs users and admins to “fiddle” with this so called OS. Please consider our limited resources on this tiny island of life (planet) in the hostile and cold universe. Today computing is totally wasting resources for next generations.

            Also I disagree with “how secure” the OS is. It isnt. Its obvious, that MSFT MVPs will defend its product.. oh sorry, service. I am on the other side of the barricade. I mean, just look at the list of steps @PKCano wrote. Thanks to him, je is very wise and able person, but do you really want to go through all this to control your PC and next build again. And again..

            How to STOP Windows Updates?

            What you do with your PC? Do you watch movies? Do you write documents? Do you surf the web? You are not gamer?
            The nswer is simple, go for GNU/Linux or Mac.

            Dell Latitude E6530, Intel Core i5 @ 2.6 GHz, 4GB RAM, W10 20H2 Enterprise

            HAL3000, AMD Athlon 200GE @ 3,4 GHz, 8GB RAM, Fedora 29

            • This reply was modified 1 day, 20 hours ago by doriel. Reason: comúplain even more
            • #2371548
              kstephens43
              AskWoody Plus

              Irrespective of the legal definition, if people bought a service, they deserve a quality service.  Windows 10 updates are not a quality service.

              When PC’s were in their infancy, I looked at both Mac’s and PCs.  I had worked with big mainframes and understood the inner workings of 8086 chips.  The Mac was designed to make it very difficult for the user to control anything.  For that reason, I went with the PC.

              Having worked with UNIX, I have been tempted from time to time to go with LINUX.  However, that makes it more difficult to use software specifically designed for Windows.  Thus, I am a slave to Microsoft.

              Back in the 1980s, having strong cryptographic skills, I was able to decode the Microsoft code scrambler.  Every now and then, I get a strong urge to take retribution against Microsoft, but always override the urge.  I do, however, take pleasure in knowing that I could.  (A side benefit:  the numerous “easter eggs” developers of Microsoft code have put into Windows.  For example, “Bill Gates is a nerd.” )

              • #2371549
                doriel
                AskWoody Lounger

                However, that makes it more difficult to use software specifically designed for Windows. Thus, I am a slave to Microsoft.

                You nailed it. If I recommend GNU/Linux to somebody, they usually response that way you did. They are not masters of their life anymore, they are slaves of their applications.

                Nearly everything can be done online today, including XLSX and DOCX in the browser. No need to be addicted to EXE applications anymore.

                In the past MAC was like driving Kawasaki Ninja with balancing wheels. Also GNU/Linux in the past was not good by any means for average users. But Windows 10 are not the only one evolving. Both MAC and GNU/Linux are better than W10 for me today.

                Dell Latitude E6530, Intel Core i5 @ 2.6 GHz, 4GB RAM, W10 20H2 Enterprise

                HAL3000, AMD Athlon 200GE @ 3,4 GHz, 8GB RAM, Fedora 29

      • #2371382
        PKCano
        Manager

        OK, some thing s you can get rid of (don’t leave them in the Recycle Bin):
        The SoftwareDistribution.2106 folder can be deleted.
        If you downloaded KB5003169 and KB5003244, you can delete those.
        There is no need for the 1909.reg file unless you want to edit it each time you want to upgrade (change the name also).
        Keep wushowhide at your fingertips.

        Where to go next:
        You have a choice to upgrade to v2004, v20H2, or v21H1.
        All three versions have the same base, get the same updates.
        The big download/install part will be the same no matter which version you choose.
        The difference between them is which Experience Pack is turned on, so once you have the base, the move from 2004 -> 20H2 -> 21H1 is minor if it does not include a monthly CU (ie, the current install is up to date)

        To move to the version of your choice at this time is simply to change the version number in the .reg file, then run it to set TRV. It will overwrite the previous Registry settings and hold you on the version of your choice until you again change the number. You can copy the above code to a .txt file in Notepad, edit the number and save it as a nnnn.reg file.
        I would suggest moving to v2004 or v20H2 – leave 21H1 alone for a while.
        Be sure Pause is turned OFF and Metered Connections are turned ON when you use the .reg file. The Feature update should show up in  wushowhide and WU. Be sure there are no surprises there also (hide them) then turn off Metered. Don’t rush things, wait for the upgrade to show up on its own.

        To control Windows Update in Home, you can use a combination of Pause and Metered connections. You have seen how to do this in the above exercise. Use Pause (remember, you won’t see updates while it’s in place). When you get ready to update, set Metered ON and turn Pause OFF, use wushowhide to hide updates, clear the WU cache to reflect the hiding (remember what you see is whet you get), then turn off Metered to update. Disconnect/reconnect the Internet at the appropriate times.

        If you have the $100, buying a Pro license and using Group Policy makes life a lot easier. You should read through AKB2000016.

        1 user thanked author for this post.
        • #2371681
          kstephens43
          AskWoody Plus

          PK:

          This afternoon, I went through your process to install the 20H2 update.

          All seemed to be going well.  It went through all the update processes (downloading, installing, rebooting, etc.).  Then at the end of 2 1/2 hours, I got a message saying the installation had failed.

          I ran Event Viewer and looked at the logs, attached below.  The COM error is the same one I got in my upgrade attempts earlier.  It occurred just before installation failure was declared during the attempts before you started helping me, and also on this latest attempt.

          Suggestions?

           

          • #2371703
            PKCano
            Manager

            Hmmmm! Wasn’t expecting that.
            Give me a day to do some searching.
            Windows has a tool, SetupDiag, to help diagnose.
            What I’d read about the COM errors before we strated working, said you could manually change permissions, but did not recommend it.
            Will let you know what I come up with.

          • #2371705
            PKCano
            Manager

            OK, working on the error code, I think I have something we can try.
            Tomorrow.

            Turn on Metered Connections so it doesn’t try again till we are ready.
            Or set TRV back to 1909.

            1 user thanked author for this post.
            • #2371707
              kstephens43
              AskWoody Plus

              Thank you.  I will check in tomorrow.  I had already turned on metered connections.

              The intriguing thing is that this latest error occurred in my earlier update attempts (before you joined the party), yet it did not occur when we installed 1909 without difficulty.

      • #2371387
        PKCano
        Manager

        We have become a disposable society. If something doesn’t work, just throw it away and get a new one. Use a sledgehammer if necessary.
        Too often we forget that sometimes it is better to take a little more time, learn how things work, and fix them instead. And sometimes it is even NECESSARY to fix things first before moving on.

        I was born during WWII and raised by parents still feeling the effects of the Great Depression. That was the “keep it, learn how it works, fix it” generation. In earlier years, I learned to repair cars, home appliances, A/C units, Refinery operations instrumentation and equipment, and, yes, computers. These days I leave the manual labor to the younger generation(s), but I still dabble in PCs.

        I hope, with this exercise, you (and any others watching) have picked up some knowledge about how Win10 works. Share it with others.

        3 users thanked author for this post.
      • #2371402
        PKCano
        Manager

        Let me know how the upgrade goes.

      • #2371407
        kstephens43
        AskWoody Plus

        Thanks PK.  I sincerely appreciate what you have done for me.

        You and I are kindred spirits, and we apparently came from similar backgrounds.  Tom Brokow was right when he called the people who served in World War II the “greatest generation.”  I have always been thankful that my parents were part of that generation.

        I will pass your information on whenever I can.

        I narrate (for free) audio textbooks in Math and Physics for students who are blind or dyslexic.  I believe I am up to 19 textbooks, including a 1200 page Calculus monster.  You haven’t lived until you have put a triple integral into the spoken word <grin>.  I believe that all of us are obligated to pass good things on to the next generation(s).  After all, we have stood on the shoulders of giants.

        Best regards, my friend.

        • #2371411
          PKCano
          Manager

          I’ve been through that book on Calculus (and Analytical Geometry) but so long ago I don’t remember if the book was blue or red (pun). Math/Computer Science was my second degree. 🙂

          Edit: First degree, my Freshman year – in 2 Semesters. (obviously not today’s latest edition).

          • #2371422
            kstephens43
            AskWoody Plus

            The actual book was Thomas’ Calculus, which was intended for six semesters of Calculus.

            • #2371619
              wavy
              AskWoody Plus

              Thomas’ Calculus,

              Still got mine, but its only 800 pages. 😂

              🍻

              Just because you don't know where you are going doesn't mean any road will get you there.
              • #2371691
                kstephens43
                AskWoody Plus

                Thomas’ is a classic that has been around for many years.  Apparently, there are various editions.  The one I narrated was the latest (as of four years ago).  It was 1208 pages, and designed for six semesters of instruction.  (As new editions come out, textbooks expand and never contract.)

                As I was doing the narration, when I said something from the book, a little bell went off in my head.  When I looked at what I was reading (and saying), I realized that there was a mathematical error  (a typo in the equation).

                I contacted the publisher to let them know what I had found.  They sent it to one of the 37 math professors who had reviewed that edition before publication.  He agreed that the typo was there, and he would give me no peace until I told him how I found it while narrating.  In a good-natured way, he said I was a “freak of nature.”

                He found it interesting that 37 experts had all missed the error.  To me, that is quite understandable.  Anyone who can proofread 1208 pages of math and not go stark raving mad is also probably a freak of nature <grin>.  In all likelihood, they went on automatic pilot after a few hundred pages.  In all fairness, I could not find any other typos in that entire book.

                 

      • #2371706
        PKCano
        Manager
      • #2371755
        PKCano
        Manager

        Onward.
        From what I read, the error seems to be related to upgrade to 2004/20H2/21H1 more than updating of 1909, although it may be related to one/some of the updates in the March/April time frame.
        Starting with “failed to install the following update with error 0x80242016”
        The error code means ‘WU_E_UH_POSTREBOOTUNEXPECTEDSTATE

        I found a couple recent postings with this error and the fix seems fairly simple to try.
        If it doesn’t work, we’ll look elsewhere.

        Read over these two, here and here, both with the same solution.
        It basically involves disabling Windows Search in Services.
        Try upgrading through Windows Update.
        Write down the current settings before you start so you can set them back if need be, then try the update again. Hopefully, the upgrade is listed in WU. If so, remove Metered connections and try updating. If it’s not listed, tickle the scan with Pause/Resume and proceed.

        Fingers crossed.

        1 user thanked author for this post.
        • #2371780
          kstephens43
          AskWoody Plus

          Thanks for the ideas.  Before I disable Windows Search in Services, attached is the log from my running setup.diag.  Please let me know whether I should proceed.

          • #2371781
            PKCano
            Manager

            Upload it as a .txt, not as a  Word Doc.

            1 user thanked author for this post.
            • #2371785
              kstephens43
              AskWoody Plus

              Thanks for the ideas.  Before I disable Windows Search in Services, attached is the log from my running setup.diag.  Please let me know whether I should proceed.

              • #2371790
                PKCano
                Manager

                Give me a few to read.

              • #2371791
                PKCano
                Manager

                First glance – look in Defender and see if Norton is registered as A/V.
                If so, unregister/remove and restart.
                Let mi finish reading.

                Error 0x000005B4 seems to be a time-out error.
                Maybe looking ro Norton at the reboot and not finding it?

      • #2371794
        PKCano
        Manager

        Suggestion:
        Be sure Norton is not in Defender anywhere (registered or otherwise).
        Disable Windows Search in Services for good measure – Apply, OK  (log settings before so you can turn it back on afterward).
        Check Program Files, Program Files (x86), Program Data, and you AppData for any Norton/Semantic folders and remove them. There’s probably still stuff in the Registry, but leave that for now.
        Restart the computer to be sure the changes are in effect.
        Try the upgrade again (see #2371755.)

        1 user thanked author for this post.
        • #2371816
          kstephens43
          AskWoody Plus

          Even though I had used the Norton removal tool downloaded from their site, when I followed your instructions above, I found (and deleted) Norton files in the directories you mentioned.  I also found (and deleted) a McAfee file.

          I also found (but did not delete) a file named McInst.exe.  I don’t know whether it is a McAfee file.  It was not in the McAfee folders.

          Along the way, I discovered that I have a Realtek card reader.  I vaguely remember some sort of article on Realtek card readers and their role in updates.  Do you recall anything related to that?

          Should I disable Windows Search and plunge forward?

          • #2371818
            PKCano
            Manager

            If you have also checked Windows Defender to be sure neither Norton (mentioned in the last SetupDiag section) or McAfee (not mentined) are are registered in any shape or form…..

            Then, yes, disable Windows Search and give it a go. Worst case scenario, it fails again.
            We may still have to deal with the Registry if it doesn’t work.

            1 user thanked author for this post.
            • #2371820
              kstephens43
              AskWoody Plus

              I used File Explorer to do a deep dive into Windows Defender.  I could find no Norton files.

              I have disabled Windows Search (it was RUNNING), and I will proceed with another attempt to install 20H2.

               

              • #2371832
                PKCano
                Manager

                I can’t find the specific instructions searching the Internet.
                Go to Update & Security\Windows Defender – go through the settings (most likely anti/virus section)  looking for anything Norton. There may be links on the right about other a/v programs as well.
                You won’t be looking for files. Look for Defender settings.

              • #2371873
                kstephens43
                AskWoody Plus

                I went through everything I could find regarding Windows Defender settings, but found no information on any third-party antivirus (Norton, McAfee, etc.)

                I disabled Windows Search and once again tried to update to 20H2.  Everything worked as expected, until the very end.  I got the usual COM error message (and a Microsoft Skype message), in Event Viewer.  I have attached the log showing the ERRORs.

                During my deep dive into Windows Defender, I found Inbound Rules and Outbound rules.  I have not knowingly changed any of them, but I remember the funny behavior when I stopped using Norton (need to give permissions for some apps to work).  I tried to make a text file from the list of rules, but could not find a way to copy them.

                The adventure continues <grin>.  As always, thank you for your hard work on this.

                PS  After the installation failure and reboot, I noticed that Windows Search was turned back on.  I KNOW that I disabled it before the installation attempt.

                 

              • #2371875
                kstephens43
                AskWoody Plus

                It finally hit me that I had not actually disabled Windows Search.  When I had clicked on Windows Search, there were only two choices STOP and START.  I had clicked on STOP.  However, that STOP goes away if there is a restart.

                When I double-clicked on Windows Search, I discovered another dialog box, which gave me the choice of DISABLE.  I set to DISABLE and then clicked on APPLY and OK.

                I confirmed that after a restart, Windows Search was still disabled.

                I will now try another installation of 20H2, and keep all my fingers crossed. Given that the process takes up to 3 1/2 hours, I should know the result by 7:15 pm CDT today.

                 

              • #2371897
                PKCano
                Manager

                Disregard this

                 

              • #2371899
                kstephens43
                AskWoody Plus

                Unfortunately, my latest effort to update failed  yet again.

                As shown on the attached log, there were three errors, including our old friend the COM error.

                Exasperating, isn’t it?

              • #2371902
                PKCano
                Manager

                Run SetupDiag one more time and let me see the last section on this failure.

      • #2371912
        PKCano
        Manager

        If the SetupDiag is the same as this morning’s here’s what I see:

        Event Viewer Errors:
        + Skype timeout. – in the Settings App, uninstall Skype. Note the version number. There is a Windows Store version and (I think) a standalone version. You can always reinstall if you use it.
        + ESENT error:
        Verify in Explorer this path exists
        \Windows\system32\config\systemprofile\AppData\Local\TileDataLayer\Database\
        If the last two directories do not exist open a Command Prompt and  at the C:\Windows\System32 prompt copy the following commands:
        cd config\systemprofile\AppData\Local
        mkdir TileDataLayer
        cd TileDataLayer
        mkdir Database

        SetupDiag Errors:
        + SetupDiag reports “RegisteredAV = Norton Security Online”
        I don’t know if this has any bearing. You have removed (supposedly) Norton, unless the problem resides in Registry entries which weren’t touched
        + Error on Updating Boot code

        Error: SetupDiag reports fatal migration plug-in failure.
        Last Phase: Finalize
        Last Operation: Update Boot Code

        Plug-in Name = SxsMigPlugin.dll
        Migration Operation = READ
        Plug-in Error: 0x000005B4

        Refer to “https://docs.microsoft.com/en-us/windows/desktop/Debug/system-error-codes&#8221; for error information.

        Last Setup Phase:
        Phase Name: Finalize
        Phase Started: 6/15/2021 10:57:14 PM
        Phase Ended: 1/1/0001 12:00:00 AM
        Phase Time Delta: 00:00:00
        Completed Successfully? False

        Last Setup Operation:
        Operation Name: Update Boot Code
        Operation Started: 6/15/2021 11:00:11 PM
        Operation Ended: 1/1/0001 12:00:00 AM
        Operation Time Delta: 0:00:00:00.0000000
        Completed Successfully? False

        This may indicate a problem in the “Boot” entry in the system reserved uefi boot partition.
        I don’t know if you are using Macrium Reflect for backup, but Macrium does have a facility to fix Windows boot issues. rebuild the bcd, using the Recovery USB.
        **************
        **************
        At this point my suggestions are limited. I can only suggest one of these two options.
        In any case, make another backup before you go further.

        From the 20H2 ISO you have (you have one?), do an over the top upgrade saving only your User Data instead of programs and data. (if that’s what you did before, this most likely won’t work). It will mean reinstalling all the third-party software, but it should clean up Windows.

        ……OR……

        Do another cleanup and try again:
        + Run “Disk Cleanup” – but DO NOT cleanup System Restore and Shadow Copies this time.

        + Run checks to verify the image and the System Files
        DISM /online /cleanup-image /restorehealth
        sfc /scannow

        + Reset Windows Update
        net stop wuauserv
        net stop cryptSvc
        net stop bits
        net stop msiserver
        Ren C:\Windows\SoftwareDistribution SoftwareDistribution.21old
        net start wuauserv
        net start cryptSvc
        net start bits
        net start msiserver
        Verify the SoftwareDistribution.21old (notice I changed the name in case you didn’t delete the other one) folder exists so we know it was successful.
        Restart the computer.

        + Run the Windows Update Troubleshooter

        + Attempt to fix the Skipe and ESENT errors as described above
        Restart the computer and try another upgrade.

        If you still get the “Update Boot Code” error in SetupDiag, start a new Topic for help with rebuilding the boot partition. I am not familiar with that procedure or Macrium Reflect software.

        I was surprised we had these problems after the 1909 update functioned correctly. The last one I ran across like this was here and afterward, the ensuing upgrade to 20H2 was successful (in another Topic).

      • #2371914
        kstephens43
        AskWoody Plus

        Thank you.  I will do some work tomorrow and let you know how it went.

    Viewing 25 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, no politics or religion.

    Reply To: How to STOP Windows Updates

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.