• How to Turn Off Web suggestions in Windows seach

    Home » Forums » AskWoody support » Windows » Windows 10 » Windows 10 version 21H2 – November 2021 Update » How to Turn Off Web suggestions in Windows seach

    • This topic has 26 replies, 7 voices, and was last updated 2 months ago.
    Author
    Topic
    #2481681

    I am setting up a new Windows 10 Pro laptop – version 21H2  build 19044-2006 – have a question about turning off any web-related search suggestions in the search box/window. I thought I had turned everything off in Group Policy, no Cortana, cloud content turned off – but I still am seeing suggestions for web searches when I use that search box to search my computer.

    Annotation-2022-09-24-172131

    I don’t want to see that list of web suggestions, nor the Quick Searches like Weather, Top News etc on the main search box. I just want it to show me searches related data on my computer.

    I am wondering if these instructions from an earlier discussion, 2425853 will work?

    It requires the addition of a registry key.

    Copy the following without any extra lines or spaces into into a Notepad blank document. Name it NoWebSearchTaskbar.reg (be sure to save as All files and include the .reg in the name).

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USERSOFTWAREPoliciesMicrosoftWindowsExplorer]

    “DisableSearchBoxSuggestions”=dword:00000001

    Right click this NoWebSearchTaskbar.reg file and select Merge. OK the UAC box and all the warnings to add the key.

    A reboot is required.

    No web results in the Taskbar Search.

    Or – is there something else that I need to try?

    Thanks!

    • This topic was modified 2 months ago by LHiggins.
    • This topic was modified 2 months ago by LHiggins.
    • This topic was modified 2 months ago by LHiggins.
    Attachments:
    Viewing 17 reply threads
    Author
    Replies
    • #2481696

      Group Policy\Windows Components\Search
      “Do not allow web search”
      “Don’t search the web or display web results in Search”
      “Don’t search the web or display web results in Search over metered connections”

      Read the implications and chose which you want to Enable.

      • #2482802

        Group Policy\Windows Components\Search “Do not allow web search” “Don’t search the web or display web results in Search” …

        Hi PKCano:

        Could you confirm that the correct path for the “Do not allow web search”, etc. settings in the Local Group Policy Editor (gpedit.msc)  is Computer Configuration | Administrative Templates | Windows Components | Search?
        ————
        Dell Inspiron 5584 * 64-bit Win 10 Pro v21H2 build 19044.2006 * Firefox v105.0.1 * Microsoft Defender v4.18.2207.7-1.1.19600.3 * Malwarebytes Premium v4.5.14.210-1.0.1767 * Macrium Reflect Free v8.0.6979

    • #2481701

      Thanks! And yes – I had already enabled all of those – plus disabled the Cortana and Cloud Search options.

      Two of them even say “If you enable this policy setting, queries won’t be performed on the web, web results won’t be displayed when a user performs a query in Search, and search highlights will not be shown in the search box and in search home” yet there are search highlights showing in the search box.

      I’ve restarted several times since setting those, but that hasn’t helped with what is displayed there. Should I try that registry setting perhaps?

      Thanks again!

      ETA – these are the same settings that I have enabled on my other Win 10 Pro laptop – 21H2 build  19044-1766 – and it doesn’t show any of that web search stuff:

      Screenshot-2022-09-24-190914

      Wonder why it won’t accept those setting changes??

      Attachments:
    • #2481841

      Right-click taskbar. Set search to box. Set News and Interest to ‘turn off’

      Attachments:
    • #2481888

      Thanks! Yes, I made those changes when I first got it up and running – exactly like yours and those web search and quick search results still show. I’ve looked everywhere, but seems that it just won’t accept those settings for search – or not to search.

    • #2481889

      I am wondering if these instructions from an earlier discussion,  2425853 will work?

      The registry key works on my Windows 10. It limits searches in that box to items on the PC…No Internet results.

      HTH, Dana:))

    • #2481903

      Thanks. When I checked – mine already had that registry key and it is still getting those web results in the search box. I have all of the likely suspects disabled or enabled in GP and nothing seems to work.

      Thanks for the reply.

    • #2481964

      Have you restarted?

      • #2482016

        Yes, several times – also a full shutdown. Still the same – web searches are showing in that search box area no matter what setting I try. Makes me wonder if GP is actually working.

         

        • #2482225

          Windows 10 21H2 Pro.

          Search doesn’t search the Web yet Web search in GPEdit is ‘not configured’.
          No registry hack either.

          My default browser is Chrome. Is your Edge ?

          Attachments:
          1 user thanked author for this post.
          • #2482313

            Search doesn’t search the Web yet Web search in GPEdit is ‘not configured’. No registry hack either.

            OK – so that’s the opposite of mine. Mine is “enabled” for Do not allow web search – but it still does. And I do have the registry hack. Very strange.

            I changed those settings to “not configured” – restarted and it still was the same showing those web results.

            I don’t use Edge – Chrome is my default right now, but I may give FF a try.

            Here’s how I have it now – and it doesn’t prevent the web searches from showing when I search start:

            Capture-3

            Next I’m going to try alejr’s registry setting for Bing, below.

            Thanks!

            Attachments:
            1 user thanked author for this post.
    • #2482293

      You also may need to Disable Bing Integration in the Start Menu.

      Open regedit and goto

      HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Search

      Change the values of the BingSearchEnabled & CortanaConsent to 0 (note, if they don’t exist, created them as DWORD.)

      1 user thanked author for this post.
      • #2482347

        Thanks to everyone for the suggestions. I wanted to just update you on what I’ve done so far.

        You also may need to Disable Bing Integration in the Start Menu.

        I looked into that registry setting and found that I didn’t have either value Bing or Cortana. So, before I started editing the registry, I searched for the phrase Disable Bing Integration online and found a Group Policy suggestion that seems to have worked. There is also a YouTube of it as well.

        The Group Policy path is as follows:

        User Configuration >Administrative Templates > Windows Components > File Explorer > Turn off display of recent search > set to Enabled.

        I restarted and so far, that seems to have worked! No more web results in a search. Hopefully that will continue to apply – will keep an eye on it.

        Thanks again for all of the help!

        Untitled

        Attachments:
        1 user thanked author for this post.
    • #2482346

      Just FYI…

      Don’t know if it’d make a difference but, comparing the screen shot of your Group Policy settings for Search with mine, I also have the “Allow Search and Cortana to use location” setting disabled.

      1 user thanked author for this post.
    • #2482422

      User Configuration >Administrative Templates > Windows Components > File Explorer > Turn off display of recent search > set to Enabled.

      User Configuration ? Aren’t you the administrator and should configure Computer Configuration ?

      1 user thanked author for this post.
    • #2482433

      I am, but all the other settings in Computer Configuration didn’t seem to work, and this one did. No idea why or how, but it did remove all of the web searches. I’ll keep looking, but so far – this has been the only thing that has worked.

      1 user thanked author for this post.
    • #2482493

      User Configuration ? Aren’t you the administrator and should configure Computer Configuration ?

      Just wanted to also say that the same path in Computer Config doesn’t have that option to “Turn off display of recent search > set to Enabled” – so I guess that’s why I tried the User Config.

      Capture-2-1

      Attachments:
    • #2482501

      Interesting.

      That setting is “Not Configured” on my Win10 Pro and, after setting the standard Group Policies that are suppose to disable web results, I’ve never had any further web results show up when I searched for something.

      After reading the description of what that GP actually does, the fact I disabledSearch History” using Winaero Tweaker probably has the same effect without needing to enable the GP.

      1 user thanked author for this post.
      • #2482543

        After reading the description of what that GP actually does, the fact I disabled “Search History” using Winaero Tweaker probably has the same effect without needing to enable the GP.

        That may explain some of the differences. No matter what I tried to set – the web results kept showing until I tried this one described at the links above. Just glad it finally worked and I can get on to the rest of my new computer list! 🙂

    • #2482804

      Just to add – this weird behavior with the GP settings for search that didn’t work on my laptop were also reported to MS back in March.

      There is a solution there – a change in the registry to disable search box suggestions.

      I didn’t try that since making the GP change in User Config seems to have addressed the issue.

    • #2482822

      I am wondering if these instructions from an earlier discussion, 2425853 will work?

        It requires the addition of a registry key.

        Copy the following without any extra lines or spaces into into a Notepad blank document. Name it NoWebSearchTaskbar.reg (be sure to save as All files and include the .reg in the name).

        Windows Registry Editor Version 5.00

        [HKEY_CURRENT_USERSOFTWAREPoliciesMicrosoftWindowsExplorer]

        “DisableSearchBoxSuggestions”=dword:00000001

        Right click this NoWebSearchTaskbar.reg file and select Merge. OK the UAC box and all the warnings to add the key.

        A reboot is required.

        No web results in the Taskbar Search.

      Or – is there something else that I need to try?

      That registry setting is the same one you asked about in your initial post, did you not try it before setting those Group Policies.

      BTW, I checked, and it is set on my PC.

      1 user thanked author for this post.
    • #2482828

      That registry setting is the same one you asked about in your initial post, did you not try it before setting those Group Policies.

      You know – I didn’t. I was ready to, but really don’t like messing with the registry too much – especially with a brand new computer. When I found that User Config idea, I thought I’d try that first, and since it worked, I didn’t go any further with the registry setting. But good to know it works on yours in case I decide to do it later on.

      Thanks!!

    • #2482860

      I didn’t try that since making the GP change in User Config seems to have addressed the issue.

      With User Configuration >Administrative Templates > Windows Components > File Explorer > Turn off display of recent search > set to Enabled.

      Do you still get search results when searching a File Explorer folder:
      File-Explorer-at-Search-box

      Or when pressing ENTER at the Search box:
      after-ENTER-at-FE-Search-Box

      Attachments:
    • #2482939

      Hmmm…good question. I have been able to search for documents and text files and find them, but not sure it is as “easy” as it should be. I’ll check on it a bit and get back to you.

      I may also run that registry setting and see if that does it.

      • #2482974

        Do you still get search results when searching a File Explorer folder

        OK – seems to be working. New computer, so not many files to search for. I’ll keep an eye on it.

         

    Viewing 17 reply threads
    Reply To: How to Turn Off Web suggestions in Windows seach

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: