• HP Network Printer Spool Problem


    Hi Guys, I am having a vexing printer problem, that I was hoping someone could help me with.

    In a nutshell, we have an HP Envy 7645 all-in-one, that is hard-wire ethernet connected to a static IP.

    We have 5 Windows 10 Machines (all 21H2)  in the house. 4 of them print to it over the network just fine.
    But the newest one doesn’t. Even in the most basic way.  Just trying to print a test page is failing. No obvious errors show up, but nothing prints.

    I’ve deleted the printer, uninstalled the software, tried the microsoft drivers, tried the HP drivers, run the HP print Dr. software, and none of them worked on this one machine. I’ve tried a Windows repair install — everything short of an actual format and re-install.

    This may have occurred when the PC was briefly upgraded to Win 11.  After a few days I decided to regress to Win 10.   I don’t recall when in the process the printer stopped working.

    I think the problem may be in the spooler. Whenever I try to print a test image, I get an error in Event Viewer, : Applications and Services Log | Microsoft | Windows | PrintService | Admin: Event 808, PrintService

    The print spooler failed to load a plug-in module                    C:\WINDOWS\system32\spool\DRIVERS\x64\3\FXSUI.DLL, error code 0x7F

    When I look in my system for FXSUI.DLL, I find two different versions:
    C:\Windows\System32\spool\drivers\x64\3\FXSUI.DLL 168 KB
    C:\Windows\System32\DriverStore\FileRepository\prnms002.inf_amd64_c3bd6686769ee10c\Amd64\FXSUI.DLL 148KB

    Comparing to a laptop that is working, it is showing the smaller FXSUI.DLL in spool\drivers\x64\3 at 148KB.

    What problems will I get into if I just copy the smaller DLL.  Do I need to register the DLL?  Have any of you seen anything similar?





    Viewing 1 reply thread
    • #2457064

      You will not be able to copy the DDL over the top, Windows actively prevents this.

      Try an over the top re-install.

      cheers, Paul

    • #2457203

      Managed to solve my own problem.  I did some more googling, and found this is somewhat common for systems that have been converted to 11, then quickly reverted back to 10. They often have printer problems, and apparently spool problems with files never getting into the printer queue.

      I was about ready to format and reinstall, but facing the daunting prospect of setting everything back up, and loading all my programs, forced me to try one more nuclear option.

      As you recall, I had another win10 machine, the same 21H2 version, that was printing just fine to this printer.  Comparing many of the DLL’s in system32/spool/drivers/x64/3/  between the good and bad PCs showed quite different versions, with the bad PC in general having newer versions (presumably windows 11 versions, that hadn’t got replaced).

      So I used 7zip, running as administrator, and and zipped up the entire Windows/system32/spool/drivers/x64/3 folder from the good pc into a .7z file.

      Copied that file to the bad PC.

      Then I tried to expand all those files into the windows\system32\spool\drivers\x64\3 but it didn’t work, complaining about not being able to create a subdirectory.  (This may have been user error, I am often surprised when I expand compressed files, and find an unwanted top-level directory).  Instead, I opened the archive, and proceeded to drag and drop modest chunks of files (10-15) from the 7zip archive into the bad pc’s drivers/x64/3 folder.  Occasionally, I would get one that wouldn’t copy, even with admin privileges, so I let those alone.  Anyway, eventually copied all the files.

      Went to manage printers, and suddenly I can print again. Test Pages, regular pages from Word, and it seems all to work.  Didn’t even need to reboot.

      Just to pull on Superman’s cape a little more, I then opened an admin cmd prompt, and ran “sfc /scannow” hoping that my surgery and transplant wouldn’t be undone. And fortunately, sfc showed no problems.


    Viewing 1 reply thread
    Reply To: HP Network Printer Spool Problem

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: