News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Improve response time

    Posted on JC Zorkoff Comment on the AskWoody Lounge

    This topic contains 22 replies, has 13 voices, and was last updated by  Zig 1 month, 4 weeks ago.

    • Author
      Posts
    • #323094 Reply

      JC Zorkoff
      AskWoody Plus

      It is painfully slow trying to navigate down the topics to find posts of interest.

      Like: AskWoody Support -> Windows -> Windows 10 -> Windows 10 – 1709

      It takes 10 to 30 seconds to reach each level and after visiting an unread message thread, it takes another 10 to 30 seconds to refresh the page it came from.

      Occasionally there will be a short 2 to 3 second update, but that is rare.

      Is this a server overload issue or is there some tuning that can improve the response?

      It seems that the top level links take longer than the actual posts, but I have no data to back this up.

      The slow response seems the same with both Pale Moon and Firefox on Win 10 1709.

       

    • #323099 Reply

      woody
      Da Boss

      I’m seeing it, too.

      I’d be willing to bet it’s a side-effect of the beta testing we’re about to set up. The devs have to siphon off the whole site to set up a beta mirror.

      With a little luck in a couple of weeks it’ll be much faster….

    • #323102 Reply

      PKCano
      Da Boss

      Things are still in a flux. And probably will be until we get Windows Secrets Lounge fully merged.
      Please be patient with the construction. We’ll get there eventually.
      The number of users has increased by a factor of 10. And the data merger will probably do more than that for the required disk space.

    • #323113 Reply

      JC Zorkoff
      AskWoody Plus

      That is good news. I am willing to wait for a fix.

      It is good to get confirmation of the slow response from the site management.

       

    • #364853 Reply

      Anonymous

      Two months later, and still S-L-O-W.

      Zig

       

      • #364988 Reply

        woody
        Da Boss

        It was downright spritely there for awhile.

        But now we’re doing some very heavy database crunching. Expect it to be slow until we get the whale swallowed – and that may take several days.

        It still boggles my mind that we can bring across a million posts, all properly sorted out, attributed and indexed, in anything less than a month….

        1 user thanked author for this post.
        • #555772 Reply

          phaolo
          AskWoody Lounger

          Ah that’s why.
          The forum has become super slow all this week for me.

    • #1636797 Reply

      petesmst
      AskWoody Plus

      Slow, slower, slowest?

      This site is still very slow for me:

      Yesterday (15 May 2019): 85 seconds to log in; 30 to 45 seconds to open any other links. Used to be considerably quicker.

      Today (16 May 2019): 127 seconds to log in; ; 60-90 seconds to open other links. (Experienced two “freezes” that I could only resolve by closing my browser and logging in again.

      It is honestly no-longer a pleasure to log in and “look around”.

      (I am using a 20Meg ADSL line that is providing download speeds of around 18-20 Megs for other sites, so I am pretty certain that the issue lies here in this forum).

      My Rig: AMD Ryzen 9 3900X 12-Core CPU; MSI X570-A PRO Mobo; Win 10 Pro (64 bit)-(UEFI-booted); 32GB RAM; 2TB Corsair Force Series MP600 2TB PCIe Gen 4.0 M.2 NVMe SSD. 1TB SAMSUNG 960 EVO M.2 NVME SSD; 512GB SAMSUNG 850 PRO SSD; Seagate 2TB Barracuda SATA6G HDD; Nvidia GeForce TX 2060 Super Ventus Graphics Card (SLI); Office 365 Home; Condusiv SSDKeeper Professional; Acronis TI 2020 Premium, VMWare Workstation12 Pro. WD My Book 3 1TB USB External Backup Drive). Dell G-Sync 144Hz Monitor.

      • #1636991 Reply

        woody
        Da Boss

        I just more-than-doubled our server capacity. The database shenanigans have slowed down. You should see things improve very soon.

        I hope…

      • #1637216 Reply

        Lugh
        AskWoody_MVP

        I am pretty certain that the issue lies here in this forum

        You are right. The big job has finished though, so expect improvement very soon.

        Lugh.
        ~
        Alienware Aurora R6; Win10 Home x64 1803; Office 365 x32
        i7-7700; GeForce GTX 1060; 16GB DDR4 2400; 1TB SSD, 256GB SSD, 4TB HD

        1 user thanked author for this post.
    • #1637441 Reply

      petesmst
      AskWoody Plus

      @woody Thanks for the feedback!

      @lugh:  I sincerely hope you are correct.  Getting back to this post from elsewhere in this forum in order to read your response took me nearly three minutes!

      Holding thumbs!!

      My Rig: AMD Ryzen 9 3900X 12-Core CPU; MSI X570-A PRO Mobo; Win 10 Pro (64 bit)-(UEFI-booted); 32GB RAM; 2TB Corsair Force Series MP600 2TB PCIe Gen 4.0 M.2 NVMe SSD. 1TB SAMSUNG 960 EVO M.2 NVME SSD; 512GB SAMSUNG 850 PRO SSD; Seagate 2TB Barracuda SATA6G HDD; Nvidia GeForce TX 2060 Super Ventus Graphics Card (SLI); Office 365 Home; Condusiv SSDKeeper Professional; Acronis TI 2020 Premium, VMWare Workstation12 Pro. WD My Book 3 1TB USB External Backup Drive). Dell G-Sync 144Hz Monitor.

      • #1637477 Reply

        woody
        Da Boss

        I’m really concerned about this. My server bill just went up exponentially!

        It’s possible that it’ll take time for the changes to propagate around the world, but if you aren’t seeing much better speeds in a day or two, yell real loud!

    • #1637539 Reply

      petesmst
      AskWoody Plus

      @woody:  (I am far away from you here in South Africa, so maybe the changes have not reached me yet LoL!!)  I will keep you posted.

      My Rig: AMD Ryzen 9 3900X 12-Core CPU; MSI X570-A PRO Mobo; Win 10 Pro (64 bit)-(UEFI-booted); 32GB RAM; 2TB Corsair Force Series MP600 2TB PCIe Gen 4.0 M.2 NVMe SSD. 1TB SAMSUNG 960 EVO M.2 NVME SSD; 512GB SAMSUNG 850 PRO SSD; Seagate 2TB Barracuda SATA6G HDD; Nvidia GeForce TX 2060 Super Ventus Graphics Card (SLI); Office 365 Home; Condusiv SSDKeeper Professional; Acronis TI 2020 Premium, VMWare Workstation12 Pro. WD My Book 3 1TB USB External Backup Drive). Dell G-Sync 144Hz Monitor.

      1 user thanked author for this post.
    • #1747518 Reply

      Berton
      AskWoody_MVP

      Yep, something wrong, I’m finding most links are opening much faster than earlier today.

      Before you wonder "Am I doing things right," ask "Am I doing the right things?"
      • #1748325 Reply

        Lugh
        AskWoody_MVP

        Yep, something wrong, I’m finding most links are opening much faster than earlier today.

        Same here. Was bad the last few days—the initial New Posts was very fast, but loading the individual topics was very slow. Some of them timed out yesterday.

        Today it’s all working great—well done, and long may it continue 🙂

        Lugh.
        ~
        Alienware Aurora R6; Win10 Home x64 1803; Office 365 x32
        i7-7700; GeForce GTX 1060; 16GB DDR4 2400; 1TB SSD, 256GB SSD, 4TB HD

    • #1747672 Reply

      cmptrgy
      AskWoody Plus

      I don’t know if this is coincidental but this is what has worked excellently for me the past 3 days in a row on the laptop recorded in my posts.
      — Today being 5/28/19 is the beginning of the 4th day in a row.

      I do use Edge as my default browser but I switched to duckduckgo as my search provider

      I have Topics with my reply & Latest topics in my Favorites in an AskWoody folder and they come up instantly when I select either one.
      — And when selecting additional items within AskWoody’s afterward, it’s still instantly consistent.

      On my desktop PC I hadn’t switched to duckduckgo yet as my search provider so I could compare actual differences.
      Yesterday morning 5/27/19, when trying to connect to AskWoody it was horrendously slow so I decided it was time for me to make the change of setting up this desktop PC to have duckduckgo as my search provider later on in the morning: it was like an instant miracle: no problems with connecting to AskWoody instantly as well as moving around to see what I was interested in.

      Naturally I hope it continues that way.

      HP EliteBook 8540w laptop Windows 10 Pro (x64)

      • #1747744 Reply

        woody
        Da Boss

        I think what you’re seeing is a coincidence.

        Sometime in the past six hours or so, the site suddenly started working right. The devs have been working on it over (US) Memorial Day weekend….

        1 user thanked author for this post.
    • #1748326 Reply

      cmptrgy
      AskWoody Plus

      I think what you’re seeing is a coincidence.

      Sometime in the past six hours or so, the site suddenly started working right. The devs have been working on it over (US) Memorial Day weekend….

      I just went through some items using only Edge and everything has been going fine. Thanks Woody for your response. The Devs are coming through for us.

      HP EliteBook 8540w laptop Windows 10 Pro (x64)

    • #1758046 Reply

      petesmst
      AskWoody Plus

      @woody:  I promised feedback (#1637539) regarding my experiencing extremely slow response times here in AskWoody. As of yesterday (29 May 2019), I have noticed a massive improvement and am experiencing virtually instantaneous responses to clicking on links and the resultant opening of next page.  Excellent, thanks. (Now I can really enjoy my browsing here!)

      My Rig: AMD Ryzen 9 3900X 12-Core CPU; MSI X570-A PRO Mobo; Win 10 Pro (64 bit)-(UEFI-booted); 32GB RAM; 2TB Corsair Force Series MP600 2TB PCIe Gen 4.0 M.2 NVMe SSD. 1TB SAMSUNG 960 EVO M.2 NVME SSD; 512GB SAMSUNG 850 PRO SSD; Seagate 2TB Barracuda SATA6G HDD; Nvidia GeForce TX 2060 Super Ventus Graphics Card (SLI); Office 365 Home; Condusiv SSDKeeper Professional; Acronis TI 2020 Premium, VMWare Workstation12 Pro. WD My Book 3 1TB USB External Backup Drive). Dell G-Sync 144Hz Monitor.

    • #1858661 Reply

      wavy
      AskWoody Plus

      slow again here in the burbs of NYC

      🍻

      Just because you don't know where you are going doesn't mean any road will get you there.
    • #1940984 Reply

      anonymous

      Kirsty, Earlier today 9-6-19 there was a lot of troubles trying to post. The web page took minutes to load. I went to isitdownrightnow dot com and it said Woodys (askwoody.com) was down. It actually is not, but I guess the response time was so bad they thought you were down.
      This was about 11:15am CST.
      Thank you.

      • #1940987 Reply

        Microfix
        Da Boss

        Kirsty not on just now but, a big increase in traffic inbound due to the change in MS-DEFCON level from 2 to 3 caused a temporary issue.
        Devs have it in hand and should be ok now.

        ********** Win7 x64/x86 | Win8.1 x64 | Linux Hybrids x64 **********

        1 user thanked author for this post.
    • #1958999 Reply

      Zig
      AskWoody Plus

      It’s still s-l-o-o-o-w. 23 secs. to get to my first forum, then quite a few to get to the subheading. FWIW.

      Zig

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Improve response time

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.