News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Intermittent Wifi Problem

    Posted on WSjcgc50 Comment on the AskWoody Lounge
    Viewing 24 reply threads
    • Author
      Posts
      • #2275500 Reply
        WSjcgc50
        AskWoody Lounger

        Not actually sure if this is a hardware problem or not.

        I have an Asus laptop a few years old running Win 10 1909. I run three PC’s on my home wifi and 2 smartphones. No problems with the other devices.

        Anywhere from every day to every 3 or 4 days web pages won’t load and only a reboot gets it working properly again. This is just used for internet surfing and email, no gaming and is probably only used a couple of hours a day.

        I’ve run DISM Restorehealth and System File Checker and no problems were found. I ran the Windows troubleshooter for internet connections and network adapter and no problems were found. I’ve restarted windows explorer and turned wifi off and on on the PC with no effect.

        I primarily use the Chrome browser but when the problem develops I’ve tried MS Edge which won’t load a page either.

        I wondered if it could be a problem with the built-in wifi card/adapter (not sure what it’s called).

        Any ideas?

      • #2275512 Reply
        PKCano
        Da Boss

        In Control Panel\Device Manager look for your WiFi card.
        Right click and choose Properties.
        On the Power Management tab uncheck “Allow the computer to turn of the device to save power”
        If that doesn’t exist, look on the Advanced tab for an option that does the same thing.

        • #2275821 Reply
          WSjcgc50
          AskWoody Lounger

          Found the setting under advanced and power management. It was checked to turn on and I unchecked it? I’m assuming that this was set that way from the beginning and this problem has only started happening in the last several weeks or more.

          Will unchecking mean that it will remain on even when the laptop is in standby or hibernation?

      • #2275664 Reply
        Paul T
        AskWoody MVP

        Can we have more info about “won’t load”? Do you get error messages, does email work (assuming it’s non-browser), Windows Update?

        cheers, Paul

        • #2275733 Reply
          WSjcgc50
          AskWoody Lounger

          The page either just doesn’t load or in some instances, I get popups saying the page is taking too long to load and asking if I want to wait or exit. When I select wait more time goes by and I get the same message again.

      • #2275676 Reply
        Bundaburra
        AskWoody Plus

        If you have a built-in graphics adapter, then it probably uses system memory, and if so it may not have enough system memory allocated.  Somewhere in your BIOS/UEFI setup there should be an option to allocate a set amount of graphics memory, up to a maximum.  In my case I have Intel HD Graphics 4600, which will allow a maximum of 1024 MB (or one GB) of memory allocation.  As I have 16 GB all up, that’s OK;  if you have less overall memory then you may not want to give up that much to graphics, but could be that what it has is not enough.  A restart would fix the problem for a while, because the full-up graphics memory would get cleared, then slowly fill up again.

        Do you only get the problem when loading web pages?  What about file downloads, for example when downloading a new version of a program?  Downloading Windows Updates?  Do they get stuck as well?

        Windows 10 Pro 64 bit 2004

        • #2275822 Reply
          WSjcgc50
          AskWoody Lounger

          The graphics is built-in and is an Intel HD 620. However, the problem is fairly recent.

      • #2275723 Reply
        Vincenzo
        AskWoody Lounger

        Make yourself familiar with the internet access icon in the system tray in the lower right. See what it says (hover over it) when everything is fine, and see what it says when the problem is happening.

        • #2275731 Reply
          WSjcgc50
          AskWoody Lounger

          I am familiar with that. It always indicates that it is connected and is connected to the internet. The next time this happens I’m going to see if a non-browser program that requires an internet connection will open and run. However, even if it does I’m not sure where that leads since two different browsers wouldn’t load pages.

      • #2275736 Reply
        anonymous
        Guest

        @WSjcgc50 – Please read this entire post before responding in any way.

        You’ve previously said (in your initial post) that the problem goes away if you reboot the computer. That makes it sound like your router or your WiFi adapter is having trouble renewing the DHCP lease that is created when a computer first connects to a router after booting up.

        The problem could lie in the router or the WiFi adapter in the computer.

        The following concept is still unclear to me based upon what you’ve posted so far to describe the problem: Does this problem only happen with your Asus laptop, or does it also happen with your smartphones and your other PC’s that are using the router for their internet access?

        The answer to the above question will help folks here better help you troubleshoot your problem.

        • #2275738 Reply
          anonymous
          Guest

          As a follow-up to my post just above (#2275736), if the problem exists only on the laptop, then the problem probably lies there, and the suggestions provided by @PKCano and @Bundaburra are good starting points.

          If the problem is also experienced by other devices such as the smartphones or the other PC’s that also use the router for their internet access, then the router is likely the root of the problem, not your laptop.

        • #2275826 Reply
          WSjcgc50
          AskWoody Lounger

          As I stated in my original post I don’t have the issue with the other devices and wondered if it was a sign of a problem with the adapter.

          If it is the adapter would a USB adapter solve that?

      • #2275785 Reply
        anonymous
        Guest

        Have you cleared both browser caches? Sometimes the interpretation of JavaScript laden sites can go wrong causing a timeout.

      • #2275836 Reply
        MrJimPhelps
        AskWoody_MVP

        See if the problem happens when you are connected with an Ethernet cable.

        Also, try a USB wifi adapter. Here’s one I like:

        I like it for two reasons:

        * I like Netgear.

        * It has a stand with a long wire, which means that you can position it where it will get the best signal. Sometimes being plugged directly into the computer means that the computer will block the signal.

        Another thing you might try: Take your laptop to a different location in your house, e.g. next to one that is working well, to see if that makes a difference.

        If moving the laptop solves the problem, then there is interference in the current location, in which case you could simply use Ethernet at the current location.

        If a different wifi adapter solves the problem, then either there is interference in the current location (if you moved the adapter away from the computer), or you have a bad internal wifi adapter. (Or maybe the Windows 10 1909 driver for your wifi adapter is bad.) If you never use the laptop in a different location, you could just use Ethernet.

        Group "L" (Linux Mint)
        with Windows 8.1 running in a VM
        • #2275845 Reply
          WSjcgc50
          AskWoody Lounger

          I had previously tried moving it to the room where another laptop is kept and it didn’t make a difference.

          • #2275900 Reply
            MrJimPhelps
            AskWoody_MVP

            That narrows down things a bit. You could try going to a friend’s house and getting on their wifi, to see if that will work. I’m not optimistic, but you never know. But in all likelihood, you have a bad wifi adapter, or perhaps a bad driver for your wifi adapter. Or maybe something is misconfigured in your computer.

            The easy way to fix it is to either use Ethernet or get a USB wifi adapter. I suggest getting the USB wifi adapter from a place where you can easily return it if it doesn’t work. (It probably will work, but just in case, make sure you can return it if it doesn’t.)

            To try to get your internal wifi adapter working, go to the website of either your laptop’s manufacturer, or the manufacturer of the internal wifi adapter, and download the driver. Then install the driver. Reboot the computer. If the internal wifi adapter now works, you are almost done. Run Group Policy Editor (if you have W10 Pro), find the section about Windows Updates, and tell it not to do driver updates when doing automatic updates. (I’m not sure how exactly that choice is worded.) In this way, you will block Windows from downloading a defective driver for your wifi adapter, because it sounds to me like that is the most likely cause of the problem.

            Group "L" (Linux Mint)
            with Windows 8.1 running in a VM
            • #2275903 Reply
              WSjcgc50
              AskWoody Lounger

              As far as drivers go I ran the update driver software option in device manager and it indicated this was the most recent driver. That driver is from Microsoft. I also checked for software updates from Asus and there was nothing. Looking at update history it has never updated this driver.

              The next time the problem starts I’ll check the ethernet option and/or another wifi source.

              I don’t have Windows Pro.

      • #2275893 Reply
        anonymous
        Guest

        @WSjcgc50

        Anonymous 2275736 here. Very sorry for not reading the last sentence of your initial post 😕After seeing your response and rereading your initial post, I’d suggest following @MrJimPhelps ‘s response just above this one…try using wired Ethernet for a while and then try a USB adapter like the one shown in his post.

        I’m willing to bet that you won’t have a problem with either one, and that there’s an issue with your built in wireless adapter.

        As others have asked (but you haven’t answered yet) when the issue with the web pages not loading arises, can you do anything else that requires an internet connection,  such as accessing email or updating a program using its own updating mechanism?

        • #2275904 Reply
          WSjcgc50
          AskWoody Lounger

          I did not check to see if a non-browser program could access the internet but plan on trying that the next time the problem happens.

      • #2275906 Reply
        anonymous
        Guest

        It’s very possible for router firmware to become corrupted and only affect one device. Phones can switch to data momentarily if wi-fi is intermittent and it might not be noticed.  The laptop’s ethernet adapter is fairly unrelated to the wifi adapter but an ethernet check is still a good idea.

        What band is the laptop using?  2.4GHz or 5 GHz?  Is the adapter or router set to pick a band automatically?  If so, disable that ability and choose one so it can’t hop around.  If you have one network name for both bands, it’s autoselect; if there are two names, it may not be.

        A windows update for 1903/9 a while back caused wifi issues with many users, there are articles here about that but I believe it’s been fixed.

        First try rebooting the router and modem, then look for newer drivers.  Device Manager in the control panel will tell you which drivers are installed.  Look for new ones on Asus’s site or the adapter manufacturer’s site.  Even if up to date, reinstall them.  Same with the router.

        If the condition continues, you can always ping the router via wifi.  Open a command prompt and enter >ping 192.168.1.1< (assuming that’s the router’s IP address) and look for a very short return time.  The ping is direct, no browser involved, if it comes back, something in the OS may be sporadically blocking browsing.  The Windows OS tools and troubleshooters are pretty basic, they’ll restore chunks of missing code and do tests you could also do but nothing special.

        If the router is the issue that can usually be fixed with a firmware reinstall.  If the laptop’s wifi card is going bad, one of the best ones out there, the Intel 9260, can be had for less than $20.  We have 4 of them, excellent.  If you have Intel 620 graphics, a fairly recent version, the right slot should be available.

        I’ve run into what you’re describing a few times.  The fix one time was scrapping a Killer Networking 1535 card, replacing with the Intel mentioned; corrupted wifi card driver another time, the other times, it was router firmware.  Look at everything, though.

        1 user thanked author for this post.
      • #2276011 Reply
        anonymous
        Guest

        Any ideas?

        Certainly sounds like you might have some kind of network issue, yes, but I do find myself wondering this: how much RAM in your laptop, friend?

        Don’t know if you’re running an email client or checking email using browser, but do know you’re running Chrome on Windows 10, bloat on bloat… (then maybe throw in the occasional problematic website/script issue…)

        Don’t mean to offend by suggesting consideration of something so obvious. But recently saw issue where user with very limited RAM, using outlook email client and chrome browser (and often excel or word), with a tendency/preference (“work flow”?) to leave pc up and apps open day after day (i.e., avoiding application restarts and pc reboots) was experiencing “browsing problems” and “slowness” and “waiting” and “freezing”. While it’s certainly possible other small issues may have contributed, her problems largely resulted from inadequate RAM.

        Hope this helps.

      • #2276651 Reply
        WSjcgc50
        AskWoody Lounger

        It has 12gb of RAM. I use browser-based email only no email client. Almost never have other programs open when using the browser.

        Today, the problem happened again. Pages wouldn’t load in Chrome or Edge. I tried opening several programs that require internet access and those would not load either. Tried connecting to another wifi source which did not fix the problem. The laptop does not have an ethernet connection.

        Network showed connected with connection to the internet.

        I opened network & internet settings and have reset the network adapters. If I read it correctly this removes and reinstalls the adapters and it has been restarted so it might be several days before I know if that solved the issue.

      • #2276655 Reply
        Microfix
        AskWoody MVP

        When you stated Edge, are you referring to the Original Edge or the Chromium based Edge (Chredge)? If Chredge, how did you install it, via WU or by the download installer?
        There have been reports that Chrome and Chromium based Edge (Chredge) do not co-exist well in Windows 10 when updated using the WU method.

        Win8.1 Pro | Linux Hybrids | Win7 Pro O/L | WinXP O/L
        • #2276681 Reply
          WSjcgc50
          AskWoody Lounger

          Sorry, all I know is it is MS Edge that came with the OS. Just checked it does say it is based on “Chromium”.

          • This reply was modified 3 months, 3 weeks ago by WSjcgc50.
      • #2276780 Reply
        Paul T
        AskWoody MVP

        Please run these commands when you next have the problem and post the results.

        In a Command Prompt.
        nslookup askwoody.com
        ping askwoody.com
        tracert askwoody.com

        cheers, Paul

      • #2276919 Reply
        WSjcgc50
        AskWoody Lounger

        Please run these commands when you next have the problem and post the results.

        In a Command Prompt.
        nslookup askwoody.com
        ping askwoody.com
        tracert askwoody.com

        cheers, Paul

        Will do and will post the results.

        Thanks for all the suggestions from everyone.

      • #2278305 Reply
        WSjcgc50
        AskWoody Lounger

        While this didn’t become totally unresponsive it did seem to be getting sluggish. Ran the various commands and attempted to paste the response into this message but immediately got taken to a window with something about being blocked due to “Wordfence” detecting some problem with what I posted. How do I get this information posted here?

      • #2278344 Reply
        WSjcgc50
        AskWoody Lounger

        After posting the above browsers became unresponsive again. I’ve restarted and am attaching a notepad document with the results copied from the command searches suggested by Paul T. Does that identify a problem?

        Attachments:
      • #2278460 Reply
        Paul T
        AskWoody MVP

        Your results show the network working as expected – no dropouts or particularly slow response.

        I’d use Task Manager to see if your machine is using loads of memory or CPU on the next slowdown.

        cheers, Paul

        1 user thanked author for this post.
      • #2288430 Reply
        WSjcgc50
        AskWoody Lounger

        I’m back again. The internet connection has been working well until today. The browser has slowed to a near standstill. I closed Chrome and opened Edge and it too has a lot of difficulty loading a page. I had previously restarted the PC for other reasons which clearly didn’t fix this.

        Checked task manager and total memory usage varies from 40 to 50%. Right now Chrome is using 1.4 gigs of 12 gigs. Ran a speedtest on my phone and speeds were around 45mbps. Test timed out on the computer with both Chrome and Edge.

        Pinged askwoody page which showed average speed of 81ms.

        I’m stumped. I am going to try yet another restart and see if that resolves anything.

         

      • #2288448 Reply
        Bundaburra
        AskWoody Plus

        Another possibility is DNS, which translates a web address (such as askwoody.com) into an actual IP address, which is just numbers.  You could have a slow or at times unresponsive DNS server?  Are you using the DNS servers provided by your ISP, or something else?  Are they specified in your router, or in your PC?  Do you use an IPv4 connection, or maybe IPv6?

        There is a handy DNS benchmarking tool which will detect slower or faster DNS servers.  It’s reasonably self-explanatory, and there’s nothing to lose by giving it a try.

        Windows 10 Pro 64 bit 2004

        • This reply was modified 2 months, 1 week ago by Bundaburra.
        • #2288495 Reply
          Paul T
          AskWoody MVP

          DNS uses a local cache, so once a site has loaded it won’t request any more DNS lookups and should re-load/refresh without issue.

          cheers, Paul

      • #2288458 Reply
        WSjcgc50
        AskWoody Lounger

        I’ve just made several attempts to post a response including an attached wordpad document where I copied the Status tab results from the DNS app. Apparently, this forum doesn’t like those and the only way to continue with your post is to start over.

        I tried pasting the Status page to a Notepad doc and it won’t paste there so not sure how to proceed.

        When looking at my connection the DHCP is set to automatic there are numbers beside IP6 address, IP4 address, and IP4 address DNS. Don’t know what that tells me.

        When I ran the DNS app it says that I either don’t have an internet connection or the firewall is blocking it. I assume that is the firewall for the router but I don’t know. I had previously restarted the computer yet again and now pages load fine and speedtests are normal. When I select Ignore in the DNS app after that initial look for a connection and check the results of the Status tab it only shows one DNS connection and that is 1.1.1.1

        I really appreciate everyone’s thoughts on this.

        • #2288469 Reply
          JohnW
          AskWoody Plus

          Well you have tried everything else, so it’s time to try a USB Wi-Fi adapter as was suggested earlier, and see how that goes.

          I’m only saying this because your other devices are working fine, so the problem cannot be with your router or internet service. So it most likely has something to do with the laptop.

          Using a hardwired Ethernet cable between your laptop and router would be the easy answer here, but you have stated that the laptop does not have an Ethernet connection. Please provide the model # of the laptop.

          1 user thanked author for this post.
      • #2288496 Reply
        Paul T
        AskWoody MVP

        When I ran the DNS app it says that I either don’t have an internet connection or the firewall is blocking i

        Maybe it is a firewall problem.
        What anti virus / firewall do you use?
        Can you disable it when the problems start?

        cheers, Paul

        p.s. to attach screen shots, save them as PNG and then attach directly. Don’t put them in another file / document.

      • #2288506 Reply
        Bundaburra
        AskWoody Plus

        With DHCP set to Automatic, it means that your local IP address, and DNS servers, are being provided by your router and do not need to be set locally.  In Network & Internet, select Status, then “Change adapter options”.  Right-click your adapter and select Properties.  Find the entry for “Internet Protocol Version 4”, highlight it and again select Properties.  Then you should see that “Obtain an IP address automatically” and “Obtain DNS server address automatically” are already selected.  If by any chance either one says “Use the following…..” then change it to “automatically”.  Then do the same for the Version 6 entry.  But before changing anything, make a note of the current setting so it can be restored if necessary.

        You might also check the same settings in one of the other devices that is working, to see if there is any difference.

        Windows 10 Pro 64 bit 2004

      • #2288568 Reply
        JohnW
        AskWoody Plus

        With DHCP set to Automatic, it means that your local IP address, and DNS servers, are being provided by your router and do not need to be set locally.  In Network & Internet, select Status, then “Change adapter options”.  Right-click your adapter and select Properties.  Find the entry for “Internet Protocol Version 4”, highlight it and again select Properties.  Then you should see that “Obtain an IP address automatically” and “Obtain DNS server address automatically” are already selected.  If by any chance either one says “Use the following…..” then change it to “automatically”.  Then do the same for the Version 6 entry.  But before changing anything, make a note of the current setting so it can be restored if necessary.

        You might also check the same settings in one of the other devices that is working, to see if there is any difference.

        Good advice to make sure that the laptop is using the same DNS servers that the router is, which is most likely what the other devices that are working fine are using. And the router is most likely defaulting to the ISP provided DNS servers.

        If the devices are all using the same DNS servers, then that would imply that something is definitely wrong with the laptop to router Wi-Fi link.

        Another advantage to having your computer use DHCP to automatically receive the IP and DNS from the router, is that you only have to manually change the router settings to assign a new DNS to everything in your network. This could some in handy if your default ISP servers have an issue, you can go to router admin and assign Google DNS, or OpenDNS, or something else of your choice.

      • #2288633 Reply
        WSjcgc50
        AskWoody Lounger

        The laptop is an Asus model Q504UAK.

        Checked and IP4 and IP6 in all 3 laptops are set to automatic.

        Antivirus and malware are the same for all three laptops. Windows Defender and Malwarebytes Premium.

        Just double-checked the Intel wifi adapter driver again from device manager and it says the Microsoft driver is the most current. Searched for drivers for my model and found Intel has a tool you download to analyze your system. It properly identified the adapter and I used that to update to a new version as of 4/2020. We’ll see if that makes a difference.

        https://www.intel.com/content/www/us/en/support/detect.html

         

    Viewing 24 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Intermittent Wifi Problem

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.