• Is there a USB 3.0 adapter for “ancient” x1 PCIe 1.0 expansion slots?

    Home » Forums » AskWoody support » PC hardware » PC hardware-General Questions » Is there a USB 3.0 adapter for “ancient” x1 PCIe 1.0 expansion slots?

    Author
    Topic
    #2533074

    I just tried a Highpoint RocketU 1022C in two PCIe 1.0 motherboards:

    one detected that card in Device Manager, but I would not install a working device driver

    the other never detected that card at all, despite being a more modern ASUS  workstation motherboard

    I’m thinking that USB 3.0 AICs were NOT seriously contemplated until PCIe 2.0 increased the raw clock rate from 2.5G to 5G per x1 lane:

    5G / 10 bits per byte  =  500 MB/second, using the former “legacy frame”:

    1 start bit + 8 data bits + 1 stop bit.

    5G is the standard clock rate for good ol’ USB 3.0 ports:

    https://en.wikipedia.org/wiki/USB_3.0

    “Transfer speed – USB 3.0 adds a new transfer type called SuperSpeed or SS, 5 Gbit/s

     

    Viewing 4 reply threads
    Author
    Replies
    • #2533123

      I remember having some in stock years ago in the shop I worked in. They were no-name cards but had NEC/Renesas chips on them.

      1 user thanked author for this post.
      • #2533164

        Many thanks for that tip.

        FYI:  I installed that Highpoint RocketU 1022C in an HP PCIe 2.0 SFF workstation, running Windows 10 x64, and Windows installed the device driver no problema.

        I plugged a USB 3.0 flash drive into one of the USB 3.0 ports, and it worked perfectly.

        So, I’m pretty sure the problem was the Gen1 PCIe chipset in those 2 older PCs.

        I’ll shop around for that Renesas controller.

    • #2533155

      I just recently installed this adapter from Amazon in two 2011/12 vintage machines w/o issue and no drivers required. Both were running Win 10 Home 22H2!

      As always YMMV!

      May the Forces of good computing be with you!

      RG

      PowerShell & VBA Rule!
      Computer Specs

      1 user thanked author for this post.
      • #2533168

        Many thanks for that tip.

        I did see that card during my search for a Gen1 compatible version.

        I clicked on your link and found this:  “Based on PCIE 2.0 standard”

        Do you know for sure what PCIe Gen you are using with that card?

        My surviving theory is that PCIe 1.0 pre-dated USB 3.0, and the raw bandwidth of an x1 PCIe 1.0 lane is only 2.5Gbps, as compared to 5.0Gbps for USB 3.0.

        I also suspect a LOT depends on the OS version and the driver.

        I’m encountering problems with 2 ancient PCs now running Windows 7 Ultimate x64.

        As such, here is my goal, if technically possible, in flow order:

        x1 PCIe 1.0 expansion slot –> USB 3.0 add-in card –> 2.5GbE Ethernet USB 3.0 dongle

         

        p.s.  I’ve tried 2 x Rosewill brand RC-20001 2.5GbE AICs, but neither worked:

        https://www.neweggbusiness.com/Product/Product.aspx?Item=9B-33-166-146

        The ASUS motherboard did not recognize it at all (model P5W64WS Pro).

        The Intel motherboard (D915PGN) activates an annoying Option ROM at POST e.g. for booting from a LAN, and there is no way around that Option ROM except to remove the card completely.

        Thanks again.

        Bleeding-Edge out .

         

        • #2533226

          such combination in such old PCs are usually “hit or miss” (meaning it either works or it does not)

          1 user thanked author for this post.
          • #2533230

            Because the ASUS motherboard did NOT recognize the Rosewill RC-20001, there was not much in the way of error messages to help isolate that problem

            I did learn something about the BIOS in our Intel D915PGN:

            the Rosewill RC-20001 did install and operate correctly PROVIDED that I responded to its Option ROM menu with the correct answers, chiefly “SKIP BOOT FROM LAN”

            on closer examination, I found a list of BIOS updates for that motherboard, which helped because its BIOS version was OLDER than the latest version in that list

            later BIOS versions added a feature to DISABLE the “Boot from LAN” option

            in the best of circumstances, flashing the latest motherboard BIOS might have actually enabled that RC-20001 to inter-operate properly withOUT launching that Option ROM menu during POST

            the issue of “upstream bandwidth” has been a technical interest of mine for many years e.g. I was a staunch advocate of “syncing” the clock rates and frame layouts of chipsets and storage devices:

            that finally did happen in PCIe 3.0:  8G per x1 lane + 128b/130b “jumbo frame”

            as such, in theory there was much to recommend a 2.5GbE AIC in an x1 PCIe 1.0 expansion slot: i.e. SAME RAW BANDWIDTH

             

            • #2533244

              just found this:

              Sabrent CP-4PTU 4-Port USB 3.0 PCI Express Card

               

              I’ll order one and try it:

              https://sabrent.com/products/cp-4ptu

              USB 3.0 interface (10X faster than USB 2.0)
              Data transfer rate: up to 5Gbps
              Supports 4-USB 3.0 Type A-ports
              Compliant with PCI-Express revision 1.0a
              Backward compatible to USB 2.0 & USB 1.1 specifications

              more text from my hardware database:

              Sabrent CP-4PTU 4-Port USB 3.0 PCI Express Card

              The 4-Port USB 3.0 PCIe 1.0a Card from Sabrent is a host controller card
              that upgrades your desktop PC to SuperSpeed USB 3.0.

              The card has four USB 3.0 ports that are reverse compatible with USB 2.0 and USB 1.1 devices.

              You can transfer files, photos, and videos at speeds of up to 5 Gb/s.

              It is PCIe revision 1.0a compliant.

            • #2533249

              several BAD reviews at Amazon:

              https://www.amazon.com/Sabrent-USB-4-port-Express-Card/product-reviews/B0085IZU7C

              e.g.

              “Installed the card and driver in my Windows 7 x64 system. The card worked but I got the Blue Screen of Death from the driver every time I shut down my computer. I tried updating the driver, but that locked the computer up. I tried a bunch of other “tricks” to fix the problem, but those didn’t work either. I ended up throwing the card in the trash and restoring a previous backup of Windows.”

            • #2533258

              I do have a Highpoint RocketU 1022C working correctly in an ASUS P5G41T-M LX motherboard, which has an Intel G41 chipset:

              https://www.intel.com/content/dam/www/public/us/en/documents/product-briefs/g41-chipset-brief.pdf

              see “500 MB/s each x1”

              I believe that number “500” is total combined bandwidth, both directions.

              Thus, 500 / 2  =  250 MB/second each x1

              Consequently, 250 MB/second x 10 bits per byte (legacy frame)

              =  2.5Gbps = PCIe Gen1

               

              G41 chipset is PCIe 1.1

               

              elsewhere, see:

              PCI Express* 1.1 interface provides 8 GB/s bandwidth

              assume x16 slot:  8 GB / 2  =  4 GB/s bandwidth, one direction

              4 GB x 10 bits per byte  =  40 Gbps, one direction

              x16 lanes x 2.5Gbps per lane  =  40 Gbps

               

              Bottom Line:  motherboard chipset and BIOS version are important, controlling factors

               

    • #2541491

      After many trials and many errors, too numerous to itemize here, I found a valuable tip on the Internet:

      My “ancient” ASUS P5W64 WS Professional motherboard was expensive when purchased brand new, mainly because it has 4 x16 PCIe expansion slots:

      either 16-0-8-0 or 8-8-4-8 lane assignments

      If PCIe expansion slots are populated from “top-down” THEN not all slots will be recognized by the motherboard BIOS.

      Here’s the TIP I found:

      If PCIe expansion slots are populated from “bottom-up” then all slots will be recognized by the motherboard BIOS.

      BUT, that PC must be RESTARTED after adding each additional card in that sequence.

      So, we started with a GeForce GT 730 video card in the bottom x16 slot, and proceeded in that “bottom-up” sequence.

      Now, a Vantec model UGT-PC345 USB 3.0 adapter is working, and it inter-operates just fine with a Sabrent NT-S25G 2.5GbE “dongle”.

      That Vantec AIC also has one 20-pin USB 3.0 port, and EN LABS sell a Y-cable that terminates at 2 x USB 3.0 Type-A females:  so, this is a convenient and inexpensive way to add 2 more thumb drives inside a chassis e.g. for storage of OS drive images.

      We like the SanDisk 256GB USB 3.0 models, because they always work out of the box, and the cost per gigabyte is incredibly low now.

      I have one more test to perform:  upgrading to a QNAP 2.5GbE unmanaged switch.

      The Sabrent NT-S25G allows auto-detection of the speed, and the speed can also be fixed with the CONFIGURE button in Network Connections.

      Sabrent Tech Support also provided us with a link to the latest device driver, which installed with no further problems.

       

      Bottom Line:  my theory about PCIe 1.0a bandwidth being equal to 2.5GbE adapters was mostly correct, EXCEPT FOR very peculiar obstacles caused by an “ancient” motherboard BIOS.

      It’s also highly recommended to contact third-party adapter manufacturers to confirm that their adapters will inter-operate in PCIe 1.0a expansion slots.

       

    • #2541492

      USB Type-A / Type-C to 2.5 Gigabit Ethernet Adapter

      https://sabrent.com/products/nt-s25g

       

      USB Type-A or Type-C to 5-Gigabit Ethernet Adapter

      https://sabrent.com/products/nt-ss5g

       

      4-Port Super Speed USB 3.0 PCIe Host Card w/ Internal 20-Pin Connector

      Model <span class=”color04″>UGT-PC345</span>

      https://vantecusa.com/products_detail.php?p_id=125&p_name=+4-Port+Super+Speed+USB+3.0+PCIe+Host+Card+w%2F+Internal+20-Pin+Connector&pc_id=16&pc_name=USB&pt_id=4&pt_name=Add-on+Cards

    • #2541493

      RESOLUTION SUMMARY:

      BIOS in ASUS P5W64 WS Professional motherboard requires AICs to be installed “bottom-up” and not in any other sequence e.g. “top-down” does NOT work!

      If “bottom-up” sequence is NOT followed, one or more expansion slots will disappear.

      The required sequence is NOT documented, however.

    Viewing 4 reply threads
    Reply To: Is there a USB 3.0 adapter for “ancient” x1 PCIe 1.0 expansion slots?

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: