News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • Is this a Windows 10 driver install issue?

    Home » Forums » AskWoody support » Windows » Windows 10 » Questions: Win10 » Is this a Windows 10 driver install issue?


    System :   Device name : DesktopPC
    Processor : Intel(R) Core(TM) i5 CPU 760 @ 2.80GHz 2.79 GHz
    Installed RAM : 16.0 GB
    System type :   64-bit operating system, x64-based processor

    Edition :   Windows 10 Home
    Version :   20H2
    Installed on :  ‎7/‎05/‎2021
    OS build :  19042.1023

    For weeks – even before the upgrade to 20H2 – I have been struggling to get my Epson Perfection 3490 scanner to work, even having lengthy online chats with Epson Support.   They were quite patient and helpful, but ultimately the problem was not resolved.

    During this time I have done many complete uninstall/wipes of Epson software from the PC, and re-installed the latest driver from Epson (SFS1_WW_WIN_30u_41).

    The scanner will perform anywhere from zero to 3 scans before it locks up and has to be cleared using Task Manager.   I sometimes get a “unable to communicate with scanner” message,

    I noticed early on in discussions with Epson Support that my PC only has a Twain 32 folder, and mentioned this to them.

    (They had included instructions on renaming the existing Twain 32 and 64 folders to ‘OLD’).   I have since read online that Windows 10 requires 64 bit drivers).

    There is no facility in the Epson download to pick which version you want installed, and I end up with 32 bit every time.

    Is this the issue, or is it something else?

    I am not averse to buying a more modern scanner, but I have also read where similar issues are occurring with later models (and other brands).

    P.S.  Sorry if this has been discussed previously, but I could not find any applicable topics.

    Really appreciate any assistance that can be provided.   Thank you.


    Viewing 6 reply threads
    • #2368824

      I had scanning problems with Samsung AIO printer and Windows 10. Couldn’t find a proper driver for scanning so I am using Windows 10 build-in ‘Fax and Scan’ (%windir%\system32\WFS.exe). Works fine.

      1 user thanked author for this post.
      • #2369186

        Hi Alex,

        Thank you for responding, and I apologise for being slow in answering.   I spent all day yesterday trying your suggestion and also that of Moonshine (below).

        Whilst Windows Fax and Scan (WFS) is listed under programs (Windows Accessories), it does not work.   I get the WFS screen, but when I select ‘New Scan’, it opens the scan setup window (recognising that it is a Epson Perfection 3490/3590), but then freezes, requiring Task Manager cancellation.

        Through online searches I am led to believe that WFS should be listed under Windows Features>Print and Document Services, but mine isn’t.   I tried all sorts of online ‘fixes’ including – uninstall/reinstall WFS, System File Check (SFC).

        I am seriously at the end of my tether with Microsoft and I’m researching a move to Linux.   I am sick of spending my days trying to fix an Operating System that just doesn’t work.

        Thank you again for your input.

    • #2368826
      1 user thanked author for this post.
    • #2369193

      Hello Moonshine.   Thanks to you also for your time and effort in providing a response to my question.

      I had already tried the download that you suggested, as it turns out.   That is one of the ones suggested by Epson, and has been tried repeatedly (with a clean out of Epson files etc in between).   As mentioned in my initial post, I am wondering if this is an issue with my PC OS, in that it will not/does not install the 64 bit version of the download.   Although I have used this download before (Epson13829.exe), I tried it again using your link, as I noticed the “+64-bit” on the end.   I hoped this might lead to a different file.   It was just the same, in that it lists all of the supported OS, win 10 32-bit, win 10 64-bit etc etc., but there is no facility to select which version you require – even though the downloads page recognises that my Operating System is “Windows 10 64-bit (detected)”.

      Anyway, the end result was that the scanner still does not work – all I get is maybe a ‘click’ where it would start the scan normally, and then it freezes up.   Or I get “no scanner found”.

      I tried installing the latest download from the Epson Support site on to my laptop (Windows 10 Pro 64 bit OS version 20H2), which had never had an Epson device on it before.  Once installed and set up, I got 4 complete scans done one after the other, and then it froze part way into the 5th.

      So, as stated above to Alex, I have had it with Microsoft.   I am sick of spending days trying to solve problems caused by their so called “Operating System”, where every time there is an update there are issues – as witnessed by all of the people posting on online sites.   Meanwhile MS goes on it’s merry way doing what IT wants.   Rant over.

      Thank you sincerely for trying to help.   Best wishes.

    • #2369214

      When – how long ago – was it that the scanner worked without errors?
      And under what version and edition of Windows?
      How old is the device?
      Have you another USB cable that you could test with?

      1 user thanked author for this post.
    • #2369570

      Hello again and thanks to Paul for your input.

      Rather than answer your specific questions, Paul, I would like to provide an update on part of my last post – quoted below, which may negate the need for answers:

      I tried installing the latest download from the Epson Support site on to my laptop (Windows 10 Pro 64 bit OS version 20H2), which had never had an Epson device on it before. Once installed and set up, I got 4 complete scans done one after the other, and then it froze part way into the 5th.

      After posting my reply (#2369193), I closed everything down.   Yesterday morning, after trying to get the PC and scanner to work again, with no success, I started checking some of the settings on the laptop, to compare with those on the PC.   I could find nothing different but did notice that ‘Windows Fax and Scan’ does not appear under ‘Print and Document Services’ on the laptop either.

      Anyway, I decided to try to use the scanner with the laptop again – without having changed anything from the previous day, when it had seized on the 5th scan.    All up I was able to print 17 scans in succession (with a half hour break in between 5th and 6th), without a hiccup.   From this I assume that:

      a.   There is nothing wrong with the scanner;

      b.   There is nothing wrong with the USB cable (which has also been used with the PC to

      test that aspect);

      c.    The computers basics appear to be very similar, in that both are Win 10 20H2 (PC

      build 19042.1023, Laptop 19042.985).   Epson scan 32 bit installed on both, which

      negates one of my concerns that it should be 64 bit to work with Windows 10.

      The Epson scan software has to date been totally removed from  the PC several times (using the “Epson Scan Maintenance Utility” – “Esmutl_v2.exe”), and reinstalled with the latest version from their website.   This Utility requires that as part of the process, the folder “Twain_32” should be renamed “Twain_32old”.   Each time I have done a re-install I have done so, renaming the newly created “Twain_32” and adding (x) after the ‘old’ – where x is a one-up number each time, meaning I now have nearly 20, Twain_32old(xx) folders.   Would this be a problem?

      I have tried using different MB USB ports on the PC to connect the scanner, and as mentioned, also used two different cables.

      Other than doing what the Epson Maint Utility says, I am at a loss as to what could be stopping the scanner from functioning on the PC, as my knowledge of computer and software setup does not extend to that depth.

      I have also been keeping both computers updated as per ‘DEFCON’ advice.

      Any advice gratefully received.   Thank you.



      • #2369573


        Processor : Intel(R) Core(TM) i5 CPU 760 @ 2.80GHz 2.79 GHz

        I see that your processor is first generation Intel Core processor. That means that your motherboard might be a decade old by now. If so, it might be a good idea to go to your motherboard manufacturer’s website to see if there are any newer drivers on their site for the motherboard I/O system or if there are any newer USB drivers listed on the site. The problem could be with the input/output system of your motherboard, which USB is a part of.

        If there are no newer drivers, then check to see if there are any BIOS updates for the board that have been released since late 2015. Updating the BIOS might solve your I/O problems, but is not a task to be taken lightly.

        1 user thanked author for this post.
        • #2369707

          Thanks Bob99,  I’ll check on those suggestions.   I appreciate your input and will get back to you when I have found the answers.

        • #2370560

          Hi Bob99.   Apologies once again for the delay.   I had to seek a response from Gigabyte regarding the way to do what you suggested.

          Yes, you are correct, the PC is exactly 10 years old.   The response I got from Gigabyte Technical Support was – Quote:

          This motherboard does not officially support for wn10.

          It only supports for Microsoft Windows 7/Vista/XP.

          To check driver version, you can go to Device Manager to check.

          To update driver, just download them from product website.

          Kindly know this MB is old, we no longer maintain its BIOS.

          Please install supporting OS and download all drivers from product website.


          I have looked at Device manager, and cannot identify which devices actually are/relate to the MB.   All of the ones I looked at all had Microsoft drivers and stated that they were the latest available.

          Looks like I’m in the market for upgrade components or a new PC.

          Thank you for putting me on the right track, although I still cannot understand how my laptop (which is 5 years old) appears to be having the same/similar problem with Epson scan – yet to be resolved.   (See my answer to alejr).


    • #2369704

      You said both computers have the same 32 bit Epson scan software installed but are they both actually using the same driver to communicate with the scanner (Device Manager > Imaging devices > Your Epson scanner > Properties > Driver tab)

      I ask because Windows 10 is infamous for insisting its Microsoft drivers are the best ones available for devices and doesn’t always install the manufacturers driver when you run their software (you have to manually install the driver by selecting “I have a disk“, browse to where the manufacturer’s .inf driver file is located, and then tell Windows to install the driver anyway when it says it can’t “verify” it’ll work with your device.)

      BTDT… many times!!

      BTW, I see on the Epson support site for that particular scanner there’s a EPSON Scan Updater dated 13-Jul-2018 in the Drivers section with the following note:

      Since updating to the new version of Window 10 (April update) Epson Scan will not launch or will freeze indefinitely after launching, using Preview or pressing the scan button.

      I know you indicated you spoke with Epson support to try and resolve your problem. I “assume” they had you download and install that update??

      1 user thanked author for this post.
      • #2370556

        Hi alejr,

        I checked both systems, and found :

        PC Epson driver details – Epson Perfection 3490/3590      Laptop :     Same

        Provider :  Epson                                               Same

        Driver date :  20/01/2010                                20/11/2006

        Driver Version :                           

        ”      Signing : Seiko Epson Corp.                  same

        The day after my previous post #2369717, I went to use the laptop to do some scanning.

        It would not scan.   Nothing had changed since I had been using it, except that the scanner USB cable had been disconnected and the laptop turned off in the interval.

        I cannot understand how a different version of the driver was installed, when I went to the Epson website and downloaded the file shown (only one offered – no choices).

        I have not had time to do anything about trying to reload the Epson software, as I’ve been flat out with finishing a car repair project and also trying to get the information to answer Bob99’s post #2369573.

        Please don’t waste your time with this issue of mine, as it seems I have to upgrade my PC at least.   I really appreciate your input.   Thank you.


    • #2369717

      I will have to double check in the morning, but I have downloaded that file back on 17 April, so I assume that I tried it. I’ll have another go as soon as I get a chance, and will check your other suggestion as well. Thank you.

      Sorry alejr, the last post was from me.   (after 1.00 AM here, and I forgot I wasn’t logged in).

      Time I went to bed.

      [Moderator edit] fixed that for you

    Viewing 6 reply threads
    Reply To: Reply #2370560 in Is this a Windows 10 driver install issue?

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.