News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • Is this patch, aka “ubuntu-system-adjustments”, legit? (Linux Mint)

    Home Forums AskWoody support Non-Windows operating systems Linux – all distros Is this patch, aka “ubuntu-system-adjustments”, legit? (Linux Mint)

    • This topic has 28 replies, 5 voices, and was last updated 5 months ago.
    Viewing 8 reply threads
    • Author
      Posts
      • #2285422
        anonymous
        Guest

        I got a patch in my update manager that is named ubuntu-system-adjustments with version being “2019.6.29.1”.  It claims to disable Firefox Telemetry. I wonder if it has to do with my Firefox ESR 69.11?  Anyay, is it safe?

         

        Thanks,

        Picky

      • #2285485
        Ascaris
        AskWoody MVP

        I take it you are using Mint?

        If so, it is a legitimate, if perhaps somewhat controversial, part of Mint. It’s in one of these system adjustments that Mint blocks snap packages by default, a decision that some individuals think is absurd, while others (like me) can see the rationale.  It’s only a change in the default… users can enable snap capability if they want it. That’s the point… if they want it, they can turn it on, accepting the reduced control over updates this implies, but it won’t just happen without the user doing anything as it would in Ubuntu.

        I can’t see the changelog for the package in question, so I can’t tell what you mean about Firefox telemetry.

        Group "L" (KDE Neon Linux 5.21.5 User Edition)

        • #2285575
          anonymous
          Guest

          Yes, I am using Linux Mint.

          I am surprised that you can’t see the changelog. That is where I got the mention of disabling the Firefox Telemetry.  That was the only thing in the changelog.

          Thank you for your reply 🙂 I think I will wait a week and see how the things shakes out then I will decide if I want to install or not. I did my best to turn off the firefox telemtry but I may have missed a few or I could not turn off via about:config.  If that is truly all the patch does then I have no objection to it, lol.

          Picky

          • #2285579
            Ascaris
            AskWoody MVP

            It’s not that something is wrong with my setup or anything like that… I can’t see the changelog because I am not using Mint.  The package in question is a Mint specific thing, and while I did search for a changelog online, I didn’t find one.

            I do have a Mint test environment on my G3, but that was the same PC I was using to write the message.

            The distro I use, KDE Neon (which is also based on Ubuntu LTS, like Mint, but currently it’s 18.04) has one package that appears to be KDE’s version of that package, neon-settings.  It’s received a bunch of updates lately, though it is my guess that it has to do with the upcoming rebase of Neon to 20.04.

             

             

            Group "L" (KDE Neon Linux 5.21.5 User Edition)

            1 user thanked author for this post.
      • #2285496
        DrBonzo
        AskWoody Plus

        FWIW, I installed that patch yesterday on three machines running Mint 19.2 Cinnamon. But note that my new version was 2019.7.29.1, not 2019.6.29.1. I don’t remember what the changelog said about it, but it does appear to be safe.

        Along with the above patch I installed about a week’s worth of patches with the exception of a grub2 patch which I believe might cause boot problems. See

        https://www.zdnet.com/article/boothole-fixes-causing-boot-problems-across-multiple-linux-distros/

        1 user thanked author for this post.
        • #2285547
          Ascaris
          AskWoody MVP

          I just tried booting Windows 10 from the GRUB menu (on the G3) with secure boot enabled, and it worked just fine with the most recent GRUB update, FWIW. I’m using KDE Neon, based on Ubuntu 18.04 currently.

          If you have secure boot off or if you only want to load Linux, apparently, you won’t see the issue. The problem I saw described only seems to be an issue with secure boot and booting Windows.

          Group "L" (KDE Neon Linux 5.21.5 User Edition)

          2 users thanked author for this post.
          • #2285592
            DrBonzo
            AskWoody Plus

            At the risk of going a bit off-topic, I’m somewhat confused about the grub2 patch.

            Said patch was not offered to my sole boot Ubuntu 18.04 machine.

            Said patch was offered to three Mint Cinnamon 19.2 machines, two of which are dual boot with Win 7 and the third of which is just a single boot. All three of these machines came with either Vista or Win 7 installed on them.

            I think I’m using the correct terminology, but just to be clear, when I say single or sole boot, I mean there is only one operating system on the machine. When I say dual boot I mean there are two operating systems on the machine but that only one OS at a time is capable of running – in other words I have to shut down the computer and reboot if I want to change the OS.

            All that said, it sounds that you think there shouldn’t be a problem with the grub2 patch in my circumstances? I know I’m being pretty cautious here, but I’m pretty new at Linux and while I don’t mind experimenting a bit, right now I need these machines to work.

            1 user thanked author for this post.
      • #2285588
        firemind
        AskWoody Lounger

        I installed the system adjustments patch and haven’t seen any issues so far over all (LM20). I did have that rare Firefox tab fail for the first time in ages but that’s probably due to the upgrade to Ff 79.

        I installed the Grub2 patch the other day and haven’t had any problems but then I don’t think I have secure boot. This patch arrived to fix grub issues (I will install it later):

        grub2 (2.04-1ubuntu26.2) focal; urgency=medium

        * debian/postinst.in: Avoid calling grub-install on upgrade of the grub-pc
        package, since we cannot be certain that it will install to the correct
        disk and a grub-install failure will render the system unbootable.
        LP: #1889556.

        1 user thanked author for this post.
      • #2287235
        anonymous
        Guest

        So, all is good with this patch, correct? I just wanted to check to be sure before I install this patch.  Thank you very much for your replies 😀

        Picky

        • #2287246
          DrBonzo
          AskWoody Plus

          FWIW, on 7/31 and 8/7 I installed all patches except the grub 2 updates offered to me on a total of 4 machines: one runs only Ubuntu 18.04 LTS, one runs only Mint 19.2, and two can boot into either Win 7 or Mint 19.2.

          Regarding the grub 2 patches, there was the original patch which was followed by a regression. You can find both here by scrolling down a bit: https://ubuntu.com/security/notices – the regression is from 8/4 and the original is from 7/29. I installed all of these last night, 8/7, and tested all possible system boots.

          No problems or issues with any of the above.

          Note: my grub 2 patches were labeled as grub2 (pc/BIOS version). All of the above machines originally came with either Vista or Win 7 installed on them, so no UEFI to the best of my knowledge. I don’t know how presence or absence of UEFI affects the grub patches.

          • This reply was modified 9 months ago by DrBonzo.
      • #2315694
        Charlie
        AskWoody Plus

        Well, last night I turned on my 2007 Sony VAIO with Linux Mint 19.1 and it wouldn’t boot up.  I tried to think of a reason for this and the only thing that came to mind was the fact that I had installed the old Grub2 software update along with a couple of new security updates the day before.  This was the first time booting up since then.  The Linux Mint Logo appears on screen then disappears and there’s just a blinking cursor in the upper left corner.

        BIOS checks out okay.  Using Grub Advanced features wont get me back to a previous kernel.  I’m currently at Kernel 15.45-123.  I have the Mint 19.1 install disk and I’m thinking I may have to reinstall it from scratch – I’m really hoping there’s a way around this but I can’t even boot.  Looking back now I know I should have hidden that Grub2 update.  Anyone have any ideas?

        • #2315749
          Charlie
          AskWoody Plus

          A couple more things to add:  the BIOS is not UEFI and I’m not really sure if this problem is being caused by the Grub2 update.  It just seems a coincidence that everything was fine before installing it.  Also, if this is not the proper or best place to have this post please let me know.  Thanks.

          • #2315751
            DrBonzo
            AskWoody Plus

            I’ve got 19.2 running on 3 computers with non-UEFI and they all boot fine after the latest Grub update. There have been 2 grub updates recently, one 2 weeks ago and another this past week. There was also a kernel update last week to 4.15.0-124 (I think you meant you’re running 4.15.0-123?).

            I installed the grub update of 2 weeks ago, then the .124 kernel the following week and then over the last couple days the latest grub update. All my computers are totally up to date with the updates offered through the update manager (including some microcode), and as I say, they all seem fine.

            Not sure if this helps you but it may point to your suspicion that your problem may not be with grub updates. BTW, the oldest computer dates back to 2009 with a Centrino processor.

            1 user thanked author for this post.
        • #2315944
          Ascaris
          AskWoody MVP

          It’s probably not GRUB at fault. By the time you get the Mint logo, you’re already past the GRUB stage.

          Can you press F1 when it gets stuck and tell us what it says? That might help narrow down what happened.

           

          Group "L" (KDE Neon Linux 5.21.5 User Edition)

          • #2315947
            Charlie
            AskWoody Plus

            Pressing F1 does nothing.  The cursor keeps blinking and the screen flickers back and forth from total black to a lighter black.  It did this before, the screen flicker was not caused by pressing the F1 key.

            • #2315982
              Ascaris
              AskWoody MVP

              Ok… so perhaps the system is hanging, as opposed to it waiting for something to happen (which looks like a hang from the outside, but it’s still processing internally).

              Can you press F1 sooner in the boot cycle and see what the last messages were (if F1 works that time)? F1 should toggle off the boot splash and list the diagnostic messages as the system boots. It used to be escape that did that, but I just tried F1 on my 2008 Core 2 Duo laptop (the only one I have that runs BIOS) running Mint, and F1 worked, so it should be the right key.

              When it hangs, can you use CTRL-ALT-F2 to switch to another session? If you get a command prompt, you can log in with your usual credentials. You can enter “startx” and see if that works, which means it will start the graphical interface and allow you to look at the logs using the graphical tools.

              Otherwise, you can enter:

              less /var/log/dmesg

              and that will let you scroll up and down in the dmesg (journald) log. There may be something toward the end of that which tells you what’s happening.

              If you don’t see anything relevant, you can also try

              less /var/log/syslog

              to view the system log. They will often both list the same events, but there are some differences. With systemd systems like the ones we’re using, dmesg is the first go-to.

              If you are not able to start a new session with CTRL-ALT-F2 (or the other function keys), you can start in a live session and mount your boot drive, then navigate to that same file on the boot drive (not in the system root at that point, since that will give you the diagnostic messages from the live session, not the previous failed boot into Mint) and double click it and read it from there. You can use the GNOME Disks utility as a shortcut to get to the drive… it will show “mounted at” at the bottom of the screen when you have the drive highlighted, and you can click that, and then navigate from there to var/log. If it is not mounted, you can mount it from there with the small “play” symbol in the graphical display of the drive partition you want to mount.

               

              Group "L" (KDE Neon Linux 5.21.5 User Edition)

              2 users thanked author for this post.
              • #2316285
                Charlie
                AskWoody Plus

                Thank you so much for all that info.  Now I have more things to try and hopefully get this laptop working properly again.  I will hold down the F1 key before turning the computer on and that should make it work.

                Hopefully I’ll have good news in my next post.

              • #2316337
                Ascaris
                AskWoody MVP

                I will hold down the F1 key before turning the computer on and that should make it work.

                No, don’t do that… the idea is to press it when the Mint logo comes up, not during POST or the GRUB phase before that. F1 is supposed to make the splash screen go away and show the boot messages, and the fact that it didn’t work once it hung is already giving us a bit of a clue. Sometimes it will still work at that point, and the last messages on the screen might give a bit of info about where to start looking for the problem.

                Group "L" (KDE Neon Linux 5.21.5 User Edition)

              • #2316397
                Charlie
                AskWoody Plus

                Okay, that’s what I did the first time and nothing happened.  I don’t get a “splash screen”, just the Mint logo, the screen normally goes black for a few seconds, and then my wallpaper comes up and I’m then fully booted.

                Thanks for telling not to hold the F1 key right from the start.  I haven’t been able to do anything with it today.  I will try again holding the F1 key down when the Logo comes up and again when it goes away, and see what happens.

      • #2315823
        Paul T
        AskWoody MVP

        Try booting a Linux live USB to be sure it’s not the PC.
        Once booted, check the disk is OK and the files are readable.

        cheers, Paul

        2 users thanked author for this post.
        • #2315943
          Charlie
          AskWoody Plus

          I used my Linux Live DVD and the SSD is okay, all files are readable and in fact I copied some files I needed to a flash drive.  All indications from my research on Google and Linux point to the Grub program being corrupted somehow.  That most likely happened when ran an old Grub2 update that had been sitting in the Update Manager for months.

          The computer boots to as far as showing the Linux Mint (LM) logo which disappears and then the screen stays black and a cursor blinks in the upper left.

           

          • #2315949
            Charlie
            AskWoody Plus

            One other thing that might have a bearing on things – the main 250 Gig SSD was not mounted when I ran the Linux Live DVD.  I had to mount it, and after that I could see everything on it.

            I also was able to bring up grub and go to “Advanced Options” and tried to load the previous kernel with no luck.  It’s showing GNU Grub version 2.02.

            • This reply was modified 5 months, 1 week ago by Charlie.
            • #2315972
              DrBonzo
              AskWoody Plus

              Since at least March of this year Grub has been listed in the boot menu as Grub 2.02, even though there have been several updated versions. When you look at History of Updates you’ll see the versions listed as 2.02-2ubuntu8.20 (most recent version from this past week, the previous version from a couple weeks ago being 2.02-2ubuntu8.19) so it’s possible you might have succeeded in installing an earlier version of Grub

              1 user thanked author for this post.
      • #2316723
        Charlie
        AskWoody Plus

        Okay first, I got F1 to work but it scrolled very fast and I didn’t see anything that I knew about. Then I tried CTRL-ALT-F2 but the message wouldn’t stay up because the screen kept flicking in and out.  So I couldn’t log in.  I then turned off the computer so I could reboot from scratch. When I started the computer up again I hit the Shift key to get Grub and went to start in Root. From there I typed in “startx” and was finally able to get the Mint GUI.

        Everything looked fine but I was in a sort of “safe mode” in that the video was a smaller resolution that normal.  I checked a lot of things but the one thing that may mean something to you is this that I got from System Reports:  VAR/Crash/-usr-sbin-slick-greeter.111.crash.  I don’t know what this is or means but hopefully it is helpful.

        • #2316758
          Ascaris
          AskWoody MVP

          When you pressed F1, was there anything that you could read before it locked up during a normal (not recovery mode) boot? I know a lot of stuff goes by, but something it says right before it locks up might be useful.

          It’s good to know that startx worked from the root session. Running X from root is not something you’d want to do under normal circumstances, though, as it has risks of messing things up (worse). We’re not in normal circumstances now, but just keep it in mind.

          It’s normal for starting an X session from there to have weird results. I tried it, and I got the safe-mode looking display (wrong resolution, and a warning about video drivers and hardware acceleration), but that was it. The desktop never came up.

          If you are able to connect an ethernet cable to the laptop to get internet, I would suggest plugging one on, then booting to the recovery mode again, then use the option “network.” That should enable networking, which will allow you to connect to the repo. Then start a root session, and try this to reinstall lightdm and the Slick Greeter:

          sudo apt install –reinstall lightdm slick-greeter liblightdm-gobject-1-0

          Then you can type ‘reboot’ and see if it worked.  If not, another question. Do you have the system configured to autologin, or does it ask for the password just before you get to the desktop?

          What kind of GPU does the Vaio have?

          Group "L" (KDE Neon Linux 5.21.5 User Edition)

          • #2316874
            Charlie
            AskWoody Plus

            Will get back to you with as much info. as I can as soon as possible.  Unfortunately right now is an unusually busy time for me and I’m lucky if I have time at night to work with that Vaio.  Thanks for the info., I appreciate it.

          • #2317333
            Charlie
            AskWoody Plus

            Hi Ascaris, I connected my ethernet cable to the Sony and booted to recovery mode and got into Network option okay.  I then tried the command you gave:  sudo apt install –reinstall lightdm slick-greeter liblightdm-gobject-1-0  which didn’t work so I tried it with just sudo apt reinstall . . and then things started happening and all the messages I got were looking positive as far as I could tell.  It said that it reinstalled slick greeter whatever thing.  At that point I typed reboot and the computer rebooted, but did same exact thing as before.

            The LM Linux logo came up, screen went black with blinking cursor, and still had the flickering back and forth between black and lighter black.  So it appears it didn’t work. Is it possible it got fixed in root but not in my account name which is Oldsony?  Most everything I do is done in the Oldsony account name I set up at the initial install.

            To answer your questions:  Yes, the computer auto logs in without needing the password.  GPU Info.:

            Intel GMA X3100
            Video Memory Shared system memory
            Graphic Type Integrated Card

            As of right now if there’s nothing else to try, I’m wondering if it might just be easier to just reinstall the Linux Mint Cinnamon 19.1 program from scratch and start over again.  Hopefully this would be the final solution?

            • #2317482
              Ascaris
              AskWoody MVP

              As of right now if there’s nothing else to try, I’m wondering if it might just be easier to just reinstall the Linux Mint Cinnamon 19.1 program from scratch and start over again. Hopefully this would be the final solution?

              It depends. If the issue is in the OS itself, that certainly should fix it, but it might not be.

              The autologin makes it unclear whether it is Mint that is failing to start or whether it is actually starting okay, but there is some issue in your profile that’s hanging it up. If that is the case, reinstalling Mint won’t help if you reuse your old home folder (which you can do by entering the same username and password at install time).

              If you can get into the root session again from the recovery mode, but instead of using ‘startx’ from that point, try:

              login yourname

              where yourname is your account name. Enter the password, then try startx, and see what happens. If it works, try turning off autologin and see how it does next time.

              Group "L" (KDE Neon Linux 5.21.5 User Edition)

              1 user thanked author for this post.
      • #2317597
        Charlie
        AskWoody Plus

        I used Grub to get to recovery mode and then went to root which came up as:

        root@oldsony:~#

        I tried logging in to oldsony – and got:  System is booting up.  “See parm_nologin(8)”  Login incorrect.  Typed in parm_nologin(8) and it did not recognize the 8.

        Tried cd oldsony and got “No such file or directory”.  Tried cd Home and got the same reply.

        Typed exit to get out of root and back to grub.  Looked in System in the grub menu and in the LVM State it had – Physical Volumes:  Not ok (BAD)  Volume Groups:  ok (Good).  I’m giving you what I see that may be of some significance.  The Pheonix BIOS sees the 250 gig SSD and lists it, that’s all.  Sorry for bad news once again.

        Edit:  I should have mentioned that I normally get a login box when I boot up but I just hit Enter and the computer boots up.  I forget how I did it but a while back I switch from password login to no password login.  Just some more information, this has worked for over a year this way.

        • This reply was modified 5 months ago by Charlie.
        • #2317639
          Ascaris
          AskWoody MVP

          I don’t know anything about LVM… but I would say that when it says ‘bad,’ it means it! I would say that’s almost certainly why it is not starting Mint properly.

          JFYI, ‘cd home’ would not work because you were in /root, the root account’s home directory. You would need ‘cd /home’ and then ‘cd oldsony’, or just ‘cd /home/oldsony’. If you are not sure what directory (folder) you are in, you can enter ‘pwd’, which stands for ‘print working directory’.

          If you posted a new topic about this with a title mentioning LVM, perhaps mn- or someone else with some LVM knowledge might see it and be able to offer some assistance.

          Group "L" (KDE Neon Linux 5.21.5 User Edition)

          1 user thanked author for this post.
          • #2317835
            Charlie
            AskWoody Plus

            Okay, I was thinking I should starting a new topic on this problem.  Maybe it will get noticed more.  The SSD in the Sony laptop is a new Samsung 860 EVO 250 Gig.  I don’t know if that is considered a physical volume, but all files and directories were there and intact when I mounted it in Live mode using the Live DVD.  I really hope it’s okay.

    Viewing 8 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, no politics or religion.

    Reply To: Is this patch, aka “ubuntu-system-adjustments”, legit? (Linux Mint)

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.