News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Linux live image-based backup solution!

    Posted on Ascaris Comment on the AskWoody Lounge

    Home Forums AskWoody support Other platforms – for Windows wonks Linux for Windows wonks Linux live image-based backup solution!

    This topic contains 7 replies, has 4 voices, and was last updated by  anonymous 3 weeks, 3 days ago.

    • Author
      Posts
    • #343571 Reply

      Ascaris
      AskWoody_MVP

      I’ve been looking for a Linux-based replacement for Macrium Reflect/Aomei Backupper/Acronis True Image for a while.  There are a number of programs around, but I hadn’t found one that ticks all of the boxes: The ability to back up live (in use) partitions, full image-type backups, the ability to write and restore from network locations or locally, compression of the image, encryption of the image, and incremental (or at least differential) backup ability. I’d also like to be able to do it without having to use the command line, and I don’t want it to cost a fortune (like the $500 a year cost for Acronis, who assumes that people performing Linux backups must be businesses backing up a server).

      Well, I think I have found it.  It’s called Veeam Agent for Linux Free.  It’s actually the full program, despite the name sounding like it’s just a part of something (to me at least).  It doesn’t have a full graphical interface like any of the aforementioned Windows programs, but its character-based terminal interface is wizard-driven, and doesn’t require any difficult to remember commands.  If you can use TAB, Space, the arrow keys, and Enter, you’ll do fine!  It works with local drives (including USB external drives like several that I have) and shared folders on the LAN (Linux NFS or Samba).

      I just had it back up my G3 laptop, and it created an encrypted, compressed backup image about as quickly as my previous speed champion, which was Aomei Backupper.  I was never able to evaluate the performance of Macrium Reflect, as it doesn’t do encryption in the free version.  It was fast in its unencrypted free version, but that doesn’t necessarily mean the encrypted performance would be just as good.  I tested all of the Windows backup programs with free versions I could find, and while several of the backup programs I tested were nice and fast with unencrypted volumes, they almost universally slowed to a crawl when I turned encryption on.  Aomei was the exception, until Aomei removed encryption from the list of options included with the free version.  It would still be a good value in the paid edition if I was looking for a Windows backup program, but I’m not anymore.

      Veeam is about as fast as Backupper with compressed/encrypted backup images, and it doesn’t require booting to Windows or to the rescue USB/disc to make it work.  And it’s free!  I don’t know what the licensing restrictions are on the free edition, but I get the idea from the Veeam site that enterprise customers who can pay the price Acronis asks are their target.  I’m just glad that they don’t choose to ignore the consumer sector of Linux users like Acronis does.

      Veeam does want you to log in before providing the link to their free program, and they provide the option of using existing social media logins or making one with them specifically.  I logged in with my Google ID that I keep mainly for the ability to log into Disqus and things like that (I don’t use its email or anything else, as it is Google, spying, you know the routine).

      The link provided after login that I used is for a very small .deb file (the equivalent of a Windows .msi file for Debian-based Linux distros like Ubuntu and Mint).  There are instructions for non-Ubuntu distros like Manjaro too, but I installed it into Neon, which is based on Ubuntu 18.04.

      I installed that .deb, and it seemed that nothing had happened.  I tried to start the program by typing “sudo veeam” into the console, but nothing was there.  I discovered that it had only installed the Veeam repo via that .deb, not the actual program.  Usually, adding a new repo involves copying and pasting a few lines of text into the terminal.  Doing it via a simple, easy to install, easy to remove .deb strikes me as a smart way of adding the repo without intimidating people who are not fans of the command line.  A quick double click and the repo’s added… easy!

      Once that little .deb is installed, you can refresh the list (sudo apt-get update for command line, or the reload button if you are using Synaptic Package Manager), and then have it install veeam and veeamsnap.  If you’re planning to use it with Windows networking shares (Samba), you may also need to install cifs-utils.  I had an error message pop up while I was setting up the location of my network share, and it said that cifs was not installed.  I saw several things in the Ubuntu repo that listed cifs, so I was not sure which to install.  I decided to try cifs-utils, and at the same time, I replaced the SMB name for the share with its IP address, and it worked.  I am not sure whether it was the addition of the cifs-utils package or the change to the IP address that did it, so I’m throwing that out there in case that was the fix.

      I will test the restoration next to make sure it works, but they’ve clearly put some thought into the product, so I would be surprised if it didn’t work.  Until it is proven, I will still make redundant backups with Macrium Reflect, but if it works as well as it should, I may soon have a replacement for Reflect that doesn’t require me to leave Linux to perform backups!

       

       

       

      Group "L" (KDE Neon User Edition 5.15.4 & Kubuntu 18.04).

      5 users thanked author for this post.
    • #343675 Reply

      JohnW
      AskWoody Plus

      I’ve always used Clonezilla for my Linux system images, but that requires taking the Linux system offline and booting into the live image utility to image the active partition.

      Anything that would enable imaging from within the running Linux OS partition like we have in Windows would be a plus!

      Please keep us informed with how the testing progresses. This looks interesting.

      1 user thanked author for this post.
      • #343720 Reply

        mn–
        AskWoody Lounger

        Well, those of us who use snapshotting filesystems or LVM have been able to do that for years… technically. Just more work during the setup phase.

        Also because of the different system design, not as important as with Windows.

        (Now where did I put that one rant by a HA server design guy about recovery images not being a substitute for proper backup procedures…)

        But yes, this is useful.

        • #343727 Reply

          JohnW
          AskWoody Plus

          Well I am just a simple home desktop user running Linux, but thanks! Not a Linux Sysadmin.

           

          1 user thanked author for this post.
        • #344234 Reply

          Ascaris
          AskWoody_MVP

          I would certainly have expected this to be the case, as I’d read that Linux had the volume snapshot ability before Windows did (which may or may not be true), but I’d have no idea how to go about it without doing some research.  All of my relatively meager experience with Linux is as a consumer-level desktop OS, since my prime motivator in moving to Linux in the first place is to avoid Windows 10 on my own PC, and the lack of a real image-type backup program that is as easy to use as any one of the many such programs in Windows was annoying.

          Until now, I’ve used Windows-based backup programs and done them from the rescue USB or the Windows installation on the drive, but that takes the PC out of commission for the time the backup is being done, so it was less than optimal.  It harkens back to the days of Norton Ghost or Acronis True Image 6, both of which (when used with Windows 9x as I was using at the time) required booting into a rescue media session to perform backups.

          So far, Veeam looks great… I’ve created the rescue USB and successfully gotten it to recognize the backup set on my Samba-based backup server (which was often difficult in the various Windows-based rescue sessions, even though the backup server itself runs Windows), but I haven’t actually performed a restore yet.  I am impressed with its speed in performing backups and ease of use despite not having a graphical interface.  Its image files are almost exactly the size of the Macrium Reflect images (as you would expect), and I’ve so far backed up my G3 to my external drive and my Swift to the backup server.

          Group "L" (KDE Neon User Edition 5.15.4 & Kubuntu 18.04).

    • #345715 Reply

      anonymous

      @YP

      mn-,

      When you say “snapshotting filesystems”, are you referring to Timeshift application? I have been using Timeshift for about 3 months on xubuntu; I’m reasonably happy with it. I definitely have used it for saving and restoring. While I was getting familiar with Linux, I was willing to be aggressive and try things; it definitely saved me butt!

      JohnW,

      I’ve done fair amount of testing with Clonezilla using Virtual box with xubuntu/guest. While I’ve imaged of my real system, I have not tried restoring yet. Actually, I tested out on my old XP and reasonable confident that restore should work on my 64bit Dell. Perhaps you can give me confidence that it does work.

      At some point, I really want to re-partition my disk to 2 partitions, OS and data. Before I do this, I need to test Clonezilla on a real machine. My Win7 Pro is sitting more or less idle since Jan. I do have a SSD that I bought 2-3 weeks ago. When I get up the energy, I might swap it in and install xubuntu and test out Clonzilla.

      I would greatly appreciate any experience or comments on Clonzilla.
      Thanks MN- and JohnW

      • #345732 Reply

        JohnW
        AskWoody Plus

        I used the Clonezilla Live version.

        Clonezilla Live runs from a live CD, based on Debian Live. You shut your system down and boot from the CD.

        Then you can image any partitions on the system to a target drive.

        I have used it for backing up a Linux hard drive install to an external USB drive. Also did several restores that worked well.

        You do need to be very familiar with Linux drive naming and paths in the Linux environment, so that you are sure that your source and target are what you expect. And definitely read the step-by-step guide on the web page!

        I have never used Clonezilla in a mixed Windows/Linux environment, or with virtual machines, or with servers, so I have no opinion on those. But it worked as advertised on a pure Linux desktop machine. 🙂

        • This reply was modified 3 weeks, 4 days ago by
           JohnW. Reason: added link to the clonezilla step by step guide
    • #345807 Reply

      anonymous

      @YP

      JohnW,

      Thxs for your response, my experience with Clonezilla Live are:
      – On XP single partition with xubuntu, image & restore works
      – On XP with WinXP, could not restore because boot loader was incorrect.
      – VM xubuntu one & two partition, image & restore works

      I am careful with dev names. I label my partitions meaningfully. I found command “lsblk -f” very useful; command list device, mount point, and label.

      It seems to me that restoring a single partition does not restore the boot loader, grup. The loader is restore only when the entire disk is restored. As mentioned early, I will need to set-up two partition on a real system & make sure works with Clonzilla. I’ve used Acronis & Paragon imaging software on windows; hence, Clonzilla was not too bad to use, once you accept the line interface. The hardest part for me was get the program to select sub-directory on the target/backup disk.

      Currently, I have a working backup system. It’s still work in progress with no urgency. Thanks again

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Linux live image-based backup solution!

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.

    Your information:


    Comments are closed.