• Linux Mint 20 64bit Won’t Boot From HD on Old Dell Inspiron. Old 32bit Will

    Home » Forums » AskWoody support » Linux for the Home user » Linux Mint » Linux Mint 20 64bit Won’t Boot From HD on Old Dell Inspiron. Old 32bit Will



    I was given a 2012 vintage Dell Inspiron N7110 (12gb RAM, 650gb HD). It originally had WIN 7 Home. I got it with Ubuntu Studio and Android installed but without any passwords. This was a “clean” linux install (no Windows remained). I tried to recover passwords but that failed. The laptop was in such nice shape I wanted to make it a Linux-only machine. I’ve installed several different small Linux distro’s over the years on old Windows notebooks and PC’s to get some life out of them. I also manage a process control system at work that use various Windows servers and PC’s as HMI terminals. I’ve been out of the deep PC hardware realm for a number of years. I understand the old MBR BIOS v.s. UEFI BIOS concepts but dont’ have much hands-on experience with the latter other than to “cookbook” adding new devices or HD’s.

    Now my problem. I created a bootable USB thumbdrive with a combo of a Mac with Etcher, and eventually a Windows machine and Rufus. I had the same problem as bassmanzam in his thread here. I didn’t try the “admin” rights process he ended up using. Etcher in the Mac ended up clobbering the USB driver. I was able to use diskutil on the Mac to recover the drive, reformat it, then put it on a Windows PC and used Rufus to create the Linux Mint Cinnamon bootable USB drive.

    The USB drive boots into “LIVE” just fine. When I went to install onto the HD, it seemed to work, but would never boot. I get the “No OS Found” prompt. It never gets to a GRUB menu or prompt. The partitions are getting created and the LInux files are copied. I can “see” the partitions when I reboot into LIVE.

    My Dell has the original BIOS which is MBR based (there is no mention of GPT or UEFI). However, when I run Gparted, the Linux installer creates a EPS or a “efi” partition between the Grub partition and the Home partition.

    I tried 3 other  modern 64 bit distros, including Linux Lite and Lubuntu. All created the same partition scheme and all fail to boot to a grub menu. I even tried the installer “change” option and attempted to create just 4 simple partions like have in the past: root, boot, swap, and home. Same result.

    On a whim, I tried a 4 year old 32 bit Linux Lite thumbdrive I used to install Linux on an old ACER ASPIRE One notebook (I still have it and it still works). The Dell booted live just fine. I ran the installation and it worked fine. The Dell works perfectly running Linux Lite version 3.8 32-bit. It even found all of my devices, including WiFi and all of the keyboard hardware keys work.

    So, I’m stumped. Why would an older, simpler, Linux Lite 32 bit distro install just fine and 3 separate 64 bit, newish Linux distros fail to install to the HD? It “seems” to be assuming that I have a UEFI BIOS, but I don’t. I even tried the LVM partition install, but that didn’t work either.

    There are 3 newer BIOS flash files for this machine (A11, A12, and A13). But the BIOS flash files give a message that “this file works only under Windows” error message when I ran them from a FreeDos USB bootable thumbdrive.

    Any ideas on how I can get a newer, 64bit Linux distro to boot from the HD on this 11 year old Dell Inspiron? I’ve got to be close, but I just can’t seem to get the HD bootable. I read a recent thread about running a linux “boot repair” program from a command line, but I’m not sure that will work. I’m never able to get to a Grub prompt.

    Thanks in advance. Oh, and I did look for this here and on other sites. Nothing I found quite matched my problem.


    Viewing 1 reply thread
    • #2516542

      Try the install again, this time putting a password on your Linux install – it can be a very simple password, if you would prefer not to have a password. I recall having issues when I did not put a password on a Linux install.

      If it doesn’t work, then format the drive and try again, with a simple password.

      If that doesn’t work, then use gnome-disks, or some other similar program, to remove all partitions on the drive, then install one big partition. Format the partition. Now install Linux in that partition, with a simple password.

      Group "L" (Linux Mint)
      with Windows 8.1 running in a VM
      • #2516592


        Thanks for the reply. I did (and always) use a USER password. Didn’t make a difference. I will try the single large partition with a dedicated drive reformat.


    • #2516547

      I remember some installers when booted from a GPT drive will want to then install GPT on the hard drive.  When you create the Live USB, create it as an MBR disk, and see here:


      1 user thanked author for this post.
      • #2516605

        Energy Saver: Thanks. The thread you linked to was exactly what I was looking for. It looks like this was quite an issue 8 years ago. I’m at work and don’t have time to digest it. But, it gives me something to experiment with. I’m wondering, now that I have an older 32bit Linux on the drive, that the newer Linux will try and keep the MBR partitioning. I wish there was a hard installation “switch” to force it to go with MBR. Or, it looks like there are some instances of a “virtual” GPT / UEFI partitioning with newer Linux installers, even with an older MBR BIOS? The answer may be in the thread.

        Thanks again.


    Viewing 1 reply thread
    Reply To: Linux Mint 20 64bit Won’t Boot From HD on Old Dell Inspiron. Old 32bit Will

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: