• Linux Mint Authentication

    Home » Forums » AskWoody support » Linux for the Home user » Linux Mint » Linux Mint Authentication

    • This topic has 5 replies, 2 voices, and was last updated 2 months ago.

    I have messed up my LM setup and I’m looking for advice.

    What happened? I was trying to figure out how to share files between users on my LM box. I have 2 users and thought I could create a directory off the root partition. I didn’t want to leave it open to the world so I tried to create a new group for both users and hopefully that would work.

    Unfortunately it didn’t work and some unforeseen issues came about.  Now I am unable to authenticate for instance when running Update Manager. When I enter my password it jiggles and says something like your password is invalid.

    I am able to login with my password. I created a snapshot before I started. But how can I run TimeShift if I can’t authenticate?  I have looked online and there are a few options. But they’re not exactly the same issue.



    Viewing 2 reply threads
    • #2522397

      When it asks for a password, is it asking for the root password or the user password?

      Can you try it and see exactly what the error is?

      If you use ‘sudo timeshift’ from the command line, or any other command (timeshift is just an example) does it fail also?

      Did you edit the /etc/sudoers file, or perhaps remove your account from the administrators group?

      Whatever it is, Timeshift should fix it.

      You can run Timeshift by booting from the drive you used to install Mint, or any other Linux  live session medium. Mint probably already has Timeshift installed in the live session, so just run that and hit the “browse” tab at the top, and browse to the location where your Timeshift snapshots are stored. You can restore from there onto your hard drive or SSD.

      If it is not a Mint life session, it probably will not have Timeshift installed, but if you connect to the internet, you can install it in the live session. It will disappear when you reset the PC, but until then, you can use it to restore the Linux installation on your hard drive or SSD.


      Dell XPS 13/9310, i5-1135G7/16GB, KDE Neon
      XPG Xenia 15, i7-9750H/16GB & GTX1660ti, OpenSUSE Tumbleweed

      1 user thanked author for this post.
    • #2523590

      Its asking me for the root password. Since I have installed LM I’ve used my user and root password as the same.

      The error message I am getting is:
      “Your authentication attempt was unsuccessful. Please try again”

      When doing sudo timeshift I get the following message
      Sorry, user <username> is not allowed to execute ‘/usr/bin/timeshift’ as root

      No I did not touch sudoers. But I think my problem is with the groups I belong to. When I issue the command “groups” it only gives me my username and family (the group I tried above for sharing files). Nothing else. I think I need to be in the admin and sudo group?

      My current setup is a dual boot between Linux Mint and Windows 7.  Will I be able to use Timeshift from my Linux Mint USB Boot drive even though I have Windows 7? Will it know which partition to install it to. Will it require an administrator password to install? Is there any other way to get my group permissions back?  I really messed up.

      Thanks in advance.

      • #2524090

        You should be in the ‘admin’ and ‘sudo’ groups, yes. How you would add yourself to those groups without being able to get superuser privileges, I don’t know offhand, other than doing the Timeshift restore.

        Mint is a Ubuntu derivative, and Ubuntu does not by default have a root password set up once installed. It has been a while since I used Mint, but if it follows the Ubuntu pattern, there won’t be a root password unless you manually set one. All it takes is to enter ‘sudo passwd root’ at the command prompt, then enter the desired password twice, but you would not be able to do that with regular user privileges. If no root password is set, you would have to authenticate as a user in the aforementioned groups, which apparently no one is on your PC now.

        Will I be able to use Timeshift from my Linux Mint USB Boot drive even though I have Windows 7?

        Yes, that will not be a problem.

        Will it know which partition to install it to.

        Yes, that information is stored in the backup, and it will also give you the chance to verify the location before the restore begins.

        Will it require an administrator password to install?

        The authentication from a live session will not require your password from the installed Linux. It will use the one from the live session, which generally is not something you need to know. When I use ‘sudo’ from a live session, it just executes the command as superuser without any password prompt.

        I am sure there are other ways to correct this other than Timeshift, but I would have to do some reading to know what they might be.

        Dell XPS 13/9310, i5-1135G7/16GB, KDE Neon
        XPG Xenia 15, i7-9750H/16GB & GTX1660ti, OpenSUSE Tumbleweed

        1 user thanked author for this post.
    • #2525154

      After spending a week viewing YouTube videos, reading threads on Linux Mint forums I followed Ascaris advice and booted in to the Live USB and ran Timeshift to restore the latest snapshot.  It took about 10 minutes to recover from the snapshot. Although it seemed to do it twice for some reason but the first time might have been a “test”.

      After logging into LM after the restore I tested by running Update Manager and installed the latest version of FF. I was also able to run Quicken via wine but I don’t think that was an issue. I also ran the “groups” command and I was pleased to see sudo, adm and a few other groups displayed! I was back in business!

      One issue I did notice when rebooting was the Grub menu. It now displays “Ubuntu” rather than “Linux Mint 21.1 Cinnamon “!! I know that LM is based on Ubuntu but why would it be changed like that? Not that it bothers me but it seemed odd to me.

      Thank you Ascaris for everything!



      • #2525697

        Just a quick note about my grub menu. Apparently it changed back to “Linux Mint 21.1 Cinnamon” from “Ubuntu”. No changes made by me. It just happened automagically!

    Viewing 2 reply threads
    Reply To: Linux Mint Authentication

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: