• LMDE 5 and external drives

    Home » Forums » AskWoody support » Linux for the Home user » Linux Mint » LMDE 5 and external drives

    Author
    Topic
    #2573969

    I am having issues when trying to “remove external drive”.

    What happens is I’ll right click on the external drive, click “remove drive” and it disappears but before I have time to  unplug it,  it reconnects on its own! It’s not the drive because I had an external hdd that didn’t disconnect and I returned it and bought an external ssd and have the same issue. It happens after doing a Timeshift snapshot.

    I haven’t tried plugging in the drive and then “removing drive” without doing a snapshot. I have waited up to 30 minutes before clicking on “remove drive” but no change.

     

     

     

    Viewing 5 reply threads
    Author
    Replies
    • #2573984

      Closest thing to that I’ve ever run into was removing a usb stick (as you described above) and then plugging a new stick in only to have it nonfunctional. That was back with Mint 19.3 Cinnamon, IIRC. A restart solved the problem.

      Does the same thing happen with a usb stick?

      What happens when you shut down the computer? Do you get any error messages or does the drive icon disappear and then reappear or stay disappeared?

      Go to System Monitor and see if any processes are running that might be relevant?

      Lastly, I’m running Mint 20.3 Cinnamon and when I plug a usb stick in, there’s an icon that shows on the desktop and also one that shows in the lower right panel. I’m guessing you right clicked on the desktop icon; does the same problem occur if you right click on the panel icon (if you have one)? Either way should work, but I have a program on an iMAC that works from the launcher at the bottom of the screen but not from the icon in the the upper right (near the wifi icon and time).

      1 user thanked author for this post.
      • #2574227

        Thanks DrBonzo you’ve given me 2 options to try:

        1. Try with USB stick

        2. Try with panel icon

        It might take some time to try these out but will report back when tried!

    • #2574034

      Do you have the external drives set to automatically mount when plugged in? If you can disable that, at least it would prevent the “rediscovered” drive from mounting before you can unplug it.

      I can only guess as I have never seen this happen.

      This appears to have been a problem with some setups for a while:
      https://forums.linuxmint.com/viewtopic.php?t=339003

      Dell XPS 13/9310, i5-1135G7/16GB, KDE Neon
      XPG Xenia 15, i7-9750H/32GB & GTX1660ti, KDE Neon
      Acer Swift Go 14, i5-1335U/16GB, KDE Neon (and Win 11)

      1 user thanked author for this post.
      • #2574228

        Ascaris, you’ve given me something to try too.

        How do you disable automatic mount? If that is the case how would you manually mount USB devices?

        • #2574328

          I am not sure where the option is. Are you using the Cinnamon desktop in LMDE? Your desktop environment probably has something similar to my setup in Neon.

          In Neon, which uses KDE Plasma for the desktop, there is an option in the System Settings for “Removable Devices,” and the setting is in there. I have it set not to automount. When I plug in a drive, I get a popup from the Disks and Devices tray icon, where I can press the button to mount and open in file manager (or just mount it, or mount and open in some other program, the usual stuff).

          In addition, I can see the drive listed in the Devices section of Dolphin, the KDE file manager. Just a click will mount the drive and open it for browsing, and I can then use it.

           

          Dell XPS 13/9310, i5-1135G7/16GB, KDE Neon
          XPG Xenia 15, i7-9750H/32GB & GTX1660ti, KDE Neon
          Acer Swift Go 14, i5-1335U/16GB, KDE Neon (and Win 11)

    • #2574240

      You might try going to Disks (from the Start menu). In the upper right of the Disks window there is an option to power off the drive (assuming the drive is selected over on the upper left). The power off option is also a menu item when you click on the three vertical dots (vertical ellipsis?)

    • #2574458

      Ok so here is how I tested things:

      1. I plugged in a USB stick, copied a few files and then right clicked on the icon for the USB stick. It said “eject” which is what happened. The icon disappeared and I unplugged the USB stick.

      Now I am not sure if it was the USB stick or there wasn’t much activity by copying only a few files as apposed to running a snapshot with the external ssd.

      2. I plugged in my ssd and ran a Timeshift snapshot. After it finished I right clicked the icon and it said “safely remove drive”. A little different message than the USB stick. I selected the option the icon disappeared and in 5 seconds the icon reappeared. I next I tried to click the icon in the panel which had the same results as above. My last attempt was to open “file manager” click on the ssd under devices and it appears the icon disappeared and did not return! The only thing is the ssd still appeared under devices but hovering over it said something like “click to mount device”. Is the ssd now safe to remove?

      Thank you all for your suggestions and advice. Much appreciated!

      • #2574462

        My money is on ‘safe to remove’, but I can’t guarantee that..

        Before you remove the drive, open it and see what’s on it. Take some notes about file size, etc. Remove the drive and then plug it back in and see what’s on it and if the file sizes, etc., are the same

        • #2575539

          If you have already ejected the drive, by clicking on it to view anything, it will remount.

          The safer way to do it is to check the mounted USB stick before you click eject, remove it, and then re-plug it in and check the for any changes in the files.

      • #2574480

        The only thing is the ssd still appeared under devices but hovering over it said something like “click to mount device”. Is the ssd now safe to remove?

        If the drive is not mounted, it is safe to remove. If the file manager is giving you the offer to mount the drive, the drive must not be already mounted, so it should be fine. The only exception would be if there is a bug somewhere and its telling you it is not mounted, but it really still is (unlikely). The Disks utility DrBonzo mentioned should also show the drive as not mounted. If it does, I would say you’re good to go at that point, go ahead and unplug it.

        It occurred to me that I don’t really remember how the desktops other than KDE Plasma handle things that temporarily block unmounting. If there is still some program that is referencing a file or location on the external drive, it could be preventing it from unmounting. If I try to unmount an external drive while something on that drive is still open, KDE Plasma will tell me that so I can go close it/them. Maybe your desktop is different, and it tries to unmount the drive, fails, and so it puts the icon back. Do you ever see failure messages like the one I described?

        The way to test this would be to close everything that could be holding on to the file and try again to unmount and see if it works. Make sure Timeshift is closed, and any file manager windows that have the location pointing to the external drive. Any file or location on the external that is open in some program should be closed.

        The other thing that is possible is write caching. External drives are supposed to have write caching disabled, but I have noticed in my own systems that when I copy an .iso to my Ventoy USB flash drive, the file manager tells me it is completed long before the light on the SSD stops flashing. That’s fine for my drives that have a light, but not all of them do.

        When this happens, the file manager wrote the copy of the .iso into the write cache, and cache writes are very speedy, so it finishes quickly. But from the point of view of the external drive, it’s not finished, and if I try to eject the drive before the write is finished, it will not let me eject (unmount) the drive. Even if I try to shut down at that point (because I lost my head and forgot what it was doing), it will hold the shutdown until the write is finished. In this case it does not tell me anything… it just hangs until the write is finished.

        I have the CPU utilization (bar) graph (per-core) in my systray, so there’s another “tell” that this is happening. If I see one of the cores maxed out, it’s probably the write to the USB drive that is still ongoing. The system will shift the active core around to (presumably) spread out the heat, but one of them will always be maxed until it finishes.

        Dell XPS 13/9310, i5-1135G7/16GB, KDE Neon
        XPG Xenia 15, i7-9750H/32GB & GTX1660ti, KDE Neon
        Acer Swift Go 14, i5-1335U/16GB, KDE Neon (and Win 11)

    • #2575538

      On Linux Mint 20.3, I have found the same behavior, click eject, and the popup disappears. As long as the USB is not shown on the desktop it is safe to remove. I have pulled out the USB with no problems, and re-insertion will reload the USB and an icon will reappear on the desktop.

      On my Sata III HDD archive drive, I have it set to NOT automount. It shows in the left side of the file manager, but will not reveal any details unless I click on the disk on the left side. Once clicked it will mount the disk and show the files and a disk icon on the desktop. If I right click to unmount it, the disk icon will still show on the left of file manager, but not on the desktop.

      1 user thanked author for this post.
      • #2575588

        Hi Bill, how do you set an external drive NOT to automount?

        I still need to do some testing but I assume if I remove the external drive from file manager, the icon disappears from the desktop and it shows in filemanager waiting for the mount command.

         

         

         

        • #2575804

          By my understanding, mounting is making the disk accessible for use. The file manager shows all connected disks, but not all are necessarily mounted. It has been awhile, but I believe I used the disks applet and unselected automount or ‘mount at boot’. I found a lot of these setting when I first built the machine and could not access disks I added after the initial build. A bit of research on the Mint forums and other sources taught me about taking ownership and assigning myself as a user.

          Previously, when I had all the disks in place when I did a Linux install, all were accessible and I had rights on them without taking ownership when I logged in.

          I also found that a flash card reader panel for my cameras and GPS units also showed all the assorted flash card format sockets as unmounted disks until I plugged a card in. That was a bit too distracting as my using that reader was not that common, so I ditched the card reader panel and went to a multi-card reader I kept with the camera bag, that I just plug into an external USB port.

    • #2576226

      I had some time to work on my LMDE and my external ssd.

      I first attached the drive and the icon appeared on the desktop. I did a Timeshift snapshot to access the drive. When that finished I opened filemanager and selected the external drive to unmount it. The icon disappeared and the drive still showed under devices but hovering over it said “click to mount”.

      I then decided to open the disks app and selected my external drive. It said it was unmounted. I noticed a button at the upper right and hovering over it said “Power off”. So I decided to click the button and it did the opposite of what you’d expect. Once I clicked on it I noticed the external drives icon reappeared on the desktop and it said the drive was mounted in disks!

      So I assume there is some “bug” in the way external drive are powered off. Unfortunately it over my paygrade to test any further. Since it does say the drive is unmounted in filemanager I’ll assume it’s safe to disconnect. Thanks to all for all the advice.

    Viewing 5 reply threads
    Reply To: LMDE 5 and external drives

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: